Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

CME 8.6 aa not working

Hi all

I've spent cumulatively about 5 hours on this now (including googling) so got to the stage where I need to ask your advice

Very simple requirement: Single aa, drop-through mode to an ephone hunt-group

Problem is, it's not working

Details:

1 - Dial Peer

dial-peer voice 4333 pots

service app-b-acd-aa

incoming called-number 4333

! I have also tried the full 01234884333 and 1234884333 with similar problem

port 0/0/0:15

! This is the correct port for my CME

2 - Hunt Group

ephone-hunt 2 longest-idle

pilot 5001

list 4334

statistics collect

3 - Queue

service app-b-acd

param queue-len 15

param number-of-hunt-grps 1

param aa-hunt1 5001

! Single hunt group - same ext as the Hunt Group above

param queue-manager-debugs 1

4 - AA

service app-b-acd-aa

paramspace english index 1

paramspace english language en

paramspace english location flash0:/cme-b-acd-2.1.2.3/

! This is the correct path to the .au files

param second-greeting-time 60

param max-time-call-retry 700

param call-retry-timer 15

param aa-pilot 4333

! As in the dial-peer, I have tried the extn as well as the full number

param number-of-hunt-grps 1

param handoff-string app-b-acd-aa

param service-name app-b-acd

I'm in the UK, so phone numbers are in the format 01234 567890. However, due to whatever, they are presented at the CME as 1234 567890 - the leading 0 is dropped at the exchange

When I add a dial-peer, I typically add just the 4 digit extension

What happens:

Dial the hunt-group target (4334) - phone rings fine

Dial the hunt group (5001) - rings fine

Dial the aa pilot (4333) and it disconnects instantly

Dial the full number (01234884333) and I get automated BT woman "The other person has hung up"

This is driving me nuts - something which should be so straighforward, so if anyone can point out where I've been stupid, I'd really appreciate it

Thanks in advance

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re:CME 8.6 aa not working

Hi Wayne,

Its great to hear that all is working fine now.

and it's up to you.

Thanks,

--

Nart

10 REPLIES

Re:CME 8.6 aa not working

You need a destination-pattern in your pots dial-peer and not a incoming called number.

Try the change.

Rate the post accordingly.

Regards,
Kevin




Sent from Cisco Technical Support Android App

Community Member

CME 8.6 aa not working

Hi Kevin

I tried that, adding the destination-pattern both as the 4 figure extn, the full number, and as the number with the leading 0 taken off - still no joy. I then tried the same after pulling the incoming called-number. Full number with/without the leading 0 I just get error tones. Extension only I go back to "other person has hung up"

Cisco Employee

Re:CME 8.6 aa not working

Hi Wayne,

Looking at your config, I see that you are missing the voicemail parameter in the aa service, add it and test.

Also, make sure that you have music on hold configured on the CME.

you can use the "debug voice application error" to see what is going on if the above doesn't work.

Have a look at the example in the link below, you can copy it and modify it to your needs:

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/bacd/configuration/guide/cme40tcl/40bacd.html#wp1003141

Let me know how it goes.

Thanks,

--

Nart

CCIE voice

Community Member

CME 8.6 aa not working

Hi Nart

I dont actually want voicemail on this - they'll all get answered eventually

Cisco Employee

Re:CME 8.6 aa not working

Hi Wayne,

You can put the VM parameter to point to any number, you can even use the hunt group number or another group.

This is a mandatory parameter and it has to be there, similar to MOH.

Please see step 31 in the link below:

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/bacd/configuration/guide/cme40tcl/40bacd.html#wp1025932

Let me know how it goes.

Thanks,

--

Nart

Re:CME 8.6 aa not working

Wayne,

Remove the port number "0/0/0:15", see if that works.

dial-peer voice 4333 pots

service app-b-acd-aa

incoming called-number 4333

! I have also tried the full 01234884333 and 1234884333 with similar problem

port 0/0/0:15

Cisco Employee

Re:CME 8.6 aa not working

You are using a drop through mode however drop through option "Parameter" is missing in the config

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/bacd/configuration/guide/cme40tcl/40bacd.html#wp1003141

Br,
Nadeem 

Please rate all useful post.

Br, Nadeem Please rate all useful post.
Community Member

Re:CME 8.6 aa not working

Okay, thanks all, it's now working. Really appreciate the swift help

Details:

1 - Dial Peer

dial-peer voice 4333 pots

service app-b-acd-aa

destination-pattern 01234884333

! Thanks Kevin for this. It also needed the full UK number, not just the 4 digit extn

port 0/0/0:15

! This is the correct port for my CME

2 - Hunt Group

ephone-hunt 2 longest-idle

pilot 5001

list 4334

statistics collect

! This was all correct

3 - Queue

service app-b-acd

param queue-len 15

param number-of-hunt-grps 1

param aa-hunt1 5001

! Single hunt group - same ext as the Hunt Group above

param queue-manager-debugs 1

! This was all correct

4 - AA

service app-b-acd-aa

paramspace english index 1

paramspace english language en

paramspace english location flash0:/cme-b-acd-2.1.2.3/

param second-greeting-time 60

param max-time-call-retry 700

param call-retry-timer 15

param aa-pilot 4333

param number-of-hunt-grps 1

param handoff-string app-b-acd-aa

param service-name app-b-acd

param voice-mail 7777

! Thanks Nart, didn't notice this was mandatory

param drop-through-option 1

! Thanks Nadeem, from the doc this appeared to be optional if you had already specified a single number-of-hunt-grps

param drop-through-prompt _bacd_welcome.au

Not sure which post to mark as Correct Answer since it was a combination, any preferences guys?

Cisco Employee

Re:CME 8.6 aa not working

Hi Wayne,

Its great to hear that all is working fine now.

and it's up to you.

Thanks,

--

Nart

Re:CME 8.6 aa not working

Glad everyone was able to help .(+ 5 )for Nart and Nadeem. great going Guys!!


Sent from Cisco Technical Support Android App

160
Views
0
Helpful
10
Replies
CreatePlease to create content