Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

CME 8 ringlist.xml

Hi everyone,

I can't seem to figure this out - when the phones boot up they display file not found: distinct  and file not found ringlist.xml. I checked the tftp server settings as shown below in the config and the ringtone files & Ringlist.xml and DistinctiveRingList.xml are present on the flash card. I also rebooted the router. The only 2 ringtones showing up are chirp.

Thanks,

David

------------------ show version ------------------

Cisco IOS Software, 2800 Software (C2800NM-IPVOICEK9-M), Version 15.1(1)T, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Mon 22-Mar-10 01:25 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

CME uptime is 9 minutes
System returned to ROM by power-on
System image file is "flash:c2800nm-ipvoicek9-mz.151-1.T.bin"
Last reload type: Normal Reload


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 2851 (revision 53.51) with 512000K/12288K bytes of memory.
Processor board ID FTX1212A1DS
2 Gigabit Ethernet interfaces
1 terminal line
4 Voice FXO interfaces
1 cisco service engine(s)
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
250880K bytes of ATA CompactFlash (Read/Write)


License Info:

License UDI:

-------------------------------------------------
Device#       PID               SN
-------------------------------------------------
*0         CISCO2851             FTX1212A1DS     



Configuration register is 0x2102


------------------ show running-config ------------------


Building configuration...



Current configuration : 6955 bytes
!
! Last configuration change at 17:11:54 UTC Thu May 10 2012
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME
!
boot-start-marker
boot-end-marker
!
enable secret 5 <removed>
enable password <removed>
!
no aaa new-model
no network-clock-participate slot 1 
!
dot11 syslog
ip source-route
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 172.16.1.1 172.16.1.10
!
ip dhcp pool VOICE
   network 172.16.1.0 255.255.255.0
   default-router 172.16.1.1 
   option 150 ip 172.16.1.1 
!
!
ip name-server 4.2.2.2
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
voice rtp send-recv
!
voice service voip
 gcid
 clid substitute name
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 sip
  e911
  transport switch udp tcp
  asserted-id ppi
  midcall-signaling passthru
  no call service stop
!
voice class codec 1
 codec preference 1 g729r8
 codec preference 2 g711ulaw
 codec preference 3 g711alaw
!
voice class h323 1
  telephony-service ccm-compatible
  ccm-compatible
!
!
!
!
voice translation-rule 2
 rule 1 /105/ /5164038926/
!
voice translation-rule 3
 rule 1 /5164038959/ /105/
!
!
voice translation-profile INCOMING
!
!
voice-card 0
!
voice-card 1
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2851 sn FTX1212A1DS
archive
 log config
  hidekeys
username cisco privilege 15 password 0 <removed>
username user3 password 0 <removed>
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 description LAN_INTERFACE
 ip address 172.16.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
 no mop enabled
!
interface Service-Engine0/1
 ip address 172.16.200.1 255.255.255.252
 service-module ip address 172.16.200.2 255.255.255.252
 service-module ip default-gateway 172.16.200.1
!
interface GigabitEthernet0/1
 description WAN_INTERFACE
 ip address xx.xxx.xx.xxx 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 no mop enabled
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:
!
ip nat inside source list 1 interface GigabitEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 xx.xxx.xx.1
!
access-list 1 permit 172.16.1.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
tftp-server flash:term06.default.loads
tftp-server flash:term41.default.loads
tftp-server flash:P00308010200.bin alias P00308010200.bin
tftp-server flash:P00308010200.loads alias P00308010200.loads
tftp-server flash:P00308010200.sb2 alias P00308010200.sb2
tftp-server flash:P00308010200.sbn alias P00308010200.sbn
tftp-server flash:term42.default.loads
tftp-server flash:term62.default.loads
tftp-server flash:term45.default.loads
tftp-server flash:term65.default.loads
tftp-server flash:term70.default.loads
tftp-server flash:term71.default.loads
tftp-server flash:/Ringtones/Ringlist.xml
tftp-server flash:/Ringtones/DistinctiveRingList.xml
tftp-server flash:/Ringtones/AreYouThereF.raw
!
control-plane
!
!
voice-port 1/0/0
 connection plar opx 102
 caller-id enable
!
voice-port 1/0/1
!
voice-port 1/0/2
!
voice-port 1/0/3
!
!
!
!
dial-peer voice 100 voip
 description DIAL_PEER_TO_CUE
 destination-pattern 77[5-9]
 session protocol sipv2
 session target ipv4:172.16.200.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 10 pots
 description POTS_DIAL_PEER_OUTGOING
 destination-pattern 1[2-9]..[2-9]......
 port 1/0/0
!
dial-peer voice 1 voip
 incoming called-number 51640389..
 voice-class sip asserted-id ppi
 no voice-class sip block 180
 no voice-class sip block 183
 no voice-class sip block 181
 voice-class sip pass-thru headers unsupp
 voice-class sip pass-thru content unsupp
 voice-class sip pass-thru content sdp
 dtmf-relay rtp-nte
!
dial-peer voice 2 voip
 destination-pattern [2-9]..[2-9]......
 session protocol sipv2
 session target ipv4:74.63.41.218
 session transport udp
 voice-class sip asserted-id ppi
 no voice-class sip block 180
 no voice-class sip block 183
 no voice-class sip block 181
 voice-class sip pass-thru headers unsupp
 voice-class sip pass-thru content unsupp
 voice-class sip pass-thru content sdp
 dtmf-relay rtp-nte
 codec g711ulaw
!
!
!
telephony-service
 authentication credential cisco cisco
 max-ephones 30
 max-dn 45
 ip source-address 172.16.1.1 port 2000
 system message IPO Law Group
 url services http://172.16.200.2/voiceview/common/login.do 
 url authentication http://172.16.200.1/CCMCIP/authenticate.asp  
 cnf-file location flash:
 load 7960-7940 P00308010200
 load 7941 term41.default.loads
 load 7942 term42.default.loads
 load 7945 term70.default.loads
 load 7961 term06.default.loads
 load 7962 term62.default.loads
 load 7965 term71.default.loads
 max-conferences 4 gain -6
 moh flash:music-on-hold.au
 multicast moh 239.1.1.1 port 2000
 web admin system name cisco password <removed>
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn  1  dual-line
 number 101
 call-forward noan 777 timeout 16
!
!
ephone-dn  2  dual-line
 number 102
 call-forward noan 777 timeout 16
!
!
ephone-dn  3  dual-line
 number 103
 call-forward busy 777
 call-forward noan 777 timeout 16
!
!
ephone-dn  4  dual-line
 number 104
!
!
ephone-dn  5  dual-line
 number 5164038959
 description DID 1 VOIPMS
!
!
ephone-dn  6  dual-line
 number 106
!
!
ephone-dn  7  dual-line
 number 107
!
!
ephone-dn  8  dual-line
 number 108
!
!
ephone-dn  9  dual-line
 number 109
!
!
ephone-dn  10  dual-line
 number 110
!
!
ephone-dn  11  dual-line
 number 111
!
!
ephone-dn  12  dual-line
 number 112
!
!
ephone-dn  13  dual-line
 number 113
!
!
ephone-dn  14  dual-line
 number 114
!
!
ephone-dn  15  dual-line
 number 115
!
!
ephone-dn  16  dual-line
 number 116
!
!
ephone-dn  17  dual-line
 number 117
!
!
ephone-dn  18  dual-line
 number 118
!
!
ephone-dn  19  dual-line
 number 119
!
!
ephone-dn  20  dual-line
 number 120
!
!
ephone-dn  21  dual-line
 number 121
!
!
ephone-dn  22  dual-line
 number 122
!
!
ephone-dn  23  dual-line
 number 123
!
!
ephone-dn  24  dual-line
 number 124
!
!
ephone-dn  25  dual-line
 number 125
!
!
ephone-dn  26  dual-line
 number 126
!
!
ephone-dn  27  dual-line
 number 127
!
!
ephone-dn  28  dual-line
 number 128
!
!
ephone-dn  29  dual-line
 number 129
!
!
ephone-dn  30  dual-line
 number 130
!
!
ephone  2
 mac-address 0013.60B5.26F1
 username "user2"
 type 7960
 button  1:2
!
!
!
ephone  3
 mac-address 000E.D759.515C
 type 7940
 button  1:3 2:5
!
!
!
line con 0
line aux 0
line 258
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 password <removed>
 login
 transport input all
!
scheduler allocate 20000 1000
end
Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

CME 8 ringlist.xml

change Ringlist.xml to RingList.xml

aslo do

tftp-server flash:/Ringtones/RingList.xml alias RingList.xml
tftp-server flash:/Ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml
5 REPLIES
New Member

CME 8 ringlist.xml

change Ringlist.xml to RingList.xml

aslo do

tftp-server flash:/Ringtones/RingList.xml alias RingList.xml
tftp-server flash:/Ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml

CME 8 ringlist.xml

No luck... File Not Found: RINGLIST.XML

Hall of Fame Super Gold

CME 8 ringlist.xml

Etiehr the file is missing, or tftp statements are not configured correctly.

Blue

CME 8 ringlist.xml

Hi

Please enter following the rings.raw file in tftp-server command  also

e.g. tftp-server flash:RingList.xml
       tftp-server flash:Piano1.raw
       tftp-server flash:Chime.raw

Regards

Ronak Patel

Please rate helpful posts.

Regards Ronak Patel Rate all helpful post by clicking stars below the answer.

Re: CME 8 ringlist.xml

Ok, working now Thanks for the help. When I pulled the config again the tftp servers were a mess, so I redid all the ringtone and ringlist server flies and aliased the DistinctiveRingList.xml, RingList.xml and all the voice files like Tun Moe said and it came up.

Thanks!

3018
Views
5
Helpful
5
Replies