Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CME 8 T.38 fax issues

Hi Guys, I need some help. Here is the setup I have, I have a 2901 router with a PRI vWic running CME 8. What I am trying to do is pass fax calls through a sip trunk to Fax for Asterisk. This however has proved much more problematic that I thought. Small (1 to 3 page) faxes complete pretty well, about 90% of the time, anything more than 3 pages and it just doesnt work. I have tried sip over TCP and UDP, but of course IOS only supports T38 over udp... Anyway, when a call comes through it passes it off to asterisk, brings up t38 and starts sending, after a couple of pages it falls back from 14.4kbps to 12kbps and if the fax is long enough it will eventually fall back to 9600... The fax call is dropped though befor it finishes... I turned ECM off (per the cisco docs) to see if that helped any, and it really did not. But I do get a different error with it off. With ECM on, the error when the call dies is T2 Timeout, however with ECM off, the error is Loss of HS Sync. I have done a packet capture and really dont see any issues that are obvious enough to stick out to me, then again I am not really fimiliar enough with this to know what to look for. The one thing I did notice is in the packet capture, the last page sent before the call dies has a tag (added by wireshark) saying T4 data fragment. None of the other pages have that tag on them, but all of the packets on the last page to go through have that tag (I guess because the call is getting dropped.) But I am at a complete loss as to what to look at next. Looking at the debug output on the router nothing sticks out as an obvious issue other than the call going away... I just cannot figure out what is killing the call.

Anyone have any ideas on what to look for?

6 REPLIES
Hall of Fame Super Gold

CME 8 T.38 fax issues

How do you interface to pstn? Take "show controllers t1".

New Member

CME 8 T.38 fax issues

As stated it's a t1 vWic with a full ISDN PRI...

T1 0/0/0 is up.

  Applique type is Channelized T1

  Cablelength is long 0db

  No alarms detected.

  alarm-trigger is not set

  Soaking time: 3, Clearance time: 10

  AIS State:Clear  LOS State:Clear  LOF State:Clear

  Version info Firmware: 20100222, FPGA: 13, spm_count = 0

  Framing is ESF, FDL is ansi & att, Line Code is B8ZS, Clock Source is Line.

  CRC Threshold is 320. Reported from firmware  is 320.

  Data in current interval (278 seconds elapsed):

     0 Line Code Violations, 0 Path Code Violations

     4 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

     4 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

  Total Data (last 24 hours)

     0 Line Code Violations, 4 Path Code Violations,

     1267 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 1 Degraded Mins,

     1268 Errored Secs, 1 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

I will say ignore the error counters as my T1 had some issues yesterday...

Hall of Fame Super Gold

CME 8 T.38 fax issues

A bit too dense post to spot details.

configure

network-clock-select 1 t1 0/0/0

and try again.

New Member

Re: CME 8 T.38 fax issues

Well, I need to run with it for a bit to see how it works over a longer period of time, but the 6 page fax I have been using to test with and a longer 10 page version went through just fine!

That is the single most useful one line of code I have ever seen in my life!!!!!

Thanks so much man, I have been fighting this for weeks trying to figure out what the issue is!

PS, I am very curious, what that command actually does in IOS... Admittidly I am not nearly as fimilar with this stuff as I should be, but in all my reading I have never see that command before.

Hall of Fame Super Gold

Re: CME 8 T.38 fax issues

The DSPs need to sync with the T1 and the commands makes that happen. It's actually an issue often meet byt people not familiar with the platform.

Please remember to rate useful posts clicking on the stars below.

New Member

Re: CME 8 T.38 fax issues

Well... We seem to be back to the fax timeout issue... worked alright for a short time and then started acting up again... Any other suggestions?

803
Views
0
Helpful
6
Replies
CreatePlease login to create content