Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CME 9.0 MOH options

I have 2 questions regarding Music On Hold options for CME 9.0

1) Can you use unicast or is multicast the only option on CME 9.0?

2) On a L3 3750 switch running IP BASE, is it possible to deliver MOH on the Voice VLAN (SVI) utilizing PIM STUB routing?

Here is my scenario:

ISDN2 (BRI)---2921--->(L3 routed)----->3750-----(VLAN211)------IP-Phones(6941)

MOH currently not working for internal calls when put on hold

2921 running CME 9.0 (15.2.2T)

- Telephony Services source is Loopback 0

- L3 routed link to the 3750 switch

3750 running IP BASE

- SVI (interface VLAN 211 defined for L3 voice vlan)

Below is are my Multicast Configs on the 2921 router and IP BASE 3750:

ROUTER:

!

ip multicast-routing

!

telephony-service

ip source-address 10.11.10.254 port 2000

moh "flash:music-on-hold.au"

multicast moh 239.0.0.1 port 2000 route 10.11.10.254 172.21.101.22

!

interface Loopback0

description ** Loopback **

ip address 10.11.10.254 255.255.255.255

!

interface GigabitEthernet0/0

description ** switch F1/0/1 **

bandwidth 100000

ip address 172.21.101.22 255.255.255.248

ip pim sparse-dense-mode

!

SWITCH:

!

ip multicast-routing distributed

!

interface FastEthernet1/0/1

description ** router G0/0 **

no switchport

bandwidth 100000

ip address 172.21.101.17 255.255.255.248

ip pim passive

speed 100

duplex full

!

interface Vlan211

description ** VOICE **

ip address 10.10.10.254 255.255.255.0

ip pim passive

!

Everyone's tags (4)
3 REPLIES
Hall of Fame Super Gold

CME 9.0 MOH options

1. by default CME automatically select MoH to be multicast or unicast depending if phone is a subnet local to to CME router, or not ('remote phone').

2. as a consequence, the best choice is to have the phones be directly connected to CME router.

New Member

CME 9.0 MOH options

Spent most of today trying L3 vs L2 vs L3 + dot1q for voice VLAN.. Same result - when internal calls are put On Hold - silence.. Finally tried a fresh set of phones with stock firmware. Everything worked straight away!

Basically, I just found a bug in 69xx CME 9.0 firmware ver 9.2.1 (SCCP). Phones on default load 9.0.2 work fine, even with a pure L3 switch on IP Base with multicast stub.

If anynoe is interested, here is my working CME multicast L3 3750 switch config on IP BASE:

!

ip routing

!

ip multicast-routing distributed

!

interface FastEthernet1/0/1

description ** router G0/0 **

no switchport

bandwidth 100000

ip address 172.21.101.17 255.255.255.248

ip pim sparse-dense-mode

speed 100

duplex full

!

interface Vlan211

description ** VOICE **

ip address 10.10.10.254 255.255.255.0

ip pim passive

!

Hall of Fame Super Gold

CME 9.0 MOH options

The 69xx are known to have more bugs in recent firmware rather than in the original one.

Good that you found a solution anyway.

649
Views
0
Helpful
3
Replies