Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CME No Agents are available but they are !

Hi There,

For over 2 years i've been running a CME 4.2 router happily.   I have a number of different hunt groups and users are able to login and out fine using the Hlog soft key.   Today I have a group of users unable to receive calls via a B-ACD service and specific hunt group.   They are logged in fine and I can connect to them directly through the hunt group.  Using the B-ACD service however  i get pushed straight to voice mail.  The debug displays the following error.  

TCL AA: >>> No Agents are available; Forwarding to Voice Mail

All indications are that the Agents are available. I can call them via the hunt group.  Through B-ACD no good.  I have rebooted and no change. I have rebooted phones an no change.  I have removed the config and re-added etc.  I'm stumped because the config is identical to the other hunt groups and aplication services which work fine.   The TCL script i'm using is app-b-acd-aa-3.0.0.2.tcl.

Any clues here would be great thanks.

Matt.

5 REPLIES
Hall of Fame Super Gold

CME No Agents are available but they are !

You should look at the last config change done before the problem occorred.

Software things don't break by themselves.

New Member

CME No Agents are available but they are !

Thanks for the advice and I do agree with you.   However we use rancid to backup our configs nightly.  There are no config diffs for some weeks.  

Matt.

Hall of Fame Super Gold

Re: CME No Agents are available but they are !

Calling the hunt pilot what happens.?

Then you can look at "debug voice application script" with "term mon".

New Member

CME No Agents are available but they are !

If I call the hunt group as configured below.. All good.

ephone-hunt 50 sequential
 pilot 8150
 list 2752, 2751, 2758, *, *, *, *, *
 timeout 15, 15, 15, 15, 15, 15, 15, 15
 statistics collect
 
If I call 7050 as below it goes straight to voicemail.

 service aa52 flash:app-b-acd-aa-3.0.0.2.tcl
  paramspace english index 1
  param drop-through-option 6
  param handoff-string aa52
  paramspace english language en
  param max-time-vm-retry 2
  param aa-pilot 7050
  param max-extension-length 4
  param queue-overflow-extension 9050
  param drop-through-prompt _aa52_bacd_dropthoughprompt.au
  paramspace english location flash:
  param second-greeting-time 120
  param queue-exit-option1 1
  param call-retry-timer 30
  param voice-mail 9050
  param max-time-call-retry 3600
  param service-name queue
  param queue-exit-extension1 9050
  param number-of-hunt-grps 1

 service queue flash:app-b-acd-3.0.0.2.tcl
  param aa-hunt7 8160
  param aa-hunt8 9990
  param aa-hunt9 8190
  param queue-len 20
  param queue-manager-debugs 1
  param aa-hunt1 8100
  param aa-hunt2 8110
  param number-of-hunt-grps 10
  param aa-hunt3 8120
  param aa-hunt4 8130
  param aa-hunt5 8140
  param aa-hunt6 8150


: //35//TCL :/tcl_PutsObjCmd: TCL B-ACD: >>> Queue index is 0 <<<

//35//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> THE QUEUE NOW IS {TclModule_4C0243F4_0_751495284 {CALL_NEW} {1329371193} {5}} <<<

//35//TCL :/tcl_PutsObjCmd: TCL B-ACD: +++ 8150 Queue Length = 1 +++

//35//TCL :/tcl_PutsObjCmd: TCL B-ACD:  >>> THE QUEUE IS {TclModule_4C0243F4_0_751495284 {CALL_HOLD} {1329371193} {5}} <<<

//38529//TCL :/tcl_PutsObjCmd: TCL AA: >>> No Agents are available; Forwarding to Voice Mail <<<

//38529//TCL :/tcl_PutsObjCmd:

New Member

CME No Agents are available but they are !

This has been resolved.  The phones needed to be factory reset. Weird.

Matt.

302
Views
0
Helpful
5
Replies