Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

CME on 2921, 7962G phone not registering

Hello everyone!

I'm in great need of solving the problem, and i can't, with the help of all docs and threads in Internet.

I need to make work IP phones 7962G on 2921's CME. So, i have new 2921, 3750G and 7962G phones, which are not registering on 2921.

about 2921:

System image file is "flash0:c2900-universalk9-mz.SPA.152-4.M3.bin"

License UDI:

-------------------------------------------------

Device#   PID                   SN

-------------------------------------------------

*0        CISCO2921/K9          FCZ1728620R

Technology Package License Information for Module:'c2900'

-----------------------------------------------------------------

Technology    Technology-package           Technology-package

                            Current       Type           Next reboot

------------------------------------------------------------------

ipbase        ipbasek9      Permanent      ipbasek9

security      None          None           None

uc            uck9          Permanent      uck9

data          None          None           None

конфиг 2921:

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool ccp-pool

  network 10.10.10.0 255.255.255.0

  default-router 10.10.10.1

  option 150 ip 10.10.10.1

!

interface GigabitEthernet0/0.2

  encapsulation dot1Q 2

  ip address 10.10.10.1 255.255.255.0

!

telephony-service

  no auto-reg-ephone

  max-ephones 10

  max-dn 100

  ip source-address 10.10.10.1 port 2000

  cnf-file location flash:

  cnf-file perphone

  time-format 24

  date-format dd-mm-yy

  max-conferences 8 gain -6

  moh "music-on-hold.au"

  transfer-system full-consult

  create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

!

ephone-dn  1

  number 2200

!

!

ephone  1

  mac-address 44AD.D9D5.182A

  type 7962

!

phone's interface on 3750G: 

interface GigabitEthernet1/0/12

  description IP Phones

  switchport trunk encapsulation dot1q

  switchport trunk native vlan 3

  switchport mode trunk

  switchport voice vlan 2

  spanning-tree portfast

Phone itself keep "Registering" and showing circle.

On 2921 in debug I see:

Sep 25 10:52:28.179: TFTP: Looking for CTLSEP44ADD9D5182A.tlv

Sep 25 10:52:28.299: TFTP: Looking for ITLSEP44ADD9D5182A.tlv

Sep 25 10:52:28.431: TFTP: Looking for ITLFile.tlv

Sep 25 10:52:28.895: TFTP: Looking for SEP44ADD9D5182A.cnf.xml

Sep 25 10:52:28.899: TFTP: Opened flash:/its/vrf1/SEP44ADD9D5182A.cnf.xml, fd 9, size 1425 for process 296

Sep 25 10:52:28.903: TFTP: Finished flash:/its/vrf1/SEP44ADD9D5182A.cnf.xml, time 00:00:00 for process 296

Sep 25 10:52:33.303: TFTP: Looking for English_United_States/mk-sccp.jar

Sep 25 10:52:34.619: TFTP: Looking for United_States/g3-tones.xml

also, 2921 sees phone, but cannot register it:

#sh ephone

ephone-1[0] Mac:44AD.D9D5.182A TCP socket:[-1] activeLine:0 whisperLine:0 UNREGISTERED

mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:0

IP:0.0.0.0* 0 Unknown 0  keepalive 0 max_line 0 available_line 0

Preferred Codec: g711ulaw

Lpcor Type: none

In "Status messages" on the phone last messages are "Error Updating Locale".

Firmware on the phone is SCCP42.9-3-1SR1-1S. I've tried to "load 7962 SCCP42.8-5-4S", but phone (after rebooting and loading) show message "Load Rejected HC  SCCP42.8-5-4S", then it shows "VPN Not configured", firmware is still 9-3, and it still not registering. 

also, i cannot download anything from cisco.com - i have no contract and nothing else that will permit me to download software. But here's what i have: 

cme-full-7.1.0.0.tar

cme-full-7.1.0.1.tar

cme-151-2Tv1.zip

i've trimmed tar for 7.1.0.0 to keep there only that files:

APPS-1.2.1.SBN

apps42.8-4-1-23.sbn

cnu42.8-4-1-23.sbn

cvm42sccp.8-4-1-23.sbn

Desktops

dsp42.8-4-1-23.sbn

gui

GUI-1.2.1.SBN

jar42sccp.8-4-1-23.sbn

music-on-hold.au

ringtones

SCCP42.8-4-2S.loads

SYS-1.2.1.SBN

term42.default.loads

TNUX-1.2.1.SBN

TNUXR-1.2.1.SBN

WLAN-1.2.1.SBN

also i've extract to 2921' flash files regarding 42/62 from cme-151-2Tv1.zip (CME 8.1).

i don't think that issue is in version (although i cannot download CME 9 and therefore cannot test it)

Please, help!

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Super Bronze

CME on 2921, 7962G phone not registering

no auto-reg-ephone

You need to enable it.

That is untrue. This command is only relevent if you want phones you haven't explicitly provisioned in the config to register. Furthermore, you would need to configure Extension Assigner to dole out ephone-dn assignments.

Did you run a create cnf-files after configuring the ephone? The timestamp above shows it was last done in 2002.

Note that you need to map the ephone-dn to the ephone using the 'button 1:1' command within the ephone.

What does a 'debug ephone register' output show?

Please remember to rate helpful responses and identify helpful or correct answers.

4 REPLIES
Community Member

CME on 2921, 7962G phone not registering

sorry, i found the cause: i've missed "button" in ephone configuration, thought it was unnecessary word for configuring special functions on the phone's buttons. i think the problem solved, sorry again. 

Community Member

CME on 2921, 7962G phone not registering

Hi there.

change this command.

no auto-reg-ephone

You need to enable it.

VIP Super Bronze

CME on 2921, 7962G phone not registering

no auto-reg-ephone

You need to enable it.

That is untrue. This command is only relevent if you want phones you haven't explicitly provisioned in the config to register. Furthermore, you would need to configure Extension Assigner to dole out ephone-dn assignments.

Did you run a create cnf-files after configuring the ephone? The timestamp above shows it was last done in 2002.

Note that you need to map the ephone-dn to the ephone using the 'button 1:1' command within the ephone.

What does a 'debug ephone register' output show?

Please remember to rate helpful responses and identify helpful or correct answers.

Community Member

CME on 2921, 7962G phone not registering

Jonathan, you're absolutely correct about 'button 1:1' command, i've missed it because of a hurry and doing all 'by the book but faster'. And about timestamp 2002 - it is because i'm first start telephony-service and after it ntp server. I did 'no telephony service' and then 'telephony-service', timestamps was correct this time. And about 'button 1:1' - by fast reading documentation i thought 'button' command is for some special functions assigned to phone's button, like on avaya phones, so i missed it - my bad, and thank you!

1130
Views
9
Helpful
4
Replies
CreatePlease to create content