Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CME Phone Load Upgrade issue

My apologies if this is a double post, I think my original went to the wrong forum.

I'm using CME 8.x on a 3800 ISR,  and a couple of 6921 phones.  Two of them have ~8.5.3 code, the others  have 9.x code (phone loads).  If I'm understanding things correctly, the  phone should be downloading the published phone load via TFTP from CME  if what it has already installed doesn't match (either an upgrade or  downgrade).

So here's what I'm seeing.

The scenario:

The phone load files exist in a folder on the flash. (/phone).

The TFTP server is configured with the appropriate information on the loads (and aliasing the path)

tftp-server flash:/phone/BOOT69xx.0-0-0-14.zz alias BOOT69xx.0-0-0-14.zz
tftp-server flash:/phone/DSP69xx.0-0-0-3.zz alias DSP69xx.0-0-0-3.zz
tftp-server flash:/phone/SCCP69xx.8-5-3-0.zz alias SCCP69xx.8-5-3-0.zz

TFTP is working fine, I've tested it with a TFTP client.

Telephony services is configured with the name of the load load 6921 SCCP69xx.8-5-3-0

telephony-service

  load 6921 SCCP69xx.8-5-3-0


The ephones are configured to use a common ephone template, and are configured as the proper model.

The problem:

The  phone will power on, request the CNF files, request the SCCP*.loads  file, and then just when I think it'll download the actual load itself  (.zz file), the phone registers, and that's it.  Nothing I do seems to  force the phone to kick into upgrade mode. It just jumps straight into  SCCP registration.

What  gives? I don't see anything that I'm doing wrong here.   I've tried  deleting and recrating the CNF files, no dice. I've tried resetting the  phone to factory defaults, no dice .Watching wireshark, it's asking for  and receiving the SCCP69xx.8-5-3-0.loads file (which has the correct .zz  files listed in it - this is all stock CME stuff) but those .zz files  are never requested or transferred via TFTP.

Would love some thoughts on this.

11 REPLIES
Hall of Fame Super Gold

Re: CME Phone Load Upgrade issue

can you try

load 6921 SCCP69xx.8-5-3-0.loads

You can take "debug tftp events", no need for packet capture.

New Member

Re: CME Phone Load Upgrade issue

I have also tried that variation (saw the note on using the file extension for recent versions). Didn't seem to make a difference.

I see the 'loads' file being successfully downloaded via TFTP. The file has the list of the binaries.  The phone just never tries to download the binaries.

Cisco Employee

Re: CME Phone Load Upgrade issue

Under telephony service in config mode do

no create cnf-files

create cnf-files

hope this helps....

New Member

Re: CME Phone Load Upgrade issue

Been there. Done that. No dice.

Is there a more advanced / better debug technique for this - at the stage I'm at?


Oct  5 13:59:18.928: TFTP: Looking for CTLSEPF866F2E7AC3F.tlv
Oct  5 13:59:18.940: TFTP: Looking for SEPF866F2E7AC3F.cnf.xml
Oct  5 13:59:18.944: TFTP: Opened flash:/its/vrf1/XMLDefault6921.cnf.xml, fd 13, size 1365 for process 96
Oct  5 13:59:18.948: TFTP: Finished flash:/its/vrf1/XMLDefault6921.cnf.xml, time 00:00:00 for process 96
Oct  5 13:59:19.372: TFTP: Looking for English_United_States/rtl-sccp.jar
Oct  5 13:59:19.384: TFTP: Looking for United_States/g3-tones.xml
Oct  5 13:59:19.396: TFTP: Looking for SCCP69xx.8-5-3-0.loads
Oct  5 13:59:19.396: TFTP: Opened flash:/phone/SCCP69xx.8-5-3-0.loads, fd 13, size 61 for process 96
hamil11a#
Oct  5 13:59:19.400: TFTP: Finished flash:/phone/SCCP69xx.8-5-3-0.loads, time 00:00:00 for process 96
hamil11a#
Oct  5 13:59:22.440: %IPPHONE-6-REG_ALARM: 25: Name=SEPF866F2E7AC3F Load=9.0.2 Last=Initialized
Oct  5 13:59:22.640: %IPPHONE-6-UNREGISTER_ABNORMAL: ephone-3:SEPF866F2E7AC3F IP:10.79.76.13 Socket:1 DeviceType:Phone has unregistered abnormally.
Oct  5 13:59:22.640: %IPPHONE-6-REGISTER: ephone-3:SEPF866F2E7AC3F IP:10.79.76.13 Socket:5 DeviceType:Phone has registered.

Hall of Fame Super Red

Re: CME Phone Load Upgrade issue

Hey folks,

Is it possible that the 8.5.3 Firmware is not "signed"??

Note A direct upgrade from firmware release 9.0(2) to 9.0(3a) is supported. After you upgrade from an earlier firmware release to 9.0(3a) and for subsequent firmware releases, you can upgrade or downgrade only to signed firmware releases.

http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/6921_6941_6961/firmware/9_0_3/english/release/notes/6900_903.html

Cheers!

Rob

New Member

Re: CME Phone Load Upgrade issue

I'm not sure how to answer that.  The new phones are 9.0.2.  The old phones are 8.5.3.   Would the new phones being at 9.0.2 prevent a rollback to 8.5.3 ? If so, am I forced to go beyond 8.5.3 to allow me to have all of my phones running the same load?.

You've got my wheels turning.  Let me take a signed 8.5.3 and place that on the system instead of what came bundled, set it up, and see if an upgrade kicks off.

Anybody else got anything more to add?

New Member

Re: CME Phone Load Upgrade issue

Well that was a goose chase.   Feel free to chime in if i'm wrong - but... the SBN files are  'intended' for call manager only, right? The file listed on the downloads page for CUCME is a zip file. The contents of that file are the load files that shipped with the CME install.  So back to square zero.

Do I use this file anyway - and change what's listed as the binary image inside the loads file? Do I get another loads file? Am I doing this weird?

This should be the most straightforward thing in the world. Why am I fighting with it? Gotta be something simple.

Thoughts?

New Member

Re: CME Phone Load Upgrade issue

Ok so I did a little more reading, and I have a better handle (I think) on how CUCME is handling signed binaries.  Let me say that the files I've got on the CME are unsigned (I'm basing this on the .zz file extension).   I believe that if they were signed, that they would be .zz.sgn files.  I'm basing that on this - that's the file naming convention inside a 9.x zip that I just downloaded.

So the question then becomes - are my 9.0.2 phones signed or unsigned images.   How do I tell if I don't know what loaded the images?

Maybe I'll download the image from CCO and look in the zip and see if they're .zz's or .zz.sgn's. 

Feel free to chime in at any time.

j

Hall of Fame Super Red

Re: CME Phone Load Upgrade issue

Hi J,

The 9.0(2) images will be signed

Note After you upgrade from firmware release 8.5(4) to 9.0(2) and for subsequent firmware releases, you can upgrade or downgrade only to signed firmware releases.

http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/6921_6941_6961/firmware/9_0_2/english/release/notes/6900_902.html#wp179277

Cheers!

Rob

New Member

Re: CME Phone Load Upgrade issue

Grumble Grumble.  I found it.

Signed loads was the key.   These phones came factory with 9.0.2 signed loads. Which means they can't roll back to what my deployed CME version of code is, because it's unsigned.  It rolled forward just fine to signed code.  I imagine it would roll back fine to signed code (will test that theory tomorrow).

New Member

Re: CME Phone Load Upgrade issue

i have the same issue.

i got 9.0.2 load on my 6961 phone working with cme8.0.

i've tried to downgrade with no avail to 8.5.3 (unsigned).

when i tried to downgrade to the signed 853 ver. i've noticed in the readme file that the signed loads are not for cme but only for cucm.

i guess the only option is to somehow delete the current version and then start from scratch...

any thoughts?

1983
Views
0
Helpful
11
Replies
CreatePlease login to create content