Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CME SIP configuration

I've a CME (3845) with couple of phones registered to it. Im trying to connect it to HIQ (call agent)

Phone 5001

Phone 5002   Call Manager Express 172.17.2.6 }  - - - -SIP CONNECT INTERFACE ----{ 172.17.2.226 HIQ/Siemens } {phone 140858214XX}

Phone 5003     

Kindly brief me on what all I need to configure?

Regards,

Sylvester

----------------------------------------

User Access Verification

Password:

CME>en

Password:

CME#

CME#

CME#show run

Building configuration...

Current configuration : 5229 bytes

!

! Last configuration change at 11:45:39 UTC Fri Dec 4 2009

! NVRAM config last updated at 11:42:14 UTC Fri Dec 4 2009

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CME

!

boot-start-marker

boot-end-marker

!

! card type command needed for slot/vwic-slot 0/3

logging message-counter syslog

enable secret 5 $1$zRDc$kVJuuxoegWPZI2kTqjAFt0

!

no aaa new-model

no network-clock-participate slot 4

no network-clock-participate wic 1

!

ip source-route

ip cef

!

!

!

!

no ip domain lookup

no ipv6 cef

ntp master

multilink bundle-name authenticated

!

!

!

!

voice-card 0

!

voice-card 4

!

!

!

voice service voip

allow-connections sip to sip

redirect ip2ip

fax protocol cisco

sip

  registrar server

  no call service stop

!

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

!

!

!

!

!

!

!

!

!

!

!

voice register global

mode cme

source-address 172.17.2.6 port 5060

max-dn 10

max-pool 10

load 7960-7940 P0S3-06-0-00

authenticate register

tftp-path flash:

file text

create profile sync 0002270562017059

!

voice register dn  1

number 5001

!

voice register dn  2

number 5002

!

voice register pool  1

id mac 0000.0000.0000

number 1 dn 1

username 5001 password 5001

codec g711ulaw

!

voice register pool  2

id mac 0000.0000.0000

number 1 dn 2

username 5002 password 5002

codec g711ulaw

!

!

voice translation-rule 1

rule 1 /14085821475/ /5001/

!

!

voice translation-profile AutoAttendant

translate called 1

!

!

!

!

archive

log config

  hidekeys

!

!

controller E1 0/1/0

!

controller E1 0/1/1

!

no ip ftp passive

ip ftp source-interface GigabitEthernet0/0

ip ftp username cisco

ip ftp password cisco123

!

!

!

!

interface GigabitEthernet0/0

ip address 172.17.2.6 255.255.255.0

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

media-type rj45

!

interface Serial0/0/0

no ip address

shutdown

!

interface Serial0/2/0

no ip address

shutdown

clock rate 2000000

!

interface Serial0/2/1

no ip address

shutdown

clock rate 2000000

!

interface FastEthernet1/0

!

interface FastEthernet1/1

!

interface FastEthernet1/2

!

interface FastEthernet1/3

!

interface FastEthernet1/4

!

interface FastEthernet1/5

!

interface FastEthernet1/6

!

interface FastEthernet1/7

!

interface FastEthernet1/8

!

interface FastEthernet1/9

!

interface FastEthernet1/10

!

interface FastEthernet1/11

!

interface FastEthernet1/12

!

interface FastEthernet1/13

!

interface FastEthernet1/14

!

interface FastEthernet1/15

!

interface Service-Engine2/0

no ip address

shutdown

!

interface Vlan1

no ip address

!

ip default-gateway 172.17.2.1

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 172.17.2.1

ip route 172.17.1.0 255.255.255.0 172.17.2.1

!

!

ip http server

ip http path flash:

!

!

!

tftp-server flash:RingList.xml

tftp-server flash:term65.default.loads

tftp-server flash:P0S3-06-0-00.bin

tftp-server flash:P0S3-06-0-00.sbn

tftp-server flash:P003-8-12-00.sbn

tftp-server flash:ATA030201SIP050616A.zup

!

control-plane

!

!

!

voice-port 4/0/0

connection plar 1001

caller-id enable

!

voice-port 4/0/1

!

voice-port 4/1/0

!

voice-port 4/1/1

!

!

mgcp fax t38 ecm

mgcp behavior g729-variants static-pt

!

!

!

dial-peer voice 5002 voip

preference 1

destination-pattern 5...

b2bua

session protocol sipv2

session target ipv4:172.17.2.6

dtmf-relay sip-notify

playout-delay maximum 300

codec g711ulaw

no vad

!

dial-peer voice 5001 voip

preference 1

destination-pattern 5...

b2bua

session protocol sipv2

session target ipv4:172.17.2.6

dtmf-relay sip-notify

playout-delay maximum 300

codec g711ulaw

no vad

!

dial-peer voice 1 voip

description **Incoming call from HiQ**

translation-profile incoming AutoAttendant

session protocol sipv2

session target ipv4:172.17.2.226

incoming called-number 1408582....

dtmf-relay rtp-nte

no vad

!

dial-peer voice 2 voip

description **Outgoing calls to HiQ**

destination-pattern 9[0-1]..........

session protocol sipv2

session target ipv4:172.17.2.225

dtmf-relay rtp-nte

no vad

!

dial-peer voice 1408 voip

description **to Hiq**

destination-pattern 14085821475

voice-class codec 1

session protocol sipv2

session target ipv4:172.17.2.225

dtmf-relay rtp-nte

no vad

!

!

gateway

timer receive-rtp 1200

!

sip-ua

authentication username 14085821400 password 7 124851474A5E54567B7F7478

no remote-party-id

retry invite 2

retry register 10

timers connect 100

registrar ipv4:172.17.2.6 expires 3600

sip-server ipv4:172.17.2.225

host-registrar

!

!

gatekeeper

shutdown

!

!

telephony-service

no auto-reg-ephone

max-ephones 10

max-dn 10

ip source-address 172.17.2.6 port 5060

load 7960-7940 P003-8-12-00

load ata ATA030201SIP050616A

max-conferences 4 gain -6

web admin system name admin password cisco

dn-webedit

time-webedit

transfer-system full-consult

login timeout 10

create cnf-files version-stamp 7960 Dec 02 2009 10:11:18

!

banner exec ^C^C

!

line con 0

line aux 0

line 130

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120

line vty 0 4

password letmein

login

!

scheduler allocate 20000 1000

end

CME#

2 REPLIES

Re: CME SIP configuration

I can't help with the Siemans, but this link might help get you going:

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_configuration_example09186a00808f9666.shtml

-- please remember to rate and mark answered helpful posts --
New Member

Re: CME SIP configuration

Ok done Deal. I was trying to configure "SIP CONNECT INTERFACE"

Now, I have the users created in Hiq, and same users gets registered on CME, (both SIP and SCCP) , now working on h323. If i can get that working, will post.

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol cisco

sip

  registrar server

  asserted-id pai

  no call service stop

!

!

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g723r63

codec preference 3 g711ulaw

codec preference 4 g711alaw

codec preference 5 g728

codec preference 6 g726r16

!

voice register global
mode cme
source-address 172.17.2.6 port 5060
max-dn 5
max-pool 5
authenticate register
tftp-path flash:
create profile sync 0006854282049246
!
voice register dn  1
number 1408xxx1483
!
voice register dn  2
number 1408xxx1484
!
voice register pool  1
id mac 0000.0000.0000
number 1 dn 1
username 1408xxx1483 password 1408xxx1483
codec g711ulaw
!
voice register pool  2
id mac 0000.0000.0000
number 1 dn 2
username 1408xxx1484 password 1408xxx1484
codec g711ulaw
!
!
dial-peer voice 1 voip
description "Outgoing calls to HIQ"
destination-pattern 1408xxx....
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
no vad
!
dial-peer voice 2 voip
description "calls coming from Hiq"
voice-class codec 1
session protocol sipv2
session target ipv4:172.17.2.6
incoming called-number 1408.......
!
!
gateway
timer receive-rtp 1200
!
sip-ua
credentials username 1408xxx1480 password 7 0870181E514C5D45435F5454 realm 172.17.2.225
no remote-party-id
retry invite 2
retry register 10
retry options 2
timers connect 100
mwi-server ipv4:172.17.2.225 expires 1800 port 5060 transport udp unsolicited
registrar ipv4:172.17.2.225 expires 1800
sip-server ipv4:172.17.2.225
notify telephone-event max-duration 500
!
!
gatekeeper
shutdown
!
!
telephony-service
max-ephones 3
max-dn 3
ip source-address 172.17.2.6 port 2000
auto assign 1 to 3
load 7960-7940 P003-8-12-00
dialplan-pattern 1 1408xxx1... extension-length 4
max-conferences 12 gain -6
transfer-system full-consult
create cnf-files version-stamp 7960 Dec 08 2009 10:30:21
!
!
ephone-dn  1  dual-line
number 1480 no-reg primary
!
!
ephone-dn  2  dual-line
number 1481 no-reg both
!
!
ephone-dn  3  dual-line
number 1482
!
!
ephone  1
no phone-ui speeddial-fastdial
no phone-ui snr
no multicast-moh
mac-address 001C.234F.BD80
keepalive 30 auxiliary 0
codec g729r8 pre-ietf
type CIPC
button  1:1 2:2
!
!
!
ephone  2
no phone-ui speeddial-fastdial
no phone-ui snr
no multicast-moh
keepalive 30 auxiliary 0
!
!
!
ephone  3
no phone-ui speeddial-fastdial
no phone-ui snr
no multicast-moh
keepalive 30 auxiliary 0
!

4790
Views
0
Helpful
2
Replies