Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CME-SRST voice hunt-group doesn't work if phones haven't registered

I have a gateway configured with CME-SRST, using voice hunt-groups, on IOS 12.4.22T5.  I ran into an interesting scenario and am wondering if anyone else has seen this.

My configuration:

voice hunt-group 1 parallel

pilot 8001

list 7002,7003

final 7010

!

!

7002,7003, and 7010 are phone DNs. 

     Scenario 1:  Phone 1 with DN 7010 is registered to the gateway in cme-srst mode, but not phones with DNs 7002 or 7003 - these phones have never been registered to the gateway.  When I call 8001, I get a fast busy, and the gateway displays the following message: %IVR-1-APP_PARALLEL_INVALID_LIST: Call terminated.  Huntgroup '1' does not contain enough valid SIP end-points to proceed with a parallel call.

     Scenario 2: I register phone 7002 to the gateway in cme-srst mode.  Now when I call 8001, it rings on phone 7002, and if I do not answer, it rolls to 7010 just fine.

     Scenario 3: I unplug phone 7002, so it unregisters from the gateway.  However, the command "show ephone unreg" displays that ephone configuration.  When I call 8001, it follows the "final 7010" command and rings on my phone with DN 7010.

It appears that a voice hunt-group will NOT follow the final command unless the DN's specified in the list have been registered at least once to the gateway.  When I do nested hunt-groups, where the final command points to the pilot for another hunt-group, the call actually hangs if the second hunt-group's list members have never been registered and I have to restart the phone that placed the call. 

I have a customer with many CIPC phones, desiring multiple hunt groups for the CIPC phones, rolling from one hunt group to the next.  It is  quite possible that none of the CIPCs in the first hunt group will  register (computers shut off), and based on my testing, the call will  never roll to the following hunt groups using the "final" command if phones in the list for the first hunt group have never registered.

Has anyone else tested this, and determined a way to have a hunt-group to follow the "final" command if the phones in the hunt-group have never been registered? 

2 REPLIES

CME-SRST voice hunt-group doesn't work if phones haven't registe

Hi.

Under call-manager-fallback  have you tried to use alias command?

Eg.

alias 1 8001 to 7002 cfw 7003 timeout 10

HTH

Regards

Carlo

Please rate all helpful posts "The more you help the more you learn"
New Member

CME-SRST voice hunt-group doesn't work if phones haven't registe

I was specifically using voice hunt-groups with cme-srst to ring as many phones as possible at the same time (parallel or blast hunt group), without using shared lines.

I did find a workaround for this - apparently all the gateway cares about is having an ephone configuration for at least one of the DNs in the list for the hunt-group.  Manually adding a dummy ephone to the gateway and making sure it's dn was in each list allows the "final" command to work now, even if no real phones for the hunt-group list have ever registered to the gateway.

1701
Views
0
Helpful
2
Replies
CreatePlease to create content