Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

CME to CME SIP Trunk

Hi,

I'm tryng to accomplish a Sip trunk between two CME version 15.1(3)T3. From CME2 to CME1 worked but from CME1 to CME2 didn't worked, after the phone is dialed a busy tone is received and I got a Sip message SIP/2.0 403 Forbidden.

                 SIP

CME1 <--------------> CME2

This is my setup:

CME 1
======
voice service voip
sip

dial-peer voice 101 voip
destination-pattern 2...
session protocol sipv2
session target ipv4:192.168.2.1
incoming called-number 3...

CME 2
======
voice service voip
sip

dial-peer voice 100 voip
destination-pattern 3...
session protocol sipv2
session target ipv4:192.168.3.2
incoming called-number 2...

Error Message:

===========

CME-Lab#
Jun 22 13:25:40.638: //156/97A6AFBC8162/SIP/Msg/ccsipDisplayMsg:
Sent:
INVITE sip:3001@192.168.3.2:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.3.1:5060;branch=z9hG4bK12EE4
Remote-Party-ID: <sip:2001@192.168.3.1>;party=calling;screen=no;privacy=off
From: <sip:2001@192.168.3.1>;tag=5325EE4-DEF
To: <sip:3001@192.168.3.2>
Date: Fri, 22 Jun 2012 13:25:40 GMT
Call-ID: 988D6623-BBA411E1-8167D777-3B5C90F4@192.168.3.1
Supported: 100rel,timer,resource-priority,replaces,sdp-anat
Min-SE:  1800
Cisco-Guid: 2544283580-3148091873-2170738551-0995922164
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Max-Forwards: 70
Timestamp: 1340371540
Contact: <sip:2001@192.168.3.1:5060>
Expires: 180
Allow-Events: telephone-event
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 234

v=0
o=CiscoSystemsSIP-GW-UserAgent 793 8771 IN IP4 192.168.3.1
s=SIP Call
c=IN IP4 192.168.3.1
t=0 0
m=audio 16452 RTP/AVP 18 19
c=IN IP4 192.168.3.1
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:19 CN/8000
a=ptime:20

Jun 22 13:25:40.858: //156/97A6AFBC8162/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 192.168.3.1:5060;branch=z9hG4bK12EE4
From: <sip:2001@192.168.3.1>;tag=5325EE4-DEF
To: <sip:3001@192.168.3.2>
Date: Fri, 22 Jun 2012 13:24:39 GMT
Call-ID: 988D6623-BBA411E1-8167D777-3B5C90F4@192.168.3.1
Timestamp: 1340371540
CSeq: 101 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0


Jun 22 13:25:40.914: //156/97A6AFBC8162/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 403 Forbidden
Via: SIP/2.0/UDP 192.168.3.1:5060;branch=z9hG4bK12EE4
From: <sip:2001@192.168.3.1>;tag=5325EE4-DEF
To: <sip:3001@192.168.3.2>;tag=89D94E8-120
Date: Fri, 22 Jun 2012 13:24:39 GMT
Call-ID: 988D6623-BBA411E1-8167D777-3B5C90F4@192.168.3.1
Timestamp: 1340371540
CSeq: 101 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Reason: Q.850;cause=21
Content-Length: 0


Jun 22 13:25:40.930: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
ACK sip:3001@192.168.3.2:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.3.1:5060;branch=z9hG4bK12EE4
From: <sip:2001@192.168.3.1>;tag=5325EE4-DEF
To: <sip:3001@192.168.3.2>;tag=89D94E8-120
Date: Fri, 22 Jun 2012 13:25:40 GMT
Call-ID: 988D6623-BBA411E1-8167D777-3B5C90F4@192.168.3.1
Max-Forwards: 70
CSeq: 101 ACK
Allow-Events: telephone-event
Content-Length: 0

CME1 Show Run:

============

CME-Legacy#show run
Building configuration...


Current configuration : 2887 bytes
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-Legacy
!
boot-start-marker
boot-end-marker
!
!
card type t1 0 3
enable secret 5 $1$0iFd$Um7r8JhKS6fMrEpFH64rB0
!
no aaa new-model
!
network-clock-participate wic 3
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-qsig
!
!
!
voice service voip
sip
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
codec preference 3 g729br8
codec preference 4 g711alaw
!
!
!
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn FHK1246F3KE
archive
log config
  hidekeys
!
redundancy
!
!
controller DSL 0/0/0
!
controller T1 0/3/0
clock source internal
cablelength long 0db
pri-group timeslots 1-2,24
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.100.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.4.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/2/0
ip address 192.168.3.2 255.255.255.0
encapsulation ppp
!
interface Serial0/2/1
no ip address
shutdown
clock rate 2000000
!
interface Serial0/3/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-qsig
isdn incoming-voice voice
no cdp enable
!
!
router eigrp 1
network 192.168.3.0
network 192.168.4.0
network 192.168.100.0
auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging esm config
!
!
!
!
!
!
control-plane
!
!
voice-port 0/3/0:23
!
voice-port 0/1/0
!
voice-port 0/1/1
!
!
mgcp fax t38 ecm
!
mgcp profile default
!
sccp local Loopback0
sccp ccm 192.168.100.1 identifier 1 priority 1 version 7.0
sccp
!
sccp ccm group 1
bind interface Loopback0
associate ccm 1 priority 1
associate profile 1 register CME-TRANSC
!
dspfarm profile 1 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
codec g723r53
maximum sessions 2
associate application SCCP
!
dial-peer voice 3001 pots
destination-pattern 3001
port 0/1/0
!
dial-peer voice 3002 pots
destination-pattern 3002
port 0/1/1
!
dial-peer voice 101 voip
destination-pattern 2...
session protocol sipv2
session target ipv4:192.168.2.1
incoming called-number 3...
!
!
!
!
telephony-service
sdspfarm units 5
sdspfarm transcode sessions 2
sdspfarm tag 1 CME-TRANSC
em logout 0:0 0:0 0:0
max-ephones 4
max-dn 4
ip source-address 192.168.100.1 port 2000
max-conferences 8 gain -6
transfer-system full-consult
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
!
line con 0
password leoleo
login
line aux 0
line vty 0 4
password leoleo
login
transport input all
!
scheduler allocate 20000 1000
end

CME-Legacy#

CME2 Show Run

============

CME-Lab#show run
Building configuration...


Current configuration : 7775 bytes
!
! No configuration change since last restart
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-Lab
!
boot-start-marker
boot system flash c2800nm-adventerprisek9-mz.151-3.T3.bin
boot-end-marker
!
!
card type t1 0 2
enable secret 5 $1$jJ.7$b/Yaq0M36fgZSrYpCK5LD/
!
no aaa new-model
!
clock timezone LAPAZ -4 0
network-clock-participate wic 2
!
dot11 syslog
ip source-route
!
!
ip cef
!
ip dhcp excluded-address 192.168.1.1 192.168.1.20
ip dhcp excluded-address 192.168.2.1 192.168.2.20
ip dhcp excluded-address 192.168.3.1 192.168.3.20
ip dhcp excluded-address 192.168.6.1 192.168.6.20
!
ip dhcp pool DATA
   network 192.168.1.0 255.255.255.0
   option 150 ip 192.168.2.1
   default-router 192.168.1.1
!
ip dhcp pool VOZ-CME
   network 192.168.2.0 255.255.255.0
   option 150 ip 192.168.2.1
   default-router 192.168.2.1
!
ip dhcp pool VOZ-CUCM
   network 192.168.6.0 255.255.255.0
   option 150 ip 192.168.6.10
   default-router 192.168.6.1
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-qsig
!
!
!
voice service voip
sip
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
codec preference 3 g729br8
codec preference 4 g711alaw
!
!
!
!
voice translation-rule 1
rule 1 /3.../ /1809544\0/
!
voice translation-rule 100
rule 1 /2/ /1002/
!
voice translation-rule 101
rule 1 /1002/ /2/
!
!
voice translation-profile SITE-CODE-CallerID
translate calling 100
!
voice translation-profile SITE-CODE-DNIS
translate called 101
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn FHK1225F3GX
archive
log config
  hidekeys
!
redundancy
!
!
controller T1 0/2/0
clock source internal
cablelength long 0db
pri-group timeslots 1-2,24
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id zone1 ipaddr 192.168.4.1 1719
h323-gateway voip h323-id CME-Lab
h323-gateway voip bind srcaddr 192.168.2.1
!
interface FastEthernet0/0.11
encapsulation dot1Q 11
ip address 192.168.6.1 255.255.255.0
!
interface FastEthernet0/0.50
encapsulation dot1Q 50
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.3.1 255.255.255.0
encapsulation ppp
clock rate 64000
!
interface Serial0/0/1
no ip address
shutdown
clock rate 2000000
!
interface Serial0/2/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-qsig
isdn timer T310 120000
isdn protocol-emulate network
isdn incoming-voice voice
no cdp enable
!
!
router eigrp 1
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
network 192.168.6.0
auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging esm config
!
!
!
!
!
tftp-server flash:/PHONE/6921_6941_6961/Sccp/cmterm-69xx-sccp.9-2-1-0.tar alias cmterm-69xx-sccp        .9-2-1-0.tar
tftp-server flash:/PHONE/6921_6941_6961/Sccp/BOOT69xx.0-0-0-14.zz.sgn alias BOOT69xx.0-0-0-14.zz        .sgn
tftp-server flash:/PHONE/6921_6941_6961/Sccp/SP69xx.0-0-0-8.zz.sgn alias SP69xx.0-0-0-8.zz.sgn
tftp-server flash:/PHONE/6921_6941_6961/Sccp/SCCP69xx.9-2-1-0.loads alias SCCP69xx.9-2-1-0.loads
tftp-server flash:/PHONE/6921_6941_6961/Sccp/SCCP69xx.9-2-1-0.zz.sgn alias SCCP69xx.9-2-1-0.zz.s        gn
tftp-server flash:/PHONE/7942_7962/Sccp/apps42.9-2-1TH1-13.sbn alias apps42.9-2-1TH1-13.sbn
tftp-server flash:/PHONE/7942_7962/Sccp/cnu42.9-2-1TH1-13.sbn alias cnu42.9-2-1TH1-13.sbn
tftp-server flash:/PHONE/7942_7962/Sccp/cvm42sccp.9-2-1TH1-13.sbn alias cvm42sccp.9-2-1TH1-13.sb        n
tftp-server flash:/PHONE/7942_7962/Sccp/dsp42.9-2-1TH1-13.sbn alias dsp42.9-2-1TH1-13.sbn
tftp-server flash:/PHONE/7942_7962/Sccp/jar42sccp.9-2-1TH1-13.sbn alias jar42sccp.9-2-1TH1-13.sb        n
tftp-server flash:/PHONE/7942_7962/Sccp/SCCP42.9-2-1S.loads alias SCCP42.9-2-1S.loads
tftp-server flash:/PHONE/7942_7962/Sccp/term42.default.loads alias term42.default.loads
tftp-server flash:/PHONE/7942_7962/Sccp/term62.default.loads alias term62.default.loads
tftp-server flash:/PHONE/7945_7965/Sccp/cmterm-7945_7965-sccp.9-2-1.tar alias cmterm-7945_7965-s        ccp.9-2-1.tar
tftp-server flash:/PHONE/7945_7965/Sccp/apps45.9-2-1TH1-13.sbn alias apps45.9-2-1TH1-13.sbn
tftp-server flash:/PHONE/7945_7965/Sccp/cnu45.9-2-1TH1-13.sbn alias cnu45.9-2-1TH1-13.sbn
tftp-server flash:/PHONE/7945_7965/Sccp/cvm45sccp.9-2-1TH1-13.sbn alias cvm45sccp.9-2-1TH1-13.sb        n
tftp-server flash:/PHONE/7945_7965/Sccp/dsp45.9-2-1TH1-13.sbn alias dsp45.9-2-1TH1-13.sbn
tftp-server flash:/PHONE/7945_7965/Sccp/jar45sccp.9-2-1TH1-13.sbn alias jar45sccp.9-2-1TH1-13.sb        n
tftp-server flash:/PHONE/7945_7965/Sccp/SCCP45.9-2-1S.loads alias SCCP45.9-2-1S.loads
tftp-server flash:/PHONE/7945_7965/Sccp/term45.default.loads alias term45.default.loads
tftp-server flash:/PHONE/7945_7965/Sccp/term65.default.loads alias term65.default.loads
tftp-server flash:/PHONE/6921_6941_6961/Sccp/DSP69xx.0-0-0-8.zz.sgn alias DSP69xx.0-0-0-8.zz.sgn
!
control-plane
!
!
voice-port 0/2/0:23
!
voice-port 0/1/0
signal groundStart
station-id name Leo Salcie
caller-id enable
!
voice-port 0/1/1
!
voice-port 0/3/0
!
voice-port 0/3/1
!
voice-port 0/3/2
!
voice-port 0/3/3
!
!
mgcp fax t38 ecm
!
mgcp profile default
!
sccp local FastEthernet0/0.10
sccp ccm 192.168.2.1 identifier 1 priority 1 version 4.1
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate profile 1 register CME-TRANSC
!
dspfarm profile 1 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729br8
codec g723r53
maximum sessions 4
associate application SCCP
!
dial-peer cor custom
name 911call
name localcall
name ldcall
!
!
dial-peer cor list 911call
member 911call
!
dial-peer cor list LD
member 911call
member localcall
member ldcall
!
dial-peer cor list localcall
member localcall
!
dial-peer cor list ldcall
member ldcall
!
dial-peer cor list LOCAL
member localcall
!
!
dial-peer voice 9809 pots
corlist outgoing localcall
destination-pattern 99809.......
port 0/3/0
forward-digits 11
!
dial-peer voice 91809 pots
corlist outgoing ldcall
destination-pattern 991809.......
port 0/3/0
forward-digits 12
!
dial-peer voice 100 voip
destination-pattern 3...
session protocol sipv2
session target ipv4:192.168.3.2
incoming called-number 2...
!
!
!
!
telephony-service
sdspfarm units 5
sdspfarm transcode sessions 4
sdspfarm tag 1 CME-TRANSC
em logout 0:0 0:0 0:0
max-ephones 12
max-dn 12
ip source-address 192.168.2.1 port 2000
auto assign 1 to 6
load 7965 SCCP45.9-2-1S
max-conferences 8 gain -6
transfer-system full-consult
create cnf-files version-stamp 7960 Jun 21 2012 09:37:02
!
!
ephone-dn  1
number 2001
!
!
ephone-dn  2
number 2002
!
!
ephone-dn  3
number 2003
!
!
ephone-dn  4
number 2004
!
!
ephone-dn  5
number 2005
!
!
ephone-dn  6
number 2006
!
!
ephone-dn  9  dual-line
number 9999
!
!
ephone  1
device-security-mode none
mac-address 503D.E5E9.2001
max-calls-per-button 2
type 6921
button  1:1
!
!
!
ephone  2
device-security-mode none
mac-address 64A0.E715.F5B2
type 7965
button  1:2
!
!
!
ephone  5
device-security-mode none
mac-address 503D.E52F.C3E4
max-calls-per-button 2
button  1:3
!
!
!
ephone  9
device-security-mode none
mac-address 00F0.1D00.0081
!
!
!
ephone  99
device-security-mode none
mac-address AABB.CC11.2233
button  1:9
!
!
!
!
line con 0
line aux 0
line vty 0 4
password leoleo
login
transport input all
!
scheduler allocate 20000 1000
ntp master 3
ntp server 192.168.2.1
end

CME-Lab#$

Any help would be appreciated

Regards

Please remember to rate useful posts clicking on the stars below. Favor calificar todos las respuestas útiles dando click en las estrellas de mas abajo. ___________________________________________ LinkedIn Profile: do.linkedin.com/in/leosalcie
Everyone's tags (6)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Super Bronze

Re: CME to CME SIP Trunk

Hi Leo,

on cme 1

configure

voice service voip                                   

    ip address trusted list                             

     ipv4 --where ipv4 is the ip address of cme 2

Or configure

voice service voip                                   

    ip address trusted list                             

ipv4 0.0.0.0 0.0.0.0 (to allow all IPs)

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
4 REPLIES
VIP Super Bronze

Re: CME to CME SIP Trunk

Hi Leo,

on cme 1

configure

voice service voip                                   

    ip address trusted list                             

     ipv4 --where ipv4 is the ip address of cme 2

Or configure

voice service voip                                   

    ip address trusted list                             

ipv4 0.0.0.0 0.0.0.0 (to allow all IPs)

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

CME to CME SIP Trunk

It worked!!!

So why from CME 2 was denying the call and CME 1 accepted the call? I would like to know if I must to setup this always, I never saw this in the book checked.

I always like to know the eassiest way do make things...

Please remember to rate useful posts clicking on the stars below. Favor calificar todos las respuestas útiles dando click en las estrellas de mas abajo. ___________________________________________ LinkedIn Profile: do.linkedin.com/in/leosalcie
VIP Super Bronze

CME to CME SIP Trunk

Leo,

The simple reason is that CME2 didnt have CME 1 in its ip address trust list.

If you issue a sh ip address trust list, you will see the ips that the gateway will accept call from. Any IP that is not in the trust list will be denied. And thats what the cause code 21 is for.

If it worked then for the benefit of others its good to mark the post answered.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

CME to CME SIP Trunk

Thanks for you help!!!

Regards

Please remember to rate useful posts clicking on the stars below. Favor calificar todos las respuestas útiles dando click en las estrellas de mas abajo. ___________________________________________ LinkedIn Profile: do.linkedin.com/in/leosalcie
4002
Views
15
Helpful
4
Replies