Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CME to CUCM - one way calling problem

Hello there,

I have set up VoIP dialplan between a CME (or CUCME) and CUCM, I don't control CUCM but only CME. The thing is that when I try to call from an extension on CME to an extension on CUCM I get busy reorder tone however the other way around the call is being established just fine.

What do I need to check out on the CME? What I noticed on CME while debugging the call I get Disconnet Cause=49 and this I think is related to QoS correct? How can I interpret that?

Thanks in advance for any suggestions.

Regards,

6 REPLIES
Silver

Could you post your CME

Could you post your CME config?

BR,

Dragan

HTH, Dragan
New Member

Thanks for a quick replay,

Thanks for a quick replay, sure I post it below:

 

CME#sh run
Building configuration...

Current configuration : 14360 bytes
!
! Last configuration change at 16:14:38 UTC Fri Apr 4 2014
! NVRAM config last updated at 16:14:39 UTC Fri Apr 4 2014
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
service internal
!
!
boot-start-marker
boot-end-marker
!
card type e1 0 0

!
aaa new-model
!
!
aaa authentication login VTY_ACCESS local
!
!
aaa session-id common
clock timezone UTC -6
clock summer-time CDT recurring 1 Sun Apr 2:00 last Sun Oct 2:00
no network-clock-participate wic 0
no ip source-route
no ip gratuitous-arps
!
!
ip cef
ip dhcp relay information trust-all
no ip dhcp use vrf connected
ip dhcp bootp ignore

!
!
!
no ip domain lookup
ip domain name android.com
ip multicast-routing
multilink bundle-name authenticated
!
!
!
trunk group  1
!
!
trunk group  ALL_FXO
 max-retry 5
 voice-class cause-code 1
 hunt-scheme longest-idle
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
!         
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
  h225 connect-passthru
 modem passthrough nse codec g711ulaw
 sip
  no update-callerid
!
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
 codec preference 3 g729br8
!
!
!
voice class h323 1
 h225 timeout tcp establish 2
 h225 timeout setup 3
!
!
!
voice class dualtone-detect-params 1
 freq-max-deviation 15
!
!
voice class custom-cptone CCAjointone
 dualtone conference
  frequency 600 900
  cadence 300 150 300 100 300 50
!
!
voice class custom-cptone CCAleavetone
 dualtone conference
  frequency 400 800
  cadence 400 50 200 50 200 50
!
!
voice class custom-cptone fxo
 dualtone disconnect
  frequency 425
  cadence 240 240
!
!
!
!
!
!
!
!
voice translation-rule 1000
 rule 1 /^9/ //
!
voice translation-rule 2000
 rule 1 // /8000/
!
!
voice translation-profile INCOMING_TRANSLATION_PROFILE
 translate called 2000
!
voice translation-profile OUTGOING_TRANSLATION_PROFILE
 translate called 1000
!         
!
!

archive
 log config
  hidekeys
!
!
controller E1 0/0/0
 framing NO-CRC4
 clock source internal
 channel-group 0 timeslots 1-31
!         
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
!
interface Loopback90
 ip address 10.1.10.2 255.255.255.252
 ip virtual-reassembly
!
interface FastEthernet0/0
 description ---| Voice Service VLAN |---
 ip address 10.9.3.5 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 duplex auto
 speed auto
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 10.9.3.5
!
interface Service-Engine0/0
 ip unnumbered Loopback90
 service-module ip address 10.1.10.1 255.255.255.252
 service-module ip default-gateway 10.1.10.2
 no keepalive
!
interface FastEthernet0/1
 duplex auto
 speed auto
!
interface Serial0/0/0:0
 no ip address
 encapsulation ppp
 no fair-queue
!
ip route 0.0.0.0 0.0.0.0 10.9.3.1
ip route 10.1.10.1 255.255.255.255 Service-Engine0/0
!
!
no ip http server
no ip http secure-server
!
!
!         
tftp-server flash:/SCCP41.8-2-2SR1S.loads alias SCCP41.8-2-2SR1S.loads
tftp-server flash:/dsp41.8-2-2ES1.sbn alias dsp41.8-2-2ES1.sbn
tftp-server flash:/apps41.8-2-2ES1.sbn alias apps41.8-2-2ES1.sbn
tftp-server flash:/cnu41.8-2-2ES1.sbn alias cnu41.8-2-2ES1.sbn
tftp-server flash:/cvm41sccp.8-2-2ES1.sbn alias cvm41sccp.8-2-2ES1.sbn
tftp-server flash:/jar41sccp.8-2-2ES1.sbn alias jar41sccp.8-2-2ES1.sbn
tftp-server flash:/term41.default.loads alias term41.default.loads
tftp-server flash:/term61.default.loads alias term61.default.loads
!
control-plane
!
call fallback active
!
!
voice-port 0/1/0
 trunk-group ALL_FXO
 supervisory disconnect dualtone mid-call
 input gain 12
 cptone MX
 timeouts call-disconnect 2
 timeouts wait-release 2
 timing hookflash-out 50
 connection plar opx 72000
 bearer-cap Speech
 caller-id enable
!
voice-port 0/1/1
 trunk-group ALL_FXO
 supervisory disconnect dualtone mid-call
 cptone MX
 timeouts call-disconnect 2
 timeouts wait-release 2
 timing hookflash-out 50
 connection plar opx 72000
 bearer-cap Speech
 caller-id enable
!
voice-port 0/1/2
!
voice-port 0/1/3
!
voice-port 0/3/0
!
voice-port 0/3/1
!
!
!
sccp local FastEthernet0/0
sccp ccm 10.9.3.5 identifier 1 version 4.0
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate profile 2 register xcodeprof1
 associate profile 1 register confprof1
!
dspfarm profile 2 transcode
 description ---| Transcoding Profile |---
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 codec g729br8
 maximum sessions 3
 associate application SCCP
 shutdown
!
dspfarm profile 1 conference
 description ---| Conference Profile |---
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 codec g729br8
 associate application SCCP
 shutdown
!
!
dial-peer voice 910 pots
 description ***Internal Calls***
 destination-pattern .....
 forward-digits all
 no sip-register
!
dial-peer voice 911 pots
 trunkgroup ALL_FXO
 description ---| Mexico Local Calls |---
 translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
 destination-pattern 9[1-9]......
 forward-digits all
 no sip-register
!
dial-peer voice 2000 voip
 description ** cue voicemail pilot number **
 destination-pattern 72900
 b2bua
 voice-class sip outbound-proxy  ipv4:10.1.10.1
 session protocol sipv2
 session target ipv4:10.1.10.1
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 2001 voip
 description ** cue auto attendant number **
 destination-pattern 72000
 b2bua
 voice-class sip outbound-proxy  ipv4:10.1.10.1
 session protocol sipv2
 session target ipv4:10.1.10.1
 dtmf-relay sip-notify
 codec g711ulaw
 no vad   
!
dial-peer voice 912 pots
 trunkgroup ALL_FXO
 description ---| Mexico LD National Calls |---
 translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
 preference 1
 destination-pattern 901..........
 forward-digits all
 no sip-register
!
dial-peer voice 913 pots
 trunkgroup ALL_FXO
 description ---| International Calls |---
 translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
 destination-pattern 900T
 prefix 00
 no sip-register
!
dial-peer voice 914 pots
 trunkgroup ALL_FXO
 description ---| Mexico Emergency Calls |---
 translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
 destination-pattern 90[6-7][0-9]
 forward-digits all
 no sip-register
!         
dial-peer voice 916 pots
 trunkgroup ALL_FXO
 description ---| Mexico Mobile Local Calls |---
 translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
 destination-pattern 9044..........
 forward-digits all
 no sip-register
!         
dial-peer voice 917 pots
 trunkgroup ALL_FXO
 description ---| Mexico Mobile LD National Calls |---
 translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
 destination-pattern 9045..........
 forward-digits all
 no sip-register
!         
dial-peer voice 10000 voip
 description ---| Routing VoIP calls to Michigan |---
 preference 1
 destination-pattern 10...
 voice-class codec 1
 session target ipv4:10.3.3.10
!         
dial-peer voice 10001 voip
 description ---| Routing VoIP calls to Michigan |---
 preference 2
 destination-pattern 10...
 voice-class codec 1
 session target ipv4:10.3.3.11
!         
dial-peer voice 73000 voip
 description ---| Routing VoIP calls to Hermosillo |---
 destination-pattern 73...
 voice-class codec 1
 session target ipv4:10.5.3.5
!         
!         
!         
telephony-service
 sdspfarm conference mute-on 111 mute-off 222
 sdspfarm units 5
 sdspfarm transcode sessions 8
 sdspfarm tag 1 confprof1
 sdspfarm tag 2 xcodeprof1
 conference hardware
 no auto-reg-ephone
 load 7941 SCCP41.8-2-2SR1S.loads
 max-ephones 42
 max-dn 144
 ip source-address 10.9.3.5 port 2000
 system message ANDROID
 url services http://10.1.10.1/voiceview/common/login.do
 url authentication http://10.1.10.2/CCMCIP/authenticate.asp
 cnf-file location flash:
 cnf-file perphone
 user-locale ES
 network-locale ES
 voicemail 72900
 max-conferences 8 gain -6
 transfer-system full-consult
 transfer-pattern 9.T
 secondary-dialtone 9
 create cnf-files version-stamp 7960 Apr 04 2014 15:16:47
!
!
ephone-template  11
 softkeys idle  Redial Cfwdall Join Pickup Gpickup Dnd HLog Login
 softkeys seized  Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
 softkeys connected  Hold Endcall Trnsfer Confrn ConfList RmLstC Acct Park Select Join
 button-layout 7931 2
!
!
ephone-dn  11  dual-line
 number 72001 no-reg primary
 label 72001
 description EX1
 name EX1
 call-forward busy 72900
 call-forward noan 72900 timeout 20
!
!
ephone-dn  12  dual-line
 number 72002 no-reg primary
 label 72002
 description EX2
 name EX2
 call-forward busy 72900
 call-forward noan 72900 timeout 20
!
!
ephone-dn  13  dual-line
 number 72003 no-reg primary
 label 72003
 description EX3
 name EX3
 call-forward busy 72900
 call-forward noan 72900 timeout 20
!
!
ephone-dn  14  dual-line
 number 72004 no-reg primary
 label 72004
 description EX4
 name EX4
 call-forward busy 72900
 call-forward noan 72900 timeout 20
!
!
ephone-dn  15  dual-line
 number 72005 no-reg primary
 label 72005
 description EX5
 name EX5
 call-forward busy 72900
 call-forward noan 72900 timeout 20
!
!
ephone-dn  16  dual-line
 number 72006 no-reg primary
 label 72006
 description EX6
 name EX6
 call-forward busy 72900
 call-forward noan 72900 timeout 20
!
!
ephone-dn  17  dual-line
 number 72007 no-reg primary
 label 72007
 description EX7
 name EX7
 call-forward busy 72900
 call-forward noan 72900 timeout 20
!
!
ephone-dn  18  dual-line
 number 72008 no-reg primary
 label 72008
 description EX8
 name EX8
 call-forward busy 72900
 call-forward noan 72900 timeout 20
!
!
ephone-dn  19  dual-line
 number 72009 no-reg primary
 label 72009
 description EX9
 name EX9
 call-forward busy 72900
 call-forward noan 72900 timeout 20
!
!
ephone  11
 mac-address 001D.450C.13C7
 ephone-template 11
 type 7941
 button  1:11
!
!
!
ephone  12
 mac-address 001D.450C.149E
 ephone-template 11
 type 7941
 button  1:12
!
!
!
ephone  13
 mac-address 001D.450C.0C51
 ephone-template 11
 type 7941
 button  1:13
!
!
!
ephone  14
 mac-address 001D.450C.4A59
 ephone-template 11
 type 7941
 button  1:14
!
!         
!
ephone  15
 mac-address 001D.450C.4FCA
 ephone-template 11
 type 7941
 button  1:15
!
!
!
ephone  16
 mac-address 001D.450C.145F
 ephone-template 11
 username "materials" password 19304
 type 7941
 button  1:16
!
!
!
ephone  17
 mac-address 001D.450C.5802
 ephone-template 11
 type 7941
 button  1:17
!
!
!
ephone  18
 mac-address 001D.450C.0AD0
 ephone-template 11
 type 7941
 button  1:18
!
!
!
ephone  19
 mac-address 001D.450C.0AFC
 ephone-template 11
 type 7941
 button  1:19
!
!
!
line con 0
 logging synchronous
line aux 0
line 194
 no activation-character
 no exec
 transport preferred none
 transport input all
 line vty 0 4
 login authentication VTY_ACCESS
 transport output telnet ssh
!
scheduler allocate 20000 1000
!
end

 

 

Thanks!

Silver

And if you can info what

And if you can info what Suresh requested?

BR,

Dragan

HTH, Dragan
New Member

Will do, cheers! Remi

Will do, cheers!

 

Remi

Hello,how have you configured

Hello,

how have you configured the connection between CME & CUCM?

could you please collect the debug voice ccapi inout (also 'debug ccsip message'  if it is SIP trunk connection) for a nonworking test call? please include the calling/called  numbers.

is RSVP enabled on CUCM side?

 

//Suresh

Please rate all the useful posts

 

 

//Suresh Please rate all the useful posts.
New Member

Thanks Suresh,As soon as I

Thanks Suresh,

As soon as I have access to the router I will let you know all the details.

 

Thanks,

Remi

172
Views
0
Helpful
6
Replies