Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CME with IPv6 configuration

Hi everyone,

Could anybody in here post a working CME configuration for VoIPv6 only? I was just wondering what are the commands that would replace commands to point to TFTP server like 'option 150 ip xxxx.xxxx.xxxx' and other new commands under DCHP or even Telephony-Service. Just a working config would do. Thanks.

8 REPLIES
Cisco Employee

CME with IPv6 configuration

Hello Aditya,

We already have some documents available on Cisco Support Community:

https://supportforums.cisco.com/docs/DOC-13453

Enabling IPv6:

ipv6 unicast-routing

DHCP CONFIGURATION:

ipv6 dhcp pool NEW

address prefix FEC0:0:0:1::/64

link-address FE80::/10

link-address FE80::1AEF:63FF:FE62:BA00/10

Interface Configuration:

interface GigabitEthernet0/0

ipv6 address FEC0:0:0:1::/64 eui-64

ipv6 enable

ipv6 dhcp server NEW

CME configuration:

telephony-service

protocol mode ipv6

ip source-address FEC0::1:1AEF:63FF:FE62:BA00 port 2000

*********************************************************************************************************************************

Switch Configuration:

IOS: c3750-ipbasek9-mz.122-55.SE.bin

Platform:  cisco WS-C3750G-48PS

Enabling IPv6:

ipv6 unicast-routing

Vlan Configuration:

interface Vlan10

ipv6 address FEC0:0:0:1::/64 eui-64

ipv6 nd autoconfig prefix

ipv6 nd prefix FEC0:0:0:1::/64

Swicth-Port configuration:

interface GigabitEthernet1/0/9

switchport access vlan 10

switchport mode access

and

http://docwiki.cisco.com/wiki/Registering_Cisco_IP_phones_with_CME_8.x_using_IPv6

I hope you will find them useful.

Regards

Amit Singh

New Member

CME with IPv6 configuration

Hi Amit

I would like you to check the other post of mine. Could you please help me with this VoIPv6 configuration? Thanks.

https://supportforums.cisco.com/message/4169270#4169270

Cisco Employee

CME with IPv6 configuration

Hello Aditya,

Sure, let me check.

Did the above answer helped in your CME configuration ?

Also, if you configure the setup for IPV4, are the Phones getting an IP address and getting registered, just to isolate any other issues ?

Regards

Amit Singh

New Member

CME with IPv6 configuration

Hi Amit

I have tried the following link which you have given but its not working (not getting IPv6 address). However, it does work with IPv4 and its getting an IPv4 address. Thanks.

http://docwiki.cisco.com/wiki/Registering_Cisco_IP_phones_with_CME_8.x_using_IPv6

CME with IPv6 configuration

Hi Aditya,

Here is a doc for your reference:

https://supportforums.cisco.com/docs/DOC-13591

*Updated* How to implement the IPv4 & IPv6 dual stack mode on CME 8.0 ?

VERSION 7                 

Introduction

This  document covers how to implement the IPv4 & IPv6 dual stack mode on  CME 8.0. This will help you if you have multiple partners connected  across ipv6 & ipv4 network and you can Make, Receive calls to your  network using any of the IP. This covers the configuration part on the  CME to enable dual stack mode.

Configuring Ipv4 & Ipv6 on CME 8.0

CME Image on 2811 Router

#

hostname 2811-ROUTER

!

boot-start-marker

boot system flash c2800nm-ipvoicek9-mz.150-1.XA1.bin

boot-end-marker

Configure the ipv6 & ipv4 dhcp pool for the IP Phones:

Configure both the ipv6 & ivp6 on the Interface configuration

interface FastEthernet0/1

description #### Internal Interface ####

ip address 124.7.115.85 255.255.255.248

duplex full

speed 100

ipv6 address 3001:E50:0:15::1/64

ipv6 enable

ipv6 dhcp server Call-manager

Telephony-service configuration for CME

# voice service voip

sip

bind control source-interface FastEthernet0/1

sccp ccm group 1

associate ccm 1 priority 1

protocol mode dual-stack preference ipv6

max-ephones 42

max-dn 144

ip source-address 124.7.115.85 port 2000

ip source-address 3001:E50:0:15::1

service phone settingsAccess 1

system message CCME 8.0

cnf-file location flash:

cnf-file perphone

load 7911 SCCP11.8-3-3SR2S

load 7970 SCCP70.9-0-2SR1S

max-conferences 16 gain -6

moh music-on-hold.au

dn-webedit

time-webedit

transfer-system full-consult secondary-dialtone 9

create cnf-files version-stamp Jan 01 2010 00:00:00

Note:-  CME with dual-stack Mode and IPV6 preference. This "dual-stack mode"  will enable CME to work on both ipv6&ipv4 and you can set any IP  version as preference.

Note:- Both ipv4 & ipv6 source address configured for communication

Configure ephone & ephone-dn

ephone-dn 1

number 1003

name testlab-1

ephone 1

nte-end-digit-delay 100

keypad-normalize

mac-address 0014.789C.3C0E

type 7970

button 1:1

Rate the post accordingly.

Regards,

Kevin

New Member

CME with IPv6 configuration

Hi Kevin

Thanks buddy. Will give a try. But before let me ask you and remind that I am using SCCP but the below configuration mentions sip. Will this make any difference? Thanks

# voice service voip

sip

bind control source-interface FastEthernet0/1

sccp ccm group 1

associate ccm 1 priority 1

protocol mode dual-stack preference ipv6

max-ephones 42

max-dn 144

ip source-address 124.7.115.85 port 2000

ip source-address 3001:E50:0:15::1

service phone settingsAccess 1

system message CCME 8.0

cnf-file location flash:

cnf-file perphone

load 7911 SCCP11.8-3-3SR2S

load 7970 SCCP70.9-0-2SR1S

max-conferences 16 gain -6

moh music-on-hold.au

dn-webedit

time-webedit

transfer-system full-consult secondary-dialtone 9

create cnf-files version-stamp Jan 01 2010 00:00:00

CME with IPv6 configuration

Hi Aditya,

It does specify configuration for Skinny too:

Configure ephone & ephone-dn

ephone-dn 1

number 1003

name testlab-1

ephone 1

nte-end-digit-delay 100

keypad-normalize

mac-address 0014.789C.3C0E

type 7970

button 1:1

Regards,

Kevin

New Member

CME with IPv6 configuration

Hi Kevin

Thanks for the prompt reply. I will try and test this soon and let you know. Thanks.

352
Views
3
Helpful
8
Replies