Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Codec issue between 7940 and ISR 2801

We had a CUCM go down at a remote site w/o a backup of the config, so we're moving it to the CUCM at another site and we're having issue. Old site was running CUCM 4.X, new site is running 7.1.


We're having an issue with the ISR 2801 running IOS 12.3R8T8 at the remote site making calls. It'll dial out, but as soon as the other line picks up, we get a fast busy signal. I'm assuming it's a codec issue, but I'm at a loss how to resolve it.


Calls are going from 7940G phones to the 2801 (H.323) and then out over an ISDN line. If I don't have a codec specified on the voice-peer, it'll ring until someone picks up and then fail. From the call history, it looks like it's negotiating g729r8. If I specify g711alaw or g711ulaw, it'll fail as soon as I dial.

Cal llog looks like this:

Cisco-2801#show call history voice last 1

GENERIC:
SetupTime=4686160 ms
Index=18
PeerAddress=<PHONE NUMBER>
PeerSubAddress=
PeerId=1
PeerIfIndex=66
LogicalIfIndex=65
DisconnectCause=1F
DisconnectText=normal, unspecified (31)
ConnectTime=4705860 ms
DisconnectTime=4705870 ms
CallDuration=00:00:00 sec
CallOrigin=1
ReleaseSource=2
ChargedUnits=0
InfoType=speech
TransmitPackets=776
TransmitBytes=15520
ReceivePackets=787
ReceiveBytes=15740
TELE:
ConnectionId=[0x18B518 0x591BF1F1 0x100A102 0xA02413E]
IncomingConnectionId=[0x18B518 0x591BF1F1 0x100A102 0xA02413E]
CallID=18
TxDuration=14000 ms
VoiceTxDuration=14000 ms
FaxTxDuration=0 ms
CoderTypeRate=g729r8
NoiseLevel=-81
ACOMLevel=22
SessionTarget=
ImgPages=0
CallerName=
CallerIDBlocked=False
AlertTimepoint=4689000 ms
OriginalCallingNumber=85965101
OriginalCallingOctet=0x0
OriginalCalledNumber=<PHONE NUMBER>
OriginalCalledOctet=0x80
OriginalRedirectCalledNumber=
OriginalRedirectCalledOctet=0xFF
TranslatedCallingNumber=85965101
TranslatedCallingOctet=0x0
TranslatedCalledNumber=<PHONE NUMBER>
TranslatedCalledOctet=0x80
TranslatedRedirectCalledNumber=
TranslatedRedirectCalledOctet=0xFF
GwReceivedCalledNumber=<PHONE NUMBER>
GwReceivedCalledOctet3=0x80
GwOutpulsedCalledNumber=<PHONE NUMBER>
GwOutpulsedCalledOctet3=0x80
GwReceivedCallingNumber=85965101
GwReceivedCallingOctet3=0x0
GwReceivedCallingOctet3a=0x81
GwOutpulsedCallingNumber=85965101
GwOutpulsedCallingOctet3=0x0
GwOutpulsedCallingOctet3a=0x81

7 REPLIES
Hall of Fame Super Silver

Codec issue between 7940 and ISR 2801

Chuck,

First of all upgrade the IOS as this is extremely old, second of all please post your full config and since you mention isdn circuit post "debug isdn q931".

This definitely sounds like a codec issue, but phone should be able to negotiate either codec. have you tried forcing it to G711 to see what happens?

Chris

New Member

Codec issue between 7940 and ISR 2801

Working on getting the contract numbers so I can get the IOS updated right now.

Here's the running config right now (with G711ulaw forced on). When I make a call out with this config, it rings out and immediatly fails. (if i change the CODEC over to G729r8, it'll at least ring until someone picks up and then fail):

Cisco-2801#show conf
Using 4479 out of 196600 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco-2801
!
boot-start-marker
boot system flash flash:c2801-spservicesk9-mz.123-11.T8.bin
boot-end-marker
!
logging buffered 51200 warnings
enable password 3sk3r!
!
clock timezone AEST 10
clock summer-time AEDT recurring last Sun Oct 2:00 last Sun Mar 2:00
network-clock-participate wic 2
network-clock-select 1 E1 0/2/0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
ip domain name esker.com.au
ip name-server 10.5.0.10
ip name-server 10.5.0.11
no ftp-server write-enable
isdn switch-type primary-net5
!
voice-card 0
!
!
voice call send-alert
voice rtp send-recv
!
!
!
!
!
!
!
!
!
!
fax receive called-subscriber $d$
fax interface-type fax-mail
mta send server sy-smtp.esker.corp port 25
mta send subject fax from AU VOIP router
mta send with-subject both
mta send postmaster inbound.fax@esker.com.au
mta send mail-from hostname au.fax
mta send mail-from username fax-mail
!
!
username esker password 0 3sk3r!
!
!
controller E1 0/2/0
pri-group timeslots 1-30
!
translation-rule 1
!
!
!
!
interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$
ip address 10.5.0.4 255.255.128.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.99.5.4 255.255.255.0
ip helper-address 10.5.0.10
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.99.5.4
!
interface Serial0/2/0:15
no ip address
isdn switch-type primary-net5
isdn incoming-voice voice
no cdp enable
!
ip default-gateway 10.5.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.5.0.1
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
!
!
!
!
control-plane
!
!
call application voice onramp flash:app_faxmail_onramp.2.0.1.3.tcl
!
!
voice-port 0/2/0:15
!
!
!
!
dial-peer voice 1 pots
destination-pattern 0T
progress_ind alert enable 8
direct-inward-dial
port 0/2/0:15
!
dial-peer voice 150 mmoip
application fax_on_vfc_onramp_app out-bound
destination-pattern 51..
information-type fax
session target mailto:inbound.fax@esker.com.au
!
dial-peer voice 2 voip
destination-pattern 51..
progress_ind setup enable 3
session target ipv4:10.2.2.14
dtmf-relay h245-alphanumeric
!
dial-peer voice 100 pots
application onramp
incoming called-number 859651[6-7].
direct-inward-dial
!
dial-peer voice 101 pots
application onramp
incoming called-number 85965151
direct-inward-dial
!
dial-peer voice 102 pots
application onramp
incoming called-number 85965152
direct-inward-dial
!
dial-peer voice 103 pots
application onramp
incoming called-number 85965153
direct-inward-dial
!
dial-peer voice 104 pots
application onramp
incoming called-number 85965154
direct-inward-dial
!
dial-peer voice 105 pots
application onramp
incoming called-number 85965155
direct-inward-dial
!
dial-peer voice 106 pots
application onramp
incoming called-number 85965156
direct-inward-dial
!
dial-peer voice 107 pots
application onramp
incoming called-number 85965157
direct-inward-dial
!
dial-peer voice 108 pots
application onramp
incoming called-number 85965158
direct-inward-dial
!
dial-peer voice 109 pots
application onramp
incoming called-number 85965159
direct-inward-dial
!
dial-peer voice 999 voip
incoming called-number .
codec g711ulaw
no vad
!
num-exp 859651.. 51..
banner login ^C
-----------------------------------------------------------------------
Cisco Router and Security Device Manager (SDM) is installed on this device.
This feature requires the one-time use of the username "cisco"
with the password "cisco".

Please change these publicly known initial credentials using SDM or the IOS CLI.
Here are the Cisco IOS commands.

username   privilege 15 secret 0
no username cisco

Replace and with the username and password you want to use.

For more information about SDM please follow the instructions in the QUICK START
GUIDE for your router or go to http://www.cisco.com/go/sdm
-----------------------------------------------------------------------
^C
!
line con 0
password 3sk3r!
login local
line aux 0
line vty 0 4
privilege level 15
password 3sk3r!
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh
!
end

Cisco-2801#

Hall of Fame Super Gold

Codec issue between 7940 and ISR 2801

As Chris mentioned, start updating the image, that can be riddled with bugs.

New Member

Codec issue between 7940 and ISR 2801

Updated to 12.4.25f, still seeing the same issue.

Hall of Fame Super Silver

Codec issue between 7940 and ISR 2801

Have you tried forcing it to G711 to see if that changes anything?

How is the GW configured in CUCM, what region (via device pool) does it have asigned, is the region the same as the phone's?

Can you post "debug isdn q931" for the call?

Chris

New Member

Codec issue between 7940 and ISR 2801

GW is in the same region/DP as the phones. I've tried it with "


Here's the results of the debug logging:

*Jan 25 18:03:20.204: ISDN Se0/2/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x0, Calling num 85965101

*Jan 25 18:03:20.208: ISDN Se0/2/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x0, Called num 001116088286090

*Jan 25 18:03:20.208: ISDN Se0/2/0:15 Q931: TX -> SETUP pd = 8  callref = 0x0089

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA9839E

                Exclusive, Channel 30

        Calling Party Number i = 0x0081, '85965101'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0x80, '001116088286090'

                Plan:Unknown, Type:Unknown

*Jan 25 18:03:20.348: ISDN Se0/2/0:15 Q931: RX <- CALL_PROC pd = 8  callref = 0x8089

        Channel ID i = 0xA9839E

                Exclusive, Channel 30

*Jan 25 18:03:23.348: ISDN Se0/2/0:15 Q931: RX <- ALERTING pd = 8  callref = 0x8089

        Progress Ind i = 0x8482 - Destination address is non-ISDN

*Jan 25 18:03:31.900: ISDN Se0/2/0:15 Q931: RX <- CONNECT pd = 8  callref = 0x8089

        Progress Ind i = 0x8482 - Destination address is non-ISDN

*Jan 25 18:03:31.904: ISDN Se0/2/0:15 Q931: TX -> CONNECT_ACK pd = 8  callref = 0x0089

*Jan 25 18:03:31.928: ISDN Se0/2/0:15 Q931: TX -> DISCONNECT pd = 8  callref = 0x0089

        Cause i = 0x80FF - Interworking error; unspecified

*Jan 25 18:03:32.048: ISDN Se0/2/0:15 Q931: RX <- RELEASE pd = 8  callref = 0x8089

*Jan 25 18:03:32.052: ISDN Se0/2/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x0089

New Member

Codec issue between 7940 and ISR 2801

After looking into it a bit more, I made the following changes:
Created an MRGL with just the MTP resources on it.

Set the Gateway in CUCM to require MTP

Forced the codec to G711ulaw on the Gateway.

Still failed, here's the result:


*Jan 25 18:29:21.159: ISDN Se0/2/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x0, Calling num 85965101
*Jan 25 18:29:21.163: ISDN Se0/2/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0 0x0, Called num 001116088286090
*Jan 25 18:29:21.163: ISDN Se0/2/0:15 Q931: TX -> SETUP pd = 8  callref = 0x008C
        Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transfer Capability = Speech
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA9839E
                Exclusive, Channel 30
        Calling Party Number i = 0x0081, '85965101'
                Plan:Unknown, Type:Unknown
        Called Party Number i = 0x80, '001116088286090'
                Plan:Unknown, Type:Unknown
*Jan 25 18:29:21.279: ISDN Se0/2/0:15 Q931: RX <- CALL_PROC pd = 8  callref = 0x808C
        Channel ID i = 0xA9839E
                Exclusive, Channel 30
*Jan 25 18:29:27.831: ISDN Se0/2/0:15 Q931: RX <- ALERTING pd = 8  callref = 0x808C
        Progress Ind i = 0x8482 - Destination address is non-ISDN
*Jan 25 18:29:32.779: ISDN Se0/2/0:15 Q931: RX <- CONNECT pd = 8  callref = 0x808C
        Progress Ind i = 0x8482 - Destination address is non-ISDN
*Jan 25 18:29:32.783: ISDN Se0/2/0:15 Q931: TX -> CONNECT_ACK pd = 8  callref = 0x008C
*Jan 25 18:29:32.807: ISDN Se0/2/0:15 Q931: TX -> DISCONNECT pd = 8  callref = 0x008C
        Cause i = 0x80FF - Interworking error; unspecified
*Jan 25 18:29:32.927: ISDN Se0/2/0:15 Q931: RX <- RELEASE pd = 8  callref = 0x808C
*Jan 25 18:29:32.931: ISDN Se0/2/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x008C
Cisco-2801#show call history voice last 1
GENERIC:
SetupTime=59415420 ms
Index=26
PeerAddress=0001116088286090
PeerSubAddress=
PeerId=1
PeerIfIndex=67
LogicalIfIndex=35
DisconnectCause=7F
DisconnectText=interworking (127)
ConnectTime=59426920 ms
DisconnectTime=59427070 ms
CallDuration=00:00:00 sec
CallOrigin=1
ReleaseSource=6
ChargedUnits=0
InfoType=speech
TransmitPackets=173
TransmitBytes=29064
ReceivePackets=186
ReceiveBytes=29760
TELE:
ConnectionId=[0x804F83D4 0xE44801F2 0x2008D02 0xA02413E]
IncomingConnectionId=[0x804F83D4 0xE44801F2 0x2008D02 0xA02413E]
CallID=26
Port=0/2/0:15 (26)
BearerChannel=0/2/0.30
TxDuration=3740 ms
VoiceTxDuration=3740 ms
FaxTxDuration=0 ms
CoderTypeRate=g711ulaw
NoiseLevel=-75
ACOMLevel=30
SessionTarget=
ImgPages=0
CallerName=
CallerIDBlocked=False
AlertTimepoint=59421970 ms
OriginalCallingNumber=85965101
OriginalCallingOctet=0x0
OriginalCalledNumber=0001116088286090
OriginalCalledOctet=0x80
OriginalRedirectCalledNumber=
OriginalRedirectCalledOctet=0xFF
TranslatedCallingNumber=85965101
TranslatedCallingOctet=0x0
TranslatedCalledNumber=0001116088286090
TranslatedCalledOctet=0x80
TranslatedRedirectCalledNumber=
TranslatedRedirectCalledOctet=0xFF
GwReceivedCalledNumber=0001116088286090
GwReceivedCalledOctet3=0x80
GwOutpulsedCalledNumber=001116088286090
GwOutpulsedCalledOctet3=0x80
GwReceivedCallingNumber=85965101
GwReceivedCallingOctet3=0x0
GwReceivedCallingOctet3a=0x81
GwOutpulsedCallingNumber=85965101
GwOutpulsedCallingOctet3=0x0
GwOutpulsedCallingOctet3a=0x81
DSPIdentifier=0/6:1
576
Views
0
Helpful
7
Replies
CreatePlease to create content