Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Configure FAX from E1

Hi,

I am having an E1 connection with 3 series of telephone numbers (100 numbers in each series). I am having an analog FAX machine (RJ11 connection). I need to configure one number from the E1 to this fax.

The E1 is terminated on a 2911 router which is confiugred as MGCP through an E1 card (VWIC3-1MFT-T1/E1). I am also having a Call Manager (UNIFIED-CMBE5K).

Please give me a solution.

Regards,

Alex George

6 REPLIES
VIP Super Bronze

Configure FAX from E1

Hi Alex,

First of all what do you intend to use to connect your fax? Are you going to use fxs ports on your Gateway or do you intend to use Analogue gateways i.e VG224, Vg204 etc.

You need to determine how you want to setup your fax machines. Once we know that then the rest should be easy. All you need to do is assign extension to the analogue ports you will be using for the fax machines either directly on the fxs ports on your gateway or to the VG204, 224 I mentioned earlier. You will then configure these gateways for fax transmission...simples

Please rate useful posts

"I am complete in God, God completes me"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Configure FAX from E1

Hi,

I am using an FXS card on the gateway router. When I am using FXS card should I do any configuration in the Call Manager.

Please give me any configuration examples or screen shot.

Regards,

Alex George

VIP Super Bronze

Configure FAX from E1

Can you send a sh run of your mgcp gateway configuration. I will then put together the necessary config for you

Please rate useful posts

"I am complete in God, God completes me"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Re: Configure FAX from E1

Hi ,

Pleas find the mgcp gateway configuration

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname SmartCity

!

boot-start-marker

boot-end-marker

!

!

card type e1 0 1

!

no aaa new-model

!

network-clock-participate wic 1

!

no ipv6 cef

ip source-route

ip cef

!

!

!

ip dhcp excluded-address 10.129.217.1 10.129.217.10

!

ip dhcp pool SMRTCTY

network 10.129.216.0 255.255.254.0

dns-server 202.138.103.100 202.138.96.2

option 150 ip 10.129.217.2

default-router 10.129.217.1

!

!

!

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-4ess

!

crypto pki token default removal timeout 0

!

!

voice-card 0

!

!

!

!

!

!

!

license udi pid CISCO2911/K9 sn FGL161912N0

hw-module pvdm 0/0

!

!

!

!

redundancy

!

!

!

!

controller E1 0/1/0

pri-group timeslots 1-31 service mgcp

!

!

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 10.129.217.1 255.255.254.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 115.254.115.141 255.255.255.252

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

shutdown

clock rate 2000000

!

interface Serial0/0/1

no ip address

shutdown

clock rate 2000000

!

interface Serial0/1/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip nat inside source list 1 interface GigabitEthernet0/1 overload

ip route 0.0.0.0 0.0.0.0 115.254.115.142

!

access-list 1 permit 10.129.216.0 0.0.1.255

!

!

!

!

!

!

control-plane

!

!

voice-port 0/1/0:15

!

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 10.129.217.2 

ccm-manager config

!

mgcp

mgcp call-agent 10.129.217.2 2427 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

!

mgcp profile default

!

!

dial-peer voice 1 pots

service mgcpapp

incoming called-number 30800..

!

!

!

!

gatekeeper

shutdown

!

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

Regards,

Alex George

New Member

Re: Configure FAX from E1

Easy solution is to get one Cisco ATA-187 and make it registered on CUCM and asscociate with one extension. I am using this setup.

VIP Super Bronze

Re: Configure FAX from E1

Alex,

Please add trhe ff configuration

ccm-manager mgcp

no ccm-manager fax protocol cisco

stcapp ccm-group 1

stcapp

sccp local XXXXX (where xxxx = interface you want to use for sccp eg gig0/0 or fa0/0)

sccp ccm y.y.y.y identifier 1 version 7 (where y.y.y.y=ip address of your primary cucm)

sccp ccm z.z.z.z. identifier 2 version 7 (where z.z.z.z=ip address of your backup cucm)

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate ccm 2 priority 2

dial-peer voice 1000 pots

service stcapp

port x/y/z......................................Port should be the fxs port on your gateway eg 0/1/0

!

Configure as many ports as you have and ensure the service stcapp is applied to them

I didnt see any voice-port for the faxs card on your sh run. Are the cards installed?

Feel free to change the dial-peer number to anything you want or you can use the suggested values.

Now the gateway config is done.

You then need to go to CUCM to configure the FXS ports....

You need to add the gateway as a SCCP gateway..NB: you omly need the last 10 digit of the mac address of the gateway. The mac address will correspond to the mac address of the interface you are using for sccp. You can find with sh interface command.

Here is a link that details how to configure fxs port for sccp on cucm

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/admin/7_1_2/ccmcfg/b06gtway.html#wp1644973

Let me know if you have any questions

Once you are done, connect the fax machines to the fxs port on the gateway and test. You may want yo plug an analogue phone to the port first and ensure you can dial out and receive calls.

!

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
1561
Views
0
Helpful
6
Replies