Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Configuring COS on non-cisco phone.

Hi all.  I am about to implement VOIP on my LAN with 10 Cisco WS-C2960S-24PD-L running 12.2(53r)SE.

Per Cisco, I have configured the following commands on my access ports where my VOIP phones plug into the network to isolate voice and data traffic onto vlan 1 and vlan 2 (voice).  I want to prioritize voice.

Can anyone give me any feedback on if these commands are accurate?

Also, how can I verify that the voice packets are prioritized using show commands?

Thanks

msl qos trust cos

switchport nonegotiate

switchport mode trunk

switchport trunk native vlan 1

switchport trunk allowed vlans 1, 2

priority-queue out

spanning-tree portfast trunk

spanning-tree bpduguard enable

1 REPLY
Green

Configuring COS on non-cisco phone.

Hi,

You really need to do a bit more than that.

Something like this

!

! ### TURN ON QOS & TUNE Qs AND BUFFERS ###

!

mls qos

!

mls qos map cos-dscp 0 8 16 24 32 46 48 56

!

mls qos srr-queue output cos-map queue 1 threshold 3  5

mls qos srr-queue output cos-map queue 2 threshold 1  2 4

mls qos srr-queue output cos-map queue 2 threshold 2  3

mls qos srr-queue output cos-map queue 2 threshold 3  6 7

mls qos srr-queue output cos-map queue 3 threshold 3  0 1

mls qos srr-queue output dscp-map queue 1 threshold 3  46

mls qos srr-queue output dscp-map queue 2 threshold 1  16 18 20 22

mls qos srr-queue output dscp-map queue 2 threshold 1  26 32 34 36 38

mls qos srr-queue output dscp-map queue 2 threshold 2  24

mls qos srr-queue output dscp-map queue 2 threshold 3  48 56

mls qos srr-queue output dscp-map queue 3 threshold 3  0 8

mls qos srr-queue output dscp-map queue 3 threshold 3  10 12 14

mls qos queue-set output 1 threshold 2 70 80 100 100

mls qos queue-set output 1 threshold 4 40 100 100 100

!

! ### NOW SET UP INTERFACES ###

!

interface FastEthernet 0/1

description *** IP-PHONE & PC PORT ***

switchport host

switchport access vlan 1

switchport vloice vlan 2

srr-queue bandwidth share 1 30 35 5

priority-queue out

switchport host

mls qos trust dscp

spanning-tree bpduguard enable

!

HTH

Alex

Please rate useful posts

Regards, Alex. Please rate useful posts.
238
Views
0
Helpful
1
Replies
CreatePlease to create content