Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

Configuring FXO: not recieving incoming calls

I've been this figure this out and have no idea what I'm missing. The FXO port will not take the calls and thus my phone will not ring. Here is the running config and debug voice ccapi inout

hostname main

!
boot-start-marker
boot-end-marker
!
card type t1 0 0
enable secret 5 $1$j/nW$ahTLPtnpkg509qVvAKq3h0
!
no aaa new-model
!
resource policy
!
clock timezone cdt -8
clock summer-time pst recurring
network-clock-participate wic 0 
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.0.1 10.10.0.10
ip dhcp excluded-address 10.15.0.1 10.15.0.10
!
ip dhcp pool Data
   network 10.10.0.0 255.255.255.0
   default-router 10.10.0.1 
   option 150 ip 10.10.0.1 
!
ip dhcp pool Voice
   network 10.15.0.0 255.255.255.0
   default-router 10.15.0.1 
   option 150 ip 10.15.0.1 
!
no ip domain lookup
!
!         
isdn switch-type primary-ni
!
voice-card 0
 no dspfarm      
!
controller T1 0/0/0
 framing esf
 clock source internal
 linecode b8zs
 pri-group timeslots 1-6,24
!
controller T1 0/0/1
 framing esf
 linecode b8zs
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.10
 description Data VLAN
 encapsulation dot1Q 10
 ip address 10.10.0.1 255.255.255.0
!
interface FastEthernet0/0.11
 description Management VLAN
 encapsulation dot1Q 11
 ip address 10.11.0.1 255.255.255.0
!
interface FastEthernet0/0.15
 description Voice VLAN 
 encapsulation dot1Q 15
 ip address 10.15.0.1 255.255.255.0
!
interface FastEthernet0/1
 ip address 192.168.0.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
interface Serial0/3/0
 no ip address
 shutdown
 no fair-queue
!
ip http server
no ip http secure-server
!

!
control-plane
!
!
!
voice-port 0/0/0:23
!
voice-port 0/2/0
 connection plar opx 1002
 caller-id enable
!
voice-port 0/2/1
!
dial-peer voice 1002 pots
 destination-pattern 1002
!
gatekeeper
 shutdown 
!
!
telephony-service
 max-ephones 8
 max-dn 20
 ip source-address 10.15.0.1 port 2000
 max-conferences 8 gain -6
 transfer-system full-consult
 create cnf-files version-stamp 7960 Jul 01 2014 08:14:00
!
ephone-dn  1  dual-line
 number 1001
!
!
ephone-dn  2  dual-line
 number 1002 secondary 6263963101
!
!
ephone  1
 device-security-mode none
 mac-address 0007.0EC4.7280
!         
!
!
ephone  2
 device-security-mode none
 mac-address 0014.6AC3.D1FA
!
!
!
line con 0
 exec-timeout 0 0
 password cisco
 logging synchronous
 login
line aux 0
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
scheduler allocate 20000 1000
ntp server 192.168.0.1
!
end

Debug 

 

Jul  1 17:05:19.579: //-1/B7175CFB802B/CCAPI/cc_api_display_ie_subfields:

   cc_api_call_setup_ind_common:
   cisco-username=
   ----- ccCallInfo IE subfields -----
   cisco-ani=
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=0
   dest=
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=0
   cisco-rdnplan=0
   cisco-rdnpi=0
   cisco-rdnsi=0
   cisco-redirectreason=0   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

Jul  1 17:05:19.579: //-1/B7175CFB802B/CCAPI/cc_api_call_setup_ind_common:
   Interface=0x4794F87C, Call Info(
   Calling Number=,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=(TON=Unknown, NPI=Unknown),
   Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=FALSE,
   Incoming Dial-peer=0, Progress Indication=ORIGINATING SIDE IS NON ISDN(3), Calling IE Present=FALSE,
   S
RtrPod1(configource Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1
Jul  1 17:05:19.583: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
Jul  1 17:05:19.583: :cc_get_feature_vsa malloc success
Jul  1 17:05:19.583: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
Jul  1 17:05:19.583:  cc_get_feature_vsa count is 1
Jul  1 17:05:19.583: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
Jul  1 17:05:19.583: :FEATURE_VSA attributes are: feature_name:0,fearture_time:1200788192,feature_id:12
Jul  1 17:05:19.583: //12/B7175CFB802B/CCAPI/cc_api_call_setup_ind_common:
   Set Up Event Sent;
   Call Info(Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=(TON=Unknown, NPI=Unknown))
Jul  1 17:05:19.583: //12/B7175CFB802B/CCAPI/cc_process_call_setup_ind:
   Event=0x48163DA0
Jul  1 17:05:19.587: //12/B7175CFB802B/CCAPI/ccCallSetContext:
   Context=0x488CE018
Jul  1 17:05:19.587: //12/B7175CFB802B/CCAPI/cc_process_call_setup_ind:
   >>>>CCAPI handed cid 12 with tag 0 to app "_ManagedAppProcess_Default"
Jul  1 17:05:19.591: //12/B7175CFB802B/CCAPI/ccCallSetupAck:
   Call Id=12
Jul  1 17:05:19.591: //12/B7175CFB802B/CCAPI/cc_api_set_transfer_info:
   Transfer Number=, Transfer Reason=0x0
Jul  1 17:05:19.591: //12/B7175CFB802B/CCAPI/ccGenerateToneInfo:
   Stop Tone On Digit=TRUE, Tone=Dial Tone,
   Tone Direction=Network, Params=0x0, Call Id=12
Jul  1 17:05:19.591: //12/B7175CFB802B/CCAPI/ccSetDigitTimeouts:
   Initial Digit Timeout=-1000(ms), Inter Digit Timeout=-1000(ms)
Jul  1 17:05:19.591: //12/B7175CFB802B/CCAPI/ccSetDigitTimeouts:
   Call Entry(Inter Digit Timeout=10000(ms), Initial Digit Timeout=10000(ms))
Jul  1 17:05:19.591: //12/xxxxxxxxxxxx/CCAPI/ccCallReportDigits:
   (callID=0xC, digit_event=0x1, enable=TRUE, consume=FALSE)
Jul  1 17:05:19.591: //12/B7175CFB802B/CCAPI/ccCallReportDigits:
   Enabled=TRUE, Call Id=12
Jul  1 17:05:19.591: //12/xxxxxxxxxxxx/CCAPI/cc_api_call_report_digits_done:
   (vdbPtr=0x4794F87C, callID=0xC, disp=0, digit_event=0x1, enable=TRUE, consume=FALSE)
Jul  1 17:05:19.591: //12/B7175CFB802B/CCAPI/cc_api_call_report_digits_done:
   Enabled=TRUE, Disposition=0x0, Interface=0x4794F87C, Call Id=12
Jul  1 17:05:19.591: //12/B7175CFB802B/CCAPI/cc_api_call_report_digits_done:
   Call Entry(Initial Digit Timeout=10000(ms), Inter Digit Timeout=10000(ms))-ephone-dn)#
RtrPod1(config-ephone-dn)#
Jul  1 17:05:29.591: //12/B7175CFB802B/CCAPI/cc_handle_inter_digit_timer:
   Generate inter-digit timeout CC_EV_CALL_DIGIT_END event
Jul  1 17:05:29.591: //12/xxxxxxxxxxxx/CCAPI/ccCallReportDigits:
   (callID=0xC, digit_event=0x0, enable=FALSE, consume=FALSE)
Jul  1 17:05:29.591: //12/B7175CFB802B/CCAPI/ccCallReportDigits:
   Enabled=TRUE, Call Id=12
Jul  1 17:05:29.591: //12/xxxxxxxxxxxx/CCAPI/cc_api_call_report_digits_done:
   (vdbPtr=0x4794F87C, callID=0xC, disp=0, digit_event=0x0, enable=FALSE, consume=FALSE)
Jul  1 17:05:29.591: //12/B7175CFB802B/CCAPI/cc_api_call_report_digits_done:
   Enabled=TRUE, Disposition=0x0, Interface=0x4794F87C, Call Id=12
Jul  1 17:05:29.591: //12/B7175CFB802B/CCAPI/cc_api_call_report_digits_done:
   Call Entry(Initial Digit Timeout=10000(ms), Inter Digit Timeout=10000(ms))
Jul  1 17:05:29.591: //12/B7175CFB802B/CCAPI/ccCallDisconnect:
   Cause Value=28, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
Jul  1 17:05:2
RtrPod1(config9.591: //12/B7175CFB802B/CCAPI/ccCallDisconnect:
   Cause Value=28, Call Entry(Responsed=TRUE, Cause Value=28)
Jul  1 17:05:29.591: //12/B7175CFB802B/CCAPI/cc_api_get_transfer_info:
   Transfer Number Is Null
Jul  1 17:05:29.591: //12/B7175CFB802B/CCAPI/cc_api_call_disc_cause_update:
   Cause Value=16
Jul  1 17:05:29.591: //12/B7175CFB802B/CCAPI/cc_api_call_disc_cause_update:
   Call Entry(Disconnect Cause=16)
Jul  1 17:05:29.687: //12/B7175CFB802B/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x4794F87C, Tag=0x0, Call Id=12,
   Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)
Jul  1 17:05:29.687: //12/B7175CFB802B/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
Jul  1 17:05:29.687: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
Jul  1 17:05:29.687: :cc_free_feature_vsa freeing 479292D8
Jul  1 17:05:29.687: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
Jul  1 17:05:29.687:  vsacount in free is 0-ephone-dn)#

8 REPLIES
VIP Gold

Please put 'cptone <as per

Please put 'cptone <as per your country>' under voice-port 0/2/0

If no success, then please attach "debug voip ccapi inout" for a failed call.

Suresh

Hi,Try enable and configure

Hi,

Try enable and configure the dspfarm and voice service voip.

Best regards,

Daniel

Daniel Sobrinho
New Member

I tried all the changes

I tried all the changes mentioned including enabling dsp farm and voip service. I can get dial-tone and call internally without issue but I can't receive external calls through the FXO port.

Here is what I get when I use debug voip ccapi inout. Could this problem be due to the fact that the phone line comes in through a cable modem? 

Debug voip ccapi inout

Main#
Jul  2 16:53:23.155: //-1/367B84A58016/CCAPI/cc_api_display_ie_subfields:
   cc_api_call_setup_ind_common:
   cisco-username=
   ----- ccCallInfo IE subfields -----
   cisco-ani=
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=0
   dest=
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=0
   cisco-rdnplan=0
   cisco-rdnpi=0
   cisco-rdnsi=0
   cisco-redirectreason=0   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

Jul  2 16:53:23.155: //-1/367B84A58016/CCAPI/cc_api_call_setup_ind_common:
   Interface=0x47EA197C, Call Info(
   Calling Number=,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=(TON=Unknown, NPI=Unknown),
   Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=FALSE,
   Incoming Dial-peer=0, Progress Indication=ORIGINATING SIDE IS NON ISDN(3), Calling IE Present=FALSE,
   S
RtrPod1#ource Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1
Jul  2 16:53:23.159: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
Jul  2 16:53:23.159: :cc_get_feature_vsa malloc success
Jul  2 16:53:23.159: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
Jul  2 16:53:23.159:  cc_get_feature_vsa count is 1
Jul  2 16:53:23.159: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
Jul  2 16:53:23.159: :FEATURE_VSA attributes are: feature_name:0,fearture_time:1206367200,feature_id:6
Jul  2 16:53:23.159: //6/367B84A58016/CCAPI/cc_api_call_setup_ind_common:
   Set Up Event Sent;
   Call Info(Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=(TON=Unknown, NPI=Unknown))
Jul  2 16:53:23.159: //6/367B84A58016/CCAPI/cc_process_call_setup_ind:
   Event=0x486B4C90
Jul  2 16:53:23.159: //6/367B84A58016/CCAPI/ccCallSetContext:
   Context=0x46A386F8
Jul  2 16:53:23.159: //6/367B84A58016/CCAPI/cc_process_call_setup_ind:
   >>>>CCAPI handed cid 6 with tag 0 to app "_ManagedAppProcess_Default"
Jul  2 16:53:23.159: //6/367B84A58016/CCAPI/ccCallSetupAck:
   Call Id=6
Jul  2 16:53:23.163: //6/367B84A58016/CCAPI/cc_api_set_transfer_info:
   Transfer Number=, Transfer Reason=0x0
Jul  2 16:53:23.163: //6/367B84A58016/CCAPI/ccGenerateToneInfo:
   Stop Tone On Digit=TRUE, Tone=Dial Tone,
   Tone Direction=Network, Params=0x0, Call Id=6
Jul  2 16:53:23.163: //6/367B84A58016/CCAPI/ccSetDigitTimeouts:
   Initial Digit Timeout=-1000(ms), Inter Digit Timeout=-1000(ms)
Jul  2 16:53:23.163: //6/367B84A58016/CCAPI/ccSetDigitTimeouts:
   Call Entry(Inter Digit Timeout=10000(ms), Initial Digit Timeout=10000(ms))
Jul  2 16:53:23.163: //6/xxxxxxxxxxxx/CCAPI/ccCallReportDigits:
   (callID=0x6, digit_event=0x1, enable=TRUE, consume=FALSE)
Jul  2 16:53:23.163: //6/367B84A58016/CCAPI/ccCallReportDigits:
   Enabled=TRUE, Call Id=6
Jul  2 16:53:23.163: //6/xxxxxxxxxxxx/CCAPI/cc_api_call_report_digits_done:
   (vdbPtr=0x47EA197C, callID=0x6, disp=0, digit_event=0x1, enable=TRUE, consume=FALSE)
Jul  2 16:53:23.163: //6/367B84A58016/CCAPI/cc_api_call_report_digits_done:
   Enabled=TRUE, Disposition=0x0, Interface=0x47EA197C, Call Id=6
Jul  2 16:53:23.163: //6/367B84A58016/CCAPI/cc_api_call_report_digits_done:
   Call Entry(Initial Digit Timeout=10000(ms), Inter Digit Timeout=10000(ms))
RtrPod1#
RtrPod1#
Jul  2 16:53:32.839: //6/367B84A58016/CCAPI/cc_api_call_disconnected:
   Cause Value=16, Interface=0x47EA197C, Call Id=6
Jul  2 16:53:32.839: //6/367B84A58016/CCAPI/cc_api_call_disconnected:
   Call Entry(Responsed=FALSE, Cause Value=16, Retry Count=0)
Jul  2 16:53:32.839: //6/367B84A58016/CCAPI/ccCallDisconnect:
   Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=16)
Jul  2 16:53:32.839: //6/367B84A58016/CCAPI/ccCallDisconnect:
   Cause Value=16, Call Entry(Responsed=TRUE, Cause Value=16)
Jul  2 16:53:32.839: //6/367B84A58016/CCAPI/cc_api_get_transfer_info:
   Transfer Number Is Null
RtrPod1#
Jul  2 16:53:32.843: //6/367B84A58016/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x47EA197C, Tag=0x0, Call Id=6,
   Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)
Jul  2 16:53:32.843: //6/367B84A58016/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
Jul  2 16:53:32.843: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
Jul  2 16:53:32.843: :cc_free_feature_vsa freeing 47E7B3D8
Jul  2 16:53:32.843: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
Jul  2 16:53:32.843:  vsacount in free is 0

New Member

After many hours of

After many hours of troubleshooting I figured out the problem. I was connecting the RJ11 line to the wrong voice-port interface... From left to right 1 0 not 0 1 so voice-port 0/2/0 should have been 0/2/1.  crying 

New Member

I tried all the changes

Tried changes suggested and still not working, added the debug response to the next post.

 

It doesn't appear that you've

It doesn't appear that you've associated the line with ephone.  Add the following under the appropriate ephone: button 1:2

Do you have dial tone or can you call internally?

Chris

HiThere is no destination

Hi

There is no destination info in the debug or calling number available.

Try change the config as shown:

voice-port 0/2/0
 connection plar 1002
 caller-id enable
 cptone (country cptone)
!
voice-port 0/2/1
!
dial-peer voice 1002 pots
 incoming called-number  1002$
 port 0/2/0

 

Configure telephony Services as exemple below

!

telephony-service
! sdspfarm units 4
!sdspfarm transcode sessions 10
! sdspfarm tag 1 XCODECOVD
! sdspfarm tag 2 CONFOVD
!conference hardware
 internal-call moh-group 0
 ip source-address 10.15.0.1 port 2000
 system message CME
 cnf-file location flash:
 time-zone 17
 time-format 24
 date-format dd-mm-yy
 max-conferences 4 gain -6
 call-forward pattern .T 
 call-forward system redirecting-expanded
 moh "flash:music-on-hold.au"
 multicast moh 239.1.1.1 port 2000
 dn-webedit
 transfer-system full-consult
 transfer-pattern .T   ------------------------------------------------------> to transfer calls
 secondary-dialtone 9

Daniel Sobrinho
New Member

I tried the configuration and

I tried the configuration and still not working. At this point I'm starting to feel like I'm going to need to study CCNP Voice if ever hope to expect to get this working live. I have no clue what the problem could be but as I said my FXO port connection goes through a cable modem could that be what's making this so difficult? 

Here's the updated config and Debug below. 

hostname main

!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$j/nW$ahTLPtnpkg509qVvAKq3h0
!
no aaa new-model
!
resource policy
!
clock timezone cdt -8
clock summer-time pst recurring
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.0.1 10.10.0.10
ip dhcp excluded-address 10.15.0.1 10.15.0.10
!
ip dhcp pool Data
   network 10.10.0.0 255.255.255.0
   default-router 10.10.0.1 
   option 150 ip 10.10.0.1 
!
ip dhcp pool Voice
   network 10.15.0.0 255.255.255.0
   default-router 10.15.0.1 
   option 150 ip 10.15.0.1 
!
no ip domain lookup
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
voice service voip 
!
crypto pki trustpoint TP-self-signed-1371503435
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1371503435
 revocation-check none
 rsakeypair TP-self-signed-1371503435
!
!
crypto pki certificate chain TP-self-signed-1371503435
 certificate self-signed 01
Bunch of code here
  quit
username jared privilege 15 password 0 cisco
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.10
 description Data VLAN
 encapsulation dot1Q 10
 ip address 10.10.0.1 255.255.255.0
!
interface FastEthernet0/0.11
 description Management VLAN
 encapsulation dot1Q 11
 ip address 10.11.0.1 255.255.255.0
!
interface FastEthernet0/0.15
 description Voice VLAN 
 encapsulation dot1Q 15
 ip address 10.15.0.1 255.255.255.0
!
interface FastEthernet0/1
 ip address 192.168.0.2 255.255.255.0
 duplex auto
 speed auto
!
ip http server
ip http authentication local
ip http secure-server    
!
tftp-server flash:phone/7940-7960/P00308010200.loads alias P00308010200.loads
tftp-server flash:phone/7940-7960/P00308010200.bin alias P00308010200.bin
tftp-server flash:phone/7940-7960/P00308010200.sb2 alias P00308010200.sb2
tftp-server flash:phone/7940-7960/P00308010200.sbn alias P00308010200.sbn
!
control-plane
!
voice-port 0/2/0
 connection plar opx 1002
 caller-id enable
!
voice-port 0/2/1
!
dspfarm profile 1 conference
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 codec g729br8
 maximum sessions 1
 associate application SCCP
!
!
dial-peer voice 1002 pots
 destination-pattern 1002
 incoming called-number 1002$
 port 0/2/0
!
gatekeeper
 shutdown
!
telephony-service
 no auto-reg-ephone
 load 7960-7940 P00308010200
 max-ephones 6
 max-dn 12
 ip source-address 10.15.0.1 port 2000
 system message main
 sdspfarm units 4
 sdspfarm transcode sessions 10
 sdspfarm tag 1 XCODECOVD
 sdspfarm tag 2 CONFOVD
 cnf-file location flash:
 max-conferences 8 gain -6
 call-forward pattern .T
 call-forward system redirecting-expanded
 transfer-system full-consult
 transfer-pattern .T
 secondary-dialtone 9

!
!
ephone-dn  1  dual-line
 number 1002
!
ephone-dn  2  dual-line
 number 1003
!
ephone  1
 device-security-mode none
 mac-address 0014.6AC3.D1FA
 type 7960
 button  1:1
!
ephone  2 
 device-security-mode none
 mac-address 0007.0EC4.7280
 type 7960
 button  1:2
!
!
!
line con 0
 exec-timeout 0 0
 password cisco
 logging synchronous
 login
line aux 0
line vty 0 4
 password cisco
 login local
line vty 5
 password cisco
 login local
line vty 6 15
 password cisco
 login
!
scheduler allocate 20000 1000
ntp server 192.168.0.1
!
end

 

Debug 

voip ccapi inout debugging is on

Jul  3 01:27:48.375: //-1/1395C148800E/CCAPI/cc_api_display_ie_subfields:
   cc_api_call_setup_ind_common:
   cisco-username=
   ----- ccCallInfo IE subfields -----
   cisco-ani=
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=0
   dest=
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=0
   cisco-rdnplan=0
   cisco-rdnpi=0
   cisco-rdnsi=0
   cisco-redirectreason=0   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

Jul  3 01:27:48.375: //-1/1395C148800E/CCAPI/cc_api_call_setup_ind_common:
   Interface=0x48236DE8, Call Info(
   Calling Number=,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=(TON=Unknown, NPI=Unknown),
   Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=FALSE,
   Incoming Dial-peer=0, Progress Indication=ORIGINATING SIDE IS NON ISDN(3), Calling IE Present=FALSE,
   S
RtrPod1(configource Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1
Jul  3 01:27:48.375: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
Jul  3 01:27:48.375: :cc_get_feature_vsa malloc success
Jul  3 01:27:48.375: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
Jul  3 01:27:48.375:  cc_get_feature_vsa count is 1
Jul  3 01:27:48.375: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
Jul  3 01:27:48.375: :FEATURE_VSA attributes are: feature_name:0,fearture_time:1206479168,feature_id:4
Jul  3 01:27:48.375: //4/1395C148800E/CCAPI/cc_api_call_setup_ind_common:
   Set Up Event Sent;
   Call Info(Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=(TON=Unknown, NPI=Unknown))
Jul  3 01:27:48.379: //4/1395C148800E/CCAPI/cc_process_call_setup_ind:
   Event=0x4875D850
Jul  3 01:27:48.383: //4/1395C148800E/CCAPI/ccCallSetContext:
   Context=0x46849A4C
Jul  3 01:27:48.383: //4/1395C148800E/CCAPI/cc_process_call_setup_ind:
   >>>>CCAPI handed cid 4 with tag 0 to app "_ManagedAppProcess_Default"
Jul  3 01:27:48.383: //4/1395C148800E/CCAPI/ccCallSetupAck:
   Call Id=4
Jul  3 01:27:48.383: //4/1395C148800E/CCAPI/cc_api_set_transfer_info:
   Transfer Number=, Transfer Reason=0x0
Jul  3 01:27:48.383: //4/1395C148800E/CCAPI/ccGenerateToneInfo:
   Stop Tone On Digit=TRUE, Tone=Dial Tone,
   Tone Direction=Network, Params=0x0, Call Id=4
Jul  3 01:27:48.383: //4/1395C148800E/CCAPI/ccSetDigitTimeouts:
   Initial Digit Timeout=-1000(ms), Inter Digit Timeout=-1000(ms)
Jul  3 01:27:48.383: //4/1395C148800E/CCAPI/ccSetDigitTimeouts:
   Call Entry(Inter Digit Timeout=10000(ms), Initial Digit Timeout=10000(ms))
Jul  3 01:27:48.383: //4/xxxxxxxxxxxx/CCAPI/ccCallReportDigits:
   (callID=0x4, digit_event=0x1, enable=TRUE, consume=FALSE)
Jul  3 01:27:48.383: //4/1395C148800E/CCAPI/ccCallReportDigits:
   Enabled=TRUE, Call Id=4
Jul  3 01:27:48.383: //4/xxxxxxxxxxxx/CCAPI/cc_api_call_report_digits_done:
   (vdbPtr=0x48236DE8, callID=0x4, disp=0, digit_event=0x1, enable=TRUE, consume=FALSE)
Jul  3 01:27:48.383: //4/1395C148800E/CCAPI/cc_api_call_report_digits_done:
   Enabled=TRUE, Disposition=0x0, Interface=0x48236DE8, Call Id=4
Jul  3 01:27:48.383: //4/1395C148800E/CCAPI/cc_api_call_report_digits_done:
   Call Entry(Initial Digit Timeout=10000(ms), Inter Digit Timeout=10000(ms))-telephony)#
RtrPod1(config-telephony)#
Jul  3 01:27:58.123: //4/1395C148800E/CCAPI/cc_api_call_disconnected:
   Cause Value=16, Interface=0x48236DE8, Call Id=4
Jul  3 01:27:58.123: //4/1395C148800E/CCAPI/cc_api_call_disconnected:
   Call Entry(Responsed=FALSE, Cause Value=16, Retry Count=0)
Jul  3 01:27:58.123: //4/1395C148800E/CCAPI/ccCallDisconnect:
   Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=16)
Jul  3 01:27:58.123: //4/1395C148800E/CCAPI/ccCallDisconnect:
   Cause Value=16, Call Entry(Responsed=TRUE, Cause Value=16)
Jul  3 01:27:58.123: //4/1395C148800E/CCAPI/cc_api_get_transfer_info:
   Transfer Number Is Null
RtrPod1(config-telephony)#
Jul  3 01:27:58.127: //4/1395C148800E/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x48236DE8, Tag=0x0, Call Id=4,
   Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)
Jul  3 01:27:58.127: //4/1395C148800E/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
Jul  3 01:27:58.127: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
Jul  3 01:27:58.127: :cc_free_feature_vsa freeing 47E96938
Jul  3 01:27:58.127: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
Jul  3 01:27:58.127:  vsacount in free is 0

 

909
Views
23
Helpful
8
Replies
CreatePlease to create content