Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Configuring switchport for non Cisco IP phones?

What is Cisco's definitive recommendation for configuring Cisco switchports when using non-Cisco IP phones with a PC connected to the IP phone? We are using Avaya IP phones.

I've seen several different configs, with pros and cons for each, but I would like Cisco to tell me which is their Best Practice recommendation.

Here are three examples I've seen:

data vlan = 60

voice vlan = 910

1.

interface FastEthernet1/0/2

switchport access vlan 60

switchport voice vlan 910

2.

interface FastEthernet1/0/3

switchport trunk encapsulation dot1q

switchport trunk native vlan 60

switchport mode trunk

switchport voice vlan 910

3.

interface FastEthernet1/0/12

switchport access vlan 60

switchport trunk encapsulation dot1q

switchport trunk native vlan 60

switchport trunk allowed vlan 60,910

switchport mode trunk

  • IP Telephony
8 REPLIES
Silver

Re: Configuring switchport for non Cisco IP phones?

Hello,

Configuration 1 is usually compatible with Cisco IP phones because the switch will determine that there is an IP phone connected and will split the traffic accordingly.

IN the second configuration you are negotiating a trunk. As I said in this configuration you are using a Non-Cisco Phone where you are creating a trunk so you can pass multiple VLANs over the port. This configuration is also applicable for Cisco IP Phones.

The last one is the same as the second however, you are securing the trunk by allowing those specific VLANs. Thus if a user tries to do some attacks and tag traffic with different VLAN tag it will be dropped. Moreover, you are setting all untagged traffic to the data VLAN.

I personnaly perfer to set the port as access and use config 1 incase I am using Cisco IP Phone. This would alliviate the security risks in having a trunk with user devices. In case you are using Non cisco Ip phone config 3 is more secure than 2 because you are filtering vlans over the trunk.

Hope this helps and answers your questions,

Regards,

New Member

Re: Configuring switchport for non Cisco IP phones?

Hi,

I have a doubt regarding this.

Cisco Switches segregates Voice and Data traffic by using the CDP packets coming Cisco IP Phones. But in the case of non Cisco IP Phones, how can the Switch determine the voice vlan ? It will be part of data vlan only.

Thanks,

Manu

Silver

Re: Configuring switchport for non Cisco IP phones?

Hello,

The switch determines that there is a Cisco IP Phone connected via CDP. However, in case of non-cisco IP Phone a trunk is negotiated and the IP Phone will be configured to tag packets.

IN short, the IP Phone will be configured to tag packets.

Regards,

New Member

Re: Configuring switchport for non Cisco IP phones?

Hi,

Thanks for your reply.

But how switch segregates between voice and data packets. Which packets will be tagged by the IP Phone ?

Thanks,

Manu

Silver

Re: Configuring switchport for non Cisco IP phones?

Hello,

I have experience with Nortel where the phone is configured to tag voice traffic for example with 60 and Data traffic with 80.

Honestly, I am not that experience in other vendor's phones and I have configured switchports for Nortel.

Soon, I am going to configure switchports for Avaya and I would know how Avaya does traffic segregation.

Regards,

Regards,

New Member

Re: Configuring switchport for non Cisco IP phones?

Hi,

Thanks for your reply. Please share your Avaya experience also once you are done as I am also going to configure the same soon.

Thanks,

Manu

Silver

Re: Configuring switchport for non Cisco IP phones?

You're Welcome and will paste a sample config.

Regards,

New Member

Re: Configuring switchport for non Cisco IP phones?

Hi

Kindly could you advise me with following :

i have a nortel ip Phone 1140E version , and 2901 Voice Gateway (2901 CME) , and i need the way to Confiure the nortel ip phone and give it Extension from 2901 CME, could you help me plz?

thanks

407
Views
0
Helpful
8
Replies
This widget could not be displayed.