Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Connect CUCM to H323 gateway through CCME

Good day,

Can anybody help me to solve the problem with h323 gateway and CUCM? I have the following ip telephony topology: CUCM 6.1 -> CUCME 7.1 -> Provider's H323 Gateway -> PSTN. When I am calling from CUCME to PSTN it's ok. All incoming and outcoming calls are working. Also all calls from CUCM to CUCME are ok too. But when I am trying to call from CUCM to PSTN it does not work. After dialing mobile number I hear the silence in the handset, but the mobile phone is ringing. When I pick up the mobile phone after few seconds the call disconnects. It seems that signaling doesn't work. But incoming calls to CUCM from PSTN are working normaly.

In the CUCM I add CUCME like gateway with ip address 10.50.2.8 and no MTP.

This is config of CUCME:

!
voice call convert-discpi-to-prog
!
voice service pots
fax rate disable
!
voice service voip
allow-connections h323 to h323
redirect ip2ip
fax protocol pass-through g711ulaw
fax-relay ans-disable
h323
  emptycapability
  h225 display-ie ccm-compatible
  h225 id-passthru
  h245 passthru tcsnonstd-passthru
modem passthrough nse codec g711ulaw
!
!

!
voice translation-rule 9
rule 1 /^[0-9]...$/ /74957758705/ type any national
!
voice translation-rule 10
rule 1 /^90/ /2660044#0/
rule 2 /^91/ /2660044#1/
rule 3 /^92/ /2660044#2/
rule 4 /^93/ /2660044#3/
rule 5 /^94/ /2660044#4/
rule 6 /^95/ /2660044#5/
rule 7 /^96/ /2660044#6/
rule 8 /^97/ /2660044#7/
rule 9 /^98/ /2660044#7/
rule 10 /^99/ /2660044#9/
!

!
interface Loopback0
ip address 10.50.2.8 255.255.255.0
no ip redirects
no ip proxy-arp
ip flow ingress
ip pim sparse-dense-mode
ip virtual-reassembly
!

!
interface GigabitEthernet0/0.22
description Voice$FW_INSIDE$
encapsulation dot1Q 22
ip address 172.22.1.1 255.255.248.0
no ip redirects
no ip proxy-arp
ip pim sparse-dense-mode
ip virtual-reassembly
!
interface GigabitEthernet0/0.39
description $H323$
encapsulation dot1Q 39
ip address 10.50.88.2 255.255.255.252
ip access-group 104 in
no ip redirects
no ip proxy-arp
ip accounting output-packets
ip inspect Voice out
ip virtual-reassembly
no cdp enable
!

ip route 195.239.254.161 255.255.255.255 10.50.88.1

!

!
dial-peer voice 2400 voip
corlist incoming 1
corlist outgoing call-local
description CCM
answer-address 24..$
destination-pattern 24..$
modem passthrough nse codec g711ulaw
session target ipv4:172.22.1.2
dtmf-relay h245-alphanumeric
codec g711ulaw
fax rate disable
ip qos dscp cs5 media
!

!
dial-peer voice 98964 voip
corlist incoming call-local
corlist outgoing call-mobil
description h323_beeline
translation-profile outgoing nat_beeline
destination-pattern 989645000441$
session target ipv4:195.239.254.161
incoming called-number 7T
codec g711ulaw
!

num-exp 74957758705 2407

!!
telephony-service
video
  maximum bit-rate 480
em keep-history
em logout 22:0 23:0
max-ephones 240
max-dn 700
ip source-address 10.50.2.8 port 2000
service phone videoCapability 1
timeouts interdigit 8
timeouts transfer-recall 20
system message Bosco Di Ciliegi
url information http://192.168.2.32/default.aspx
url services http://192.168.2.32/default.aspx
url authentication http://172.22.1.1/CCMCIP/authenticate.asp 
cnf-file location flash:
cnf-file perphone
user-locale 3 U3 load CME-locale-ru_RU-Russian-7.0.1.1.tar
load 7914 S00105000300
load 7906 SCCP11.8-4-2S.loads
load 7911 SCCP11.8-4-2S
load 7920 cmterm_7920.4.0-03-02
load 7921 CP7921G-1.1.1
load 7931 SCCP31.8-3-3S
load 7960-7940 P00308000500
load 7941 SCCP41.8-4-2S
load 7941GE SCCP41.8-4-2S
load 7942 SCCP42.8-3-3S
load 7945 SCCP45.8-3-3S
load 7961 SCCP41.8-3-3S
load 7962 SCCP42.8-3-3S
load 7965 SCCP45.8-3-3S
load 7970 SCCP70.8-3-3S
load 7971 SCCP70.8-3-3S
load 7975 SCCP75.8-3-3S
time-zone 32
time-format 24
date-format dd-mm-yy
keepalive 360 auxiliary 360
max-conferences 12 gain -6

!

2 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

Re: Connect CUCM to H323 gateway through CCME

Sounds like there is a codec mismatch occurring if the call drops when the called party goes offhook. Can you collect the following debug output for a failed call.

debug voip ccapi inout

debug h225 asn1

debug h245 asn1

Note the calling and called party numbers.

-Felipe

Cisco Employee

Re: Connect CUCM to H323 gateway through CCME

Most likely u were simply missing following command

but since the issue is resolved perhaps u want to mark

this thread as answered.

interface Loopback0
  ip address 10.50.2.8 255.255.255.0

  h323-gatway voip bind srcaddr 10.50.2.8  <---------

4 REPLIES
Cisco Employee

Re: Connect CUCM to H323 gateway through CCME

Sounds like there is a codec mismatch occurring if the call drops when the called party goes offhook. Can you collect the following debug output for a failed call.

debug voip ccapi inout

debug h225 asn1

debug h245 asn1

Note the calling and called party numbers.

-Felipe

New Member

Re: Connect CUCM to H323 gateway through CCME

Hi, Felipe. Thanks for reply.

This is debug, I called from 2407 to 989645000441:

CRV3845#sh debugging

H.225:
  H.225 ASN1 Messages debugging is on
H.245:
  H.245 ASN1 Messages debugging is on
CCAPI:
  debug voip ccapi inout is ON (filter is OFF)

CRV3845#
CRV3845#
184773: Oct 12 19:12:40.595 GMT: H225.0 INCOMING ENCODE BUFFER::= 20B0060008914A000501401F0049005000200043006F006D006D0075006E0069006300610074006F00720000000000000000000000000000000000000000000000000000000000000000000022C0B50000120F436973636F43616C6C4D616E61676572003100010580CBC9783337740080A94A26E87A41CB66056101C0A8079600D50D80000700AC16010206B8110080A94A26E87A41CB66056101C0A80796010001000100010010A001000F0140B5000012088144000400010300
184774: Oct 12 19:12:41.567 GMT: //-1/FE080AF4A6FB/CCAPI/cc_api_display_ie_subfields:
   cc_api_call_setup_ind_common:

184776: Oct 12 19:12:44.623 GMT: //39005/FE080AF4A6FB/CCAPI/cc_api_call_info:
   Info Digits=7, Info Complete=FALSE,
   Interface=0x71386A44, Data Bitmask=0x0, Call Id=39005
184777: Oct 12 19:12:45.707 GMT: //39005/FE080AF4A6FB/CCAPI/cc_api_call_info:
   Info Digits=2, Info Complete=FALSE,
   Interface=0x71386A44, Data Bitmask=0x0, Call Id=39005
184778: Oct 12 19:12:46.755 GMT: H225.0 INCOMING ENCODE BUFFER::= 23C0060008914A00042800B500001240013C05010000C3EFFEA19BDB1B0C00110080A94A26E87A41CB66056101C0A807960180018010A801003A0140B50000123360010100011E2C1E0284881C269E8100036774640000001B41434D2C0D0A50524E2C6973646E2A2C2C4E4554352A2C0D0A0D0A224204677464011B41434D2C0D0A50524E2C6973646E2A2C2C4E4554352A2C0D0A0D0A
184779: Oct 12 19:12:48.235 GMT: //39005/FE080AF4A6FB/CCAPI/cc_api_call_info:
   Info Digits=6, Info Complete=FALSE,
   Interface=0x71386A44, Data Bitmask=0x0, Call Id=39005
184781: Oct 12 19:12:49.903 GMT: //39005/FE080AF4A6FB/CCAPI/cc_api_call_info:
  
184782: Oct 12 19:12:50.895 GMT: //39005/FE080AF4A6FB/CCAPI/cc_api_call_info:
   Info Digits=1, Info Complete=FALSE,
   Interface=0x71386A44, Data Bitmask=0x0, Call Id=39005
184783: Oct 12 19:12:52.455 GMT: //39005/FE080AF4A6FB/CCAPI/cc_api_call_info:
   Info Digits=7, Info Complete=FALSE,
   Interface=0x71386A44, Data Bitmask=0x0, Call Id=39005
184784: Oct 12 19:12:52.535 GMT: //-1/xxxxxxxxxxxx/CCAPI/cc_build_feature_vsa:
  
184785: Oct 12 19:12:52.535 GMT: :Inside cc_build_feature_vsa
184788: Oct 12 19:12:56.619 GMT: //39005/FE080AF4A6FB/CCAPI/cc_api_call_disconnected:
   Cause Value=16, Interface=0x71386A44, Call Id=39005
CRV3845#

Also I mentioned that the call is connected with G729 codec, but my provider is waiting G711 codec. Why is it happened?

GENERIC:
SetupTime=418208020 ms
Index=37620
PeerAddress=2407
PeerSubAddress=
PeerId=2400
PeerIfIndex=130
LogicalIfIndex=0
DisconnectCause=2F 
DisconnectText=no resource (47)
ConnectTime=0 ms
DisconnectTime=418224220 ms
CallDuration=00:00:00 sec
CallOrigin=2
ReleaseSource=2
ChargedUnits=0
InfoType=speech
TransmitPackets=0
TransmitBytes=0
ReceivePackets=0
ReceiveBytes=0
VOIP:
ConnectionId[0x80A94A26 0xE87A41CB 0x66056101 0xC0A80796]
IncomingConnectionId[0x80A94A26 0xE87A41CB 0x66056101 0xC0A80796]
CallID=39003
RemoteIPAddress=172.22.1.2
RemoteUDPPort=0
RemoteSignallingIPAddress=172.22.1.2
RemoteSignallingPort=57260
RemoteMediaIPAddress=0.0.0.0
RemoteMediaPort=0
SRTP = off
TextRelay = off
Fallback Icpif=0
Fallback Loss=0
Fallback Delay=0
RoundTripDelay=0 ms
SelectedQoS=best-effort
tx_DtmfRelay=inband-voice
FastConnect=FALSE

AnnexE=FALSE

Separate H245 Connection=TRUE

H245 Tunneling=FALSE

SessionProtocol=cisco
ProtocolCallId=
SessionTarget=
OnTimeRvPlayout=0
GapFillWithSilence=0 ms
GapFillWithPrediction=0 ms
GapFillWithInterpolation=0 ms
GapFillWithRedundancy=0 ms
HiWaterPlayoutDelay=0 ms
LoWaterPlayoutDelay=0 ms
ReceiveDelay=0 ms
LostPackets=0
EarlyPackets=0
LatePackets=0
VAD = enabled
CoderTypeRate=g729r8 pre-ietf
CodecBytes=0
cvVoIPCallHistoryIcpif=0
MediaSetting=flow-through
CallerName=IP Communicator
CallerIDBlocked=False
OriginalCallingNumber=2407
OriginalCallingOctet=0x0
OriginalCalledNumber=989645000441
OriginalCalledOctet=0x80
OriginalRedirectCalledNumber=
OriginalRedirectCalledOctet=0xFF
TranslatedCallingNumber=2407
TranslatedCallingOctet=0x0
TranslatedCalledNumber=989645000441
TranslatedCalledOctet=0x80
TranslatedRedirectCalledNumber=
TranslatedRedirectCalledOctet=0xFF
GwReceivedCalledNumber=989645000441
GwReceivedCalledOctet3=0x80
GwReceivedCallingNumber=2407
GwReceivedCallingOctet3=0x0
GwReceivedCallingOctet3a=0x81
MediaInactiveDetected=no
MediaInactiveTimestamp=
MediaControlReceived=
LongDurationCallDetected=no
LongDurationCallTimerStamp=
LongDurationCallDuration=
Username=
MlppServiceDomain=0 (NO_MLPP_DOMAIN)
PrecedenceLevel=0 (PRECEDENCE_LEVEL_NONE)

GENERIC:

New Member

Re: Connect CUCM to H323 gateway through CCME

Felipe,

I solve my problem. I added new gateway with ip address of sub interface on my CUCME - 10.50.88.2. Through this interface I connect to PSTN. Before I have only one gateway with main ip address of CUCME in CUCM.

Whatever, thanks for your help.

Cisco Employee

Re: Connect CUCM to H323 gateway through CCME

Most likely u were simply missing following command

but since the issue is resolved perhaps u want to mark

this thread as answered.

interface Loopback0
  ip address 10.50.2.8 255.255.255.0

  h323-gatway voip bind srcaddr 10.50.2.8  <---------

691
Views
0
Helpful
4
Replies
CreatePlease to create content