Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.

Connecting IP Phone in different cluster via H.323 gateway

Hi,

I have configured R2 as H.323 GW and registered to CUCM.

Created route group,route list and route pattern for 9001 phone in CUCM.

call can not be established between these two phones.

Below is the scenario and find the configuration.

I am new in IP Telephony, Please suggest.

CME to CUCM via h.323.png

Configuration for R1

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2014.02.23 00:02:33 =~=~=~=~=~=~=~=~=~=~=~=

sh run

Building configuration...

Current configuration : 1417 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CME-VOICE

!

interface FastEthernet0/0

ip address 192.168.0.254 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 172.16.0.1 255.255.255.252

duplex auto

speed auto

!

router ospf 10

log-adjacency-changes

network 172.16.0.0 0.0.0.255 area 10

network 192.168.0.0 0.0.0.255 area 10

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

control-plane

!

enable password cisco

!

dial-peer voice 1 voip

destination-pattern 2...

session target ipv4:10.113.113.2

!

!

telephony-service

no auto-reg-ephone

max-ephones 10

max-dn 10

ip source-address 192.168.0.254 port 2000

max-conferences 8 gain -6

transfer-system full-consult

!

!

ephone-dn  1

number 9001

name LAPTOP-PH

!

!

ephone  1

device-security-mode none

mac-address 0025.B347.FD44

button  1:1

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

password cisco

login

!

!

end

CME-VOICE#

Configuration for R2

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2014.02.23 00:01:49 =~=~=~=~=~=~=~=~=~=~=~=

terminal

CUCM#terminal length 0

CUCM#sh run

Building configuration...

Current configuration : 982 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CUCM

!

interface FastEthernet0/0

ip address 10.113.113.254 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.113.113.254

!

interface FastEthernet0/1

ip address 172.16.0.2 255.255.255.252

duplex auto

speed auto

!

router ospf 10

log-adjacency-changes

network 10.113.113.0 0.0.0.255 area 10

network 172.16.0.0 0.0.0.255 area 10

!

ip forward-protocol nd

!

!

ip http server

no ip http secure-server

!

control-plane

!

line con 0

line aux 0

line vty 0 4

password cisco

login

!

!

end

CUCM#

Regards,

Shibasish

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Connecting IP Phone in different cluster via H.323 gateway

You need to add R1 as the GW or ICT in CUCM for direct connection between CME and CUCM, as your dial-peer on R1 points to CUCM via: session target ipv4:10.113.113.2

Chris

9 REPLIES
Hall of Fame Super Silver

Re: Connecting IP Phone in different cluster via H.323 gateway

Describe your call flow, what is R1 doing here? Who is calling who?

Sent from Cisco Technical Support iPhone App

Connecting IP Phone in different cluster via H.323 gateway

Hi chris,

R1 is working as a CME. Currently One Ip phone is registered in R1.Assume that, R1 and R2 are in different cluster. While calling from 9001 to 2001 or vise versa,both way call is not connecting.

Please find the R2's dial-peer with previous config:

R2's dial-peer config

dial-peer voice 2 voip

destination-pattern 9...

session target ipv4:172.16.0.1

Hall of Fame Super Silver

Connecting IP Phone in different cluster via H.323 gateway

Which side is 9001 on and which side is 2001 on?

What is R2 for then? 

None of your interfaces on R1 are defined for h323, i.e.


interface FastEthernet0/0

ip address 10.113.113.254 255.255.255.0

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.113.113.254

you also need:

voice service voip

allow-connections h323 to h323

Chris

Connecting IP Phone in different cluster via H.323 gateway

9001 phone is registered in R1(CME) and 2001 is register with CUCM(10.113.113.2). I have already configured R2 as h.323 gw with its interface FastEthernet0/0 interface (already mentioned with earlier post).

Regards,

shibasish

Hall of Fame Super Silver

Connecting IP Phone in different cluster via H.323 gateway

You need to add R1 as the GW or ICT in CUCM for direct connection between CME and CUCM, as your dial-peer on R1 points to CUCM via: session target ipv4:10.113.113.2

Chris

Connecting IP Phone in different cluster via H.323 gateway

That is working. In the previous scenario, I've configured R1 as h.3233Gw in CUCM and it was working fine. Now I'm trying to configure R2 as Gw in CUCM assuming R1 is in at branch office while R2 & CUCM is in at HQ.

Will it be possible?

Regards,

Shibasish

Hall of Fame Super Silver

Connecting IP Phone in different cluster via H.323 gateway

For what purpose?

You can have both R1 for the CUCM to CME integration, and R2 for whatever other purpose you wan it.

HTH, please rate all useful posts!

Chris

Connecting IP Phone in different cluster via H.323 gateway

I mean if I leave R1 just as CME (without configring it as h.323 gw), and register R2 as a H.323 Gw then also I am having the same issue.

Regards,

Shibasish

Hall of Fame Super Silver

Connecting IP Phone in different cluster via H.323 gateway

I dont follow what you are trying to do, your original post was about integrating CME (r1) with CUCM which is done directly without the need for "CUBE" in between, so what is R2 for? What do you have on R2 that you need to integrate to this environment?

Chris

264
Views
5
Helpful
9
Replies
CreatePlease to create content