Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Create dvd for upgrade from 6.1.3.3190-1 to 7.1.2.21900-5

I have downloaded the 2 files for this upgrade and combined them into a single file as per the readme for 7.1(2a)Su1:

 

 

UCSInstall_UCOS_7.1.2.21900-5.sgn.iso

I created a dvd  with a copy of this file on it and checked the MD5 from the dvd.  It checks out.  When I put the DVD in my Publisher and try to start the upgrade it shows the name of the file but then when I click next it complains that an unknown error occured with the disk.  So I don't know if I have a bad DVD or I did not make the DVD correctly.  There seems to be confusion about what to put on the DVD.  Posts here say you just need to copy the file to a DVD - ie a data DVD and if you make an DVD with all the files on it - that won't work.  The instructions in the Software Upgrade Procedure from the OS Admin Guide say it has to be an iso image (which I think means all the files get created from the .iso file).  I did actually order the upgrade via PUT but they sent 7.1(3a) which is not compatible with the IOS version I have on my gateways.  I noted that the disk they sent has all the files and folders on it - not the .iso file.  This is very frustrating - especially on Christmas eve !

Thanks,

Bill

7 REPLIES
VIP Super Bronze

Re: Create dvd for upgrade from 6.1.3.3190-1 to 7.1.2.21900-5

I thought there was a bug about this but I believe I am mistaken. There was a bug where if you canceled an upgrade from DVD it would fail to unmount the drive or eject until a restart. There was also a bug in 7.1.2 that prevented you from upgrading during initial install. Neither seem relevent though.

You may want to try using an FTP server instead so you can move forward. OS Administration will give you an option for Remote Filesystem.

You are correct that you should be using an ISO image file. If you burn the ISO to a disc it will fail. The media shipped from Cisco is bootable and that is why they unpack everything onto the disc. It's a royalties thing with Redhat and other vendors as I understand it.

I am curious what you mean by 7.1(3) being incompatible with your IOS though. Care to elaborate?

Message was edited by: Jonathan Schulenberg

Please remember to rate helpful responses and identify helpful or
New Member

Re: Create dvd for upgrade from 6.1.3.3190-1 to 7.1.2.21900-5

Jonathan,

Thanks for the reply.

  • So I need to make an iso image from that file to dvd.  What exactly will be on the DVD?  I think my first try I told it to do that but the only thing on the disk is that one file.  Is that correct?
  • Also you are saying that what I got from my Cisco order is a bootable disk and that is why all the files are there?
  • As far as 7.1(3) goes, the compatibility matrix lists IOS release 15 as required for gateways.  7.1(2) only needs 12.4(24)T1 - which we just had our network guy upgrade all gateways to.
  • The only access I have to an FTP server (I think it has to be SFTP?) is across a wireless link which is a little slow and has been known to go down from time to time - especially in our winter weather

Thanks,

Bill

VIP Super Bronze

Re: Create dvd for upgrade from 6.1.3.3190-1 to 7.1.2.21900-5

  1. You should be getting two files from CCO and then using "copy /b" to join them into a valid ISO. If your MD5 matches the documentation you must have done that correctly. You then take that file and write it to the DVD. You do NOT burn the ISO itself. The DVD should have just the single ISO on it.
  2. Correct. This is how Cisco is controlling new installs and how much they need to pay in royalties to other companies such as Redhat. The ISO images from CCO cannot be used to install from scratch, only the media shipped can.
  3. I presume you are looking at this document? If so, that is not attempting to infer that that is the ONE AND ONLY version of IOS that will work with UCM. It is only saying that is what they primarily tested against. You should be fine running older [more stable] IOS versions in most cases. Example: I have customers running UCM 7.1.3.10000 with IOS 12.4(15)T9 as MGCP gateways without issue. This is even less of an issue if you have SIP or H.323 since they are peers to UCM, not slaves. The older versions of IOS typically mean that you may be missing some new feature that was rolled in relavent to UCM.
  4. Upgrades do not require SFTP, only backups. When you select Remote Filesystem you can then select normal FTP. You can install Filezilla FTP server (or any other FTP server that you prefer) and be good to go.
Please remember to rate helpful responses and identify helpful or
New Member

Re: Create dvd for upgrade from 6.1.3.3190-1 to 7.1.2.21900-5

Ok - thanks. One more point to clear up. Can you use the DVD they

sent with all the files to do an upgrade or is that just for new

installs? So you still need the UCSinstall_UCOS file for the upgrade?

On Thu, Dec 24, 2009 at 3:42 PM, j.schulenberg

VIP Super Bronze

Re: Create dvd for upgrade from 6.1.3.3190-1 to 7.1.2.21900-5

I honestly haven't tried to do an upgrade from the media so I don't know that one. I just download out of habit.

Also, don't forget your feature license key when upgrading between major versions (e.g. 6.x to 7.x) or the CallManager service won't start.

Please remember to rate helpful responses and identify helpful or
New Member

Re: Create dvd for upgrade from 6.1.3.3190-1 to 7.1.2.21900-5

Thanks. I have the PAK license key from what Cisco sent me from the

7.1.3 PUT order.

On Thu, Dec 24, 2009 at 5:59 PM, j.schulenberg

New Member

Re: Create dvd for upgrade from 6.1.3.3190-1 to 7.1.2.21900-5

I tried this using Filezilla server.  I can see the call manager login to the ftp server, then the ftp server says it goes to Passive mode, then after a delay Call Manager says it failed to connect.  I tried FreeFTPd also and got similair results.

907
Views
0
Helpful
7
Replies