Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CUBE and BE3k

Hey guys,

First time with cube for me. Trying to configure cube with be3k to the service provider.

Please share some sample config for CUBE.

Thanks

Varadarajan.R

Everyone's tags (6)
2 ACCEPTED SOLUTIONS

Accepted Solutions

CUBE and BE3k

Hi Varadarajan,

you are missing few important configs like, binding media and signaling interfaces, inbound & outbound dialpeers to and from CUCM & ITSP.

Also check with your provider about the codec the support and how many digits the called number to be sent to ITSP. and configure translation rules if needed

Please have a look at the post from Deji (aokanlawon):

https://supportforums.cisco.com/message/4117173#4117173

it would help you to understand the CUBE config.

Please rate all the useful posts

//Suresh Please rate all the useful posts.

CUBE and BE3k

what transport protocol does your ISP expect UDP or TCP?

Please spesify in your dialpeer that as well:

(config-dial-peer)#session transport ?

  system  defer to voice service voip session transport

  tcp     Transport Layer Protocol - TCP

  udp     Transport Layer Protocol - UDP

I see in your traces the following:

Here is tries via UDP:

Sent:

INVITE sip:14089217525@125.22.86.19:5060 SIP/2.0

Via: SIP/2.0/UDP 172.16.1.10:5060;branch=z9hG4bK1835

From: <5501>;tag=33AF1D7C-96A

To: <14089217525>

Date: Thu, 09 Jan 2014 09:29:27 GMT

Call-ID: 5E8BDBBE-784711E3-852884E5-8465EDA2@172.16.1.10

Here it tries via TCP:

Received:

ACK sip:14089217525@172.16.1.10:5060 SIP/2.0

Via: SIP/2.0/TCP 172.16.1.2:5060;branch=z9hG4bK2cd43d97d3cc

From: <5501>;tag=36932~43a596bc-8a16-4858-b2e2-3b8931e63a9c-17094314

To: <14089217525>;tag=33AFCF40-2005

Date: Thu, 09 Jan 2014 09:39:41 GMT

Call-ID: f562f200-2ce16e5d-2c8d-20110ac@172.16.1.2

So it seems to me you are sending UDP and your ISP is answering in TCP.

Voice CCIE #37771
18 REPLIES
New Member

CUBE and BE3k

I have a fee basic config on the cube. i am getting the following error right now for debug

Router#

*Jan  8 17:06:02.012: //-1/8F7E58000000/CCAPI/cc_api_display_ie_subfields:

   cc_api_call_setup_ind_common:

   cisco-username=5501

   ----- ccCallInfo IE subfields -----

   cisco-ani=5501

   cisco-anitype=0

   cisco-aniplan=0

   cisco-anipi=0

   cisco-anisi=1

   dest=14089217525

   cisco-desttype=0

   cisco-destplan=0

   cisco-rdie=FFFFFFFF

   cisco-rdn=

   cisco-rdntype=0

   cisco-rdnplan=0

   cisco-rdnpi=-1

   cisco-rdnsi=-1

   cisco-redirectreason=-1   fwd_final_type =0

   final_redirectNumber =

   hunt_group_timeout =0

*Jan  8 17:06:02.012: //-1/8F7E58000000/CCAPI/cc_api_call_setup_ind_common:

   Interface=0x8A4912A4, Call Info(

   Calling Number=5501,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=User,                                                                                                  Passed, Presentation=Allowed),

   Called Number=14089217525(TON=Unknown, NPI=Unknown),

   Calling Translated=FALSE, Subscriber Type Str=Unknown, FinalDestinationFlag=T                                                                                                 RUE,

   Incoming Dial-peer=0, Progress Indication=NULL(0), Calling IE Present=TRUE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALS                                                                                                 E), Call Id=124

*Jan  8 17:06:02.012: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jan  8 17:06:02.012: :cc_get_feature_vsa malloc success

*Jan  8 17:06:02.012: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jan  8 17:06:02.012:  cc_get_feature_vsa count is 1

*Jan  8 17:06:02.012: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jan  8 17:06:02.012: :FEATURE_VSA attributes are: feature_name:0,feature_time:2                                                                                                 343578488,feature_id:18

*Jan  8 17:06:02.016: //124/8F7E58000000/CCAPI/cc_api_call_setup_ind_common:

   Set Up Event Sent;

   Call Info(Calling Number=5501(TON=Unknown, NPI=Unknown, Screening=User, Passe                                                                                                 d, Presentation=Allowed),

   Called Number=14089217525(TON=Unknown, NPI=Unknown))

*Jan  8 17:06:02.016: //124/8F7E58000000/CCAPI/cc_process_call_setup_ind:

   Event=0x8B2E5360

*Jan  8 17:06:02.016: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:

   Try with the demoted called number 14089217525

*Jan  8 17:06:02.016: //124/8F7E58000000/CCAPI/ccCallSetContext:

   Context=0x882E3C6C

*Jan  8 17:06:02.016: //124/8F7E58000000/CCAPI/cc_process_call_setup_ind:

   >>>>CCAPI handed cid 124 with tag 0 to app "_ManagedAppProcess_Default"

*Jan  8 17:06:02.020: //124/8F7E58000000/CCAPI/ccCallProceeding:

   Progress Indication=NULL(0)

*Jan  8 17:06:02.020: //124/8F7E58000000/CCAPI/ccCallDisconnect:

   Cause Value=1, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Ca                                                                                                 use=0)

*Jan  8 17:06:02.020: //124/8F7E58000000/CCAPI/ccCallDisconnect:

   Cause Value=1, Call Entry(Responsed=TRUE, Cause Value=1)

*Jan  8 17:06:02.028: //124/8F7E58000000/CCAPI/cc_api_call_disconnect_done:

   Disposition=0, Interface=0x8A4912A4, Tag=0x0, Call Id=124,

   Call Entry(Disconnect Cause=1, Voice Class Cause Code=0, Retry Count=0)

*Jan  8 17:06:02.028: //124/8F7E58000000/CCAPI/cc_api_call_disconnect_done:

   Call Disconnect Event Sent

*Jan  8 17:06:02.028: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Jan  8 17:06:02.028: :cc_free_feature_vsa freeing 8BB02B70

*Jan  8 17:06:02.028: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Jan  8 17:06:02.028:  vsacount in free is 0

*Jan  8 17:06:02.028: //124/8F7E58000000/SIP/Call/sipSPICallInfo:

The Call Setup Information is:

Call Control Block (CCB) : 0x0x8B6E1180

State of The Call        : STATE_DEAD

TCP Sockets Used         : YES

Calling Number           : 5501

Called Number            : 14089217525

Source IP Address (Sig  ): 172.16.1.10

Destn SIP Req Addr:Port  : 172.16.1.2:5060

Destn SIP Resp Addr:Port : 172.16.1.2:42971

Destination Name         : 172.16.1.2

*Jan  8 17:06:02.028: //124/8F7E58000000/SIP/Call/sipSPIMediaCallInfo:

Number of Media Streams: 1

Media Stream             : 1

Negotiated Codec         : No Codec

Negotiated Codec Bytes   : 0

Nego. Codec payload      : 255 (tx), 255 (rx)

Negotiated Dtmf-relay    : 0

Dtmf-relay Payload       : 0 (tx), 0 (rx)

Source IP Address (Media): 172.16.1.10

Source IP Port    (Media): 16418

Destn  IP Address (Media):  -

Destn  IP Port    (Media): 0

Orig Destn IP Address:Port (Media): [ - ]:0

*Jan  8 17:06:02.028: //124/8F7E58000000/SIP/Call/sipSPICallInfo:

Disconnect Cause (CC)    : 1

Disconnect Cause (SIP)   : 404

CUBE and BE3k

Can we see your cube config and dial-peer as well?

Voice CCIE #37771
New Member

Re: CUBE and BE3k

Hi Hermanus,

Please find attached.

New Member

Re: CUBE and BE3k

hostname Router

!

boot-start-marker

boot system flash:c880voice-universalk9-mz.153-3.M1.bin

boot-end-marker

!

aqm-register-fnf

!

enable password cisco

!

no aaa new-model

memory-size iomem 10

!

no ip domain lookup

ip cef

no ipv6 cef

!

multilink bundle-name authenticated

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

sip

  referto-passing

  asserted-id pai

  early-offer forced

  midcall-signaling passthru

  privacy-policy passthru

!

voice class codec 1

codec preference 1 g729r8

!

voice class h323 1

!

voice class sip-profiles 1

!

!

license udi pid CISCO881G-G-K9 sn FGL1602G

license boot module c880-iad level advipservices

license boot module c880-iad level advipservices

!

!

username admin privilege 15 password 0

username cisco privilege 15 password 0

!

controller Cellular 0

!

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface FastEthernet4

ip address 172.16.1.10 255.255.0.0

duplex auto

speed auto

!

interface Cellular0

no ip address

encapsulation ppp

!

interface Vlan1

no ip address

!

ip forward-protocol nd

no ip http server

         no ip http secure-server

!

!

mgcp behavior rsip-range tgcp-only

mgcp behavior comedia-role none

mgcp behavior comedia-check-media-src disable

mgcp behavior comedia-sdp-force disable

!

mgcp profile default

!

!

dspfarm profile 1 mtp 

codec g729r8

maximum sessions software 20

shutdown

!

dial-peer voice 2 voip

destination-pattern 9.T

session protocol sipv2

session target ipv4:125.22.XX.XX

voice-class sip early-offer forced

dtmf-relay rtp-nte

no vad

!

dial-peer voice 1 voip

session target ipv4:172.16.1.2

incoming called-number 55..

dtmf-relay h245-alphanumeric

!

CUBE and BE3k

Hi Varadarajan,

you are missing few important configs like, binding media and signaling interfaces, inbound & outbound dialpeers to and from CUCM & ITSP.

Also check with your provider about the codec the support and how many digits the called number to be sent to ITSP. and configure translation rules if needed

Please have a look at the post from Deji (aokanlawon):

https://supportforums.cisco.com/message/4117173#4117173

it would help you to understand the CUBE config.

Please rate all the useful posts

//Suresh Please rate all the useful posts.
New Member

CUBE and BE3k

I have this right now. Still no luck.

voice service voip

ip address trusted list

  ipv4 125.22.86.19 255.255.255.255

  ipv4 172.0.0.0 255.0.0.0

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

sip

  header-passing

  error-passthru

  referto-passing

  asserted-id pai

  early-offer forced

  midcall-signaling passthru

  privacy-policy passthru

!

voice class codec 1

codec preference 1 g729r8

!

voice class h323 1

!

voice class sip-profiles 1

!

!

controller Cellular 0

!

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface FastEthernet4

ip address 172.16.1.10 255.255.0.0

duplex auto

speed auto

!

interface Cellular0

no ip address

encapsulation ppp

!

interface Vlan1

no ip address

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

ip route 0.0.0.0 0.0.0.0 172.16.1.1

!

control-plane

!

mgcp behavior rsip-range tgcp-only

mgcp behavior comedia-role none

mgcp behavior comedia-check-media-src disable

mgcp behavior comedia-sdp-force disable

!

mgcp profile default

!

!

dspfarm profile 1 mtp

codec g729r8

maximum sessions software 20

shutdown

!

dial-peer voice 200 voip

session protocol sipv2

session target ipv4:172.16.1.2

dtmf-relay rtp-nte

!

dial-peer voice 100 voip

destination-pattern 1408.......

session protocol sipv2

session target ipv4:125.22.XX.XX

voice-class sip bind control source-interface FastEthernet4

voice-class sip bind media source-interface FastEthernet4

dtmf-relay rtp-nte

CUBE and BE3k

could you please post 'debug ccsip message & debug voice ccapi inout' with calling party & called party details?

incoming calls are working?

Please rate all the useful posts

//Suresh Please rate all the useful posts.
New Member

Re: CUBE and BE3k

There is no incoming. just outgoing. calling: 5501 called 14089217525

Please find attached.

Thanks

Varadarajan.R

CUBE and BE3k

There is no inbound dial-peer from CUCM to CUBE and hence the call is matching default dial-peer 0.

the outbound dialpeer matched to 100 and the early offer invite message is sent from GW to your provider with G729 codec in the SDP.

however the provider is not responding to your invite and hence the invite message is sent for 6 more times without any success.

Perhaps the ITSP IP address: 125.22.86.19 you are sending the call to is either down or wrong.

Please talk to your provider and ask them why they are not responding the call.

Also confirm the codec the support and the calling & called number format.

Please rate all the useful posts

//Suresh Please rate all the useful posts.

CUBE and BE3k

Also what codec is your ISP expecting from you?

I see you have a voice class codec set for g729r8 but you do not use it on the voip dial peer and also it seems like the SIP trunk between you and the ISP is not up from the debug, there is also no codec negotation between you and the ISP.

Please sent what sureshsub2 has asked for.

Voice CCIE #37771
New Member

Re: CUBE and BE3k

i have set it now. ISP wants g729. I have attached the logs.

Thanks

Varadarajan.R

CUBE and BE3k

what transport protocol does your ISP expect UDP or TCP?

Please spesify in your dialpeer that as well:

(config-dial-peer)#session transport ?

  system  defer to voice service voip session transport

  tcp     Transport Layer Protocol - TCP

  udp     Transport Layer Protocol - UDP

I see in your traces the following:

Here is tries via UDP:

Sent:

INVITE sip:14089217525@125.22.86.19:5060 SIP/2.0

Via: SIP/2.0/UDP 172.16.1.10:5060;branch=z9hG4bK1835

From: <5501>;tag=33AF1D7C-96A

To: <14089217525>

Date: Thu, 09 Jan 2014 09:29:27 GMT

Call-ID: 5E8BDBBE-784711E3-852884E5-8465EDA2@172.16.1.10

Here it tries via TCP:

Received:

ACK sip:14089217525@172.16.1.10:5060 SIP/2.0

Via: SIP/2.0/TCP 172.16.1.2:5060;branch=z9hG4bK2cd43d97d3cc

From: <5501>;tag=36932~43a596bc-8a16-4858-b2e2-3b8931e63a9c-17094314

To: <14089217525>;tag=33AFCF40-2005

Date: Thu, 09 Jan 2014 09:39:41 GMT

Call-ID: f562f200-2ce16e5d-2c8d-20110ac@172.16.1.2

So it seems to me you are sending UDP and your ISP is answering in TCP.

Voice CCIE #37771
New Member

Re: CUBE and BE3k

Thanks a lot for the kind inputs Suresh and Hermanus. I will contact ISP and get back.

Thanks

Varadarajan.R

New Member

Re: CUBE and BE3k

Hey,

I spoke to the ISP. We have the CUBE inside LAN. And the call has to go thru the firewall. Should we do something on the firewall as well ? Because ISP says your initiater IP should be the public address. Do we need to do something for this ?

Thanks

Varadarajan.R

CUBE and BE3k

Hi,

Yes you need to point your SIP traffic to the ISP SIP address.

So yes on the FW you will need to make changes to allow the SIP traffic and RTP traffic bi directional.

dial-peer voice 100 voip

destination-pattern 1408.......

session protocol sipv2

session target ipv4:(ISP IP address:5060)

session transport (UDP/TCP)

voice-class sip bind control source-interface FastEthernet4

voice-class sip bind media source-interface FastEthernet4

dtmf-relay rtp-nte

Voice CCIE #37771

CUBE and BE3k

you should bind the interface where your public ip is configured for media & signalling. make sure the TCP/UDP 5060 port is opened in the firewall.

http://www.cisco.com/en/US/docs/ios/12_2/12_2x/12_2xb/feature/guide/ftbind.html#wp1024644

Please rate all the useful posts

//Suresh Please rate all the useful posts.
New Member

CUBE and BE3k

Its working. Thanks a lot guys. The International carrier was rejecting UDP. They shifted to one more carrier. Earlier the ISP had allowed the wrong address of our end. We also had to disable early offer.

Thanks

Varadarajan.R

VIP Super Bronze

CUBE and BE3k

Suresh and Hermanus (+5) for the great work on this forum..Suresh I love your contributions on SIP..Well done.

I wrote a blog on binding signall and media for CUBE..I am sure its nothing new to both of you, but just thought I should let you guys see it, just in case you find it useful..

https://supportforums.cisco.com/community/netpro/collaboration-voice-video/ip-telephony/blog/2013/04/04/cube-sip-media-and-signalling-binding-to-an-interface

Please rate all useful posts

"The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
353
Views
10
Helpful
18
Replies
CreatePlease to create content