Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CUBE config question

I have minimal experience in CUBE, I need to configure SIP Trunk for a customer in couple of days so I need some help.  Here is their setup, customer has MPLS router at their HQ to connect to all the remote branches, in the same MPLS router customer is adding the SIP from the same SP.  I got the SIP information from the SP and need some  clarifications from the experts what I need to do on the MPLS/CUBE router. Here are the information I got from SP

(All IP's are for eg. )

Customer IP : 1.1.1.1

SP SBC IP : 1.2.1.1 port 5060

RTP IP and Port range : 1.3.1.1 (port 8000 - 39998)

Firewall ports open 1.3.1.0/28

My question is

1. Do I need to configure the customer IP (1.1.1.1) as a loopback address and bind that interface to SIP traffic going to SP?

2. Do I need to configure another private IP as another loopback address and bind that to CUCM traffic?

3. What should be done to route this SP provided IP's to make the calls go through?

AND What is the best way to do this?

Thanks for your help in Advance.

MPLS router is 3945 IOS version 15.0.x M7

CUCM verison 9.X

------------------------------------------------------------------------------------------------------------------------------------------------------------------

Here is the part of the MPLS config

interface GigabitEthernet0/0

To MPLS SP

ip address x.x.x.x 255.255.255.252

duplex full

speed 100

!

!

router eigrp 99

network x.x.x.x 0.0.0.255

!

router bgp XXXXX

no synchronization

bgp log-neighbor-changes

bgp redistribute-internal

neighbor 192.168.255.12 remote-as 65001

neighbor 192.168.255.12 update-source Loopback10

neighbor 192.168.255.12 next-hop-self

neighbor 2.2.2.2 remote-as 299

  neighbor 2.2.3.1 route-map BGP-FILTER-IN in

neighbor 2.2.3.1route-map BGP-FILTER-OUT out

no auto-summary

!

!

ip prefix-list xxx filter in seq 100 deny 192.168.1.0/24

ip prefix-list xxx filter in  seq 110 deny 192.168.100.0/24

!

ip prefix-list xxx filter out seq 90 permit 192.168.255.100/32

ip prefix-list xxx filter out seq 100 permit 192.168.10.0/24

!

--------------------------------------------------------------------------------------------------------------------------------------------------------

  I can handle the Dial-Peers for inbound and outbound once I know what I need to do with routing part.

Everyone's tags (1)
2 REPLIES

CUBE config question

hi ,

Please find the responses to your questions below...

1) this depends on what ip address your provider expects to see. Most providers allow sip traffic into their network only if they see an ip address they recognise.

2) not required . Just make sure that on the callmanger sip trunk page the ip address mentioned  is the ip address of the cube that callmanger can reach .   Same applies to the session target mentioned in the sip dialpeers on the cube.

3) i) configure  an outbound sip dial -peer with the ip address of  sip provider  this will help  in routing of oubound calls

    ii) If your provider  has asked for autentication  then sure that in your sip user agent configuration you have the sip service provider's ip address  listed  and have the correct credentals.

Here is  a configuration example that  has all the configuration examples of what I have explained. It covers all the basics and configuration....

http://www.cisco.com/en/US/products/sw/voicesw/ps5640/products_configuration_example09186a00808ead0f.shtml#sip

Hope this helps!

Regards,

Karthik Sivaram

New Member

CUBE config question

Karthik,

Thank you so much for your response. We got the SIP trunk working fine now, we ended up creating customer IP as a loopback and advertise on the BGP side and added some inbound prefix for SP IP's to come in and I also have to change the SIP trunk IP address on the CM as the customer IP to make the call go through in and out. Now I'm battling with t38 fax on the SIP trunk which I think we can fix it soon.

Thanks again.

391
Views
0
Helpful
2
Replies