Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

CUBE DTMF problems!

Hello,

I have a CUCM 6.1 connected to a Cube on a h323 trunk to the pstn. Calls inbound and outbound operate normally except for the length of the DTMF tone sent to the PSTN. The signal is being sent h245-signal but should be sent h245- Alphanumeric.

I have programed the dial peers to send alpha but the debug shows a 4000 ms signal being sent to the PSTN.

Is there a timer that i can set in the cube to shorten this? CUCM is sending the proper 100 ms tone.

Is this a call setup problem?

here is my config.

hostname CUBE_2

!

boot-start-marker

boot system flash:c2800nm-ipvoice_ivs-mz.124-25.bin

boot-end-marker

!

!

ip cef

!

!

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

voice rtp send-recv

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

h323

emptycapability

no h225 h245-address facility

h225 id-passthru

h245 tunnel disable

h245 passthru tcsnonstd-passthru

!

!

!

interface FastEthernet0/0

ip address 10.133.2.249 255.255.255.0

duplex auto

speed 100

h323-gateway voip interface

h323-gateway voip id GWC_3 ipaddr XXX.47.158.68 1719

h323-gateway voip h323-id XXXX_datec_cube2

h323-gateway voip bind srcaddr 10.133.2.249

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/0/0

!

interface FastEthernet0/0/1

!

interface FastEthernet0/0/2

!

interface FastEthernet0/0/3

!

interface Vlan1

no ip address

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.133.2.254

!

no ip http server

!

!

!

control-plane

!

!

!

!

!

sccp local FastEthernet0/0

sccp ccm 10.133.2.60 identifier 10 version 4.1

sccp

!

sccp ccm group 10

bind interface FastEthernet0/0

associate ccm 10 priority 1

associate profile 10 register cube2_mtp

associate profile 20 register xcoder

!

dspfarm profile 20 transcode

associate application SCCP

shutdown

!

dspfarm profile 10 mtp

codec g711ulaw

maximum sessions hardware 32

maximum sessions software 250

associate application SCCP

!

!

dial-peer voice 1 voip

answer-address 306683....

dtmf-relay h245-alphanumeric

codec transparent

ip qos dscp cs5 media

ip qos dscp cs5 signaling

!

dial-peer voice 100 voip

preference 1

destination-pattern .T

session target ras

dtmf-relay h245-alphanumeric

codec transparent

ip qos dscp cs5 media

ip qos dscp cs5 signaling

!

dial-peer voice 200 voip

preference 10

service voip

destination-pattern 383.

session target ipv4:10.133.2.60

dtmf-relay h245-alphanumeric

codec transparent

ip qos dscp cs5 media

ip qos dscp cs5 signaling

!

gateway

timer receive-rtp 1200

Thanks

Trent

3 REPLIES

Re: CUBE DTMF problems!

Hi Trent,

I would start by adding 'incoming called-number .' to one of your voip dial peers with h245-alpha defined on it.

If that doesn't work, I would go to a T-train release (12.4(22)T1) since CUBE may not act quite right for some more specific features like this in 12.4 mainline.

-nick

New Member

Re: CUBE DTMF problems!

Thanks Nick.

I loaded 12.4.22(t1) that resolved the long tone tones, then only had DTMF reconigised one direction. Then loaded 12.4.24T and all works great!

I love fighting with IOS bugs!

Trent

Re: CUBE DTMF problems!

Hi Trent,

Glad I could help. Technically this may not have been a bug. CUBE has had a lot of *features* added in 12.4T, as many IPIPGW scenarios weren't tested in mainline. But it could be a bug too :)

-nick

610
Views
0
Helpful
3
Replies
CreatePlease to create content