Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CUCiMOC - No Phone Number associated when trying to place a call to MOC

Hi we have recently installed CUCIMOC in a pilot for my company. I have everyhting working apart from beign able to drag a contact to place a call. I am running CUCM v6.1.4 and OCS 2007 R2. The simple problem is that I get an error message when I try to call a "MOC" client only. I know that 6.1(4) is not E.164 compatible but thought there was a workaround with the Application Dial Rules but I have implemented but still not working. I can call a MOC user by dialling the number but would like to be able to simply right click and call or just drag and drop. Any ideas would be appreciated.

New Member

Re: CUCiMOC - No Phone Number associated when trying to place a

Couple of questions for clarification. Sounds like your attempting mutliple things here (CUCIMOC functionality and UCM direct to OCS calls).

1. Do you have a sip trunk between OCS and CUCM?

2. Do MOC users have + sign in front of phone number?

3. You say you can dial from UCM to MOC user directly, what is the number you dial direct?

4. Can MOC only user call cisco ip phone?

New Member

Re: CUCiMOC - No Phone Number associated when trying to place a

Hi UComp2007,

1. We have a working SIP trunk between OCS & CUCM.

2. MOC users have a + sign in front of their number in OCS but not in AD.

3. MOC Users have extensions 79XX IP Phones 78XX. The number I dial direct is 7900.

4. MOC users can dial IP phones no problem. We have a mediation server in place. There is also normalisation rules on the OCS.

New Member

Re: CUCiMOC - No Phone Number associated when trying to place a

Are you using CUCIMOC softphone, or using CUCIMOC to control hardphone? If controlling hardphone, what is phone model. Type A phones (7940, 7960) can't deal with + sign.

If your using CUCIMOC softphone, I would run wireshark on MOC users pc to see what digits are being passed, and also to see if application dial rule is being invoked.

UCM 6.x does not have support for dealing with + sign, so i'm wondering even though you have the application dial rule setup, if UCM can strip that + sign.

We have this all setup in similar fashion on UCM 7 and have no issues (but UCM 7 does have full support for dialing normalization and dealing with + sign).


New Member

Re: CUCiMOC - No Phone Number associated when trying to place a

I am actually using CUCIMOC to control both but I am simply using the softphone when using drag to call. I have created the Application dial rule to strip the + which is being invoked as I can actually dial one MOC only user using drag to Call. I tried running wireshark to take a sniffer trace but could not see any digits being passed so I do not know if CUCIMOC is even getting that far. I suspect this may be something to do with AD users numbers not being in E.164 format despite OCS using normalisation. I also got a login for the OCS Server and found several errors relating to AD E.164 and OCS Address Book errors. I will let you knwo how I get on as I am continuing to work on it.


Re: CUCiMOC - No Phone Number associated when trying to place a

Maybe I am barking up a wrong tree here but it is my understanding that you do not have + E.164 numbers in AD. I recently had a CUCiMOC pilot for a customer who did not want to format their numbers in AD either. Their format in the Telephone Field was XXX-XXX-XXX and had 4 digit internal extensions in Call Manager. I ended up normalizing OCS so when I dragged a call to a contact the dialed number was normalized before it is dialed. I was a little overwhelmed at first because I had never configured OCS. I finally found this blogged that helped out tremendously.

Otherwise if I did not normalize in OCS I would have to had created 10 digit to 4 digit translation patterns in Call Manager did not want to do that because I would start to have an overlapping dial plan.

Hope that makes sense...


Re: CUCiMOC - No Phone Number associated when trying to place a

CUCIMOC does not require SIP trunk between OCS and CUCM.

CUCIMOC gets the phone number from MOC and requires E.164 format.

If you got "no phone number associated", you should troubleshoot MOC/OCS.

Steps to Resolve

* Make sure the Address book Synchronize error is not displayed on MOC.

* If the error is displayed , follow the link here to resolve it.

* If MOC checks out for above (Address book Synchronize error is not displayed on MOC), then perform a manual sync of OCS to its LDAP

o Manually Sync OCS address book

Open cmd prompt on OCS Server and type the following,

* cd C:\Program Files\Microsoft Office Communications Server 2007\Server\Core

* C:\Program Files\Microsoft Office Communications Server 2007\Server\Core\abserver -syncnow

Delete your local copy of MOC Database - GalContacts.db

* C:\Documents and Settings\\Local Settings\Application Data\Microsoft\Communicator\GalContacts.db file

* If MOC Client still contains wrong information, then delete local copy of GalContacts.db

o Exit out of MOC

o XP - C:\Documents and Settings\\Local Settings\Application Data\Microsoft\Communicator

o Vista - C:\Users\\AppData\Local\Microsoft\Communicator

Hope this helps.