Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

CUCM 10.0 Cisco 7821 phone displays time 1 hour wrong

Some phones (in same device pool) are displaying the time incorrectly. There is only one NTP source for whole network.

 

Any ideas?

 

Rich

Everyone's tags (1)
20 REPLIES
Hall of Fame Super Silver

Are these phones the same

Are these phones the same model and using the same protocol sip vs sccp as others that are working?

If you browse to the IP address of the phone and look at the time zone does it properly show it?

Chris

New Member

Hi Chris, All same type 7821

Hi Chris,

 

All same type 7821 using SIP.

 

A few phones show time one hour wrong and same when I browse to them! :( Time is wrong but timezone is correct.

 

Richard

Hall of Fame Super Silver

Are they on the same firmware

Are they on the same firmware?

I have seen this issue caused by firmware not upgraded properly.  If you browse to the network settings page do you see all parameters correctly, i.e. proper CUCM servers the phones communicate with, etc?

Chris

New Member

They were. Due to getting XML

They were. Due to getting XML Parse Error TAC have provided a new firmware which we've applied to 'select' phones. This time issue was happening beforehand when all phones has same firmware. Network settings look correct.

 

I'm not convinced with these 78xx phones :(
 

Hello Rich, Even I am facing

Hello Rich,

 

Even I am facing the same issue. have you got solution to this?

 

 

New Member

Hi Maninder, We applied the

Hi Maninder,

 

We applied the very latest firmware which seems to have resolved the XML Parse issue but no fix for the time issue yet!

sip78xx.10-2-1-12ES1

 

Good luck

 

Richard

 

Please vote if it helps :)

Thanks Richard, But still

Thanks Richard,

 

But still getting incorrect time on few device.:)

 

 

Are all the phones registered

Are all the phones registered to the same subscriber? I had this issue before, I SSHd into the subscriber and did "utils ntp status" and NTP was unsynchronized, apparently after a power outage.

 

Thanks,

 

Frank

New Member

Hi Frank, NTP status looks

Hi Frank,

 

NTP status looks good. This happens for a few phones on same CUCM. If I browse to the phone it shows incorrect timezone for affected phones but I they are all configured the same.

 

Rich

Bronze

Before we jump to firmwares,

Before we jump to firmwares, just wanted to ask whether or not your date time group for that device pool is the correct one. Also, any chance whatsoever that your cluster DST file is not up to date (probably unlikely this late into autumn, but it's feasible)?

New Member

I have the same issue. Not

I have the same issue. Not sure how to resolve. some phones are good with time.

Others choose to ignore the timezone...7841 in this case

New Member

Me too, all the 7800 series

Me too, all the 7800 series looks not working well.

New Member

Same issue here, I am so

Same issue here, I am so pissed with the Cisco New SIP series.

I have the IBM J9 uploaded in TFTP, have the firmware upgrade.

The Phone shows in correct Timezone but the display time actually is GMT. But for me only one phone have this issue.

 

New Member

Got it solved at my customers

Got it solved at my customers. A keypad factory reset made it.

 

Unplug the phone, press and hold # and plugin. After 2-3seconds press 123456789*0#. That's it. 

 

https://csemmler.wordpress.com/2015/08/04/cisco-78xx-shows-wrong-time-gmt-timezone-regardless-of-configured-timezone/

- Please rate helpful posts -
New Member

For me, this solved my issues

For me, this solved my issues with some stubborn phones.

New Member

It works, I had this problem

It works, I had this problem with few phones but when I performed the Keypad Factory Reset the issue was solved.

New Member

Got it solved at my customers

Problem solved with a keypad factory reset. Some background info on my case when comparing 7841 phones showing correct/wrong time:

 

Firmware is identical:         rootfs78xx.11-5-1SR1-1

Hardware is identical:         Revision 0 / V03

Configuration is identical:          SEPxxxxxxxxxxxx.cnf.xml

Timezone info is correct:    Configuration/Web Interface

Time on 1 phone is wrong:  Always at UTC (a coincidence? Offset changed during DST change)

Upon Reset, this phone shows an ERR in the console logs

 

6384 ERR Oct 30 21:27:47.949383 (9477:9702) JAVA-21:27:47|Message : /usr/local/lib/zi/Africa/Tunis

       Exception Stack Trace :

       java.io.FileNotFoundException: /usr/local/lib/zi/Africa/Tunis

               at java.io.FileOutputStream.<init>(Unknown Source)

               at java.io.FileOutputStream.<init>(Unknown Source)

               at cip.cfg.Config.updateFile(Unknown Source)

               at cip.cfg.Config.updateTimeZone(Unknown Source)

               at cip.cfg.Config.handleTzupdaterTftpResponse(Unknown Source)

               at cip.cfg.Config.tftpRequest(Unknown Source)

               at cip.tftp.ITftpListener$Dispatcher.sinkMessage(Unknown Source)

               at cip.tftp.ITftpListener$Dispatcher.sinkMessage(Unknown Source)

               at cip.sys.MessageQueueManager.sinkMessage(Unknown Source)

               at cip.sys.MessageQueueThread.sendElement(Unknown Source)

               at cip.sys.MessageQueueThread.onRun(Unknown Source)

               at cip.sys.SystemThread.run(Unknown Source)

5258 NOT Oct 30 21:27:07.321165 (8577:8800) JAVA-configmgr MQThread - Deletion of file Successful/tmp/ram/j9-tzdata.jar

New Member

Maybe you hit the same issue

Maybe you hit the same issue with the 7821 like the bugreport for 7841 > CSCul26124

https://tools.cisco.com/bugsearch/bug/CSCul26124

Further Problem Description:
we noticed one 7841 phone is showing wrong time on phone.it shows 4:54 AM, while it's 12:54 now
I checked the time group and the configuration is correct

Try to reset the ITL (Trust

Try to reset the ITL (Trust List). It is located on the phone menu - Settings - Security Configuration - Trust List - ITL File. (Unlock the settings of the phone pressing #**#) and than reset the Trust List, apply phone defaults .
After that reset the phone through CUCM. 

**Also try to check if the PORTS where those IP phones are connected are placed in correct VLANS.

New Member

Hi Seniors,

Hi Seniors,

I am having the same issue with an IP Phone, this phone is displaying time 4 hours behind the original time, all phones including this phone are registered with the same CUCM, but all of the other phones are displaying the correct time only this phone is not displaying the correct time.

I have done:

Re-registered this phone again with the CUCM

Erased Network Settings on the phone

I accessed the phone Ip via HTTP and i checked this phone is showing time zone of Greenwich Standard Time.

all other phones are having the correct time zone, can anyone suggest how we can change the time zone for this phone

Regards,

5544
Views
10
Helpful
20
Replies
CreatePlease to create content