Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

CUCM 7.1.3 DBREPLICATION ERROR


Hi i am having an issue with dbreplication on CUCM 7.1.3, Sytem is an upgrade from version 4.X to 7.1.3 and has 1 pub 3 sub server. I install 1 Pub and 2 sub so far and having dbreplication problem i go through utill dbreplication stop and util dbreplication reset all and still having the same problem. On both sub servers Replicate_state shows 4.


Publisher
admin:show perf query class "Number of Replicates Created and State of Replication"
==>query class :

- Perf class (Number of Replicates Created and State of Replication) has instances and values:
    ReplicateCount  -> Number of Replicates Created   = 427
    ReplicateCount  -> Replicate_State                = 2


Subscriber
admin:show perf query class "Number of Replicates Created and State of Replication"
==>query class :

- Perf class (Number of Replicates Created and State of Replication) has instances and va                                  lues:
    ReplicateCount  -> Number of Replicates Created   = 0
    ReplicateCount  -> Replicate_State                = 4

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: CUCM 7.1.3 DBREPLICATION ERROR

Before resetting replication, check a few fundamental things.  Execute the following commands and look for inconsistencies between nodes and with your expectations.

1. On each cluster node, check the network:

show network cluster

2. On each cluster node, validate the network

utils diagnose module validate_network

3. On each cluster node validate ntp

utils ntp status

Since you did a migration I have to ask if you changed the host name and/or IP address of the cluster servers on install?  If so, did you ensure that the server objects defined in CUCM match the IP/hostname for the subscriber nodes?  Use the following command on the publisher node:

run sql select name,nodeid from processnode

Does the output look correct?  You can also check the CCMAdmin web interface (System>Servers).  Also, look at the IP addresses and names from the first three commands.

Fix any issues you find as a result of the above discovery.  Once you have resolved the issues then you can use "utils dbreplication reset all" from the publisher node.

HTH.


Regards,
Bill

Please remember to rate helpful posts.

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

6 REPLIES

Re: CUCM 7.1.3 DBREPLICATION ERROR

Before resetting replication, check a few fundamental things.  Execute the following commands and look for inconsistencies between nodes and with your expectations.

1. On each cluster node, check the network:

show network cluster

2. On each cluster node, validate the network

utils diagnose module validate_network

3. On each cluster node validate ntp

utils ntp status

Since you did a migration I have to ask if you changed the host name and/or IP address of the cluster servers on install?  If so, did you ensure that the server objects defined in CUCM match the IP/hostname for the subscriber nodes?  Use the following command on the publisher node:

run sql select name,nodeid from processnode

Does the output look correct?  You can also check the CCMAdmin web interface (System>Servers).  Also, look at the IP addresses and names from the first three commands.

Fix any issues you find as a result of the above discovery.  Once you have resolved the issues then you can use "utils dbreplication reset all" from the publisher node.

HTH.


Regards,
Bill

Please remember to rate helpful posts.

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

Community Member

Re: CUCM 7.1.3 DBREPLICATION ERROR

Hi William,

Thank you for your reply, İ did try those before, i read some of your older posts before, but i check them again and, show network cluster looks ok. utils diagnose module validate_network return passed, utils ntp status show publisher as ntp server and have the correct time. I did not change the ip adress or the host names, and from webpage they look normal.

Just one thing i did not undestand is run sql select name,nodeid from processnode command, how should i wrote this one on cli?

Thanks again for your help,

Gokhan

Re: CUCM 7.1.3 DBREPLICATION ERROR

Example:

admin:run sql select name,nodeid from processnode

name nodeid

================== ======

EnterpriseWideData 1

10.3.4.20 2

10.3.4.21 3

admin:

HTH.

Regards,

Bill

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

Community Member

Re: CUCM 7.1.3 DBREPLICATION ERROR

Hi William,

run sql select name,nodeid from processnode command show the fallowing output. Whole system has 1 Pub and 3 Subscriber server but i didn't upgrade one of the subscriber for backup purposes, i delete that one drom system->Server page

admin:run sql select name,nodeid from processnode
name               nodeid
================== ======
EnterpriseWideData 1
10.100.0.254       2
10.100.14.254      4
10.100.0.253       5

For now from RTMT page i saw fallowing output. One of the subscriber has a Replication Status of 4 and 0 Replication Created.

Community Member

Re: CUCM 7.1.3 DBREPLICATION ERROR

After i delete the sub server whic i didnt used for backup purpose from system-> server page, i restart the server , run the util dbreplication reset all command and everything start to work fine.

Re: CUCM 7.1.3 DBREPLICATION ERROR

Good to hear. Thanks for letting us know what the final resolution was.

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

3086
Views
5
Helpful
6
Replies
CreatePlease to create content