Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CUCM 7.1.3 Incorrect Time 7940 (Hour Out) October 2010

Hi There,

Has anyone else found a problem with the time shifting an hour forward on the first generation Cisco 7940's this morning. We are running CUCM 7.1.3.30000-1 and all of our SCCP 7940's are running firmware load 'P00308010200' with CUCM date/time groups set to the '(GMT) Europe/London*' timezone. It is as if the last Sunday in October daylight savings have kicked in a week early.

All CUCM nodes have the correct date/time and all of the newer java based Cisco 7942s ('SCCP42.8-5-3S') and 7941's ('SCCP41.8-5-3S') are fine showing the correct date/time.

Sounds like we could have a phone load or CUCM bug, just about to get this logged with Cisco. Not causing major issues at this time apart for generating calls to our support desk!

Jason

  • IP Telephony
Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: CUCM 7.1.3 Incorrect Time 7940 (Hour Out) October 2010

Hello all

Final answer would be:

For those in CUCM 7.1.3
There will be a file in CCO shortly.
In the meantime i am attaching the file needed in this message:

Installation Instructions:

  • Installation to all machines in the cluster is required
  • As with any installation or upgrade, it is recommended that you  apply       this Update during off peak hours.
  • When applying this Package be advised that a clusterwide reboot is       required.
  • It is also recommended that this update be installed on all  machines in       the cluster before the cluster is rebooted.
  • This COP file applies only to UCM 7.1.3       versions before 7.1.3.33031-1
65 REPLIES
New Member

Re: CUCM 7.1.3 Incorrect Time 7940 (Hour Out) October 2010

Hey Jason,

I have this problem with 2 of my customers today (so far but it's early!).  One is on CUCM 7.1.3a with 8.0.4 Loads on the 7940's 7960's and another on 7.1.3bSU2 with 8.1.2 loads.  The 7941's and 7942's etc are showing the correct time, it's only the 2nd Gen Phones having the issue.

It may be a new bug, as the last sunday of the month of october is also the last day of the month. So the 2nd Gen phones seem to have jumped early.

If I get anywhere else on this, I'll post an update.

Bill

New Member

Re: CUCM 7.1.3 Incorrect Time 7940 (Hour Out) October 2010

Hi,

we have the same problem today with 6941 phone at SCCP 8.5.3 in CUCM 7.1.3.32011-1. Upgrade  SCCP to 9.0.3a for 6941 doesn't fix it. 7970 and 7975 works well.

New Member

Re: CUCM 7.1.3 Incorrect Time 7940 (Hour Out) October 2010

Same issue for us also. CUCM 7.1.3.32900.4 with 7940 load P00308010200.

Cisco Employee

Re: CUCM 7.1.3 Incorrect Time 7940 (Hour Out) October 2010

Hello


it is being tracked already in TAC.


So far affected versions are:

7.1.X

8.0.X

Only 7940/7960 series are affected.

3rd Gen phones looks to be not affected.

7.1.5 and 7.0.X versions apparently are not affected after my tests in the lab.

Will keep posting more information about it.

Thanks
Fernando

Re: CUCM 7.1.3 Incorrect Time 7940 (Hour Out) October 2010

Hi

Same issue with CUCM 7.1.3.200000-2.

Our 7941's and 7961's running firmware SCCP41.8-5-2SR1S are all showing the correct time. Our 7940's and 7960's running firmware P00308010100 are all 1 hour behind.

Problem doesn't seem to be server, NTP time reference or call manager group related. Just looks like they have switched to GMT a week early.

On the bright side, I can stick the 7940 under my boses nose and claim I wasn't late this morning and substitute it for a 7961 at knocking off time. Result!

Cheers

Richard McL

Cisco Employee

Re: CUCM 7.1.3 Incorrect Time 7940 (Hour Out) October 2010

Hi


CUCM sends using SKINNY protocol a message to establish the date and time on the phone.

It sends 2 things:

UNIX timestamp

Time and Date information explicitly:

Year:2010

Month:10

dayofWeek:1

Day:25

Hour:10

Minute:23

Seconds:36

Timestamp: 1287998616

CUCM is sending the right UNIX time stamp but the wrong time/date info.

BU is engaged to analyze the problem.

Thanks
Fernando

Re: CUCM 7.1.3 Incorrect Time 7940 (Hour Out) October 2010

Hi Fernando.

Thanks very much for the update. Its appreciated.

Kind regards

Richard

New Member

Re: CUCM 7.1.3 Incorrect Time 7940 (Hour Out) October 2010

Thanks Fernado. Have a TAC case open but this seems to be the best source of information.

Anyone know how this is likely to effect CDRs (if at all), are these going to come over with the incorrect time? Have yet to test as I don't have an original 7940 to hand.

Re: CUCM 7.1.3 Incorrect Time 7940 (Hour Out) October 2010

Hi Jason

I don't think that CDR is affected but just to be sure I've  carried out a rough and ready test from a 7940 to a 7961 (internal to internal) and then looked at the detail for the orginating extension (the 7940) in CAR. The originating time logged there is correct. Only the time listed under "placed calls" on the 7940 is incorrect, it is right everywhere else.

Hope this helps.

Regards

Richard McL

18286
Views
57
Helpful
65
Replies
This widget could not be displayed.