Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

CUCM 7.x - Cant delete a user - stay inactive - problem with associated device

Hi there,

I have CUCM integrated with LDAP.

I delete a specific user in the LDAP.  We have done an LDAP sync and event after  a week, it still show as inactive. 

The problem is this user have a device association with a device that doesnt exist anymore.

If I try to dissociate it, it doesnt work. ( it doesnt show an error but it just doesnt work )

If I try to re-create this device, I have an error.

( Add failed. One of the required fields on the page has the same value as an  entry that already exists in the database. Please check the corresponding Find  List page to verify your entry does not exist. )

Is there any CLI SQL command to fix that.. probably

thanks

4 REPLIES
New Member

CUCM 7.x - Cant delete a user - stay inactive - problem with ass

you may need to restart some dependant services

Super Bronze

CUCM 7.x - Cant delete a user - stay inactive - problem with ass

Hi

Post up the output of these commands from the server CLI (connect via SSH/putty):

run sql select name from device where name = 'SEP123412341234'

(where SEP123412341234 is the name of the device you have deleted). This will show whether the  device really does exist.

Secondly, get the output of this:

run sql select e.userid, d.name from enduserdevicemap eud join enduser e on e.pkid = eud.fkenduser join device d on d.pkid = eud.fkdevice where userid = 'yourdeleteduser'

This will show any associations for this user.

Once we have that info we'll know what needs to be done...

Regards

Aaron Harrison

Please rate helpful posts...

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

CUCM 7.x - Cant delete a user - stay inactive - problem with ass

aaronharrison

I did'nt run it yet.. but I will let you know.

But, I have another major issue..

I have a lot of end-user in CUCM that have a device associated with it.  The device in question exist but we cannot remove the device in the device association list.

If we did it, we don't have an error. It seems to work but when we go in the end user page the device is still there.

any idea?

ps : We allready reboot the server.

Super Bronze

CUCM 7.x - Cant delete a user - stay inactive - problem with ass

Hi

What browser are you using? May be something odd to do with that... try a different one.

Otherwise you might want to check soem of the administration/DB logs via RTMT to see what happens when you attempt to remove an association. Usually DB errors would be reported back to the browser.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
558
Views
0
Helpful
4
Replies
CreatePlease login to create content