Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

CUCM 9.1.1 - MGCP gateway won't register to my 2811

Hello

I am trying to add a MGCP gateway on a 2811.

I have configured as per the book, but it is not registering,

here is my Router config:

2811 uptime is 2 hours, 4 minutes
System returned to ROM by power-on
System image file is "flash:c2800nm-adventerprisek9-mz.124-11.XJ4.bin"


Cisco 2811 (revision 53.50) with 509952K/14336K bytes of memory.
Processor board ID FHK1302F0YV
3 FastEthernet interfaces
24 Serial interfaces
1 Channelized T1/PRI port
1 Virtual Private Network (VPN) Module
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
125440K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102


-------------------------------------

2811#sh run
Building configuration...

Current configuration : 7125 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 2811
!
boot-start-marker
boot-end-marker
!
card type t1 0 2
enable secret 5 $1$ax07$1yOFpGS1rHGYm873l9n9q/
!
no aaa new-model
clock timezone PCLAIRE -5
clock summer-time PCLAIRE recurring
network-clock-participate wic 2
network-clock-select 1 T1 0/2/0
!
!
ip cef
no ip dhcp use vrf connected

!
!
ip domain name homelab.local
!
multilink bundle-name authenticated
!        
isdn switch-type primary-ni
!        
voice-card 0
dspfarm 
dsp services dspfarm
!        
!        

controller T1 0/2/0
framing esf
linecode b8zs
pri-group timeslots 1-24
description Home_PBX
vlan internal allocation policy ascending
!        
!        
!        
!        
!        
!        

!        
interface FastEthernet0/0/0
description To Home Network$ETH-LAN$
ip address 192.168.15.50 255.255.255.0
duplex auto
speed auto
!        
interface Serial0/2/0:23
description Home_PBX
no ip address
encapsulation ppp
isdn switch-type primary-ni
isdn incoming-voice voice

!        
control-plane
!        
!        
!        
voice-port 0/2/0:23
description Home_PBX
!        
ccm-manager mgcp
ccm-manager config server 192.168.15.11 - THIS IS THE SUBSCRIBER , SHOULD IT BE THE PUBLISHER ?
ccm-manager config
!        
mgcp     
!        
!        

!        
!        
gateway  
timer receive-rtp 1200
!        
!        
!    

Here is what I get:

2811(config)#do sh ccm-manager
MGCP Domain Name: 2811.homelab.local
Priority        Status                   Host
============================================================
Primary         None                    
First Backup    None                    
Second Backup   None                    

Current active Call Manager:    None
Backhaul/Redundant link port:   2428
Failover Interval:              30 seconds
Keepalive Interval:             15 seconds
Last keepalive sent:            09:55:04 PCLAIRE Jan 16 2014 (elapsed time: 02:00:24)
Last MGCP traffic time:         11:34:19 PCLAIRE Jan 16 2014 (elapsed time: 00:21:08)
Last failover time:             None
Last switchback time:           None
Switchback mode:                Graceful
MGCP Fallback mode:             Not Selected
Last MGCP Fallback start time:  None
Last MGCP Fallback end time:    None
MGCP Download Tones:            Disabled

Backhaul/Redundant link is down
Configuration Auto-Download Information
=======================================
No configurations downloaded
Current state: Downloading XML file
Configuration Download statistics:
        Download Attempted             : 1
          Download Successful          : 1
          Download Failed              : 0
        Configuration Attempted        : 0
          Configuration Successful     : 0
          Configuration Failed(Parsing): 0
          Configuration Failed(config) : 0
Last config download command:
FAX mode: cisco
Configuration Error History:
2811(config)#

Any help greatly appreciated

John Bachman

2 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Super Bronze

CUCM 9.1.1 - MGCP gateway won't register to my 2811

That is because you have not configured your T1 controller for mgcp..

controller T1 0/2/0

pri-group timeslots 1-31 service mgcp

After you add this you should be able to add the bind command to the seria interface

Please rate all useful posts

"The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
Cisco Employee

CUCM 9.1.1 - MGCP gateway won't register to my 2811

controller T1 0/2/0

framing esf

linecode b8zs

pri-group timeslots 1-24

description Home_PBX

vlan internal allocation policy ascending

you are having this config already, First shut the controller

#controller T1 0/2/0

# shut

# no pri-group timeslots 1-24

# pri-group timeslot 1-24 service mgcp

# no shut



Br,
Nadeem 

Please rate all useful post.

Br, Nadeem Please rate all useful post.
10 REPLIES
VIP Super Bronze

CUCM 9.1.1 - MGCP gateway won't register to my 2811

You are missing the bind command on the serial interface..

interface Serial0/2/0:23
isdn bind-l3 ccm-manager

Add this...then do no mgcp, mgcp and test again

Please rate all useful posts

"The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
Community Member

CUCM 9.1.1 - MGCP gateway won't register to my 2811

Thank you aokanlawon

I do not have this command, the only choice I get is q931, not ccm-manager...

2811(config)#interface Serial0/2/0:23
2811(config-if)#
2811(config-if)#isdn bind-l3 ?
  q931  Select IOS Q.931

2811(config-if)#isdn bind-l3 q931
2811(config-if)#isdn bind-l3 q931 ?
 

2811(config-if)#isdn bind-l3 q931

VIP Super Bronze

CUCM 9.1.1 - MGCP gateway won't register to my 2811

That is because you have not configured your T1 controller for mgcp..

controller T1 0/2/0

pri-group timeslots 1-31 service mgcp

After you add this you should be able to add the bind command to the seria interface

Please rate all useful posts

"The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
Community Member

Re: CUCM 9.1.1 - MGCP gateway won't register to my 2811

2811(config)#controller t1 0/2/0

2811(config-controller)#pri-group timeslots 1-23 service mgcp

Cannot overwrite no serv type with one. Unconfigure existing configuration and reconfigure

2811(config-controller)#

2811#

I have reloaded my router and still i see this error....

Cisco Employee

Re: CUCM 9.1.1 - MGCP gateway won't register to my 2811

Adding one point even your config do not have mgcp command

Mgcp call agent x.x.x.x service mgcp



Sent from Cisco Technical Support iPhone App

Br, Nadeem Please rate all useful post.
Community Member

CUCM 9.1.1 - MGCP gateway won't register to my 2811

Thank you, Nadeem, I will go step by step, looks like the tutorial I have is incomplete...

Cisco Employee

Re: CUCM 9.1.1 - MGCP gateway won't register to my 2811

just made this sample config.

controller T1 0/0/2

pri-group timeslots 1-24 service mgcp

interface Serial0/0/0:23

isdn bind-l3 ccm-manager

ccm-manager config server 1.1.1.2 1.1.1.1 (frist sub and second pub ip) if you want to have redundancy.actually it depeneds which one is primary tftp and secondary one.

ccm-manager config

ccm-manager redundant-host 1.1.1.1

ccm-manager mgcp

mgcp

mgcp call-agent 1.1.1.2 service-type mgcp version 0.1

add Gateway on Call manager , make sure domain name sure be exactly the same on call manager. and do no mgcp and mgcp on gateway.


Br,
Nadeem 

Please rate all useful post.

Br, Nadeem Please rate all useful post.
Community Member

Re: CUCM 9.1.1 - MGCP gateway won't register to my 2811

Still same problem, I have erased all that related to mgcp on my router, to start from scratch

2811(config)#controller T1 0/2/0

2811(config-controller)#pri-group timeslots 1-24 service mgcp

Cannot overwrite no serv type with one. Unconfigure existing configuration and reconfigure

2811(config-controller)#

Where is this error coming from ??

      

Here is what I want to try:

192.168.15.10  - pub

192.168.15.11 - sub

controller T1 0/2/0

pri-group timeslots 1-24 service mgcp


interface Serial0/0/0:23

isdn bind-l3 ccm-manager


ccm-manager config server 192.168.15.10 192.168.15.11


ccm-manager config

ccm-manager redundant-host 192.168.15.11

ccm-manager mgcp

mgcp

mgcp call-agent 192.168.15.10 service-type mgcp version 0.1

Cisco Employee

CUCM 9.1.1 - MGCP gateway won't register to my 2811

controller T1 0/2/0

framing esf

linecode b8zs

pri-group timeslots 1-24

description Home_PBX

vlan internal allocation policy ascending

you are having this config already, First shut the controller

#controller T1 0/2/0

# shut

# no pri-group timeslots 1-24

# pri-group timeslot 1-24 service mgcp

# no shut



Br,
Nadeem 

Please rate all useful post.

Br, Nadeem Please rate all useful post.
Community Member

Re: CUCM 9.1.1 - MGCP gateway won't register to my 2811

Got it registered, thanks guys, I will pursue with route groups.

Thanks a lot

460
Views
0
Helpful
10
Replies
CreatePlease to create content