Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

CUCM 9 SUB Database replication

Dear

 

The database replication for only 1 subscriber is not working for another 2 subscribers is perfect the i did the reset and stop for Database but no effect.

according to the link below but no susccess.

https://supportforums.cisco.com/document/52421/troubleshooting-cucm-database-replication-linux-appliance-model#checking-current-replication-status

 

Cluster Detailed View from CUCMPUB01DC (4 Servers):

                                PING            CDR Server      REPL.   DBver&  REPL.   REPLICATION SETUP
SERVER-NAME     IP ADDRESS      (msec)  RPC?    (ID) & STATUS   QUEUE   TABLES  LOOP?   (RTMT) & details
-----------     ------------    ------  ----    --------------  -----   ------- -----   -----------------
CUCMPUB01DC    10.X.X.X      0.027   Yes     (2)  Connected   0      match   Yes     (2) PUB Setup Completed
CUCMSUB01DC    10.X.X.X     0.499   Yes     (?)  Off-Line    N/A    0       N/A     (4) Setup Completed

 

thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Your backup is probably

Your backup is probably failing because of the dbreplication issue. If you don't have a recent backup and are nervous of something bad happening by running the "dbreplication reset all" command then I would just delete that SUB and re-install.

Yosh

HTH Regards, Yosh
18 REPLIES

Did you just install this Sub

Did you just install this Sub? Has this Sub ever worked?

Regards,

Yosh

HTH Regards, Yosh
New Member

yes this SUB was working

yes this SUB was working before and due to replicating status (3) mismatch in tables i did a  reset for specific this server and also did a repair but no luck,

I have 2 question please answer.

Now i have spend plenty of time in solving this issue if i delete this sub from CUCM PUB and i will delete the subsriber VM completely and i then i will fresh install the new subsriber, will it affect disturbance in PUB database .

By mistake i  type a command on publisher utils dbreplication < publisher itself> and now all the nodes are off-line how to get them connected.

 

thanks

 

Samuel,You may need to

Samuel,

You may need to perform the following.

run the following command on all subscriber servers:
utils dbreplication stop

Then, run the following commands on the publisher server:
utils dbreplication stop
then
utils dbreplication reset all

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/trouble/9_0_1/CUCM_BK_T863AF5C_00_troubleshooting-guide-cucm-90/CUCM_BK_T863AF5C_00_troubleshooting-guide-for-cucm_chapter_011.html#CUCM_TP_D31B2F41_00

Regards,

Yosh

HTH Regards, Yosh
VIP Purple

Hi Samuel,[+5] to Yosh . you

Hi Samuel,

[+5] to Yosh .

 

you can try the steps provided by Yosh. Deleting the subscriber and doing the fresh installation is not going to harm any working IP phones registered to working PUB and SUB.

Since you are doing the fresh installation of Subscriber 2, you need to delete Sub from  from PUB and add it again.

regds,

aman

 

 

New Member

i will carry out the steps

i will carry out the steps and i will reply back

thanks for the reply yosh and aman

New Member

Dears Do I need to take a

Dears

 

Do I need to take a backup before running the commands??, or they will absolutely not crash the system as I am afraid becz if anything goes wrong I have to reconfigure the whole CUCM.

 

thanks

It never hurts to have a

It never hurts to have a backup.

Yosh

HTH Regards, Yosh
New Member

that's the reason I posted

that's the reason I posted for tftp error, becz I preferred to be little late & safe.

Your backup is probably

Your backup is probably failing because of the dbreplication issue. If you don't have a recent backup and are nervous of something bad happening by running the "dbreplication reset all" command then I would just delete that SUB and re-install.

Yosh

HTH Regards, Yosh
New Member

so you are confirming me that

so you are confirming me that instead of running the propose commands if I delete the subscriber and reinstall that will be more quicker and safer, which will not affect in existing publisher database.

 

Also I get the attached error between the publisher and subsribers, I have done the below but still. this all I s happening becz of database failure.

set cert regen tomcat
utils service restart Cisco Tomcat

 

 

thanks

I'm not saying it's quicker

I'm not saying it's quicker but it can be "safer". The reset all command is just going to force all the Subs to re-sync. It's almost like a broadcast to the Subs. Please see the below information and link, which is a great document!

Using Replication Commands

Meaning of each command

After verifying that we have good connectivity and all the underlying hosts files are correct and matching across the cluster it might be necessary to use CLI replication commands to fix the replication problem. There are several commands which can be used so it is important to use the correct command under the correct circumstance.   The following table lists each command and it's function.  Certain commands are not available in each version of CUCM.

 

commandfunction
utils dbreplication stop

Normally run on a subscriber. Stops currently replication running, restarts A Cisco DB Replicator, deletes marker file used to signal replication to begin. This can be run on each node of the cluster by doing “utils dbreplication stop”.

In 7.1.2 and later “utils dbreplication stop all” can be run on the Publisher node to stop replication on all nodes

utils dbreplication repair 

utils dbreplication repairtable

utils dbreplication repairreplicate

Introduced in 7.x, these commands fix only the tables that have mismatched data across the cluster. This mismatched data is found by issuing a utils dbreplication status. These commands should only be used if logical connections have been established between the nodes.
utils dbreplication resetAlways run from the publisher node, used to reset replication connections and do a broadcast of all the tables. This can be executed to one node by hostname “utils dbreplication reset nodename” or on all nodes by “utils dbreplication reset all”.
utils dbreplication quickauditCheckes critical dynamic tables for consistency.  To check all tables run utils dbreplication status.
utils dbreplication clusterreset

Always run from the publisher node, used to reset replication connections and do a broadcast of all tables. Error checking is ignored. Following this command 'utils dbreplication reset all' should be run in order to get correct status information. Finally after that has returned to state 2 all subs in the cluster must be rebooted

Note:  This command is no longer functional as of CUCM 9.0(1).  Use "utils dbreplication reset all" instead.

utils dbreplication runtimestateAvailable in 7.X and later this command shows the state of replication as well as the state of replication repairs and resets. This can be used as a helpful tool to see which tables are replicating in the process.
utils dbreplication forcedatasyncsubThis command forces a subscriber to have its data restored from data on the publisher.  Use this command only after the 'utils dbreplication repair' command has been run several times and the 'utils dbreplication status' ouput still shows non-dynamic tables out of sync.
utils dbreplication dropadmindbRun on a publisher or subscriber, this command is used to drop the  syscdr database. This clears out configuration information from the  syscdr database which forces the replicator to reread the configuration  files. Later examples talk about identifying a corrupt syscdr database.
utils dbreplication dropadmindbforceSame as above, but may need to be used in cases where above command fails
utils dbreplication setprocess

Sets the "process" value within Informix.  This enables multithreading and improves replication setup time at the slight cost of processing power.  Recommended to set to 40 for large clusters (10+ nodes). 

 

https://supportforums.cisco.com/document/52421/troubleshooting-cucm-database-replication-linux-appliance-model

Yosh

HTH Regards, Yosh
New Member

Dear yosh,Do I need the below

Dear yosh,

Do I need the below command as well.

 

Utils dbreplication dropadmindb (PUB)

 

utils dbreplication dropadmindb (SUB)

 

thanks

Samuel,You don't need to run

Samuel,

You don't need to run those commands.

Regards,

Yosh

HTH Regards, Yosh
New Member

Dear Yosh,I have run those

Dear Yosh,

I have run those commands but the status is below, thesub1 came in status of (3). and sub2 and sub3 in status of 4.

sub2, and sub3 are in status of 4 this can be becz of the error attached,

 

Cluster Detailed View from CUCMPUB01DC (4 Servers):

                                PING            CDR Server      REPL.   DBver&  REPL.   REPLICATION SETUP
SERVER-NAME     IP ADDRESS      (msec)  RPC?    (ID) & STATUS   QUEUE   TABLES  LOOP?   (RTMT) & details
-----------     ------------    ------  ----    --------------  -----   ------- -----   -----------------
CUCMPUB01DC    10.X.X.X      0.042   Yes     (2)  Connected   0      match   Yes     (3) PUB Setup Completed
CUCMSUB01DC    10.X.X.X      0.319   Yes     (5)  Connected   0      match   Yes     (3) Setup Completed
cucmsub02dc    10.X.X.X     3.759   Yes     (?)  Off-Line    N/A    match   No              (4) Not Setup
cucmsub03dc    10.X.X.X     3.702   Yes     (?)  Off-Line    N/A    match   No               (4) Not Setup

 

On sub02 and sub03

i see the below

admin:utils dbreplication runtimestate
Replication is not setup, exiting...


thanks

VIP Purple

Hi Samuel, Have u added these

Hi Samuel,

 

Have u added these two subscribers in Publisher ?please let us know what is  10.20.15.15 in attached snapshot.

regds,

aman

New Member

I have rebooted the whole

thanks for the reply aman,

i have just put the fake ip's so pls don't consider.only consider the error " unable to connect node"

Have u added these two subscribers in Publisher ?please let us know what is  10.20.15.15 in attached snapshot

those were added from start and the attached error is when accessing the subscriber 2 and subscriber 3, from the serviceability page from the publisher

I have rebooted the whole cluster and Now the status is as below

                                PING            CDR Server      REPL.   DBver&  REPL.   REPLICATION SETUP
SERVER-NAME     IP ADDRESS      (msec)  RPC?    (ID) & STATUS   QUEUE   TABLES  LOOP?   (RTMT) & details
-----------     ------------    ------  ----    --------------  -----   ------- -----   -----------------
CUCMPUB01DC   10.X.X.X       0.050   Yes     (2)  Connected   0      match   Yes     (2) PUB setup completed
CUCMSUB01DC    10.X.X.X       0.392   Yes     (?)  Off-Line    N/A    match   Yes     (4) N/A
cucmsub02dc   10.X.X.X      3.657   Yes     (7)  Connected   0      match   N/A     (0) Setup in progress
cucmsub03dc    10.X.X.X      3.776   Yes     (8)  Connected   0      match   N/A     (0) Setup in progress

 

 

New Member

DearsThe problem is solved,

Dears

The problem is solved, there was  port (8500)  blocked on network side for subscriber to other subscribers but it is strange that between the subscriber 8500 was not reachable and the node was seen off-line, i was thinking that the replication is done by publisher to subscriber but by this issue I came to know that between the subscriber also we need these opens.

1 question,

how would I verify the port is open from CUCM node to the other CUCM node.

as such from windows we do telnet 10.X.X.X  8500

 

Thanks

Thanks Aman [+5]Yosh

Thanks Aman [+5]

Yosh

HTH Regards, Yosh
699
Views
10
Helpful
18
Replies
CreatePlease to create content