Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

CUCM Cisco TFTP trace file - phone firmware upgrade

Hi all,

I will really appreciate if anyone can share how to read tftp trace file to know the reasons why firmware upgrade fails. The reason I am asking is that I have been upgrading phones, almost all phones are upgraded successfully (approx 10,000 phones), few phones were not so phones were physically power recycled and upgraded to new firmware (9.3.1.SR2) successfully. There are about 200 remote agents, who connect to CUCM via internet using vpn, many of these phones are not upgraded and sitting with old firmware (9.2.1), these phones were first reset using cucm Device --> Phone --> Reset, and later tried with power cycling, both attempts were un-successful. It is suspected that could be related with the poor internet connectivity (low latency/bandwidth), but wanted to know the root cause. Tried to replicate the issue in lab by setting up latency ( in vpn router) to 246 ms, the phone took approx 2 hrs to download firmware but it was upgraded successfully.

I have collected cisco tftp logs from cucm and see many reason codes 6 with the phones that were not upgraded, but i wanted to find out any key word like firmware upgrade request fail, or timeout etc with the phone mac or ip address.

Could anyone please help me to find root cause from Cisco tftp trace?

CUCM : 8.6.1SU1

Phones : 7942/7962

Centralized TFTP Server, two clusters

Also, any details to collect and analyze phone logs for this issue.

Much appreciated.

Azad

Everyone's tags (1)
2 REPLIES

CUCM Cisco TFTP trace file - phone firmware upgrade

Hi Azad,

From your description it would appear that you have an issue with the ITL Files on the phones, if the ITL File does not trust the TFTP Server(s) then they will not accept an updated config file and therefore will not be able to upgrade based on the new PhoneLoad specified. Check the Status Messages log on the phone for any messages relating to ITL or Trust List updates, or just delete the ITL File and see if that causes the upgrade to start.

Also, as you have a centralised TFTP configuration, did you perform the bulk certificate export?

Akhil Behl (Author of "Securing Cisco IP Telephony Networks") and myself are hosting a series of educational Webinars that covers this very issue as well as the most effective way to upgrade phone firmware using PhoneView http://www.unifiedfx.com

You can register for the sessions here:

http://events.unifiedfx.com

Kind Regards.

Stephen Welsh

CUCM Cisco TFTP trace file - phone firmware upgrade

I'd look at it from the other end: Get the logs off the phone. That'll give you an easier to digest indiction of what the phone's doing.

GTG

Please rate all helpful posts.

Please rate all helpful posts.
1192
Views
0
Helpful
2
Replies
CreatePlease to create content