Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

CUCM H.323 Gateway / Outbound calls working but no voice

Hi,

i`m playing with my lab and have a problem with cucm h.323 voice gateway perform an outbound call throug my sip provider.

I can perform an outgoing call, the other side is ringing but i hear nothing. And before the call is established i hear no dial tone on my cisco phone. I thing this is a maybe codec problem?

Here are the voice gateway config:

!

voice class codec 1

codec preference 1 g711alaw

!        

voice class h323 1

  h225 timeout tcp establish 3

  call start slow

  no telephony-service ccm-compatible

  ccm-compatible

!

!

dial-peer voice 130 voip

description *** from CUCM to GW ***

translation-profile outgoing SIP-Outgoing

answer-address 1...

voice-class codec 1 

dtmf-relay h245-signal

no vad

!

dial-peer voice 140 voip

description *** from GW to SIP Provider ***

translation-profile outgoing SIP-Outgoing

destination-pattern 0T

session protocol sipv2

session target dns:sip.sipgate.de

session transport udp

voice-class codec 1 

voice-class sip dtmf-relay force rtp-nte

dtmf-relay rtp-nte

no vad

!

In the CUCM regions i have configured G.711 .

What do i wrong?

Thanks

Jason

12 REPLIES
Cisco Employee

CUCM H.323 Gateway / Outbound calls working but no voice

add following lines to gateway router global config, to see if it helps..

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

Pls rate the post if it helps.


GP.

New Member

CUCM H.323 Gateway / Outbound calls working but no voice

Sadly, no sucess. Here is my global voice config:

voice service voip

no ip address trusted authenticate

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

redirect ip2ip

fax protocol pass-through g711alaw

h323

modem passthrough nse codec g711alaw

sip     

  bind control source-interface FastEthernet0/0

  registrar server expires max 3600 min 3600

  redirect contact order best-match

  localhost dns:sip.sipgate.de

!

CUCM H.323 Gateway / Outbound calls working but no voice

Hi Jason.

Try to use g711ulaw as codec.

Is  your VG behind NAT  or Firewall?

Where your IP Phones are registered to?

Let me know

Regards

Carlo

Please rate all helpful posts "The more you help the more you learn"
New Member

Re: CUCM H.323 Gateway / Outbound calls working but no voice

Hi Carlo,

i`ve already tried this codec. Th VG is behind a Firewall.

But before i started this LAB the VG was configured as CME and with this configuration calls worked fine. :-/

I have already tried to erase config on VG with no CME configuration.

Any further suggestions? :-)

Thanks and happy new year.

CUCM H.323 Gateway / Outbound calls working but no voice

Hi Jason.

Which IOS version and CUCM version are you using?

Can you please post the entire VG config.

Thanks

Regards

Carlo

Please rate all helpful posts "The more you help the more you learn"
New Member

Re: CUCM H.323 Gateway / Outbound calls working but no voice

Im using this IOS -> c2800nm-adventerprisek9-mz.151-4.M2.bin

See attached config.

Re: CUCM H.323 Gateway / Outbound calls working but no voice

Hi Jason.

You config is ok.

Please send me the output of a show rtp connections and a show call active voice compact during an active call.

Thanks

Regards

Carlo

Please rate all helpful posts "The more you help the more you learn"
New Member

CUCM H.323 Gateway / Outbound calls working but no voice

Hi Carlo,

here are the outputs:

show call active voice compact

  A/O FAX T Codec       type        Peer Address       IP R:

Total call-legs: 2

        24 ANS     T13    g711alaw    VOIP        P1002     192.168.5.10:24580

        25 ORG     T13    g711alaw    VOIP        P0049301234567     62.53.235.118:41064

and show rtp connections is no command on the router only rtp call and rtp statistics, but both show "no active call found"

show rtp call                 

No Active calls found

show rtp statistics

No Active calls found

I don`t know, but should "P1002" show public extenstion instead of internal "1002" number?

Here is also a debug of ccsip calls if the call is established and i think it looks ok or what do you think?

*Jan  3 18:37:55.167: //32/806C039B0E00/SIP/Call/sipSPICallInfo:

The Call Setup Information is:

Call Control Block (CCB) : 0x4BEFE638

State of The Call        : STATE_ACTIVE

TCP Sockets Used         : NO

Calling Number           : 0049301276543

Called Number            : 0049301234567

Source IP Address (Sig  ): 192.168.5.99

Destn SIP Req Addr:Port  : 62.53.230.92:5060

Destn SIP Resp Addr:Port : 62.53.230.92:5060

Destination Name         : sip.sipgate.de

HQ#

*Jan  3 18:37:55.167: //32/806C039B0E00/SIP/Call/sipSPIMediaCallInfo:

Number of Media Streams: 1

Media Stream             : 1

Negotiated Codec         : g711alaw

Negotiated Codec Bytes   : 160

Nego. Codec payload      : 8 (tx), 8 (rx)

Negotiated Dtmf-relay    : 6

Dtmf-relay Payload       : 99 (tx), 99 (rx)

Source IP Address (Media): 192.168.5.99

Source IP Port    (Media): 16484

Destn  IP Address (Media): 62.53.235.118

Destn  IP Port    (Media): 55342

Orig Destn IP Address:Port (Media): [ - ]:0

New Member

CUCM H.323 Gateway / Outbound calls working but no voice

Any idea Carlo?

CUCM H.323 Gateway / Outbound calls working but no voice

Hi Jason.

I assume that you are behind nat.

If so try to add these commands:

sip-ua

nat symmetric role  passive

nat check-media-src.

Hope this helps.

Regards

Carlo

Please rate all helpful posts "The more you help the more you learn"
New Member

Re: CUCM H.323 Gateway / Outbound calls working but no voice

Ok. Now i tried to change the sip provider with another sip provider. And with this provider the call can be established and both sides hear each other but before the call is established ,i hear sadly still no ringtone. :-(

If i use a third party softphone it worked so it have to be in context with VoiceGW/Call Manager configuration?

UPDATE:

Ok, if i use g711ulaw it works with the ringtone but i don`t know why? I thougt g711ulaw is for America/China only?

UPDATE:

Wuahh im confused. if i use ulaw the ringtone worked but the voice did not work anymore

CUCM H.323 Gateway / Outbound calls working but no voice

Hi Jason.

In many cases, SIP providers use G711ulaw as preferred codec but G711alaw should also work.

No particular config is required between CUCM and H323 gateway.

The only thing I would pay attention is on NAT.

Please tell me if applying nat commands in my previous post.

HTH.

Regards

Carlo

Please rate all helpful posts "The more you help the more you learn"
1775
Views
0
Helpful
12
Replies
CreatePlease to create content