Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

CUCM R8.0 and SRST issues

I have the following situation, one central office and tree remote offices each one have a 2911 as SRST, the 2911 also have FXO and FXS ports for analog internal users and analog trunks.

When the data link with central Office it´s lost, all the IP phones register on SRST device and can call each other, even they can call the FXS users and made external call to PSTN.

So maybe you are wondering which are the issues? at first eventhoug that on SRST mode a could made external call to PSTN, when there are external inbound calls to our systems, the call rings once and then nothing happen, nor ringing signal on the assitants IP phone. And the FXO port stay on busy stated.

Second when we tried to made a call from a FXS users, picking up the handset on the analog phone, and we didn't hear any dial tone, nor we could dial any DN.

Any Ideas?

Regards,

Luis Martinez

1 ACCEPTED SOLUTION

Accepted Solutions

CUCM R8.0 and SRST issues

Try this

Configure the following commads and this should work -

!

application

global

  service alterenate default

!

!

!

ccm-manager fallback-mgcp

!

!

dial-peer voice 123 pots

destination-pattern

port

And take look on this documentation:

http://www.cisco.com/en/US/tech/tk1077/technologies_tech_note09186a0080144630.shtml#prob1

Regards

Rate this if helps you

Happy new year

6 REPLIES
Green

CUCM R8.0 and SRST issues

Hi Luis

Under normal working is the SRST gateway H323 or MGCP

Can you post the SRST gateway config

Regards

Alex

Regards, Alex. Please rate useful posts.

CUCM R8.0 and SRST issues

Alex,

The SRST device in normal working it's MGCP, below you will find the sh run

RT2911VCBB01#sh run

Building configuration...

Current configuration : 14456 bytes

!

! Last configuration change at 09:46:49 BO Wed Dec 28 2011 by dima

! NVRAM config last updated at 11:01:53 BO Wed Dec 28 2011 by dima

!

version 15.1

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

no service password-encryption

!

hostname RT2911VCBB01

!

boot-start-marker

boot-end-marker

!

!

logging buffered 4096000

!

aaa new-model

!

!

aaa authentication login vty group tacacs+ local

aaa authorization exec default group tacacs+ if-authenticated

aaa authorization commands 1 default group tacacs+ if-authenticated

aaa authorization commands 15 default group tacacs+ if-authenticated

aaa accounting exec default start-stop group tacacs+

aaa accounting commands 1 default start-stop group tacacs+

aaa accounting commands 15 default start-stop group tacacs+

!

!

!

!

!

aaa session-id common

clock timezone BO -4 0

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

!

voice class custom-cptone ENTEL

dualtone disconnect

  frequency 427

  cadence 202 195

!

voice class custom-cptone COMTECO

dualtone disconnect

  frequency 427

  cadence 500 497

!

voice class custom-cptone Telular

dualtone disconnect

  frequency 427

  cadence 529 490

!

!

!

!

!

!

application

global

  service alternate Default

!

!

license udi pid CISCO2911/K9 sn FTX1523AJ5A

hw-module pvdm 0/0

!

redundancy

!

!

ip ssh version 2

!

!

!

!

interface GigabitEthernet0/0

description "ENLACE TRONCAL SW2948VCBBA01"

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.2019

description "GATEWAY DE DATOS"

encapsulation dot1Q 2019

ip address 172.20.192.254 255.255.255.0

ip helper-address 172.20.192.1

!

interface GigabitEthernet0/0.2119

description "GATEWAY DE VOZ"

encapsulation dot1Q 2119

ip address 172.21.192.252 255.255.255.0

ip helper-address 172.20.192.1

!

interface GigabitEthernet0/1

description "ENLACE ROUTER ENTEL"

ip address 10.10.10.2 255.255.255.252

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip route 0.0.0.0 0.0.0.0 10.10.10.1

!

logging trap warnings

logging 172.20.197.231

!

!

control-plane

!

!

voice-port 0/0/0

supervisory disconnect dualtone mid-call

supervisory custom-cptone COMTECO

no battery-reversal

echo-cancel coverage 64

cptone CO

timeouts call-disconnect 3

timeouts wait-release 3

timing hookflash-out 50

connection plar opx 6130

description "Linea 44762179"

!

voice-port 0/0/1

supervisory disconnect dualtone mid-call

supervisory custom-cptone COMTECO

no battery-reversal

echo-cancel coverage 64

cptone CO

timeouts call-disconnect 3

timeouts wait-release 3

timing hookflash-out 50

connection plar opx 6130

description "Linea 44762497-P"

!

voice-port 0/0/2

supervisory disconnect dualtone mid-call

supervisory custom-cptone COMTECO

no battery-reversal

echo-cancel coverage 64

cptone CO

timeouts call-disconnect 3

timeouts wait-release 3

timing hookflash-out 50

connection plar opx 6130

description "Linea 44762499"

!

voice-port 0/0/3

supervisory disconnect dualtone mid-call

supervisory custom-cptone COMTECO

no battery-reversal

echo-cancel coverage 64

cptone CO

timeouts call-disconnect 3

timeouts wait-release 3

timing hookflash-out 50

connection plar opx 6139

description "Linea 44762498 - FAX"

!

voice-port 0/1/0

supervisory disconnect dualtone mid-call

supervisory custom-cptone ENTEL

no battery-reversal

echo-cancel coverage 64

cptone CO

timeouts call-disconnect 3

timeouts wait-release 3

timing hookflash-out 50

description "ENTEL - 44117371"

!

voice-port 0/1/1

supervisory disconnect dualtone mid-call

supervisory custom-cptone ENTEL

no battery-reversal

echo-cancel coverage 64

cptone CO

timeouts call-disconnect 3

timeouts wait-release 3

timing hookflash-out 50

description "ENTEL - 44117372"

!

voice-port 0/1/2

supervisory disconnect dualtone mid-call

supervisory custom-cptone ENTEL

no battery-reversal

echo-cancel coverage 64

cptone CO

timeouts call-disconnect 3

timeouts wait-release 3

timing hookflash-out 50

connection plar opx 6129

description "ENTEL - 44117373 - FAX"

!

voice-port 0/1/3

supervisory disconnect dualtone mid-call

supervisory custom-cptone Telular

no battery-reversal

echo-cancel coverage 64

cptone CO

timeouts call-disconnect 3

timeouts wait-release 3

timing hookflash-out 50

description "Telular 67598569"

!

voice-port 0/2/0

cptone CO

!

voice-port 0/2/1

cptone CO

!

voice-port 0/2/2

!

voice-port 0/2/3

cptone CO

!

ccm-manager redundant-host trscccm01

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 172.21.200.10 172.21.200.40

ccm-manager config

!

mgcp

mgcp call-agent trscccm02 2427 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

!

mgcp profile default

!

sccp local GigabitEthernet0/0.2119

sccp ccm 172.21.200.40 identifier 1 version 7.0

sccp ccm 172.21.200.10 identifier 2 version 7.0

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate ccm 2 priority 2

associate profile 1 register RT2911VCBB01-CF

!

sccp ccm group 2

associate ccm 1 priority 1

associate ccm 2 priority 2

associate profile 2 register RT2911VCBB01-XC

!

dspfarm profile 2 transcode universal 

description "3 sesiones de Xcode"

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

maximum sessions 3

associate application SCCP

!

dspfarm profile 1 conference 

description "son 2 conferencias de 8 participantes"

codec g711ulaw

codec g729r8

codec g729ar8

codec g729abr8

codec g711alaw

maximum sessions 2

associate application SCCP

!

dial-peer voice 999000 pots

service mgcpapp

port 0/0/0

!

dial-peer voice 999001 pots

service mgcpapp

port 0/0/1

!

dial-peer voice 999002 pots

service mgcpapp

port 0/0/2

!

dial-peer voice 999003 pots

service mgcpapp

port 0/0/3

!

dial-peer voice 999010 pots

service mgcpapp

port 0/1/0

!

dial-peer voice 999011 pots

service mgcpapp

port 0/1/1

!

dial-peer voice 999012 pots

service mgcpapp

port 0/1/2

!

dial-peer voice 999013 pots

service mgcpapp

port 0/1/3

!

dial-peer voice 999020 pots

service mgcpapp

port 0/2/0

!

dial-peer voice 999021 pots

service mgcpapp

port 0/2/1

!

dial-peer voice 999023 pots

service mgcpapp

port 0/2/3

!

dial-peer voice 996129 pots

description "interno 6129"

destination-pattern 6129

port 0/2/0

forward-digits all

!

dial-peer voice 996134 pots

description "interno 6134"

destination-pattern 6134

port 0/2/1

forward-digits all

!

dial-peer voice 996139 pots

description "interno 6139"

destination-pattern 6139

port 0/2/3

forward-digits all

!

dial-peer voice 999900 pots

description "llamada local 1XX"

preference 1

destination-pattern 91..

port 0/0/0

prefix 1

!

dial-peer voice 999901 pots

description "llamada local 1XX"

preference 2

destination-pattern 91..

port 0/0/1

prefix 1

!

dial-peer voice 999902 pots

description "llamada local 1XX"

preference 3

destination-pattern 91..

port 0/0/2

prefix 1

!

dial-peer voice 999903 pots

description "llamada local 4XXXXXX"

preference 1

destination-pattern 94......

port 0/0/0

prefix 4

!

dial-peer voice 999904 pots

description "llamada local 4XXXXXX"

preference 2

destination-pattern 94......

port 0/0/1

prefix 4

!

dial-peer voice 999905 pots

description "llamada local 4XXXXXX"

preference 3

destination-pattern 94......

port 0/0/2

prefix 4

!

dial-peer voice 999906 pots

description "llamada celular 6XXXXXXX"

destination-pattern 96.......

port 0/1/3

prefix 6

!

dial-peer voice 999907 pots

description "llamada celular 7XXXXXXX"

destination-pattern 97.......

port 0/1/3

prefix 7

!

dial-peer voice 999908 pots

description "llamadas a 800XXXXXX"

preference 1

destination-pattern 9800......

port 0/1/0

prefix 800

!

dial-peer voice 999909 pots

description "llamadas a 800XXXXXX"

preference 2

destination-pattern 9800......

port 0/1/1

prefix 800

!

dial-peer voice 9999010 pots

description "llamadas a 800XXXXXX"

preference 3

destination-pattern 9800......

port 0/1/2

prefix 800

!

dial-peer voice 999911 pots

description "llamada 90XXXXXXX"

preference 1

destination-pattern 990.......

port 0/1/0

prefix 90

!

dial-peer voice 999912 pots

description "llamada 90XXXXXXX"

preference 2

destination-pattern 990.......

port 0/1/1

prefix 90

!

dial-peer voice 999913 pots

description "llamada 90XXXXXXX"

preference 3

destination-pattern 990.......

port 0/1/2

prefix 90

!

dial-peer voice 999914 pots

description "llamada LDN"

preference 1

destination-pattern 90........

port 0/1/0

prefix 010

!

dial-peer voice 999915 pots

description "llamada LDN"

preference 2

destination-pattern 90........

port 0/1/1

prefix 010

!

dial-peer voice 999916 pots

description "llamada LDN"

preference 3

destination-pattern 90........

port 0/1/2

prefix 010

!

dial-peer voice 999917 pots

description "llamadas LDI"

preference 1

destination-pattern 900T

port 0/1/0

prefix 0010

!

dial-peer voice 999918 pots

description "llamadas LDI"

preference 2

destination-pattern 900T

port 0/1/1

prefix 0010

!

dial-peer voice 999919 pots

description "llamadas LDI"

preference 3

destination-pattern 900T

port 0/1/2

prefix 0010

!

!

!

!

gatekeeper

shutdown

!

!

call-manager-fallback

max-conferences 8 gain -6

transfer-system full-consult

ip source-address 172.21.192.252 port 2000

max-ephones 25

max-dn 25

system message primary SRST Fallback Active

system message secondary SRST Fallback

!

end

Any help or idea will be very grateful.

Regards,

Luis Martinez

CUCM R8.0 and SRST issues

Try this

Configure the following commads and this should work -

!

application

global

  service alterenate default

!

!

!

ccm-manager fallback-mgcp

!

!

dial-peer voice 123 pots

destination-pattern

port

And take look on this documentation:

http://www.cisco.com/en/US/tech/tk1077/technologies_tech_note09186a0080144630.shtml#prob1

Regards

Rate this if helps you

Happy new year

CUCM R8.0 and SRST issues

Hi Leonardotadeu,

I already had this lines on my configuration

!

application

global

  service alterenate default

!

I didn't have this: " ccm-manager fallback-mgcp" I wil put on the configuration, tested and see what happen.

Could you explain what would do the dial-peer voice 123 pots configuration?

Regards,

Luis Martinez

Silver

CUCM R8.0 and SRST issues

Please see this link it might help:

http://www.cisco.com/en/US/tech/tk652/tk653/technologies_tech_note09186a00800ae2d1.shtml

also insert (service mgcpapp) into the dial peers

---

Posted by WebUser Mohamed Libya

CUCM R8.0 and SRST issues

Hi Mohamed Libya,

Thanks for the link, I used the disconect tone configuration to solutions this issue "when there are external inbound calls to our systems, the call rings  once and then nothing happen, nor ringing signal on the assitants IP  phone. And the FXO port stay on busy stated." Now the FXO port after put in busy stated get free a few seconds later.

Inserting the "service mgcpapp" on the dial peers witch of the following issues will be solve?

a) That the incoming call on FXO ports are not ringing on the IP phone of the secretary

b) When we tried to made a call from a FXS users, picking up the  handset on the analog phone, and we didn't hear any dial tone, nor we  could dial any DN.

Regards,

Luis Martinez

614
Views
0
Helpful
6
Replies
CreatePlease login to create content