Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CUCM Replication after a restore

Hi All,

I have just completed a restore of a CUCM 9.1.1.20000-5 Publisher and Subscriber, all seems to be ok however replication is broken bewteen the two servers.

When I run "utils dbreplication runtimestate" from the publisher, it fails with the following:

admin:utils dbreplication runtimestate

DB and Replication Services: ALL RUNNING

DB CLI Status: No other dbreplication CLI is running...

Cluster Replication State: BATCHING SYNC Requests from nodes at: 2013-12-06-14-59
     Sync Request Progress: Received 1 node requests for DB sync
     Sync Request Errors: NO ERRORS

Traceback (most recent call last):
  File "/usr/local/cm/bin/DbReplRTstate.py", line 1143, in ?
    maxTime = getMaxDelay()
  File "/usr/local/cm/bin/DbReplRTstate.py", line 604, in getMaxDelay
    (rhostname, aliaslist, ipaddrlist) = socket.gethostbyaddr(temp[1])
socket.herror: (2, 'Host name lookup failure')

               

when i check the DB status from the reports, my pubnlisher is status = 3 (bad) and the publisher is status = 4 (initializing)

I have tried to reset the replication etc but dont seem to be getting anywhere.

Any help appreciated.

Thanks

Jason

  • IP Telephony
7 REPLIES
New Member

CUCM Replication after a restore

After I posted this i re-run the DB status report and both Pub and Sub are now showing stats =3 (bad)..

Cisco Employee

CUCM Replication after a restore

Hi Jason,

Have you changed the hostname on the CUCM.

Try the following commands

"utils dbreplication dropadmindb" on Subs and then Pub

"utils dbreplication reset all" on Pub

Very good link for db issues

https://supportforums.cisco.com/docs/DOC-13672

Rate if it helps

Thanks

Ajay

VIP Purple

CUCM Replication after a restore

Hi Jason,

Was the Call manager backup restored successfully on new servers?

Secondly, when u have build both the servers , did u keep all credentials same  like Hostname, NTP, DNS, GW,Subnet Mask, OS Username /password, Security password and application username /password.

what is the new hardware u are using?

regds,

aman

New Member

CUCM Replication after a restore

THanks Guys,

No issues with the restore.

Nothing changed in regrads to hostname, ip, etc.  All details were kept the same.

The new hardwrae is a VMserver, we are testing the backup and restore process in the event of a DR failure.

All looks to be working Ok, phones are registered and making calls updates made to DN and Users and being replicatied but the Replica state is still showing 3 - Bad.

I have working through the doc that Ajay has mentioned, and replication foes through the steps and I can see it initalising but then after a while it go back to state 3.

Thanks

Jason

VIP Purple

CUCM Replication after a restore

Hi Jason,

can u please issue the commands and wait for sometime say 30 minutes ti check dbreplication status

a utils dbreplication stop all : PUBLISHER . wait till the command is finished on this server.

b.utils dbreplication dropadmindb : on all servers successfully. Wait till command is finished on this server and then, run on next

c. utils dbreplication reset all : on publisher

regds,

aman

CUCM Replication after a restore

Hi jason,

Have you checked the status before restoring ? Was it the same what you have now?

Can you check the dbstatus from RTMT as well.

Are the phones registered to SUB?

Because if phones are registered and you are able to make calls and DN status can be updated then you might be hitting some bug.

Regards,

Nishant Savalia

Regards, Nishant Savalia
Cisco Employee

CUCM Replication after a restore


Run the unified Cmdatabase status from the reporting and please check if the  following host value matches in the output.

Unified CM Hosts
Unified CM Rhosts
Unified CM Sqlhosts

Run a "utils diagnose test" from the CLI and check for any errors.

Regards

Ajay

1102
Views
0
Helpful
7
Replies
This widget could not be displayed.