Cisco Support Community
Community Member

CUCM - Reset OS admin password unsuccessfully

Hi All,

Encountered the error information when tried to reset CUCM OS admin password through CLI.

admin:set password user admin
   Please enter the old password: ****************
   Please enter the new password: ****************
Reenter new password to confirm: ****************
Please wait...

Executed command unsuccessfully
Password changed too soon

This CUCM server is one of the subscribers. There is no issue with the publisher and the rest of the subscribers.

The version of CUCM is

Your comments here will be really appreciated.



Community Member

I have encountered the same

I have encountered the same thing, did you find a solution?





Hi joeharb, check this link

Hi joeharb,

 check this link Password Change too Soon.


Hope this helps.


Community Member

I found that link, it appears

I found that link, it appears to be for Connection and it refers to the security password, is the procedure the same?  Do you need to reverse the steps. 



Hi joeharb, it looks like the

Hi joeharb,

 it looks like the same problem to me.


Hope this helps.




[+5] to Marcelo for sharing

[+5] to Marcelo for sharing the link.I just found the bug but is for UCXN.


Suggest involve TAC for resolution.


"set password user admin" on sub server may fail with "changed too soon"

We have seen that attempting to change the platform administrator account password on a subscriber Unity Connection server version (platform version will fail with the following error message:

"password changed too soon"

This being erroneous because nobody had never changed the password since the system was installed.

First seen in Unity Connection server version (platform version

If this problem is encountered in version 8.x you can work around it by running the following command to disable the minimum password age check.

"set password expiry minimum-age disable"

If this problem is seen on earlier versions, call TAC for support.
Community Member

I had this problem with

I had this problem with version 10.5

The solution for me was to disable message history via "set password history 0" the default value is 10 and can be set back to this after changing the password.

Also note that in 10.5 there are separate settings for min-age and max-age so in case you need these commands as well they are "set password expiry minimum-age disable" and "set password expiry maximum-age disable". This differs slightly from the provided link where "set password expiry disable" is used for older versions.



Community Member

Thank you.

Thank you.

Thank you for your post. By

Thank you for your post. By setting password history to 0 and after the password change back to 10 helped me to overcome a similar issue that I had with a newly configured user.

Community Member

Re: I had this problem with

Thanks it worked!!!
CreatePlease to create content