Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

CUCM to CME

I've seen posts dancing around this, but none that deal specifically with this.  For reasons that are too odd to go into, I want to send calls from a phone registered to a CUCM server through a voice gateway to a CME gateway (using H.323 not a PRI) and into another phone registered to CME.  Kind of like what I have below:

PHONE <--SCCP--> CUCM <--H.323--> GATEWAY <--H.323--> CME <--SCCP--> PHONE

The "GATEWAY" is configured as an H.323 gateway in CUCM, but I do not want to have the CME gateway configured as a gateway within CUCM, I just want it to be a stand-alone device.  I have a pattern pointing from CUCM to the voice gateway, and a dial-peer on the gateway pointing to CME.  I also have a dial-peer on CME going in the other direction to the gateway and a dial-peer on the gateway pointing back at CUCM.  I've double-checked the patterns and dial-peers.  I have the appropriate interfaces bound with the "h323-gateway voip interface" and "h323-gateway voip bind srcaddr <local ip>" commands on each router.  I even put an "allow-connections h323 to h323" under voice service voip to see if it would help.  But nothing is working correctly.

At the moment, if I dial from a CUCM phone to a CME phone I get a fast-busy.  A "debug voice ccapi inout" shows that the call is making it to CME, though, and with the correct numbers dialed.  If I do a "csim start" on the CME router, the phone rings. 

If I call from the CME phone to the CUCM phone the call goes through, but I only get one-way audio. 

If I add yet a second CME gateway to the mix, I can call between it and the first CME gateway all afternoon long.  So it would seem there's just something I haven't learned yet dealing with a TCP link between a CUCM registered gateway and a CME gateway.

There are no firewalls in the way and no ACLs configured anywhere.  This is just a lab environment at the moment, but I'm doing it here to troubleshoot a production problem elsewhere.

Thanks.

13 REPLIES
Hall of Fame Super Silver

CUCM to CME

Use debug voice dialpeer to make sure call gets where it needs to, also do you have these on both routers:

voice service voip

allow-connections h323 to h323

What IOS version are you running?

Chris

Green

CUCM to CME

Hi,

I think the clue here is One way transmission

You need to bind the H323  IP address to an interface in
both the the GATEWAY and the CME routers.

It might be a good idea to create a loopback interface in the
GATEWAY and bind the H323 tio this.  Use this address as the CUCM
H323 Gateway address. Also use as the voip dial peer target.

Like

!
int loopback 100
desc *** H323 BINDING ***
ip address 10.255.255.100 255.255.255.252
h323-gateway voip bind srcaddr 10.255.255.100
!

HTH
Alex

Regards, Alex. Please rate useful posts.
Community Member

Re: CUCM to CME

I already had H.323 bound to the interface that is being routed through the system on both gateways.  I'll give the loopback a shot, though, for the sake of trying everything.  Like I say I'm out of other ideas.

Community Member

CUCM to CME

I already have the "allow-connection" command in both routers.  I'm using IOS v15.1(4)M3.  I've also tried it on 15.2(1)T1.

Green

Re: CUCM to CME

Hi,

Can you post the Gateway and CME configs

Regards

Alex

Regards, Alex. Please rate useful posts.
Community Member

Re: CUCM to CME

Here are the configs.

Gateway #1 (CUCM)

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname voicegw-01

!

boot-start-marker

boot system flash:c2801-adventerprisek9-mz.151-3.T.bin

boot-end-marker

!

!

card type t1 0 1

logging buffered 51200 warnings

enable secret 5 $1$N8Aw$om8uCV1XRo7uX633Q4LP//

!

no aaa new-model

!

clock timezone EDT -5 0

clock summer-time EDT recurring

network-clock-participate wic 1

dot11 syslog

ip source-route

!

!

!

!

!

ip cef

no ip domain lookup

ip domain name cisco.com

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-ni

!

!

!

voice service voip

no ip address trusted authenticate

allow-connections h323 to h323

!

!

!

!

!

voice-card 0

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-2677475789

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2677475789

revocation-check none

rsakeypair TP-self-signed-2677475789

!

!

crypto pki certificate chain TP-self-signed-2677475789

certificate self-signed 01

  30820257 308201C0 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 32363737 34373537 3839301E 170D3130 31323036 31333030

  33365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 36373734

  37353738 3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100F280 87E09F9D 9D006D54 8DF525C3 AE8DD0E7 20CA9127 A93F07C9 EA0163DA

  B44CB77B C91B3340 A95736E1 5AEBD512 3865566C 03F58ACD 9B1DE473 7F0B6522

  97B3D7E9 A0C01DE9 46E84B05 7FB81E30 C5E5CC05 9CD07788 FE784B56 F6D5B98C

  58B2DE37 00F7519C 7663E64A 1F1DA1A8 D8BF6162 BB384F30 77F501BD 61A2CB4D

  85490203 010001A3 7F307D30 0F060355 1D130101 FF040530 030101FF 302A0603

  551D1104 23302182 1F636E63 6E772D76 6F696365 67772D30 312E796F 7572646F

  6D61696E 2E636F6D 301F0603 551D2304 18301680 14E65C17 AC3AE1B5 49EA1311

  3F2E1B1D C2875F48 10301D06 03551D0E 04160414 E65C17AC 3AE1B549 EA13113F

  2E1B1DC2 875F4810 300D0609 2A864886 F70D0101 04050003 818100CB 2CE17753

  8E8A58D7 A2DE7325 C974E39F EE865AAC D4FFF398 1BA6CEC4 A0C2DD4F 4CBB08F9

  B745D499 D72CFC8F 200E32C1 206615A6 5081627C 4E6E7BCD 9977CE2B CB42BE50

  62717F89 B2C19CEF 8CBC735C 752ED3DD 93F11A23 E479A921 73F8DD5A B8F6E246

  3710CBA8 11A498A0 2213C7B5 C448E2D6 C460F189 05A6F1C2 5AB710

   quit

!

!

license udi pid CISCO2801 sn FTX132480XT

archive

log config

  hidekeys

username administrator privilege 15 secret 5 $1$L7z0$/kv/jpmZZccEhRWN1.iFK0

!

redundancy

!

!

controller T1 0/1/0

cablelength long 0db

pri-group timeslots 1-24 service mgcp

!

ip ssh version 2

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 172.19.1.2 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 172.19.1.2

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface Serial0/1/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

!

router eigrp 100

network 10.0.0.0

network 172.19.0.0

auto-summary

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

ip route 172.19.2.0 255.255.255.0 172.19.1.3

!

logging esm config

!

!

!

!

!

!

control-plane

!

disable-eadi

!

voice-port 0/1/0:23

!

!

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial

!

dial-peer voice 2 voip

incoming called-number .

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 3 voip

session protocol sipv2

incoming called-number .

codec g711ulaw

no vad

!

dial-peer voice 1001 voip

destination-pattern 2025225...

session target ipv4:172.19.1.10

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 1002 voip

destination-pattern 2025226...

session target ipv4:172.19.2.10

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 1003 voip

destination-pattern 2025227...

session target ipv4:172.19.3.10

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

!

!

!

call-manager-fallback

secondary-dialtone 9

max-conferences 1 gain -6

transfer-system full-consult

timeouts interdigit 3

ip source-address 172.19.1.2 port 2000

max-ephones 10

max-dn 10

system message primary SRST Mode

dialplan-pattern 1 2023345... extension-length 4

transfer-pattern .T

no huntstop

alias 1 5... to 5001

call-forward pattern .T

moh music-on-hold.au

time-zone 12

!

!

!

line con 0

exec-timeout 0 0

logging synchronous

login local

line aux 0

line vty 0 4

exec-timeout 0 0

privilege level 15

password sanjose

logging synchronous

login local

transport input telnet ssh

line vty 5 15

privilege level 15

login local

transport input ssh

!

scheduler allocate 20000 1000

ntp master 5

end

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname voicegw-03

!

boot-start-marker

boot-end-marker

!

!

enable secret 5 $1$yeN8$qlKRoeq1wFfekyFBQY4c8/

!

no aaa new-model

no network-clock-participate slot 1

!

voice-card 0

dspfarm

dsp services dspfarm

!

voice-card 1

dspfarm

!

dot11 syslog

ip source-route

!

!

ip cef

ip dhcp excluded-address 172.19.3.3

ip dhcp excluded-address 172.19.3.10

!

!

!

no ip domain lookup

ip domain name cncnw.com

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-ni

!

!

!

voice service voip

no ip address trusted authenticate

allow-connections h323 to h323

!

!

!

!

voice translation-rule 1

rule 1 /^[012345789]\(.*\)/ /6010/

!

!

voice translation-profile 1

translate called 1

!

!

crypto pki token default removal timeout 0

!

!

!

!

license udi pid CISCO2811 sn FTX1140A43L

username administrator privilege 15 password 7 15200E0A162B267579

!

!

controller T1 1/0/0

pri-group timeslots 1-24

!

controller T1 1/0/1

!

ip ssh version 2

!

!

!

!

!

interface FastEthernet0/0

ip address 172.19.3.10 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 172.19.3.10

!

interface FastEthernet0/1

ip address 192.168.1.3 255.255.255.0

duplex auto

speed auto

!

interface Serial0/1/0

no ip address

shutdown

clock rate 2000000

!

interface Serial0/2/0

no ip address

shutdown

clock rate 2000000

!

interface Serial1/0/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

!

router eigrp 100

network 172.19.0.0

network 192.168.1.0

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

ip route 0.0.0.0 0.0.0.0 172.19.3.3

!

logging esm config

!

!

tftp-server flash:apps42.8-5-4TH1-6.sbn

tftp-server flash:cnu42.8-5-4TH1-6.sbn

tftp-server flash:dsp42.8-5-4TH1-6.sbn

tftp-server flash:jar42sccp.8-5-4TH1-6.sbn

tftp-server flash:cvm42sccp.8-5-4TH1-6.sbn

tftp-server flash:term42.default.loads

tftp-server flash:term62.default.loads

tftp-server flash:SCCP42.8-5-4S.loads

!

control-plane

!

!

voice-port 0/0/0

!

voice-port 0/0/1

!

voice-port 0/3/0

!

voice-port 0/3/1

!

voice-port 1/0/0:23

translation-profile incoming 1

!

!

!

mgcp profile default

!

!

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial

!

dial-peer voice 2 voip

incoming called-number .

dtmf-relay h245-signal h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 1001 voip

destination-pattern 2025225...

session target ipv4:172.19.1.10

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 1002 voip

destination-pattern 2025226...

session target ipv4:172.19.2.10

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

!

!

telephony-service

no auto-reg-ephone

authentication credential administrator cisco

max-ephones 25

max-dn 100

ip source-address 172.19.3.10 port 2000

timeouts interdigit 6

system message User Options

load 7941 SCCP41.9-1-1SR1S

load 7942 SCCP42.8-5-4S

time-zone 12

max-conferences 8 gain -6

call-forward pattern .T

web admin system name administrator password cisco

transfer-system full-consult

transfer-pattern .T

secondary-dialtone 9

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-template  1

softkeys idle  Newcall Cfwdall Redial

softkeys seized  Endcall Cfwdall Redial

softkeys alerting  Endcall

softkeys connected  Endcall Hold Park Trnsfer Confrn

!

!

ephone-dn  1

number 2025227010

label Jimi Hendrix - 2025227010

name Jimi Hendrix

!

!

ephone-dn  2

number 2025227011

label Janis Joplin - 2025227011

name Janis Joplin

!

!

ephone  1

mac-address 0021.5504.464E

type 7941

button  1:1 2m2

!

!

!

ephone  2

mac-address 0026.0BD7.DD3C

type 7942

button  1:2

!

!

!

!

line con 0

exec-timeout 0 0

logging synchronous

login local

line aux 0

line vty 0 4

exec-timeout 0 0

logging synchronous

login local

transport input all

!

scheduler allocate 20000 1000

end

version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname voicegw-01
!
boot-start-marker
boot system flash:c2801-adventerprisek9-mz.151-3.T.bin
boot-end-marker
!
!
card type t1 0 1
logging buffered 51200 warnings
enable secret 5 $1$N8Aw$om8uCV1XRo7uX633Q4LP//
!
no aaa new-model
!
clock timezone EDT -5 0
clock summer-time EDT recurring
network-clock-participate wic 1
dot11 syslog
ip source-route
!
!
!
!
!
ip cef
no ip domain lookup
ip domain name cisco.com
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-ni
!
!
!
voice service voip
no ip address trusted authenticate
allow-connections h323 to h323
!
!
!
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-2677475789
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2677475789
revocation-check none
rsakeypair TP-self-signed-2677475789
!
!
crypto pki certificate chain TP-self-signed-2677475789
certificate self-signed 01
  30820257 308201C0 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32363737 34373537 3839301E 170D3130 31323036 31333030
  33365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 36373734
  37353738 3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100F280 87E09F9D 9D006D54 8DF525C3 AE8DD0E7 20CA9127 A93F07C9 EA0163DA
  B44CB77B C91B3340 A95736E1 5AEBD512 3865566C 03F58ACD 9B1DE473 7F0B6522
  97B3D7E9 A0C01DE9 46E84B05 7FB81E30 C5E5CC05 9CD07788 FE784B56 F6D5B98C
  58B2DE37 00F7519C 7663E64A 1F1DA1A8 D8BF6162 BB384F30 77F501BD 61A2CB4D
  85490203 010001A3 7F307D30 0F060355 1D130101 FF040530 030101FF 302A0603
  551D1104 23302182 1F636E63 6E772D76 6F696365 67772D30 312E796F 7572646F
  6D61696E 2E636F6D 301F0603 551D2304 18301680 14E65C17 AC3AE1B5 49EA1311
  3F2E1B1D C2875F48 10301D06 03551D0E 04160414 E65C17AC 3AE1B549 EA13113F
  2E1B1DC2 875F4810 300D0609 2A864886 F70D0101 04050003 818100CB 2CE17753
  8E8A58D7 A2DE7325 C974E39F EE865AAC D4FFF398 1BA6CEC4 A0C2DD4F 4CBB08F9
  B745D499 D72CFC8F 200E32C1 206615A6 5081627C 4E6E7BCD 9977CE2B CB42BE50
  62717F89 B2C19CEF 8CBC735C 752ED3DD 93F11A23 E479A921 73F8DD5A B8F6E246
  3710CBA8 11A498A0 2213C7B5 C448E2D6 C460F189 05A6F1C2 5AB710
   quit
!
!
license udi pid CISCO2801 sn FTX132480XT
archive
log config
  hidekeys
username administrator privilege 15 secret 5 $1$L7z0$/kv/jpmZZccEhRWN1.iFK0
!
redundancy
!
!
controller T1 0/1/0
cablelength long 0db
pri-group timeslots 1-24 service mgcp
!
ip ssh version 2
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 172.19.1.2 255.255.255.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr 172.19.1.2
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface Serial0/1/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
!
router eigrp 100
network 10.0.0.0
network 172.19.0.0
auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 172.19.2.0 255.255.255.0 172.19.1.3
!
logging esm config
!
!
!
!
!
!
control-plane
!
disable-eadi
!
voice-port 0/1/0:23
!
!
dial-peer voice 1 pots
incoming called-number .
direct-inward-dial
!
dial-peer voice 2 voip
incoming called-number .
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 3 voip
session protocol sipv2
incoming called-number .
codec g711ulaw
no vad
!
dial-peer voice 1001 voip
destination-pattern 2025225...
session target ipv4:172.19.1.10
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 1002 voip
destination-pattern 2025226...
session target ipv4:172.19.2.10
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 1003 voip
destination-pattern 2025227...
session target ipv4:172.19.3.10
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
!
!
!
call-manager-fallback
secondary-dialtone 9
max-conferences 1 gain -6
transfer-system full-consult
timeouts interdigit 3
ip source-address 172.19.1.2 port 2000
max-ephones 10
max-dn 10
system message primary SRST Mode
dialplan-pattern 1 2023345... extension-length 4
transfer-pattern .T
no huntstop
alias 1 5... to 5001
call-forward pattern .T
moh music-on-hold.au
time-zone 12
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
login local
line aux 0
line vty 0 4
exec-timeout 0 0
privilege level 15
password sanjose
logging synchronous
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input ssh
!
scheduler allocate 20000 1000
ntp master 5
end

Gateway #2 (CME)

version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname voicegw-03
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$yeN8$qlKRoeq1wFfekyFBQY4c8/
!
no aaa new-model
no network-clock-participate slot 1
!
voice-card 0
dspfarm
dsp services dspfarm
!
voice-card 1
dspfarm
!
dot11 syslog
ip source-route
!
!
ip cef
ip dhcp excluded-address 172.19.3.3
ip dhcp excluded-address 172.19.3.10
!
!
!
no ip domain lookup
ip domain name cncnw.com
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-ni
!
!
!
voice service voip
no ip address trusted authenticate
allow-connections h323 to h323
!
!
!
!
voice translation-rule 1
rule 1 /^[012345789]\(.*\)/ /6010/
!
!
voice translation-profile 1
translate called 1
!
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn FTX1140A43L
username administrator privilege 15 password 7 15200E0A162B267579
!
!
controller T1 1/0/0
pri-group timeslots 1-24
!
controller T1 1/0/1
!
ip ssh version 2
!
!
!
!
!
interface FastEthernet0/0
ip address 172.19.3.10 255.255.255.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr 172.19.3.10
!
interface FastEthernet0/1
ip address 192.168.1.3 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/2/0
no ip address
shutdown
clock rate 2000000
!
interface Serial1/0/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable
!
!
router eigrp 100
network 172.19.0.0
network 192.168.1.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 172.19.3.3
!
logging esm config
!
!
tftp-server flash:apps42.8-5-4TH1-6.sbn
tftp-server flash:cnu42.8-5-4TH1-6.sbn
tftp-server flash:dsp42.8-5-4TH1-6.sbn
tftp-server flash:jar42sccp.8-5-4TH1-6.sbn
tftp-server flash:cvm42sccp.8-5-4TH1-6.sbn
tftp-server flash:term42.default.loads
tftp-server flash:term62.default.loads
tftp-server flash:SCCP42.8-5-4S.loads
!
control-plane
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/3/0
!
voice-port 0/3/1
!
voice-port 1/0/0:23
translation-profile incoming 1
!
!
!
mgcp profile default
!
!
dial-peer voice 1 pots
incoming called-number .
direct-inward-dial
!
dial-peer voice 2 voip
incoming called-number .
dtmf-relay h245-signal h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 1001 voip
destination-pattern 2025225...
session target ipv4:172.19.1.10
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 1002 voip
destination-pattern 2025226...
session target ipv4:172.19.2.10
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
!
!
telephony-service
no auto-reg-ephone
authentication credential administrator cisco
max-ephones 25
max-dn 100
ip source-address 172.19.3.10 port 2000
timeouts interdigit 6
system message User Options
load 7941 SCCP41.9-1-1SR1S
load 7942 SCCP42.8-5-4S
time-zone 12
max-conferences 8 gain -6
call-forward pattern .T
web admin system name administrator password cisco
transfer-system full-consult
transfer-pattern .T
secondary-dialtone 9
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-template  1
softkeys idle  Newcall Cfwdall Redial
softkeys seized  Endcall Cfwdall Redial
softkeys alerting  Endcall
softkeys connected  Endcall Hold Park Trnsfer Confrn
!
!
ephone-dn  1
number 2025227010
label Jimi Hendrix - 2025227010
name Jimi Hendrix
!
!
ephone-dn  2
number 2025227011
label Janis Joplin - 2025227011
name Janis Joplin
!
!
ephone  1
mac-address 0021.5504.464E
type 7941
button  1:1 2m2
!
!
!
ephone  2
mac-address 0026.0BD7.DD3C
type 7942
button  1:2
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
login local
line aux 0
line vty 0 4
exec-timeout 0 0
logging synchronous
login local
transport input all
!
scheduler allocate 20000 1000
end

Gold

Re: CUCM to CME

Also, remember that IOS 15.x introduced toll fraud prevention for H.323 which might explain your fast busy CUCM -> CME.

When booting a version of IOS with the toll-fraud prevention application, this is printed to the device’s console during the boot sequence:

Following voice command is enabled:                     
   voice service voip                                    
    ip address trusted authenticate                      
                                                         
 The command enables the ip address authentication       
 on incoming H.323 or SIP trunk calls for toll fraud     
 prevention supports.                                    
                                                         
 Please use "show ip address trusted list" command       
 to display a list of valid ip addresses for incoming    
 H.323 or SIP trunk calls.                               
                                                         
 Additional valid ip addresses can be added via the      
 following command line:                                 
   voice service voip                                    
    ip address trusted list                              
     ipv4  [] 

You can disable this for testing purposes:

voice service voip

no ip address trusted authenticate

HTH. Barry

P.S For one way audio issues, I'd be checking the state of the RTP sessions on the gateways and also wireshark tracing as and when required. If you are brave you can look at the "monitor capture" command on the CME, which is useful if port mirroring is not practical.

Community Member

Re: CUCM to CME

I actually did forget the toll bypass prevention, which is insane because I said something to a collague about it just this morning.  However, now that it has been configured, there's no difference.

Re: CUCM to CME

Barry +5 I had an issue with ios 15.x which might now be resolved.

HTH Regards, Yosh
Green

Re: CUCM to CME

Hi, REFRAM

Firstly sorry for the delay.

Looking at the configs you supplied.

What devices are 172.19.1.10 & 172.19.2.10 --- I think they may be CUCMs

On the CUCM gateway config page what is the IP address you are using ?

Regards

Alex

Regards, Alex. Please rate useful posts.
Community Member

Re: CUCM to CME

172.19.1.10 is the CUCM.

172.19.1.2 is the gateway that's attached to the CUCM (it's the IP that I use in the Gateway config. on CUCM also)

172.19.2.10 is an additional CME router that isn't really part of this particular scenario.  I had the dial-peer in there as another test to make sure that calls could go from CME to CME. 

Green

Re: CUCM to CME

Hi,

Can you change the CME dial peer 1001


!
dial-peer voice 1001 voip
desc *** TO CUCM VIA V-GATEWAY ***
destination-pattern 2025225...
session target ipv4:172.19.1.2
incoming called-number .
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!

On the CUCM-V/GATEWAY

Add/Change

!
dial-peer voice 2 voip
desc *** MATCH INCOMING ***
incoming called-number .
dtmf-relay h245-signal h245-alphanumeric
codec g711ulaw
no vad
!
!
dial-peer voice 1001 voip
desc *** TO CUCM ***
destination-pattern 2025225...
session target ipv4:172.19.1.10
incoming called-number .
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
!
dial-peer voice 1003 voip
desc *** TO CME ***
destination-pattern 2025227...
session target ipv4:172.19.3.10
incoming called-number .
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!

Regards
Alex

Regards, Alex. Please rate useful posts.
Community Member

CUCM to CME

I am curious if you have a fix yet, I am experiencing the same issue.  Initially I received a fast busy CUCM ->CME but it was a codec mismatch.  Now I get a RNA dialing CUCM -> CME.  Dialing CME->  CUCM I get one way audio and can hear on the CME side but not on the CUCM phone.  I too am using softphone on the CME side to test. Liz

1294
Views
5
Helpful
13
Replies
CreatePlease to create content