Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CUCM10 CSS import fails

Hi!

I'm in migration from CUCM 7.x to 10.x. As CUCM 7.x is on HW platform and CUCM 10.x is virtualized, I have done jump upgrade; installed clear CUCM 7.x in vmware, restored backup from HW CUCM 7.x to it...and than upgraded to 10.x

Now, i am trying to migrate configuration from this jump upgraded CUCM 10.x to clean installed CUCM 10. However, when I perform export/import configuration via bulk administration from jump upgraded CUCM 10 to clean installed CUCM 10...I have problems with importing CSS (and some other components). Partitions are imported OK.

For every CSS that I have, in log file there is this message:

"Cannot insert a null into column (callingsearchspacemember.fkroutepartition)."

 

What is going on?? I cannot see anything wrong in csv file for CSS...

Everyone's tags (1)
11 REPLIES
New Member

Actualy, if I do export CSSs

Actualy, if I do export CSSs on freshly installed CUCM10 and than delete CSSs...and than import previously exported file back to same CUCM...it again fails with same error.

 

Strange...looks like there is some bug in CUCM10 export/import?

Bronze

Same issue with me! How

Same issue with me! How unbelievably frustrating. 

Avoiding entering these manually saves HOURS and minimizes typo errors win CSS configurations and we know how important the order of PTns is for goodness sake.

I have tried all kinds of workarounds, filling in blank PTn's in the import .csv and nothing works. It HAS to be a bug!?!?!

Anyone with a workaround?

Bronze

https://communities.cisco.com

https://communities.cisco.com/docs/DOC-43414

Found this, it's probably a scripting bug in CUCM10.x?

New Member

I had this problem too but

I had this problem too but found a decent workaround.  I created a bunch of bogus partitions just named 1, 2, 3, 4, 5, etc to the quantity needed to fill my smallest CSS to match the largest.  then i just added them as filler to each CSS so they all had the same number of partitions and did one import.  After I was able to just select all the numeric partitions in the Partition search list and delete them which removed them from the CSS's as well.

Bronze

Thanks.I did try that method

Thanks.

I did try that method actually and it burped with some obtuse error. I think I had the logic right, but perhaps just didn't build the css.csv properly.

Anyway, my workaround was to do about 6 imports in the end of the css.csv file.

I just created multiple versions of the css.csv each with the same number of ROUTE PARTITIONS and then just deleted any remaining 'null' ROUTE PARTION columns.

Took about 1-2 hours, but got the job done and better then typing the CSSs all in again!

Just when Cisco are really starting to get the hang of things, and they throw this wee hurdle to upset one's carefully and well honed implementation processes. QA process slipping as usual, biz unit needed to get the product to market probably and ultimately this is some of the price that is paid.

Not sure which documentation

Not sure which documentation you are following but for jump upgrades, you necessarily dont have to export/import configurations using CSV. Once you install version 7 in the lab on a virtual server, you can do an in-place upgrade all the way to version 10. Once thats complete, takes a DRS backup and restore it into production. Here is a high-level preso: http://www.cisco.com/web/learning/le21/le39/docs/tdw_207_preso.pdf

You could also use PCD to do this kind of migration if you are going to version 10. http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/ucmap/10_0_1/CUCM_BK_U9C58CB1_00_ucmap-administration-guide/CUCM_BK_U9C58CB1_00_ucmap-administration-guide_chapter_011.html

Please rate useful posts.
New Member

Hi George, yes I know what

Hi George,

 

yes I know what procedure for jump upgrade is, but I have other reasons for not to do backup/restore. Current version 7 is also upgraded from 4 so I want to clear some dormant configuration and there is also change in other settings like IP adresss, domain name...etc.

Regardless to reason why I want to do export/import CSS and other configuration, this obviously does not work as it shuold. Like I said, if I manually create CSS on CUCM10 and than export that CSS in export file....delete CSS on CUCM10 and than try to import same file where that deleted CSS is...import fails. So, this looks like problem with export/import component in CUCM.

What is the point of exporting configuration if you cannot import it back?

Does anyone knows...is this a known bug or new one?

New Member

I had the same problem.It

I had the same problem.

It seems to be an issue when importing CSS's with different numbers of partions assigned to them.  I was able to import CSS's into our 10.0.1 release by importing all CSS with 22 partions, then importing the CSS's with 21 partions and so on.

 

It was a huge pain, and I think there must be some kind of bug in there.

New Member

Hi,I did a fresh install of

Hi,

I did a fresh install of CUCM 10.5.1.10000-7

I have the same problem while importing (I was doing it a lot with 8.6).  Here is my css.csv file

NAME,DESCRIPTION,TYPE OF PARTITION USAGE,ROUTE PARTITION 1,ROUTE PARTITION 2,ROUTE PARTITION 3
CSS1,Description1,General,PT1,PT2,PT3
CSS2,Description2,General,PT1,PT2,
CSS3,Description2,General,PT3,,

Usually, a css file contain all commas for each column.

So, I tried the following without success:

NAME,DESCRIPTION,TYPE OF PARTITION USAGE,ROUTE PARTITION 1,ROUTE PARTITION 2,ROUTE PARTITION 3
CSS1,Description1,General,PT1,PT2,PT3
CSS2,Description2,General,PT1,PT2,""
CSS3,Description2,General,PT3,"",""

But, importing the following was working (without any trailing comma):

NAME,DESCRIPTION,TYPE OF PARTITION USAGE,ROUTE PARTITION 1,ROUTE PARTITION 2,ROUTE PARTITION 3
CSS1,Description1,General,PT1,PT2,PT3
CSS2,Description2,General,PT1,PT2
CSS3,Description2,General,PT3

 

I don't know if it's the right behavior, but it changed since 8.6

Even the export with 10.5 is including the commas.

New Member

I can confirm this works.  I

I can confirm this works.  I guess it is better than rebuilding 240 Calling Search Spaces...

New Member

Hi, Same problem with this

Hi, Same problem with this

Open the .csv with notepad and delete all the trailing commas,

565
Views
10
Helpful
11
Replies