Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CUCM6.1 - dbreplication errors

Hello,

Facts:

Cluster with Publisher and 1 Subscriber all with CUCM Version: 6.1.4.2000-2

Because of an inconsistencies in the file system I had to reinstall the publisher.

After that I restored the Backup.

The System is up and running.

But now I have problems with the dbreplication:

I get the error in CiscoSyslog:   

: 11011: Sep 20 08:18:58.741 UTC : %CCM_DB_LAYER-DB-3-IDSReplicationFailure: Combined alarm for emergency and error situations. IDS Replication has failed Event Class ID:Realtime Replication is broken Event class message:replstate = 3 Event Specific Message:Please run utils dbreplication status from publisher Cluster ID:StandAloneCluster Node ID:CUCM6-P

I checked the dbreplication status:

admin:file view activelog cm/trace/dbl/sdi/ReplicationStatus.2010_09_20_09_04_32.out

SERVER                 ID STATE    STATUS     QUEUE  CONNECTION CHANGED
-----------------------------------------------------------------------
g_cucm6_p_ccm6_1_4_2000_2    2 Active   Local           0

-------------------------------------------------



utils dbreplication status output

To determine if replication is suspect, look for the following:
        (1) Number of rows in a table do not match on all nodes.
        (2) Non-zero values occur in any of the other output columns for a table
        (3) ***** PLEASE IGNORE MISMATCHES IN ReplicationDynamic TABLE *****

Processing ccmdbtemplate_cucm6_p_ccm6_1_4_2000_2_1_86_typedberrors with 803 rows group 1
Error returned 99 at 1342
Error returned 99 at 823
command failed -- *Error* <99> is not a known Enterprise Replication error (99)

// How can I have a look to these errors or resolve them?

admin:show perf query class "Number of Replicates Created and State of Replication"
==>query class :

- Perf class (Number of Replicates Created and State of Replication) has instances and values:


    ReplicateCount  -> Number of Replicates Created   = 393
    ReplicateCount  -> Replicate_State                = 3

Here is the Unified CM Database Status Report with errors (also as attachment)

cucm61_report.gif

How can I fix/sync these files?

I did all the stuff which I could find in the world wide web.

The only thing which I haven't done is

utils dbreplication forcedatasyncsub

Have somebody tried out this command before?

Is the Publisher working fine in that time of sync process?

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: CUCM6.1 - dbreplication errors

Hi Marcus,

Please reboot the publisher first and then subscriber in down time, and then provide us fressh snap shots of the unified reporting.

Regards

Kunal

7 REPLIES
Silver

Re: CUCM6.1 - dbreplication errors

hello,

Try the following in the exact same sequence below:

>>utils dbreplication stop on the subscriber



>> once it is stopped on the subscriber then utils dbreplication stop
on the publisher



>> wait for a few minutes for it to finish



>> utils dbreplication dropadmindb on the publisher



>> wait for it to finish



>> utils dbreplication dropadmindb on the subscriber



>> wait for a few minutes for it to finish



>>utils dbreplication reset all on the publisher


Give it some time and then run the following:

show perf query class "Number of Replicates Created and State of Replication"

on both the servers to see if the replication status moves to 2 on both the servers.

HTH

kunal

Silver

Re: CUCM6.1 - dbreplication errors

Just had a look at the screen shot provided, the rhost and the sql hosts files on the servers dont match, might need root access to edit the files.

Please open a TAC case so we can fix this.

HTH

kunal

New Member

Re: CUCM6.1 - dbreplication errors

Thank you for your answers.

How does it happen that the rhost and the sql hosts files on the servers dont match?

Which of these Server Publisher/Subscriber have the right files?


Have I configured something (when yes - what?) wrong through the reinstallation process?

I have finished all thinks before I had reconneted the Publisher to the network...

My problem is that I have no contract for this cluster so I can't open a TAC case

Silver

Re: CUCM6.1 - dbreplication errors

Hi Marcus,

192.168.0.2 ------> rhosts file does not contain the entry of CUCM6-S


Confirm the IP address/Hostname of both the servers.

He the files got messed up, there could be many reasons.

With out having root access, and editing the files, i do see the replication coming up.

Has a reboot of the publisher and then subscriber been tried?

Regards

Kunal

New Member

Re: CUCM6.1 - dbreplication errors

Since I have reconnected the Publisher to the network, I never have rebooted it.

The Subscriber I have rebooted after that.

Ok I will try the reboot from the Publihser and after the Subscriber.

But I can only do this during a slack period. :-/

But it is weird that Unified CM Cluster Overview is fine and the others not...

Silver

Re: CUCM6.1 - dbreplication errors

Hi Marcus,

Please reboot the publisher first and then subscriber in down time, and then provide us fressh snap shots of the unified reporting.

Regards

Kunal

New Member

Re: CUCM6.1 - dbreplication errors

Hi Kunal,

I have rebooted the cluster.

After that I followed "Database Replication Error in Cisco Unified Communication Manager 6.1.pdf"


and now it is working fine :-)

Thank You very much for your help!

2008
Views
0
Helpful
7
Replies
CreatePlease login to create content