Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

CUCMv7 upgrade CUCMv8

Hi ,

I am doing a upgrade from CUCMv7 to CUCM8. I have restored the configuration version 7 through DRS, and was sucessfull.

So, I installed the upgrade file in the server to install the CUCMv8, and was installed. Now I have in the CUCMv7 in the active partition and CUCMv8 in the inactive partition, but when I select Switch Version, and I have this message:

"error: Switch version disallowed during Licensing Grace Period Failed to Switch Version and Restart the Appliance"

What should I do?

What is the meaning of this message?

Everyone's tags (3)
6 REPLIES
Hall of Fame Super Red

CUCMv7 upgrade CUCMv8

Hi Matthew,

It looks like this bug;

CSCtb86875 - Upgrades are prohibited during License Grace Period

Description

Symptom:

After Disaster Recovery System (DRS) backup is done on the old server, we DRS restore all the data into the newly replaced server. The license file for old server is valid for 30 days.

During license grace period, you can not proceed due to the upgrade error message "Upgradeds are prohibited during License Grace Period".

Conditions:

It only occurs after DRS backup and restore data to newly replaced servers.

One example of an erroneous document:

http://www.cisco.com/en/US/partner/docs/voice_ip_comm/cucm/install/7_1_2/cluster/clstr712.html#wp87717

The problem is steps 7-9.  The order should be:

7. install the same version

8. restore the DRS backup

9. upload the new license file

Workaround:

If license is uploaded before DRS restore then use the following steps to correct the state of licensing on the system:

1. Remove the rehosted (new) license files using cli commond "file delete xxx.lic"

2. Restart license manager.

3. Re-upload the rehosted (new) license files.

Details

1st Found-in:                          (1)

7.1(3.10000.3)

Status:

Fixed

Last Modified:

Mar 29,2012

Fixed-in:                          (1)

Release Pending

Product:

Cisco Unified Communications Manager (CallManager)

Platform:

Dependent

Severity:

3 - moderate

Customer Reported:                          (169)

Cheers!

Rob

New Member

CUCMv7 upgrade CUCMv8

Hi Rob,

I have the similar scenario, I installed CUCM 7.1.5.30000-1 UNRST on new hardware and restored the backup, after restore I inserted the rehost licenses.

Now when I try to start the upgrade "Upgrade Install" returns (Upgrades are Prohibited During Licensing Grace Period).

I need to do the same workaround?

Thanks.

Joao.

New Member

CUCMv7 upgrade CUCMv8

Hello,

Also this happened to me and I had to open a case so a TAC guy connected to my CUCM using root access and deleted a file in the licensing folder and then it started working properly.

Bye

New Member

Re: CUCMv7 upgrade CUCMv8

Hi Cecilia,

Thanks for information, I open the tac and solve the problem.

Bye.

CUCMv7 upgrade CUCMv8

Do you remember how TAC solved this problem? I got the same issue, and this was my process. I'm upgrading from 7.1.5.10000-12 on MCS to 8.6 on UCS.

1. DRS backup production 7.1.5.10000-12 on MCS

2. Install 7.1.5.10000-12 on a VM. Yes, I get that it's not supported, but it should still work. I've done numerous upgrade from 4.x to 7.x on a VM to 8.x, and it always worked.

3. DRS restore

4. Now trying to upgrade to 8.6 and getting this error "Upgrades are prohibited during Licensing Grace Period"

It's gotta to be some simple trick with license files that could fix this. I tried installing rehosted NODE/PHONE license to the license mac, that didn't help. I tried removing all licenses, that also didn't help.

Do you remember what was the trick?

New Member

Re: CUCMv7 upgrade CUCMv8

Hi Roman,

I did have the same problem, for solve the problem was necessary removed all old license files in database informix the CUCM. I opened the case in TAC because is necessary root account to delete files in database.

Regards.

João Rosa

1316
Views
0
Helpful
6
Replies
CreatePlease to create content