Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

CUE giving a fast busy

I am facing a weird issue and wondering if someone have seen this before...

Plateforme is 2801 with CME 8.6, IOS 15.1 and CUE 7.4. I believe the version of CUE is compatible and should work with CME 8.6.

What's happening is I get an immediate fast busy when hitting the VM button on a phone.

The dial-peer is below for the VM pilot number:

dial-peer voice 7000 voip
 destination-pattern 7000
 session protocol sipv2
 session target ipv4:10.1.150.2
 dtmf-relay sip-notify
 codec g711ulaw
!

Debug voip ccapi inout shows disconnection error code 38 - Network out of order

Not output from debug ccsip messages

Debug ccsip all shows CME creating a sip connection to the CUE module but it immediatly fails:


*Aug 17 15:07:40.983 CST: //6/FA0D0B74800E/SIP/State/sipSPIChangeState: 0x6A5BAEC0 : State change from (STATE_DISCONNECTING, SUBSTATE_NONE)  to (STATE_DEAD, SUBSTATE_NONE)
*Aug 17 15:07:40.983 CST: //6/FA0D0B74800E/SIP/Call/sipSPICallInfo: 
The Call Setup Information is:
Call Control Block (CCB) : 0x6A5BAEC0
State of The Call        : STATE_DEAD
TCP Sockets Used         : YES
Calling Number           : 4444
Called Number            : 7000
Source IP Address (Sig  ): 3.3.3.3
Destn SIP Req Addr:Port  : 10.1.150.2:5060
Destn SIP Resp Addr:Port : 10.1.150.2:5060
Destination Name         : 10.1.150.2

 

Tthe CUE module is up, licenses are installed and doesn't show any errors. Except dealing with a defective CUE module not sure why it is not accepting incoming SIP connections.

I would appreciate any inputs.

 

 

        

10 REPLIES
Super Bronze

Can you post up your configs?

Can you post up your configs?

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

CME and CUE configs attached.

CME and CUE configs attached.

Hello Amine Can you do a

Hello Amine 

Can you do a reload for CUE module ?.Also share the output of "debusg ccsip messages" .

 

Thanks

please rate all useful information

I reloaded the CUE multiple

I reloaded the CUE multiple times. No output when doing debusg ccsip messages.

I removed dial-peer 102 but no change. Debug voip dialpeer inout shows 7000 being matched.

Also no change after setting 

ccn subsystem sip

 default gateway address

 default gateway port

All I can see is CUE not accepting a SIP connection and CCAPI inout debug shows Disconnection code 38 - Network out of order.

 

Amine1- The problem happen

Amine

1- The problem happen internal when users press VM . Can you try to also dial from the phone VM.

2-Can u do upgrade for your CUE ?. Maybe this will solve your issue . I think no issues on your configuration.

 

Thanks

Please rate all useful information

I finally found what was

I finally found what was causing this issue. My config had this:

sip
  bind control source-interface Loopback0
  bind media source-interface Loopback0
  session transport tcp <<<<<<<<<<<<<

Looks like CUE doesn't like TCP as a transport protocol for SIP or the default is UDP. As soon as I removed the command from the config, CUE started accepting calls. Another workaround would be to set the transport protocol for SIP to UDP at the Dial-peer.

Glad I can put this to bed now!

Super Bronze

Hi

Hi

Try removing this peer, or setting preference to 9 temporarily.

dial-peer voice 102 voip
 destination-pattern 1...
 session target ras

Default preference is 0 so this is probably taking the call rather than your peer 7000.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

Can you ping the CUE module

Can you ping the CUE module sourcing from Loopback0?

 

ping 10.1.150.2 source loop0

Yep, connectivity works.#ping

Yep, connectivity works.

#ping 10.1.150.2 source loop0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.150.2, timeout is 2 seconds:
Packet sent with a source address of 3.3.3.3 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 

I was also able to run the initialization Wizard successfully so I know CUE can talk to CME. 

Might be worth reloading the

Might be worth reloading the module.

 

You can also try setting the sip subsystem to default config:

ccn subsystem sip

 default gateway address

 default gateway port

366
Views
5
Helpful
10
Replies