Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

CUE will not sync time with CME

I currently have a UC520 system that CUE time is incorrect on by 5 hours. I have set the time with both Configuration Assistant (the most current version) and from the command line. Last night I also attempted to set the ntp server while logged into CUE and get messages that follows:

UC500-CUE(config)> ntp server 192.168.10.1

WARNING!!! Could not reach 192.168.10.1 using NTP.

WARNING!!! 192.168.10.1 might not have been configured as

WARNING!!! NTP server.

WARNING!!! NTP Server 192.168.10.1 Will be entered in the NTP List

IP address: 192.168.10.1 is the CME side of the UC520

UC500-CUE> conf t

Enter configuration commands, one per line.  End with CNTL/Z.

UC500-CUE(config)> clock timezone

Please identify a location so that time zone rules can be set correctly.

Please select a continent or ocean.

1) Africa            4) Arctic Ocean     7) Australia       10) Pacific Ocean

2) Americas          5) Asia             8) Europe

3) Antarctica        6) Atlantic Ocean   9) Indian Ocean

#? 2

Please select a country.

1) Anguilla                 27) Honduras

2) Antigua & Barbuda        28) Jamaica

3) Argentina                29) Martinique

4) Aruba                    30) Mexico

5) Bahamas                  31) Montserrat

6) Barbados                 32) Netherlands Antilles

7) Belize                   33) Nicaragua

8) Bolivia                  34) Panama

9) Brazil                   35) Paraguay

10) Canada                   36) Peru

11) Cayman Islands           37) Puerto Rico

12) Chile                    38) St Barthelemy

13) Colombia                 39) St Kitts & Nevis

14) Costa Rica               40) St Lucia

15) Cuba                     41) St Martin (French part)

16) Dominica                 42) St Pierre & Miquelon

17) Dominican Republic       43) St Vincent

18) Ecuador                  44) Suriname

19) El Salvador              45) Trinidad & Tobago

20) French Guiana            46) Turks & Caicos Is

21) Greenland                47) United States

22) Grenada                  48) Uruguay

23) Guadeloupe               49) Venezuela

24) Guatemala                50) Virgin Islands (UK)

25) Guyana                   51) Virgin Islands (US)

26) Haiti

#? 47

Please select one of the following time zone regions.

1) Eastern Time

2) Eastern Time - Michigan - most locations

3) Eastern Time - Kentucky - Louisville area

4) Eastern Time - Kentucky - Wayne County

5) Eastern Time - Indiana - most locations

6) Eastern Time - Indiana - Daviess, Dubois, Knox & Martin Counties

7) Eastern Time - Indiana - Starke County

8) Eastern Time - Indiana - Pulaski County

9) Eastern Time - Indiana - Crawford County

10) Eastern Time - Indiana - Switzerland County

11) Central Time

12) Central Time - Indiana - Perry County

13) Eastern Time - Indiana - Pike County

14) Central Time - Michigan - Dickinson, Gogebic, Iron & Menominee Counties

15) Central Time - North Dakota - Oliver County

16) Central Time - North Dakota - Morton County (except Mandan area)

17) Mountain Time

18) Mountain Time - south Idaho & east Oregon

19) Mountain Time - Navajo

20) Mountain Standard Time - Arizona

21) Pacific Time

22) Alaska Time

23) Alaska Time - Alaska panhandle

24) Alaska Time - Alaska panhandle neck

25) Alaska Time - west Alaska

26) Aleutian Islands

27) Hawaii

#? 21

The following information has been given:

        United States

        Pacific Time

Therefore TZ='America/Los_Angeles' will be used.

Is the above information OK?

1) Yes

2) No

#? 1

Local time is now:      Fri Nov 20 03:51:44 PST 2009.

Universal Time is now:  Fri Nov 20 11:51:44 UTC 2009.

Save the change to startup configuration and reload the module for the new timez

one to take effect.

UC500-CUE(config)>

I have rebooted the system and the time is still off. Additionally I was not able to find any other way in documentation to set the time manually in CUE. I don't really know where to go from here. Any help or advise, Thank you,

Jon Blomquist

17 REPLIES

Re: CUE will not sync time with CME

Here are a couple of items to check.

1. Can you ping 192.168.10.1 from the CUE module?

2. Check your timezone in CUE

3. Check for the "ntp master" command in CME

4. There is a bug relating to this issue - CSCsu36827. Check the link below to see if this applies.

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCsu36827

Hope this helps.

Brandon

New Member

Re: CUE will not sync time with CME

Brandon,

Thank you for your quick reply.

Yes you can ping from CUE.

In my first post that was me setting the Timezone on CUE to Pacific which was also done last night without results.

On CME I set it to have an NTP server prefer and then the NTP master was also set. I then set CUE to use CME as the NTP server and got the error at the beginning of my first post. I left it over night and time is still incorrect.

I will check the Bug you linked and get back to you as soon as possible.

Thanks again,

Jon

New Member

Re: CUE will not sync time with CME

Ok, further update, I have read the Bug link and attempted to ping an external ntp server, however from CUE I am only able to ping the CME and no other IP addresses. I think this is the problem. When pinging the Domain controller local (192.168.10.5) I get Destination unreachable reported by 10.1.10.2 the CUE. I also get the same response when pinging the IP address for north-america.pool.ntp.org 1 A 209.167.68.100. Any ideas of how to resolve.

Thanks again.

Jon

Re: CUE will not sync time with CME

Does your CUE module interface have a default gateway. Sounds like a routing problem.

Brandon

Hall of Fame Super Blue

Re: CUE will not sync time with CME

Jon

Apologies for using this thread to pass a message to Brandon but the new site is proving slightly problematic.


Brandon

Don't know whether you got my response from invite a friend. Collin Clark also invited me but the e-mails are not working properly so whenever you or Collin try to e-mail me apparently it just goes back to Dan using the supportforums-info@cisco.com.

Just didn't want you to think i was ignoring you in case you didn't get response.

Jon

Re: CUE will not sync time with CME

Jon,

     I received a couple of messages from you yesterday. One appeared as if it was meant for Collin. I don't think you can reply directly to an email message. I think you have to go back to the site and email from there. However, I haven't seen a way to email you. Could be because your email address is hidden and mine is not?

Brandon

New Member

Re: CUE will not sync time with CME

Brandon,

I am a newer user to CUE can you give me instructions for checking the default gateway for CUE? I too think the issue is routing related.

Jon

Re: CUE will not sync time with CME

In the CME config, you should see something similar to:

interface Service-Engine0/0
ip unnumbered GigabitEthernet0/0
ip nat inside
ip virtual-reassembly
service-module ip address 1.1.1.2 255.255.255.0
service-module ip default-gateway 1.1.1.1

Brandon

New Member

Re: CUE will not sync time with CME

Brandon,

This is from the configuration:

interface Loopback0

ip address 10.1.10.2 255.255.255.252

ip virtual-reassembly

!

interface FastEthernet0/0

ip address dhcp client-id FastEthernet0/0

ip virtual-reassembly

duplex auto

speed auto

!

interface Integrated-Service-Engine0/0

description cue is initialized with default IMAP group

ip unnumbered Loopback0

ip virtual-reassembly

service-module ip address 10.1.10.1 255.255.255.252

service-module ip default-gateway 10.1.10.2

Re: CUE will not sync time with CME

Is CUE pointing to 10.1.10.2 for NTP? Is this router NATing traffic out to the internet? If so, and you want CUE to point to an external NTP server, I believe you will need "ip nat inside" on the service engine interface.

Brandon

New Member

Re: CUE will not sync time with CME

Brandon,

CUE is not pointing to 10.1.10.2 for NTP and when I set NTP to it I also get the error message saying NTP server could not be contacted. I set ip nat inside on the interface as suggested and this also has not resolved the problem. This router is not routing traffic to the internet there is a PIX locally on the same subnet as the router. It's IP address is 192.168.10.2

I do not have access to any other UC520 systems to compare configuration too. Any other help or ideas for me to check out would great.

Thank you again for you help so far.

Jon

Re: CUE will not sync time with CME

OK. If there is another device connecting to the internet and doing NAT, you will not need the nat statement on the CUE interface. Is the PIX setup to NAT addresses in the 10.1.10.0 subnet to the internet? Is the CME getting NTP (show ntp status)?

Brandon

New Member

Re: CUE will not sync time with CME

Brandon,

I don't believe the PIX is setup to nat the 10.1.10.0 address space.

Here is the output from CME ntp status:

ColRheumUC520#sh ntp status

Clock is unsynchronized, stratum 16, no reference clock

nominal freq is 250.0000 Hz, actual freq is 250.0000 Hz, precision is 2**32

reference time is CEB17784.2B1E292A (12:16:04.168 PST Fri Nov 20 2009)

clock offset is 0.0000 msec, root delay is 0.00 msec

root dispersion is 5.13 msec, peer dispersion is 0.00 msec

loopfilter state is 'CTRL' (Normal Controlled Loop), drift is 0.000000000 s/s

system poll interval is 64, last update was 342049 sec ago.

Does not seem to be sync'd. However my question is shouldn't CUE time itself from the CME? Time is correct on CME though manually set at this time.

Thanks again

Jon

Anonymous
N/A

Re: CUE will not sync time with CME

Jon,

Can you ping 66.96.30.35 from CME?  Can you re-post the current "sh ntp status" from CUE?

- alan

New Member

Re: CUE will not sync time with CME

Alan,

Information requested below:

ColRheumUC520#sh ntp status

Clock is unsynchronized, stratum 16, no reference clock

nominal freq is 250.0000 Hz, actual freq is 250.0000 Hz, precision is 2**32

reference time is CEB17784.2B1E292A (12:16:04.168 PST Fri Nov 20 2009)

clock offset is 0.0000 msec, root delay is 0.00 msec

root dispersion is 5.33 msec, peer dispersion is 0.00 msec

loopfilter state is 'CTRL' (Normal Controlled Loop), drift is 0.000000000 s/s

system poll interval is 64, last update was 355611 sec ago.

ColRheumUC520#sh ntp ?

  associations  NTP associations

  status        NTP status

ColRheumUC520#sh ntp asso

ColRheumUC520#sh ntp associations

  address         ref clock       st   when   poll reach  delay  offset   disp

~192.168.10.2    .INIT.          16      -   1024     0  0.000   0.000 15937.

* sys.peer, # selected, + candidate, - outlyer, x falseticker, ~ configured

ColRheumUC520#

ColRheumUC520#ping 66.96.30.35

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 66.96.30.35, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

ColRheumUC520#se

ColRheumUC520#sess

ColRheumUC520#ser

ColRheumUC520#service-module int

ColRheumUC520#service-module integrated-Service-Engine 0/0 sess

ColRheumUC520#service-module integrated-Service-Engine 0/0 session

Trying 10.1.10.2, 2002 ... Open

Cisco Configuration Assistant. Version: 1.9 (1). Mon Apr 27 13:23:06 PDT 2009

User Access Verification

Username: elevate

Password:

UC500-CUE>

UC500-CUE> sh ntp status

NTP reference server :        10.1.10.1

Status:                       reject

Time difference (secs):       0.0

Time jitter (secs):           4.0

NTP reference server :        192.168.10.1

Status:                       reject

Time difference (secs):       0.0

Time jitter (secs):           4.0

UC500-CUE>

Thank you,

Jon

Anonymous
N/A

Re: CUE will not sync time with CME

Jon,

You have a routing issue from your CME to the Internet and therefore you will not be able to contact outside time source for your CME.  You can set routes on your router/firewall to fix this issue.  As Brandon pointed out, you need to be able to ping 192.168.10.1 from CUE.  Please verify and use the following config in your CME.

ntp master

ntp update-calendar

ntp server 66.96.30.35

as for your CUE config, make sure you have the following in place

no ntp server 10.1.10.1

no ntp server 192.168.10.1

ntp server 192.168.10.1 prefer

After this is in place, restart CUE and your time will sync with the CME time.

New Member

Re: CUE will not sync time with CME

The fix for this is fairly simple:

go here: https://www.myciscocommunity.com/community/smallbizsupport

Look for the link: UC500 Software Download - Cisco Smart Business Communications Systems

https://supportforums.cisco.com/docs/DOC-9829

Accept the agreement, enter your CCO information:

Look for the most current download for your UC500 system and update the system to the most current software load.

Lots of fixes to multiple problems with the UC500 systems are solved by upgrading them.

The most current update changed the older UC500 system way it handles timing itself.

Problem solved:

Good Luck,

Jon Blomquist

jon@elevate.net

4029
Views
0
Helpful
17
Replies
CreatePlease to create content