Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CUPS 7.0 and Exchange 2007

Hi Every one

I've been trying to do an exchange 2007 integration with CUPS 7.X but it was unsucessful

I have followed the book from Micheal H Lou

1) upload the CA certificate to the CUPS server

2) set an email account with Exchange admin view only, this account also has received as enable so it can read all other people calendar

3) add gateway as exchange. The exchange server is reacheable and Certificate is verifed

4)set up the meeting in outlook and set it as busy

5)log into CUPC and they status display as Available.


1) Found error 401 Authentication issues between the CUPS and Exchange

Action: check the login as domain\cupsexch

we even setup the Wedav as this login format to makesure we can login

2) error found 503 Service Available return from the exchange

Open a TAC cas the TAC engineer has been veryhelpful he has spent two days working with me on this. However the issue remains the same

In TOPIC search he has found similar case where they just enable

Webexch and OWA to the login method domain/user and restart IIS to fix it. We have tried this and even set the default local domain on Exchange to be domain.lab and changed the login from the CUPS as a cupsexch however we didnt have any lucks.

I hope someone out there that has done this integration out there can shed some lights on this issue

below are the trace of the Presence server + IIS on the Exchange

Many Thanks for your help,



Re: CUPS 7.0 and Exchange 2007

Could you upload a screenshot of CUPS > Presence > Gateway > Outlook Gateway?




Re: CUPS 7.0 and Exchange 2007

In PE logs, I only saw "503 service unavailable".  I didn't see "401 Unauthorized".

Could you restart PE and re-login to CUPC?  Then get PE (Presence Engine) logs from the time of PE restart to the time CUPC re-login.

"503 service unavailable" usually means WebDAV was disabled.  Have you checked with Microsoft on this?

Also, from the logs, the email was  But you put "aop.local\cupsexch" as the account name.

What's the relationship between and aop.local?



New Member

Re: CUPS 7.0 and Exchange 2007

Hi Michael

Thanks alot for looking into the trace

we have confirmed that Wedav is enable on the customomer Exchange 2007

please see attachment

1) The reason for aop.local is the internal domain name when we tried to point to the exchange as exchange.aop.local we have 401 error

2) while the certificate is certified as hence we have to point to the exchange server as

3) I have asked the customer to create dns for presece (internal people can reach the cups server by either using the name or FQDN)

Thanks again, your book has been great help for me.