Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Data and voice on same interface

Hi there,

My customer doesn't want to use subinterfaces or multiple interfaces (Data and Vice) on the Gateway, he is configuring the subinterfaces on the router.

The remote site ip phones registers correctly. But the SRST test failed.

The config is as follow:

ip dhcp pool DATA_GNG_02

network 10.20.26.192 255.255.255.192

default-router 10.20.26.253

dns-server 10.20.1.17 10.20.1.19

!

ip dhcp pool VOICE_GNG_02

network 10.20.26.128 255.255.255.192

default-router 10.20.26.129

dns-server 10.20.1.17 10.20.1.19

option 150 ip 10.20.149.34

!

interface GigabitEthernet0/0

description Liaison Vers LAN Gounghin

ip address 10.20.26.1 255.255.255.192

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.20.26.1

!

call-manager-fallback

max-conferences 8 gain -6

transfer-system full-consult

ip source-address 10.20.26.1 port 2000

max-ephones 58

max-dn 116

system message primary Systeme de Secours Actif

transfer-pattern ....

no huntstop

date-format dd-mm-yy

!

Can i keep the same interface for data and voice? or should i configure a loopback interface for example?

Regards


11 REPLIES

Data and voice on same interface

Hi Youssef,

I dont see the subinterface configured in this configuration. What IP addresses are the phones getting since the subinterface is missing?

Please rate useful posts.

Please rate useful posts.
New Member

Data and voice on same interface

Sorry i mean that the customer is configuring the subinterfaces on the firewall not on the router

Thanks in advance.

Data and voice on same interface

Can you put your PC in the voice vlan and see if you can ping the address 10.20.26.1. Has this address been added under the SRST Reference/device pool?

Please rate useful posts.

Please rate useful posts.
New Member

Data and voice on same interface

I have done this exact test and i can ping 10.20.26.1 from the voice vlan , the gw and srst reference has this same ip address.

Data and voice on same interface

Is this a ISR G2 router? Has the EULA been accepted?

Please rate useful posts.

Please rate useful posts.
New Member

Data and voice on same interface

This is a Cisco 3925 with IPvoice license, and yes, i have already accepted the EULA.

Thanks George

Data and voice on same interface

The only thing I can think off is the firewall is doing some kind of inspections on TFTP/SCCP (since voice traffic needs to route through the firewall to get to this router) traffic which is causing the issue. I guess you will have to see if someone else has some other ideas.

It would be ideal if you could move the subinterface to this router to rule out that issue.

Please rate useful posts.

Please rate useful posts.
New Member

Data and voice on same interface

Thank you george for your support,

We have disabled the Sccp inspection on the Juniper Firewall because it was causing registration issues. But now the problem with SRST is that the phones (Cisco 7942) registers to the gateway but no ephone dn is assigned to it. When we remove the firewall and use subinterfaces on the gw all works fine.

Data and voice on same interface

That to me sounds like the firewall is doing something. I would turn off TFTP inspection as well and see if that makes a difference.

Please rate useful posts.

Please rate useful posts.
New Member

Data and voice on same interface

I am pretty sure that the security guy has already disabled the tftp inspection, now back to the main question : Can i use the same GigabitEthernet0/0 for data and voice?

Data and voice on same interface

Yes, you can keep same interface for data and voice. Best practice is loopback but that varies depending on environments.

Please rate useful posts.

Please rate useful posts.
178
Views
0
Helpful
11
Replies
CreatePlease to create content