Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Deleted phones are registering

We are trying to configure phones that were deleted from Call Manager, but they keep registering with their old extensions.  We are running 7.1.3.30000-1.  I have restarted both Call Managers in the cluster, but this did not resolve the issue.

I also ran the following command via ssh: run sql select * from device and was able to locate the device in the database.  However, it is now showing up when I do a search for phones.

Any ideas?

Everyone's tags (1)
19 REPLIES

Re: Deleted phones are registering

Have you checked your db replication status lately to make sure there's nothing wonky going on there?

New Member

Re: Deleted phones are registering

How would I check that?

Re: Deleted phones are registering

RTMT (CallManager->Database Summary), the CLI (utils dbreplication status), or the GUI (Unified Reporting->Unified CM Database Status).  Take your pick!

Any dbreplication status other than '2' is bad...

New Member

Re: Deleted phones are registering

Here are the results:

SERVER                 ID STATE    STATUS     QUEUE  CONNECTION CHANGED
-----------------------------------------------------------------------
g_pgpublisher_ccm7_1_3_30000_1    2 Active   Connected     140 Aug 17 22:25:09
g_pgsubscriber_ccm7_1_3_30000_1    4 Active   Local           0             

SERVER                 ID STATE    STATUS     QUEUE  CONNECTION CHANGED
-----------------------------------------------------------------------
g_pgpublisher_ccm7_1_3_30000_1    2 Active   Local           0               
g_pgsubscriber_ccm7_1_3_30000_1    4 Active   Connected       0 Aug 17 22:25:09

When I run show perf query class "Number of Replicates Created and State of Replication"

here are the results:

admin:show perf query class "Number of Replicates Created and State of Replication"
==>query class :

- Perf class (Number of Replicates Created and State of Replication) has instances and values:
    ReplicateCount  -> Number of Replicates Created   = 427
    ReplicateCount  -> Replicate_State                = 2


admin:
admin:show perf query class "Number of Replicates Created and State of Replication"
==>query class :

- Perf class (Number of Replicates Created and State of Replication) has instances and values:
    ReplicateCount  -> Number of Replicates Created   = 427
    ReplicateCount  -> Replicate_State                = 2


admin:

Re: Deleted phones are registering

Well at least you database appears to be ok.

Just out of curiosity, are you using auto-registration in your cluster?  If you're not using it can you verify that it is off?

New Member

Re: Deleted phones are registering

How would I verify auto-registration?

Re: Deleted phones are registering

All the settings are under the System->CallManager menu.  To enable auto-registration, one has to specify a directory number range for auto-reg'd phones to use, turn on auto-registration and specify an auto-registration CallManager group.  I don't have access to CM at the moment so I apologize for not remembering exactly where all those options are off the top of my head.

New Member

Re: Deleted phones are registering

Ok, I was able to locate the Auto Registration information.

It is disabled on Subscriber, but enabled on Publisher using extension 7100-7110.  The deleted phones are not using their extensions, they are using their old extensions.

New Member

Re: Deleted phones are registering

is this happens even when you delete the unassigned numbers from CUCM through route plan report?

New Member

Re: Deleted phones are registering

Yes, the extensions are deleted from the unassigned extensions as well!

Re: Deleted phones are registering

I know we already checked dbreplication, but...

You stated that you can delete a phone and verify via CCMAdmin that it's gone.  Can you try deleting a phone (and unplugging it before it re-registers) and verifying via CCM Admin on all CCM servers in the cluster that it's gone?  I still feel like something strange may be going on with replication despite the good replication status.  I hope I'm wrong though!

New Member

Re: Deleted phones are registering

I will give that a try and let you know the results. 

I have also found that a couple phones that were deleted are actually auto registering.  I was able to configure one of the them with a new extension, but when I moved the phone from the Default device pool into one created for the facility, the phone pulled its old extension.  Weird...

New Member

Re: Deleted phones are registering

Ok, I deleted a phone and confirmed it is deleted in both CCMAdmins.

Re: Deleted phones are registering

And if you plug it back in does it come back anyway?

New Member

Re: Deleted phones are registering

Yup, it comes back online with its old extension

New Member

Re: Deleted phones are registering

You should delete all associated Directory Numbers from Routing -> Directory Numbers. Hope it will help

Re: Deleted phones are registering

He already has.  So far we've verified that after he deletes a phone he is able to verify on all servers in the CUCM cluster that it is gone.  When he plugs it back in it auto-registers like it is supposed to; however, if he changes the device pool on the phone it re-registers with its old extension.

Correct?

New Member

Re: Deleted phones are registering

Hello,

He should check the Device Pool configuration. Specificaly Cisco Unified CallManager Group field perhaps this group contains a subcribers or TFTP server which is not synchronized correctly.

JP

Re: Deleted phones are registering

He even checked the dbreplication status to make sure the databases were all synced, too...

This is a strange issue for sure!

529
Views
0
Helpful
19
Replies
CreatePlease to create content