Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Bronze

Desperate help needed,

Well,

just came back from a simple upgrade and now i am in a total mess.

Scenario customer has about 14 7912G phones and just purchased 7912G-A phones, five. these new phones was not registering on CCM 4.0 (4A) SR2. downloaded devicepak and ran the upgrade. New phones finally registered. then i decided to test the srst and that was giving some issues failing over back to the primary. i changed the connection duration monitor time and it asked me to reset all devices. Resetted and NOW ALL 7912G(Old phones) are DEAD.

phones have both the red/green lights on and thats it. i checked the switch and the inline pwr stat and it shows the phones asking for 15.4W with a line cisco systems .

ive tried in vain to upgrade the firmware, installed CCME loaded the 7912 phone load but still nothing. please please please tell me that there is a fix. if not, i think ill probably start a career in agriculture.

i still cant beleive this could happen.

8 REPLIES
Bronze

Re: Desperate help needed,

anyone?

Hall of Fame Super Red

Re: Desperate help needed,

Hi Arvind,

Don't get out the coveralls and plows quite yet :) I'm sure there is a fix. Have a look at these 2 bugs first off to see if this is what you are hitting. Just to clarify, the 14 original 7912's are dead and the 5 new are working? Is that correct? Could also be a firmware issue, can you load the original firmware that had the 14 working? Did the firmware go from signed to un-signed?

CSCeg20129

CSCef44998

Symptom:

Set "Backup Server Keep Alive Interval" to 10 seconds, and a Cisco 7912 IP

phone will not automatically fall back from the SRST router

and register to the Cisco CallManager (CCM) server when the CCM server comes

back online.

Condition:

This problem may occur with a Cisco 7912 IP phone running phone

load 4.0(0) (CP7912040000SCCP040701A).

If the Cisco 7912 IP phone fails over to register with a local router in SRST mode

due to a CallManager or WAN failure, the phone will not automatically register with

the CallManager after the CallManager or WAN failure is resolved.

Workaround:

The issue is caused by setting very short "Backup Server Keep Alive Interval" (e.g. 10sec.).

If no special reason, just set Backup Keepalive interval to 60 seconds, which is

default value and 7912 will fallback to CCM after 2 mins as design.

Manually reset the Cisco 7912 phone by entering the key sequence "**#**" while

the phone is onhook. The phone will then prompt the user "Do you want to reboot

the phone?" Select "Yes". After the phone is rebooted it will register with the

CallManager as expected. Alternatively, the phone user can reboot the phone by

removing and reapplying power.

Let us know,

Rob

Bronze

Re: Desperate help needed,

hey,

thanks for the response. the phones were working fine. they were missing the local directory and the netw phones CP-7912G-A were not registering. i downloaded the firmware for the 7912 and ran it on the CCM. the new phones registered after and everthing was fine. i resetted all memebers after making some adjustments and the old phones (cp-7912g) resetted , resetted again and got stuck with both lights. no Cisco logo nutting. obviously when i reset the members, it allowed for the new firmware to download to these phones and somehow ALL OLD phones didnt take it and are now dead.

so basically, the new phones we not registering, upgrade firmaware and worked (but i did this globally) the old phones got the new firmware and bammm. gone. nutting.

remember - NOT EVEN THE CISCO LOGO is coming up. power is granted to the phone and both hold and configuration lights are constantly on.

New Member

Re: Desperate help needed,

Hi,

I have the same problem with a 7912G IP Phone.

I tried to change the logo on the display, and when i reboot the phone, never start again...

So, you found any solution?

Hall of Fame Super Gold

Re: Desperate help needed,

When a 7912 doesn't start, it is probably looking for an image file via TFTP that cannot find. Using a tftp server like the router or tftp32, observe the requested filename, and prepare a valid 7912 firmware image (any) with that name, or alias in case of TFTP on the router. After the phone correctly loads the image, it will be resurrected and working.

Bronze

Re: Desperate help needed,

well after my initial post i tried all of the mentioned solutions to no avail. the phone just stays with all lights on. not reqests and if i do ah show power inline i see it as 15W and stay there forever.

My solution was phone replacements. luckily we got the replacements in quickly. learnt a valuable lesson :)

Re: Desperate help needed,

about the logo chage

there is a bug when you change the logo for 7905/7912 where they get stuck with their lights lit on and the official workaround is RMA. So if you do this with ccm4.1(X) first search for this bug to check if you are using the "buggy" versions of ccm and firmware.

New Member

Re: Desperate help needed,

Yes,

I've upgrading CCM 4.1(3) to SR1, and i find this on the documentation:

CSCsa72417:7912 dies when configuring Graphics via TFTP on CCM 4.1

and this:

CSCsa74660: During cross upgrade, power off/on the phone & the phone never come up

So be careful, and upgrade CCM... that's the lesson :P

405
Views
0
Helpful
8
Replies