Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DHCP server selection

hello,

i have call manager cluster ( 1 publisher 2 subscriber)

i will add a new subscriber to the cluster lets name it sub3.

the sub3 server will be placed in a different vlan from the cluster(pub and 2 sub). ip access will be granted between the two vlans.

i have a group of phones that should be registerd with the new sub3. this can be done through device pool by selecting the sub3 server as a first priority in the call manager group assigned. so that phone will select sub3 as first priority for registration.

in my case the pub is the tftp server. the new group of phones and the sub3 are in a different vlan.

so new added phones should take the ip address config from the sub3 (same vlan) on this way i have to configure the tftp server for the new group of iphones to be sub3. so sub3 will be a tftp server with a group of ip address to assign through dhcp server different from the ip address range on the first server.

how can be this done? and ow may set for the group of new phones to register with sub3 and have tftfp server and dhcp server as sub 3 while keep the old ip phones to have tftfp and dhcp server as the pub.

also one thing, if sub3 got down the new group of phones that were registerd with sub3 should now register with sub2 or sub 1 or pub, so there will be a problem concerning the ip address? shall new reqgistration requires a new ip address to be assigned to the ip phones? if not can the ip phone having an ip address different then the sub2 to be registered with sub2?(sure assuming network connectivity and access)

appreciate if i can have a detailed answer for the group of scenarios mentioned above.

thanks,

3 ACCEPTED SOLUTIONS

Accepted Solutions
Blue

Re: DHCP server selection

Hi

your auery :- on the "dhcp subnet" i set the pool of the primary tftp/dhcp server, by  setting the start ip address and the second ip address of the primary  tftf/dhcp server.

Answer :- We donot have option of giving secondary DHCP server in DHCP subnet configuration. Only we can have multiple TFTP servers.  TFTP serves and DHCP is different, so even if your TFTP 3 is down, it will not take ip address from the old DHCP pool.

Your Query :-

how may i link the group of the new phones to register with the  secondary tftp server and not on the primary tftp server!? is it the ip  helper? so that way , i have to enter under interface vlan sub3, the ip  helper command where i enter the ip address of sub3, while on the  interface vlan pub, i enter the ip helper command where i enter the ip  address of the pub?! this command alone will do the job to set the new  group of iphones to consider the ip address setted with this command to  be there tftp/dhcp server? nothing from the cucm config?

Answer :- 1stly we do not register phone to tftp server we register it to Call manager server. TFTp server is just the server which stores the configuration. CUCM can be TFTP server. Linking/registering new phone to another Call manager ( Not TFTP server) can be done at CUCM group configuration level + Device pool level. TFTp is not involved here.

Your query :-

my second question if sub3 get down, i dont want the new ip phones to  take the ip address of the pub(primary tftfp/dhcp server) and vice versa  how may i do so? and can they keep on there native ip address assigned  from sub3 range and registerd with pub? any additional config required  to do not get a new ip address ?

Answer :- New phones will not take ip address from primary ip address  pool. When Subscriber 3 goes down. the phones will have ip address of there current pool only but they will register to the next CUCM present in Call manager group configuration.

Regards

Ronak

Regards Ronak Patel Rate all helpful post by clicking stars below the answer.
Blue

Re: DHCP server selection

Question :- 

one small issue to point to, is that if i want the dhcp server to act  also as a tftp server, the tftp server configuration is done through the  dhcp subnet config  only and not in somewhere else right?! i guess yes.

Answer :- Yes correct.

Question :-

i didnt get you answer about where on cucm configuration, i tell the  phones to take there ip addresses from sub3. which mean in other word,  having pub as dhcp server for group of old ip phones, how to configure  sub3 to be the dhcp server for the new group of ip phones OR  (second  option based on you answer above) how to tell the same pub which is the  initial dhcp server to be a dhcp server but with specifying for it two  different ip addresses ranges from 2 different subnets? also how to tell  the phones to have the pub as dhcp server but to take an ip address  from the second range not the first range with keeping for the old  phones group to still take there ip addresses from the pub dhcp server  but from the first range.

Answer :- As already said. The DHCP server reply with the ip address form the range of that subnet only from which the request has come. When you use ip helper address command on your router/L3 switch for that vlan/subnet, the CUCM ( DHCp server) Will reply to DHCP request with the address pool only.

For Example

1) Pool 1 ( your Old Pool ) :- 10.10.10.0 and Pol 2 ( Your New Pool ) 10.10.20.0 and pool 3 10.10.30.0

Now the new phone will always be connected to the l3 port which will have ip address of 10.10.20.0 network (Default-Gateway). The ip helper comand will send DHCP request to CUCM ( DHCP server ) with the information that I want IP address from the range of 10.10.20.0. CUCM ( DHCp server) will only reply with new pool ip address to the new phones.

If you even have 3rd kind of new phone which wants ip address from network 10.10.30.0. In this case these phones will be connected to the l3 port which will have ip address of 10.10.30.0  network (Default-Gateway). The ip helper comand will send DHCP request  to CUCM ( DHCP server ) with the information that I want IP address from  the range of 10.10.30.0. SO no ip phone in this range will get ip from 10.10.10.0 or  10.10.20.0. Ip helper takes care of ip addressing. 

Question :-

related to tftp, can i configure sub3 to be the tftfp server for the new  group of phones with keeping the pub as the tftp server for the other  old group of ip phones?

Answer :- Yes, the tftp configraion is part of DHCP pool configuration in CUCM.

Regards Ronak Patel Rate all helpful post by clicking stars below the answer.
Blue

Re: DHCP server selection

No,

If you have one PUB as DHCP server. How can you use Sub3 in ip helper address....

Ip helper address will have ip address of the DHCP server.

interface vlan 20 (vlan of new sub 3)

ip address 192.168.20.1 255.255.255.0

ip helper-address 192.168.10.10

Now when ip phone from vlan 20 ask for IP address, the CUCM PUB will only reply with the range in

192.168.20.0 /24 for this vlan phones.

Regadrs

Ronak patel

Regards Ronak Patel Rate all helpful post by clicking stars below the answer.
17 REPLIES
New Member

DHCP server selection

Hi learnsec, I think we should reply each of the questions seperately.

First of all. TFTP Server, CUCMs and DHCP Server can act differently, they can be different devices and they can be in different subnets/networks.

Regarding;

so new added phones should take the ip address config from the sub3  (same vlan) on this way i have to configure the tftp server for the new  group of iphones to be sub3.

Sub3 doesn't have to be TFTP Server, but if you want to do so, you can specify as a primary tftp server or secondary tftp server in the DHCP in the subnet which Publisher and Sub1,Sub2 resides.

Regarding;

how can be this done? and ow may set for the group of new phones to  register with sub3 and have tftfp server and dhcp server as sub 3 while  keep the old ip phones to have tftfp and dhcp server as the pub.

If you want to keep TFTP and DHCP server as the Publisher, you can do it by using IP Helper address in your router/routing interface. Assuming your publisher IP address is 192.168.10.10 and the subnet that contains Sub3 is 192.168.20.0, and assuming you are using Switch Virtual Interface you have to make configuration like this;

interface vlan 20 (I assume VLAN 20 is the VLAN that Sub3 has)

ip address 192.168.20.1 255.255.255.0

ip helper-address 192.168.10.10

!

ip forward-protocol udp

On the other hand if you are using Cisco IOS DHCP, you can make this kind of configuration;

ip dhcp pool Sub3

network 192.168.20.0 /24

default-router 192.168.20.1

option 150 ip 192.168.10.10 192.168.20.10

!

(again assuming Sub3 is 192.168.20.10)

You can make similar configuration in CUCM DHCP

Regarding;

also one thing, if sub3 got down the new group of phones that were  registerd with sub3 should now register with sub2 or sub 1 or pub, so  there will be a problem concerning the ip address? shall new  reqgistration requires a new ip address to be assigned to the ip phones?  if not can the ip phone having an ip address different then the sub2 to  be registered with sub2?

Again Call Processing Engines can be different devices in different subnets, you can specify in a prioritized list in CUCM Group in Device Pool, so there is no matter which CPE is in which subnet. If you could configure your infrastructure correctly, it will work as you wish.

Hope this helps

Ali TADIR

New Member

Re: DHCP server selection

thanks Ali,

but your answer is not clear for me,

you say sub 3 can assign IP Addresses to the new group of ip phones registered with sub3 without being a tftp server or dhcp server! how this? you mean by configuring the switch where the interface vlan exist for sub3 by the following:

!

interface vlan 20 (I assume VLAN 20 is the VLAN that Sub3 has)

ip address 192.168.20.1 255.255.255.0

ip helper-address 192.168.10.10

!

ip forward-protocol udp

!

ip dhcp pool Sub3

network 192.168.20.0 /24

default-router 192.168.20.1

option 150 ip 192.168.10.10 192.168.20.10

option 150 ip 192.168.20.20 192.168.20.250 (both boundaries should be same vlan as sub3 right?!)

!

????

the ip helper-address will do what?

it is not the preffered way for me.

concerning the second option you mention, about configure primary tftp sever as pub (current config), then configure secondary tftfp server as the sub3, this will not solve my problem, because on the dhcp subnet config (where i configure primary & Secondary tftp server) there is only one pool of ip address to configure. so i can configure 2 pools.

but if you mean i can create 2 dhcp subnet rules, where in the first there is the pub is primary dhcp and tftp server and the old pool of ip addresses, and in the second dhcp subnet rule i configure the sub3 as the primary dhcp and tftp server and the new pool of ip addresses, this may be logic but how may i link the rules with the correspondant phone devices?

is there any link between call  manager groups, or maybe devicepool and the "dhcp server" / " dhcp subnet" rules created?

for me i prefere to configure 2 dhcp servers in the cucm config and do not use switch configuration.

thank you again Ali,

Blue

DHCP server selection

Hi,

1) You can use same PUB as DHCP server for both the subnet, you can confiure two pools of IP address in one DHCP server. The new phones will get ip address from the subnet range from which they are requesting for IP address. Ip helper command will do th trick here.

2) The tftp option manipulation you can do at  "DHCP Subnet Configuration"

3) The Callmanager priority configuratoin is done at  "Cisco Unified CM Groups" level. This is assigned to DP and DP is asigned to phone.

I hope this clears the doubt.

regards

Ronak Patel


Regards Ronak Patel Rate all helpful post by clicking stars below the answer.
New Member

Re: DHCP server selection

hello ronak,

what you said is great and what i want exactly, but i would like to clarify the following:

1)

- on the "dhcp server" i configure only the ip address of the pub.

- on the "dhcp subnet" i set the pool of the primary tftp/dhcp server, by setting the start ip address and the second ip address of the primary tftf/dhcp server.

-HERE., you probably say i have the option to enter a second pool for the secondary tftp/dhcp server. so here i enter the start ip address and end ip address of the secondary tftp/dhcp server.

so my question if you mean so, can i configure a pool of the secondary tftp/dhcp server without configuring the ip address of sub3 as it is the secondary tftp/dhcp server?

in addition, how may i link the group of the new phones to register with the secondary tftp server and not on the primary tftp server!? is it the ip helper? so that way , i have to enter under interface vlan sub3, the ip helper command where i enter the ip address of sub3, while on the interface vlan pub, i enter the ip helper command where i enter the ip address of the pub?! this command alone will do the job to set the new group of iphones to consider the ip address setted with this command to be there tftp/dhcp server? nothing from the cucm config?

my second question if sub3 get down, i dont want the new ip phones to take the ip address of the pub(primary tftfp/dhcp server) and vice versa how may i do so? and can they keep on there native ip address assigned from sub3 range and registerd with pub? any additional config required to do not get a new ip address ?

thank you again,

Blue

Re: DHCP server selection

Hi

your auery :- on the "dhcp subnet" i set the pool of the primary tftp/dhcp server, by  setting the start ip address and the second ip address of the primary  tftf/dhcp server.

Answer :- We donot have option of giving secondary DHCP server in DHCP subnet configuration. Only we can have multiple TFTP servers.  TFTP serves and DHCP is different, so even if your TFTP 3 is down, it will not take ip address from the old DHCP pool.

Your Query :-

how may i link the group of the new phones to register with the  secondary tftp server and not on the primary tftp server!? is it the ip  helper? so that way , i have to enter under interface vlan sub3, the ip  helper command where i enter the ip address of sub3, while on the  interface vlan pub, i enter the ip helper command where i enter the ip  address of the pub?! this command alone will do the job to set the new  group of iphones to consider the ip address setted with this command to  be there tftp/dhcp server? nothing from the cucm config?

Answer :- 1stly we do not register phone to tftp server we register it to Call manager server. TFTp server is just the server which stores the configuration. CUCM can be TFTP server. Linking/registering new phone to another Call manager ( Not TFTP server) can be done at CUCM group configuration level + Device pool level. TFTp is not involved here.

Your query :-

my second question if sub3 get down, i dont want the new ip phones to  take the ip address of the pub(primary tftfp/dhcp server) and vice versa  how may i do so? and can they keep on there native ip address assigned  from sub3 range and registerd with pub? any additional config required  to do not get a new ip address ?

Answer :- New phones will not take ip address from primary ip address  pool. When Subscriber 3 goes down. the phones will have ip address of there current pool only but they will register to the next CUCM present in Call manager group configuration.

Regards

Ronak

Regards Ronak Patel Rate all helpful post by clicking stars below the answer.
New Member

Re: DHCP server selection

thanks ronak but not getting your answer, please clarify:

for me it is clear that ip phone registration is done based on the call manager group priority which is assigned through the DP. ok this point is done and closed.

second point, it is not mandatory to have the dhcp server and tftp server to be the same; they can be different. also got it.

the tftp server is used to get firmware and config, while dhcp server is used for ip addressing only. also got it.

one small issue to point to, is that if i want the dhcp server to act also as a tftp server, the tftp server configuration is done through the dhcp subnet config  only and not in somewhere else right?! i guess yes.

i didnt get you answer about where on cucm configuration, i tell the phones to take there ip addresses from sub3. which mean in other word, having pub as dhcp server for group of old ip phones, how to configure sub3 to be the dhcp server for the new group of ip phones OR  (second option based on you answer above) how to tell the same pub which is the initial dhcp server to be a dhcp server but with specifying for it two different ip addresses ranges from 2 different subnets? also how to tell the phones to have the pub as dhcp server but to take an ip address from the second range not the first range with keeping for the old phones group to still take there ip addresses from the pub dhcp server but from the first range.

related to tftp, can i configure sub3 to be the tftfp server for the new group of phones with keeping the pub as the tftp server for the other old group of ip phones?

is there any config relation that links between the Call mAnager group or device pool from a side / with DHCP Server or tftp server configuration from the second side???????

thank you again,

Blue

Re: DHCP server selection

Question :- 

one small issue to point to, is that if i want the dhcp server to act  also as a tftp server, the tftp server configuration is done through the  dhcp subnet config  only and not in somewhere else right?! i guess yes.

Answer :- Yes correct.

Question :-

i didnt get you answer about where on cucm configuration, i tell the  phones to take there ip addresses from sub3. which mean in other word,  having pub as dhcp server for group of old ip phones, how to configure  sub3 to be the dhcp server for the new group of ip phones OR  (second  option based on you answer above) how to tell the same pub which is the  initial dhcp server to be a dhcp server but with specifying for it two  different ip addresses ranges from 2 different subnets? also how to tell  the phones to have the pub as dhcp server but to take an ip address  from the second range not the first range with keeping for the old  phones group to still take there ip addresses from the pub dhcp server  but from the first range.

Answer :- As already said. The DHCP server reply with the ip address form the range of that subnet only from which the request has come. When you use ip helper address command on your router/L3 switch for that vlan/subnet, the CUCM ( DHCp server) Will reply to DHCP request with the address pool only.

For Example

1) Pool 1 ( your Old Pool ) :- 10.10.10.0 and Pol 2 ( Your New Pool ) 10.10.20.0 and pool 3 10.10.30.0

Now the new phone will always be connected to the l3 port which will have ip address of 10.10.20.0 network (Default-Gateway). The ip helper comand will send DHCP request to CUCM ( DHCP server ) with the information that I want IP address from the range of 10.10.20.0. CUCM ( DHCp server) will only reply with new pool ip address to the new phones.

If you even have 3rd kind of new phone which wants ip address from network 10.10.30.0. In this case these phones will be connected to the l3 port which will have ip address of 10.10.30.0  network (Default-Gateway). The ip helper comand will send DHCP request  to CUCM ( DHCP server ) with the information that I want IP address from  the range of 10.10.30.0. SO no ip phone in this range will get ip from 10.10.10.0 or  10.10.20.0. Ip helper takes care of ip addressing. 

Question :-

related to tftp, can i configure sub3 to be the tftfp server for the new  group of phones with keeping the pub as the tftp server for the other  old group of ip phones?

Answer :- Yes, the tftp configraion is part of DHCP pool configuration in CUCM.

Regards Ronak Patel Rate all helpful post by clicking stars below the answer.
New Member

Re: DHCP server selection

firstly is ther a way to cancel "the correct answer" i selected for one  of your answers, and replace it by your last answer to be the correct one?

so back to our discussion, your last answer solved my dominno:)

but (this "but" is always there hehehe)

on the dhcp subnet config, i have primary pool(start end ip address) and secondary pool (start end ip address) so is it here where i enter my second pool? also there is no place for a third pool for that i am asking.

lastly, if i want to configure sub3 to be a dhcp server for a group of ip phones can be done? and how? also hoe to tell the new group of ip phones to talk with the sub 3 as a dhcp server and not to pub

Blue

Re: DHCP server selection

Question :-

on the dhcp subnet config, i have primary pool(start end ip address) and  secondary pool (start end ip address) so is it here where i enter my  second pool? also there is no place for a third pool for that i am  asking.

Answer :- In One DHCP Subnet Configuration, you will not have  primary pool(start end ip address) and  secondary pool (start end ip address). You will have to create DHCP Subnets  for all the subnets for which you want to have DHCP service. You can add multiple DHCP Subnets by going to System----> DHCp----> DHCp Subnet and add all the pools you want.

Question :-

lastly, if i want to configure sub3 to be a dhcp server for a group of  ip phones can be done? and how? also hoe to tell the new group of ip  phones to talk with the sub 3 as a dhcp server and not to pub

Answer :- You can add Sub 3 also as DHCP server. Go to System---> DHCP-----> DHCP server. Add Sub 3 as server.

And in Ip phelper address comand give your Sub 3 ip address .

regards

Ronak

Regards Ronak Patel Rate all helpful post by clicking stars below the answer.
New Member

Re: DHCP server selection

Thanks ronak fo your answer,

considering i went with considering pub is the dhcp server  in the cluster and i identified two dhcp subnet rules where i identify the pool 1 on the first dhcp subnet rule and pool 2 on the second dhcp subnet rule.

so then, on the two vlans where pub and sub 3 resides the ip helper address command will be the same ip address used?(which is the ip address of pub)

on the switch the only config will be:

!

interface vlan 10 (vlan of Pub)

ip address 192.168.10.1 255.255.255.0

ip helper-address 192.168.10.10 (This IP Address should be the ip address of pub)?

!

!

interface vlan 20 (vlan of new sub 3)

ip address 192.168.20.1 255.255.255.0

ip helper-address 192.168.20.10 (This IP Address should be the ip address of sub3 )?

!

and thank you for the whole support,

best regards,

Blue

Re: DHCP server selection

No,

If you have one PUB as DHCP server. How can you use Sub3 in ip helper address....

Ip helper address will have ip address of the DHCP server.

interface vlan 20 (vlan of new sub 3)

ip address 192.168.20.1 255.255.255.0

ip helper-address 192.168.10.10

Now when ip phone from vlan 20 ask for IP address, the CUCM PUB will only reply with the range in

192.168.20.0 /24 for this vlan phones.

Regadrs

Ronak patel

Regards Ronak Patel Rate all helpful post by clicking stars below the answer.
New Member

Re: DHCP server selection

thanks ronak,

My problem is now solved

sorry if bothering,

best regards,

Blue

Re: DHCP server selection

Happy to help....

Regards Ronak Patel Rate all helpful post by clicking stars below the answer.
New Member

Re: DHCP server selection

hello,

i would like to check if the "ip helper-address" command is alone enough to work properly for the reason you know about my setup, or i have an addional config like "service dhcp" or "dhcp server" ?

on my setup i dont have dhcp server and i dont want to configure a globall dhcp server on the main switch or running dhcp server to affect my current setup.

it is really critical,

please advice,

Blue

Re: DHCP server selection

Hi,

I am not able to understand your query...Let me know in detail.

Regards

Ronak patel

Regards Ronak Patel Rate all helpful post by clicking stars below the answer.
New Member

Re: DHCP server selection

hi,

i mean on my network i don't use any dhcp configuration, dhcp is disabled on all switches, dhcp is only used by call manager to assign IP Addresses to phones, so on my CUCM solution now i have one dhcp server configured with two different dhcp subnet pools, the phones will take an IP from its correspondant pool based on the interface vlan comming from, more specifically based on the command "ip helper-address IP_of_PUB" placed under the interface vlan.

my question is shall i have to configure any additional command globally on the main switch in order to allow for the "ip helper-address" command to work properly? i  mean by global config something like "service dhcp" or "dhcp server"?!

and if so, shall it affect the other network vlans? as we added a global command?!

regards,

Blue

Re: DHCP server selection

Hi,

I am not master of switcing , but you will have to enable "service dhcp" as the feature you require needs relay features. And

relay feature require service dhcp.

Regards

Ronak Patel

Regards Ronak Patel Rate all helpful post by clicking stars below the answer.
1366
Views
5
Helpful
17
Replies