Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

dial-peer voice pots doesn't strip prefix digits.

Hello,

I try to separate calls for different E1 ports:

!

dial-peer voice 10 pots

huntstop

destination-pattern 111.+

port 1/0:15

!

dial-peer voice 20 pots

destination-pattern 222.+

incoming called-number .T

port 1/1:15

!

And I want the prefixes 111 and 222 will be deleted when call reaches the outbound POTS dial peer. But it not happen. Do somebody know why?

So as DNIS number come to device the same number goes from outbound POTS dial peer.

debug voip ccapi inout

*Mar 23 20:31:44.951: //-1/30F4380BE637/CCAPI/cc_api_display_ie_subfields:

   cc_api_call_setup_ind_common:

   cisco-username=95.215.0.5

   ----- ccCallInfo IE subfields -----

   cisco-ani=8123749844

   cisco-anitype=0

   cisco-aniplan=1

   cisco-anipi=0

   cisco-anisi=0

   dest=11178123367575

   cisco-desttype=0

   cisco-destplan=1

   cisco-rdie=FFFFFFFF

   cisco-rdn=

   cisco-rdntype=-1

   cisco-rdnplan=-1

   cisco-rdnpi=-1

   cisco-rdnsi=-1

   cisco-redirectreason=-1

*Mar 23 20:31:44.951: //-1/30F4380BE637/CCAPI/cc_api_call_setup_ind_common:

   Interface=0x883EAF5C, Call Info(

   Calling Number=8123749844(TON=Unknown, NPI=ISDN, Screening=Not Screened, Presentation=Allowed),

   Called Number=11178123367575(TON=Unknown, NPI=ISDN),

   Calling Translated=FALSE, Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE,

   Incoming Dial-peer=50, Progress Indication=NULL(0), Calling IE Present=TRUE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=14

*Mar 23 20:31:44.955: //-1/30F4380BE637/CCAPI/ccCheckClipClir:

   In: Calling Number=8123749844(TON=Unknown, NPI=ISDN, Screening=Not Screened, Presentation=Allowed)

*Mar 23 20:31:44.955: //-1/30F4380BE637/CCAPI/ccCheckClipClir:

   Out: Calling Number=8123749844(TON=Unknown, NPI=ISDN, Screening=Not Screened, Presentation=Allowed)

*Mar 23 20:31:44.955: //14/30F4380BE637/CCAPI/cc_api_call_setup_ind_common:

   Set Up Event Sent;

   Call Info(Calling Number=8123749844(TON=Unknown, NPI=ISDN, Screening=Not Screened, Presentation=Allowed),

   Called Number=11178123367575(TON=Unknown, NPI=ISDN))

*Mar 23 20:31:44.959: //14/30F4380BE637/CCAPI/cc_process_call_setup_ind:

   Event=0x8873ED70

*Mar 23 20:31:44.967: //14/30F4380BE637/CCAPI/ccCallSetContext:

   Context=0x888EE554

*Mar 23 20:31:44.967: //14/30F4380BE637/CCAPI/cc_process_call_setup_ind:

   >>>>CCAPI handed cid 14 with tag 50 to app "_ManagedAppProcess_Default"

*Mar 23 20:31:44.971: //14/30F4380BE637/CCAPI/ccCallProceeding:

   Progress Indication=NULL(0)

*Mar 23 20:31:44.975: //14/30F4380BE637/CCAPI/ccCallSetupRequest:

   Destination=, Calling IE Present=TRUE, Mode=0,

   Outgoing Dial-peer=10, Params=0x888EF204, Progress Indication=NULL(0)

*Mar 23 20:31:44.975: //14/30F4380BE637/CCAPI/ccCheckClipClir:

   In: Calling Number=8123749844(TON=Unknown, NPI=ISDN, Screening=Not Screened, Presentation=Allowed)

*Mar 23 20:31:44.975: //14/30F4380BE637/CCAPI/ccCheckClipClir:

   Out: Calling Number=8123749844(TON=Unknown, NPI=ISDN, Screening=Not Screened, Presentation=Allowed)

*Mar 23 20:31:44.979: //14/30F4380BE637/CCAPI/ccCallSetupRequest:

   Destination Pattern=111.+, Called Number=11178123367575, Digit Strip=TRUE

*Mar 23 20:31:44.979: //14/30F4380BE637/CCAPI/ccCallSetupRequest:

   Calling Number=8123749844(TON=Unknown, NPI=ISDN, Screening=Not Screened, Presentation=Allowed),

   Called Number=11178123367575(TON=Unknown, NPI=ISDN),

   Redirect Number=, Display Info=

   Account Number=95.215.0.5, Final Destination Flag=TRUE,

   Guid=30F4380B-B36A-F94F-E637-000046464636, Outgoing Dial-peer=10

*Mar 23 20:31:44.979: //14/30F4380BE637/CCAPI/cc_api_display_ie_subfields:

   ccCallSetupRequest:

   cisco-username=95.215.0.5

   ----- ccCallInfo IE subfields -----

   cisco-ani=8123749844

   cisco-anitype=0

   cisco-aniplan=1

   cisco-anipi=0

   cisco-anisi=0

   dest=11178123367575

   cisco-desttype=0

   cisco-destplan=1

   cisco-rdie=FFFFFFFF

   cisco-rdn=

   cisco-rdntype=-1

   cisco-rdnplan=-1

   cisco-rdnpi=-1

   cisco-rdnsi=-1

   cisco-redirectreason=-1

*Mar 23 20:31:44.983: //14/30F4380BE637/CCAPI/ccIFCallSetupRequestPrivate:

   Interface=0x8477CB48, Interface Type=6, Destination=, Mode=0x0,

   Call Params(Calling Number=8123749844(TON=Unknown, NPI=ISDN, Screening=Not Screened, Presentation=Allowed),

   Called Number=11178123367575(TON=Unknown, NPI=ISDN), Calling Translated=FALSE,

   Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE, Outgoing Dial-peer=10, Call Count On=FALSE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)

*Mar 23 20:31:44.983: //15/30F4380BE637/CCAPI/ccIFCallSetupRequestPrivate:

   SPI Call Setup Request Is Success; Interface Type=6, FlowMode=1

*Mar 23 20:31:44.983: //15/30F4380BE637/CCAPI/ccCallSetContext:

   Context=0x888EF1B4

*Mar 23 20:31:44.983: //14/30F4380BE637/CCAPI/ccSaveDialpeerTag:

   Outgoing Dial-peer=10

*Mar 23 20:31:45.092: //15/30F4380BE637/CCAPI/cc_api_call_disconnected:

   Cause Value=21, Interface=0x8477CB48, Call Id=15

*Mar 23 20:31:45.096: //15/30F4380BE637/CCAPI/cc_api_call_disconnected:

   Call Entry(Responsed=TRUE, Cause Value=21, Retry Count=0)

*Mar 23 20:31:45.096: //15/30F4380BE637/CCAPI/ccCallSetAAA_Accounting:

   Accounting=0, Call Id=15

*Mar 23 20:31:45.096: //15/30F4380BE637/CCAPI/ccCallDisconnect:

   Cause Value=21, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=21)

*Mar 23 20:31:45.096: //15/30F4380BE637/CCAPI/ccCallDisconnect:

   Cause Value=21, Call Entry(Responsed=TRUE, Cause Value=21)

*Mar 23 20:31:45.100: //15/30F4380BE637/CCAPI/cc_api_get_transfer_info:

   Transfer Number Is Null

*Mar 23 20:31:45.104: //15/30F4380BE637/CCAPI/cc_api_call_disconnect_done:

   Disposition=0, Interface=0x8477CB48, Tag=0x0, Call Id=15,

   Call Entry(Disconnect Cause=21, Voice Class Cause Code=0, Retry Count=0)

*Mar 23 20:31:45.104: //15/30F4380BE637/CCAPI/cc_api_call_disconnect_done:

   Call Disconnect Event Sent

*Mar 23 20:31:45.108: //14/30F4380BE637/CCAPI/ccCallDisconnect:

   Cause Value=21, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)

*Mar 23 20:31:45.112: //14/30F4380BE637/CCAPI/ccCallDisconnect:

   Cause Value=21, Call Entry(Responsed=TRUE, Cause Value=21)

*Mar 23 20:31:45.112: //14/30F4380BE637/CCAPI/cc_api_get_transfer_info:

   Transfer Number Is Null

*Mar 23 20:31:45.120: //14/30F4380BE637/CCAPI/cc_api_call_disconnect_done:

   Disposition=0, Interface=0x883EAF5C, Tag=0x0, Call Id=14,

   Call Entry(Disconnect Cause=21, Voice Class Cause Code=0, Retry Count=0)

*Mar 23 20:31:45.120: //14/30F4380BE637/CCAPI/cc_api_call_disconnect_done:

   Call Disconnect Event Sent

*Mar 23 20:34:45.127: //-1/xxxxxxxxxxxx/CCAPI/ccAppShutdownMode:

   ccAppShutdownMode: remove it from the queue

Router#sh ver

Load for five secs: 1%/0%; one minute: 0%; five minutes: 0%

No time source, *20:51:47.330 UTC Sat Mar 23 2002

Cisco IOS Software, C2600 Software (C2600-IPVOICEK9-M), Version 12.4(23b), RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2009 by Cisco Systems, Inc.

Compiled Sun 02-Aug-09 19:54 by prod_rel_team

ROM: System Bootstrap, Version 12.2(8r) [cmong 8r], RELEASE SOFTWARE (fc1)

Router uptime is 1 hour, 25 minutes

System returned to ROM by reload

System image file is "flash:c2600-ipvoicek9-mz.124-23b.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

Cisco 2651XM (MPC860P) processor (revision 3.1) with 221184K/40960K bytes of memory.

Processor board ID JAE0823KMFA

M860 processor: part number 5, mask 2

2 FastEthernet interfaces

43 Serial interfaces

4 Channelized E1/PRI ports

1 ATM/Voice AIM

32K bytes of NVRAM.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Router#sh run

Load for five secs: 0%/0%; one minute: 0%; five minutes: 0%

No time source, *20:52:30.714 UTC Sat Mar 23 2002

Building configuration...

Current configuration : 3438 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

logging queue-limit 100000

logging buffered 1024000 debugging

logging rate-limit 10000

no logging console

enable secret 5 $1$DGq4$fNPWEp4IpEwFw1eCSbKm8/

!

no aaa new-model

memory-size iomem 15

no network-clock-participate slot 1

no network-clock-participate wic 1

voice-card 0

dspfarm

no local-bypass

!

voice-card 1

dspfarm

!

ip cef

!

!

!

!

ip name-server 85.235.192.2

ip name-server 85.235.193.2

isdn switch-type primary-5ess

!

!

voice call carrier capacity active

!

voice service pots

!

voice service voip

allow-connections h323 to h323

h323    

  h225 timeout tcp call-idle never

  h225 timeout setup 30

  session transport udp

  h245 tunnel disable

  h245 caps mode restricted

!

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

!

!

!

!

!

!

!

!

!

!

!

username admin privilege 15 password 7 060506324F41

!

!

controller E1 0/0

shutdown

framing NO-CRC4

!

controller E1 0/1

framing NO-CRC4

pri-group timeslots 1-31

!

controller E1 1/0

framing NO-CRC4

pri-group timeslots 1-5,16

!

controller E1 1/1

framing NO-CRC4

pri-group timeslots 1-5,16

!

!

!

!

interface FastEthernet0/0

ip address XXX.XXX.XXX.XXX 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.99.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-5ess

isdn incoming-voice voice

isdn send-alerting

isdn sending-complete

no cdp enable

!

interface Serial1/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-5ess

isdn incoming-voice voice

isdn send-alerting

isdn sending-complete

no cdp enable

!

interface Serial1/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-5ess

isdn incoming-voice voice

isdn send-alerting

isdn sending-complete

no cdp enable

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 XXX.XXX.XXX.XXX

!

ip http server

no ip http secure-server

!

!

!

control-plane

!

!

!

voice-port 0/1:15

shutdown

!

voice-port 1/0:15

!

voice-port 1/1:15

!

!

!

!

!

dial-peer voice 10 pots

huntstop

destination-pattern 111.+

port 1/0:15

!

dial-peer voice 20 pots

destination-pattern 222.+

incoming called-number .T

port 1/1:15

!

dial-peer voice 30 pots

destination-pattern 333.T

incoming called-number .T

port 0/1:15

!

dial-peer voice 50 voip

destination-pattern .T

voice-class codec 1

session target ipv4:192.168.99.2

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 60 voip

preference 1

destination-pattern .T

voice-class codec 1

session target ipv4:217.174.106.50

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 70 voip

preference 2

destination-pattern .T

voice-class codec 1

session target ipv4:46.4.114.175

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 80 voip

preference 3

shutdown

destination-pattern .T

voice-class codec 1

session target ipv4:95.215.0.5

dtmf-relay h245-alphanumeric

no vad

!

!

line con 0

line aux 0

line vty 0 4

login local

exec prompt timestamp

transport input telnet

!

!

end

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

dial-peer voice pots doesn't strip prefix digits.

Take 'debug isdn q931' only.

8 REPLIES
Hall of Fame Super Gold

Re: dial-peer voice pots doesn't strip prefix digits.

Configure

destination-pattern 111...

with as many dots as digits following '111'. If it can be a variable lenght number, then place the minium dots, followed by T

Community Member

Re: dial-peer voice pots doesn't strip prefix digits.

Hi, Paolo.

I tried different variants: dots, forward-digits, translation-ruls. Nothing help.

I have configured as you said, result the same.

!

dial-peer voice 10 pots

huntstop

destination-pattern 111...........

port 1/0:15

!

*Mar 23 21:22:15.852: //-1/30F4980A603A/CCAPI/cc_api_display_ie_subfields:

   cc_api_call_setup_ind_common:

   cisco-username=95.215.0.5

   ----- ccCallInfo IE subfields -----

   cisco-ani=8123749844

   cisco-anitype=0

   cisco-aniplan=1

   cisco-anipi=0

   cisco-anisi=0

   dest=11178123367575

   cisco-desttype=0

   cisco-destplan=1

   cisco-rdie=FFFFFFFF

   cisco-rdn=

   cisco-rdntype=-1

   cisco-rdnplan=-1

   cisco-rdnpi=-1

   cisco-rdnsi=-1

   cisco-redirectreason=-1

*Mar 23 21:22:15.856: //-1/30F4980A603A/CCAPI/cc_api_call_setup_ind_common:

   Interface=0x883EAF5C, Call Info(

   Calling Number=8123749844(TON=Unknown, NPI=ISDN, Screening=Not Screened, Presentation=Allowed),

   Called Number=11178123367575(TON=Unknown, NPI=ISDN),

   Calling Translated=FALSE, Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE,

   Incoming Dial-peer=50, Progress Indication=NULL(0), Calling IE Present=TRUE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=16

*Mar 23 21:22:15.856: //-1/30F4980A603A/CCAPI/ccCheckClipClir:

   In: Calling Number=8123749844(TON=Unknown, NPI=ISDN, Screening=Not Screened, Presentation=Allowed)

*Mar 23 21:22:15.856: //-1/30F4980A603A/CCAPI/ccCheckClipClir:

   Out: Calling Number=8123749844(TON=Unknown, NPI=ISDN, Screening=Not Screened, Presentation=Allowed)

*Mar 23 21:22:15.860: //16/30F4980A603A/CCAPI/cc_api_call_setup_ind_common:

   Set Up Event Sent;

   Call Info(Calling Number=8123749844(TON=Unknown, NPI=ISDN, Screening=Not Screened, Presentation=Allowed),

   Called Number=11178123367575(TON=Unknown, NPI=ISDN))

*Mar 23 21:22:15.860: //16/30F4980A603A/CCAPI/cc_process_call_setup_ind:

   Event=0x8873ED70

*Mar 23 21:22:15.868: //16/30F4980A603A/CCAPI/ccCallSetContext:

   Context=0x888EFE14

*Mar 23 21:22:15.868: //16/30F4980A603A/CCAPI/cc_process_call_setup_ind:

   >>>>CCAPI handed cid 16 with tag 50 to app "_ManagedAppProcess_Default"

*Mar 23 21:22:15.872: //16/30F4980A603A/CCAPI/ccCallProceeding:

   Progress Indication=NULL(0)

*Mar 23 21:22:15.876: //16/30F4980A603A/CCAPI/ccCallSetupRequest:

   Destination=, Calling IE Present=TRUE, Mode=0,

   Outgoing Dial-peer=10, Params=0x888F0AC4, Progress Indication=NULL(0)

*Mar 23 21:22:15.880: //16/30F4980A603A/CCAPI/ccCheckClipClir:

   In: Calling Number=8123749844(TON=Unknown, NPI=ISDN, Screening=Not Screened, Presentation=Allowed)

*Mar 23 21:22:15.880: //16/30F4980A603A/CCAPI/ccCheckClipClir:

   Out: Calling Number=8123749844(TON=Unknown, NPI=ISDN, Screening=Not Screened, Presentation=Allowed)

*Mar 23 21:22:15.880: //16/30F4980A603A/CCAPI/ccCallSetupRequest:

   Destination Pattern=111..........., Called Number=11178123367575, Digit Strip=TRUE

*Mar 23 21:22:15.880: //16/30F4980A603A/CCAPI/ccCallSetupRequest:

   Calling Number=8123749844(TON=Unknown, NPI=ISDN, Screening=Not Screened, Presentation=Allowed),

   Called Number=11178123367575(TON=Unknown, NPI=ISDN),

   Redirect Number=, Display Info=

   Account Number=95.215.0.5, Final Destination Flag=TRUE,

   Guid=30F4980A-8A76-F94F-603A-000046464636, Outgoing Dial-peer=10

*Mar 23 21:22:15.880: //16/30F4980A603A/CCAPI/cc_api_display_ie_subfields:

   ccCallSetupRequest:

   cisco-username=95.215.0.5

   ----- ccCallInfo IE subfields -----

   cisco-ani=8123749844

   cisco-anitype=0

   cisco-aniplan=1

   cisco-anipi=0

   cisco-anisi=0

   dest=11178123367575

   cisco-desttype=0

   cisco-destplan=1

   cisco-rdie=FFFFFFFF

   cisco-rdn=

   cisco-rdntype=-1

   cisco-rdnplan=-1

   cisco-rdnpi=-1

   cisco-rdnsi=-1

   cisco-redirectreason=-1

*Mar 23 21:22:15.884: //16/30F4980A603A/CCAPI/ccIFCallSetupRequestPrivate:

   Interface=0x8477CB48, Interface Type=6, Destination=, Mode=0x0,

   Call Params(Calling Number=8123749844(TON=Unknown, NPI=ISDN, Screening=Not Screened, Presentation=Allowed),

   Called Number=11178123367575(TON=Unknown, NPI=ISDN), Calling Translated=FALSE,

   Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE, Outgoing Dial-peer=10, Call Count On=FALSE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)

*Mar 23 21:22:15.884: //17/30F4980A603A/CCAPI/ccIFCallSetupRequestPrivate:

   SPI Call Setup Request Is Success; Interface Type=6, FlowMode=1

*Mar 23 21:22:15.888: //17/30F4980A603A/CCAPI/ccCallSetContext:

   Context=0x888F0A74

*Mar 23 21:22:15.888: //16/30F4980A603A/CCAPI/ccSaveDialpeerTag:

   Outgoing Dial-peer=10

*Mar 23 21:22:16.000: //17/30F4980A603A/CCAPI/cc_api_call_disconnected:

   Cause Value=21, Interface=0x8477CB48, Call Id=17

*Mar 23 21:22:16.000: //17/30F4980A603A/CCAPI/cc_api_call_disconnected:

   Call Entry(Responsed=TRUE, Cause Value=21, Retry Count=0)

*Mar 23 21:22:16.004: //17/30F4980A603A/CCAPI/ccCallSetAAA_Accounting:

   Accounting=0, Call Id=17

*Mar 23 21:22:16.004: //17/30F4980A603A/CCAPI/ccCallDisconnect:

   Cause Value=21, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=21)

*Mar 23 21:22:16.004: //17/30F4980A603A/CCAPI/ccCallDisconnect:

   Cause Value=21, Call Entry(Responsed=TRUE, Cause Value=21)

*Mar 23 21:22:16.004: //17/30F4980A603A/CCAPI/cc_api_get_transfer_info:

   Transfer Number Is Null

*Mar 23 21:22:16.012: //17/30F4980A603A/CCAPI/cc_api_call_disconnect_done:

   Disposition=0, Interface=0x8477CB48, Tag=0x0, Call Id=17,

   Call Entry(Disconnect Cause=21, Voice Class Cause Code=0, Retry Count=0)

*Mar 23 21:22:16.012: //17/30F4980A603A/CCAPI/cc_api_call_disconnect_done:

   Call Disconnect Event Sent

*Mar 23 21:22:16.016: //16/30F4980A603A/CCAPI/ccCallDisconnect:

   Cause Value=21, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)

*Mar 23 21:22:16.020: //16/30F4980A603A/CCAPI/ccCallDisconnect:

   Cause Value=21, Call Entry(Responsed=TRUE, Cause Value=21)

*Mar 23 21:22:16.020: //16/30F4980A603A/CCAPI/cc_api_get_transfer_info:

   Transfer Number Is Null

*Mar 23 21:22:16.024: //16/30F4980A603A/CCAPI/cc_api_call_disconnect_done:

   Disposition=0, Interface=0x883EAF5C, Tag=0x0, Call Id=16,

   Call Entry(Disconnect Cause=21, Voice Class Cause Code=0, Retry Count=0)

*Mar 23 21:22:16.028: //16/30F4980A603A/CCAPI/cc_api_call_disconnect_done:

   Call Disconnect Event Sent

*Mar 23 21:22:21.926: %SYS-5-CONFIG_I: Configured from console by admin on vty0 (77.37.179.84)

Hall of Fame Super Gold

dial-peer voice pots doesn't strip prefix digits.

Take 'debug isdn q931' only.

Community Member

dial-peer voice pots doesn't strip prefix digits.

Thx! With this debug I see that number is changed.

*Mar 23 23:13:00.439: ISDN Se1/0:15 Q931: pak_private_number: Invalid type/plan 0x0 0x1 may be overriden; sw-type 3

*Mar 23 23:13:00.439: ISDN Se1/0:15 Q931: pak_private_number: Invalid type/plan 0x0 0x1 may be overriden; sw-type 3

*Mar 23 23:13:00.447: ISDN Se1/0:15 Q931: Applying typeplan for sw-type 0x3 is 0x2 0x1, Called num 3367575

*Mar 23 23:13:00.447: ISDN Se1/0:15 Q931: TX -> SETUP pd = 8  callref = 0x0082

        Sending Complete

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech 

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA98385

                Exclusive, Channel 5

        Calling Party Number i = 0xA1, '8123749844'

                Plan:ISDN, Type:National

        Called Party Number i = 0xA1, '3367575'

                Plan:ISDN, Type:National

*Mar 23 23:13:00.519: ISDN Se1/0:15 Q931: RX <- RELEASE pd = 8  callref = 0x8082

        Cause i = 0x8095 - Call rejected

*Mar 23 23:13:00.527: ISDN Se1/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x0082

*Mar 23 23:14:16.355: ISDN Se1/0:15 Q931: pak_private_number: Invalid type/plan 0x0 0x1 may be overriden; sw-type 3

*Mar 23 23:14:16.355: ISDN Se1/0:15 Q931: pak_private_number: Invalid type/plan 0x0 0x1 may be overriden; sw-type 3

*Mar 23 23:14:16.359: ISDN Se1/0:15 Q931: Applying typeplan for sw-type 0x3 is 0x2 0x1, Called num 78123367575

*Mar 23 23:14:16.363: ISDN Se1/0:15 Q931: TX -> SETUP pd = 8  callref = 0x0083

        Sending Complete

        Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech 

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA98385

                Exclusive, Channel 5

        Calling Party Number i = 0xA1, '8123749844'

                Plan:ISDN, Type:National

        Called Party Number i = 0xA1, '78123367575'

                Plan:ISDN, Type:National

*Mar 23 23:14:16.415: ISDN Se1/0:15 Q931: RX <- RELEASE pd = 8  callref = 0x8083

        Cause i = 0x8095 - Call rejected

*Mar 23 23:14:16.423: ISDN Se1/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x0083

Green

dial-peer voice pots doesn't strip prefix digits.

Hi,

Can you confirm you ISDN switch type selection.

You are using

!

interface Serial1/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-5ess

isdn incoming-voice voice

This for connection in the US and I would have thought for T1 not E1

primary-5ess

AT&T 5ESS switch type

If you are in Europe New Zealoand or Asia

You would normally use primary-net5 for E1 PRI

primary-net5

European, New Zealand and Asia ISDN PRI switches (covers the Euro-ISDN E-DSS1 signaling system and is ETSI-compliant)

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
Community Member

dial-peer voice pots doesn't strip prefix digits.

Hi Alex,

Yes, I know about primary-5ess and primary-net5. But ISDN provider recommended to use this type of ISDN switch.

ISDN Serial1/0:15 interface

        dsl 1, interface ISDN Switchtype = primary-5ess

    Layer 1 Status:

        ACTIVE

    Layer 2 Status:

        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

    Layer 3 Status:

        0 Active Layer 3 Call(s)

    Active dsl 1 CCBs = 0

    The Free Channel Mask:  0x8000001F

    Number of L2 Discards = 0, L2 Session ID = 1

Ok I will check.

Community Member

dial-peer voice pots doesn't strip prefix digits.

The primary-net5 is also working. But how it can influence to dial-peer translation?

ISDN Serial1/0:15 interface

        dsl 1, interface ISDN Switchtype = primary-net5

    Layer 1 Status:

        ACTIVE

    Layer 2 Status:

        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

    Layer 3 Status:

        0 Active Layer 3 Call(s)

    Active dsl 1 CCBs = 0

    The Free Channel Mask:  0x8000001F

    Number of L2 Discards = 0, L2 Session ID = 4

Hall of Fame Super Gold

dial-peer voice pots doesn't strip prefix digits.

Telco is rejecting the call. Show them the ISDN trace and ask why. If they insist that is router fault, invite them on your premises to place calls using their test equipment.

1463
Views
5
Helpful
8
Replies
CreatePlease to create content