Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Digit translation working weird

Here is my rule:

     LAB_2610XM(config)#voice translation-rule 40

     LAB_2610XM(cfg-translation-rule)#rule 1 /[25-79]000/ /3000/

Here are my results:

LAB_2610XM(cfg-translation-rule)#do test voice translation-rule 40 8012000111

Matched with rule 1

Original number: 8012000111     Translated number: 8013000111

Original number type: none     Translated number type: none

Original number plan: none     Translated number plan: none

This time we tested a ten digit number and again we get the expected results.

LAB_2610XM(cfg-translation-rule)#do test voice translation-rule 40 3525000555

Matched with rule 1

Original number: 3525000555     Translated number: 3300000555

Original number type: none     Translated number type: none

Original number plan: none     Translated number plan: none

Take a good look at this example. Yes It does match our criteria with the 5000 in the number 3525000555 but look what the translated to number is; 3300000555. Here is one of those unexpected results you must watch out for and is why we test our configurations. CME found a matching number because of the 5000 in the string and when it replaced it with 3000 as our expression states, it placed the 3000 at the first 5 in the string.

I am trying to write a CCNA Voice lab manual and am worndering why the last example did what it did and what can I do to get it to give a result of 3523000555.

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Digit translation working weird

Works fine for me on 12.4(24)T2:

Router#test voice translation-rule 40 3525000555

Matched with rule 1

Original number: 3525000555     Translated number: 3523000555

Original number type: none      Translated number type: none

Original number plan: none      Translated number plan: none


What IOS version are you running?  May be a bug.

Try running the test while also running "debug voice translation" and attach the debug as well.

2 REPLIES
Silver

Digit translation working weird

Works fine for me on 12.4(24)T2:

Router#test voice translation-rule 40 3525000555

Matched with rule 1

Original number: 3525000555     Translated number: 3523000555

Original number type: none      Translated number type: none

Original number plan: none      Translated number plan: none


What IOS version are you running?  May be a bug.

Try running the test while also running "debug voice translation" and attach the debug as well.

New Member

Digit translation working weird

I am using c2600-ipvoicek9-mz.124-15.t7.bin.  There must be a bug in my version.  I have also tested version 15.1 and it works fine.  I found a bug in my version then.   Thank you for you help.

146
Views
0
Helpful
2
Replies