Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Disconnect cause=38

Hi All,

I hava some problem on my voip network. when I make calls to the router that PLAR to the call manager, i get an error "Disconnect cause=38" and call couldn't completely and there is a busy tone. i have tried to check and telnet port 1720 and there is no problem. what i have to do?

Really need your helps.

Thanks,

DPSRTR01#csim start 6388

*Jul 20 04:07:28.761: csim: called number = 6388, loop count = 1 ping count = 0

*Jul 20 04:07:28.761: csimSetupPeer peer type(2), destPat(6388), matched(4), target()

*Jul 20 04:07:28.761: //-1/xxxxxxxxxxxx/CCAPI/ccCallSetupRequest:

   Destination=, Calling IE Present=FALSE, Mode=0,

   Outgoing Dial-peer=3, Params=0x45629278, Progress Indication=NULL(0)

*Jul 20 04:07:28.761: //-1/xxxxxxxxxxxx/CCAPI/ccCheckClipClir:

   In: Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)

*Jul 20 04:07:28.761: //-1/xxxxxxxxxxxx/CCAPI/ccCheckClipClir:

   Out: Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)

*Jul 20 04:07:28.761: //-1/xxxxxxxxxxxx/CCAPI/ccCallSetupRequest:

   Destination Pattern=6388, Called Number=6388, Digit Strip=FALSE

*Jul 20 04:07:28.761: //-1/xxxxxxxxxxxx/CCAPI/ccCallSetupRequest:

   Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),

   Called Number=6388(TON=Unknown, NPI=Unknown),

   Redirect Number=, Display Info=

   Account Number=, Final Destination Flag=FALSE,

   Guid=41697C14-D157-11E1-80A2-9FBA2AB422CC, Outgoing Dial-peer=3

*Jul 20 04:07:28.761: //-1/xxxxxxxxxxxx/CCAPI/cc_api_display_ie_subfields:

   ccCallSetupRequest:

   cisco-username=

   ----- ccCallInfo IE subfields -----

   cisco-ani=

   cisco-anitype=0

   cisco-aniplan=0

   cisco-anipi=0

   cisco-anisi=0

   dest=6388

   cisco-desttype=0

   cisco-destplan=0

   cisco-rdie=FFFFFFFF

   cisco-rdn=

   cisco-rdntype=-1

   cisco-rdnplan=-1

   cisco-rdnpi=-1

   cisco-rdnsi=-1

   cisco-redirectreason=-1   fwd_final_type =0

   final_redirectNumber =

   hunt_group_timeout =0

*Jul 20 04:07:28.761: //-1/xxxxxxxxxxxx/CCAPI/ccIFCallSetupRequestPrivate:

   Interface=0x47267AE0, Interface Type=1, Destination=, Mode=0x0,

   Call Params(Calling Number=,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),

   Called Number=6388(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,

   Subscriber Type Str=, FinalDestinationFlag=FALSE, Outgoing Dial-peer=3, Call Count On=FALSE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)

*Jul 20 04:07:28.761: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jul 20 04:07:28.761: :cc_get_feature_vsa malloc success

*Jul 20 04:07:28.761: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jul 20 04:07:28.761:  cc_get_feature_vsa count is 1

*Jul 20 04:07:28.761: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jul 20 04:07:28.761: :FEATURE_VSA attributes are: feature_name:0,feature_time:1188713008,feature_id:137

*Jul 20 04:07:28.761: //137/41697C1480A2/CCAPI/ccIFCallSetupRequestPrivate:

   SPI Call Setup Request Is Success; Interface Type=1, FlowMode=1

*Jul 20 04:07:28.761: //137/41697C1480A2/CCAPI/ccCallSetContext:

   Context=0x49817C14

*Jul 20 04:07:28.825: //137/41697C1480A2/CCAPI/cc_api_call_disconnected:

   Cause Value=38, Interface=0x47267AE0, Call Id=137

*Jul 20 04:07:28.829: //137/41697C1480A2/CCAPI/cc_api_call_disconnected:

   Call Entry(Responsed=TRUE, Cause Value=38, Retry Count=0)

*Jul 20 04:07:28.829: csim_do_test: cid(137), ev(12), disp(0)

*Jul 20 04:07:28.829: csimTraceSct: cid(137),st(0),oldst(0)

*Jul 20 04:07:28.829: csim err csimDisconnected recvd DISC cid(137)

*Jul 20 04:07:28.829: //137/41697C1480A2/CCAPI/ccCallDisconnect:

   Cause Value=38, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=38)

*Jul 20 04:07:28.829: //137/41697C1480A2/CCAPI/ccCallDisconnect:

   Cause Value=38, Call Entry(Responsed=TRUE, Cause Value=38)

*Jul 20 04:07:28.829: //137/41697C1480A2/CCAPI/cc_api_get_transfer_info:

   Transfer Numbe

DPSRTR01#r Is Null

*Jul 20 04:07:28.829: voip_rtp_release_port: rtcp_socket=0x47BFBC38

*Jul 20 04:07:28.829: //137/41697C1480A2/CCAPI/cc_api_call_disconnect_done:

   Disposition=0, Interface=0x47267AE0, Tag=0x0, Call Id=137,

   Call Entry(Disconnect Cause=38, Voice Class Cause Code=0, Retry Count=0)

*Jul 20 04:07:28.829: //137/41697C1480A2/CCAPI/cc_api_call_disconnect_done:

   Call Disconnect Event Sent

*Jul 20 04:07:28.829: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Jul 20 04:07:28.829: :cc_free_feature_vsa freeing 46DA5228

*Jul 20 04:07:28.829: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Jul 20 04:07:28.829:  vsacount in free is 0

*Jul 20 04:07:28.833: csim_do_test: cid(137), ev(13), disp(0)

*Jul 20 04:07:28.833: csimTraceSct: cid(137),st(2),oldst(0)

*Jul 20 04:07:29.333: csim: loop = 1, failed = 1 

*Jul 20 04:07:29.333: csim: call attempted = 1, setup failed = 1, tone failed = 0

*Jul 20 04:07:29.333: //-1/xxxxxxxxxxxx/CCAPI/ccAppShutdownMode:

   ccAppShutdownMode: remove it from the queue

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Super Bronze

Disconnect cause=38

can you please add this command to your interface FastEthernet0/0.1

h323-gateway voip interface

Can you also confirm what IP is showing on cucm for the gateway?

Once you have added the command enbale the ff: debug

debug cch323 all

debug ip tcp transaction

Do a test call. Send the result of the logs here.

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
20 REPLIES
VIP Super Bronze

Disconnect cause=38

That cause code means that your network is out of order. This is most likely a configuration issue. can you send a sh run. Can you also tell us what your call flow is like

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Disconnect cause=38

Hi Aokanlawon,

Thanks for your Help,

my router configuration as attached.

my call flow is :

router site 1 - WAN - router HO - Call manager

i used H.323 gateway, from router site 1 can reach call manager.

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname site1

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

enable secret 5 $1$EC73$qlak3XI97oUAB4HerO4uJ/

!

no aaa new-model

dot11 syslog

!

multilink bundle-name authenticated

!

trunk group  PSTN_FXO_Trunk

!

voice-card 0

dspfarm

dsp services dspfarm

!

voice service voip

no supplementary-service h225-notify cid-update

h323

  no h225 timeout keepalive

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g729br8

codec preference 3 g711ulaw

!

voice class h323 1

h225 timeout tcp establish 3

!

voice translation-rule 1

rule 1 /^91/ /1/

rule 2 /^92/ /2/

rule 3 /^93/ /3/

rule 4 /^94/ /4/

rule 5 /^95/ /5/

rule 6 /^96/ /6/

rule 7 /^97/ /7/

rule 8 /^98/ /8/

rule 9 /^99/ /9/

rule 10 /^90/ /0/

!

voice translation-rule 3

rule 1 /^9\(.*\)/ /\1/

!

voice translation-profile PSTN

translate called 1

!

voice translation-profile PSTN3

translate called 3

!

crypto pki trustpoint TP-self-signed-3762798833

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3762798833

revocation-check none

rsakeypair TP-self-signed-3762798833

!

crypto pki certificate chain TP-self-signed-3762798833

certificate self-signed 01

  30820251 308201BA A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33373632 37393838 3333301E 170D3130 30333233 30393038

  33355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 37363237

  39383833 3330819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100E155 AD90C511 FCAD1267 2A0FECBB 122E7725 954485C6 5821072C 8C5D90D2

  FD3C2265 DBDD8D99 F5661F44 E3143844 7CA80BD8 E6EB2C45 98857F26 319990D0

  9E1097F7 5FC34BA4 8F41ABA2 24F83B45 A0DCE835 641A3615 579CAEE7 D3737166

  ED6FE147 55E9003F 1055D6C2 75E5BA41 DE85FC07 43F86A49 9AF3CDDE A9EBD9DB

  B8250203 010001A3 79307730 0F060355 1D130101 FF040530 030101FF 30240603

  551D1104 1D301B82 19445053 52545230 312E6162 61637573 2D696E64 2E636F2E

  6964301F 0603551D 23041830 16801445 DD3AA715 9AF897C9 A5111E78 0530BD87

  EE2F6430 1D060355 1D0E0416 041445DD 3AA7159A F897C9A5 111E7805 30BD87EE

  2F64300D 06092A86 4886F70D 01010405 00038181 00682D9E 8FAD7672 F3EE6090

  F52AFF07 23830BAC D8FAEF50 B9AD02FA 66B7184A EA70470A 4844A83C 00F54913

  EA24A877 8F3394FD 65619889 0AD7FFD8 CE3438BB 3F8E1C68 646CDF65 AD3526CB

  33642487 AD8EE698 6E436055 52145838 3FD3459D CB7B332F 9DD609FD F7E85177

  DE7C6B89 C494648D 1CECA7FC D2E3C0C0 6B7FFBF5 AB

      quit

!

archive

log config

  hidekeys

!

class-map match-any voice_data

match access-group name VoIP-Data

match protocol rtp audio

match  dscp ef

match  precedence 5

match ip dscp ef

match  dscp cs5

match ip precedence 5

class-map match-any voice_control

match ip dscp af31

match  dscp cs3

match access-group name VoIP-Control

match access-group name Telnet-Traffic

match protocol h323

match protocol rtcp

match protocol skinny

match protocol sip

match protocol mgcp

match ip precedence 3

match ip precedence 2

!

policy-map QoS_Inside

class voice_data

  set ip precedence 5

class voice_control

  set ip precedence 2

class class-default

  set ip precedence 0

policy-map QoS_Outside_MPLS

class voice_data

  priority percent 35

  set ip precedence 5

class voice_control

  bandwidth percent 20

  random-detect

  set ip precedence 2

class class-default

  bandwidth percent 40

  random-detect

  set ip precedence 0

policy-map QoS_Outside

class voice_control

  set ip dscp cs3

  bandwidth percent 15

  random-detect dscp-based

class voice_data

  set ip dscp ef

  bandwidth percent 50

  random-detect dscp-based

   compress header ip rtp

  class class-default

  fair-queue

  random-detect

  set ip precedence 0

!

translation-rule 2

Rule 0 ^90.% 0

Rule 1 ^91.% 1

Rule 2 ^92.% 2

Rule 3 ^93.% 3

Rule 4 ^94.% 4

Rule 5 ^95.% 5

Rule 6 ^96.% 6

Rule 7 ^97.% 7

Rule 8 ^98.% 8

Rule 9 ^99.% 9

!

translation-rule 4

Rule 0 ^90 0

Rule 1 ^91 1

Rule 2 ^92 2

Rule 3 ^93 3

Rule 4 ^94 4

Rule 5 ^95 5

Rule 6 ^96 6

Rule 7 ^97 7

Rule 8 ^98 8

Rule 9 ^99 9

!

translation-rule 3

Rule 1 ^903611.% 1

Rule 2 ^903612.% 2

Rule 3 ^903613.% 3

Rule 4 ^903614.% 4

Rule 5 ^903615.% 5

Rule 6 ^903616.% 6

Rule 7 ^903617.% 7

Rule 8 ^903618.% 8

Rule 9 ^903619.% 9

!

interface Loopback0

ip address 1.2.3.254 255.255.255.252

!

interface FastEthernet0/0

description connection to JKTNMC

no ip address

duplex full

speed auto

service-policy input QoS_Inside

!

interface FastEthernet0/0.1

description VLAN_Data_Gateway

encapsulation dot1Q 1 native

ip address 1.2.0.1 255.255.248.0

ip nat inside

ip virtual-reassembly

h323-gateway voip bind srcaddr 10.54.0.1

service-policy input QoS_Inside

!

interface FastEthernet0/0.15

description VLAN_Voice

encapsulation dot1Q 15

ip address 1.2.10.1 255.255.255.224

service-policy input QoS_Inside

!

interface Service-Engine0/1

ip unnumbered Loopback0

service-module ip address 1.2.10.253 255.255.255.252

service-module ip default-gateway 10.54.10.254

!

interface FastEthernet0/1

ip address 4.5.6.7 255.255.255.0

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface Serial0/1/0

description connection to JKTNMC

bandwidth 512

no ip address

encapsulation frame-relay

no fair-queue

clock rate 2000000

frame-relay traffic-shaping

frame-relay lmi-type ansi

!

interface Serial0/1/0.220 point-to-point

ip address 4.5.7.8 255.255.255.252

snmp trap link-status

no cdp enable

frame-relay interface-dlci 220  

  class VOIPovFR

!

interface Serial0/1/0.230 point-to-point

ip address 4.5.9.2 255.255.255.252

snmp trap link-status

no cdp enable

frame-relay interface-dlci 230  

  class VOIPovFR

!

interface Serial0/1/1

no ip address

shutdown

clock rate 2000000

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 192.168.100.1

ip route 1.2.0.0 255.255.0.0 10.54.0.3

ip route 1.2.10.0 255.255.255.0 10.54.0.3

ip route 1.3.10.0 255.255.255.0 10.54.0.3

ip route 1.4.10.253 255.255.255.255 Service-Engine0/1

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip http path flash:

ip nat pool wan 192.168.100.100 192.168.100.100 prefix-length 24

ip nat inside source list 10 pool wan overload

!

ip access-list extended Telnet-Traffic

permit tcp any any eq telnet

permit tcp any eq telnet any

ip access-list extended VoIP-Control

remark H.323

permit tcp any any eq 1720

permit tcp any eq 1720 any

permit tcp any any range 11000 11999

remark MGCP

permit udp any any eq 2427

permit tcp any any eq 2428

remark Cisco Skinny

permit tcp any any range 2000 2002

remark UCCX_Chat

permit tcp any any eq 59000

permit tcp any eq 59000 any

permit tcp any any eq 59020

permit tcp any eq 59020 any

permit tcp any any eq 59021

permit tcp any eq 59021 any

ip access-list extended VoIP-Data

permit udp any any range 16384 32767

!

map-class frame-relay VOIPovFR

frame-relay cir 512000

frame-relay bc 5120

frame-relay be 0

frame-relay mincir 486400

frame-relay adaptive-shaping becn

service-policy input QoS_Inside

service-policy output QoS_Outside_MPLS

access-list 10 permit 10.54.0.0 0.0.255.255

!

control-plane

!

voice-port 0/0/0

supervisory disconnect dualtone mid-call

cptone ID

timeouts interdigit 2

connection plar opx 6388

caller-id enable

!

voice-port 0/0/1

supervisory disconnect dualtone mid-call

cptone ID

timeouts interdigit 2

connection plar opx 6388

caller-id enable

!

voice-port 0/0/2

supervisory disconnect dualtone mid-call

cptone ID

timeouts interdigit 2

connection plar opx 6388

caller-id enable

!

voice-port 0/0/3

supervisory disconnect dualtone mid-call

cptone ID

timeouts interdigit 2

connection plar opx 6388

caller-id enable

!

voice-port 0/2/0

trunk-group PSTN_FXO_Trunk

supervisory disconnect dualtone mid-call

cptone ID

timeouts interdigit 2

connection plar opx 6388

caller-id enable

!

voice-port 0/2/1

trunk-group PSTN_FXO_Trunk

supervisory disconnect dualtone mid-call

cptone ID

timeouts interdigit 2

connection plar opx 6388

caller-id enable

!

voice-port 0/2/2

supervisory disconnect dualtone mid-call

cptone ID

timeouts interdigit 2

connection plar opx 6388

caller-id enable

!

voice-port 0/2/3

supervisory disconnect dualtone mid-call

cptone ID

timeouts interdigit 2

connection plar opx 6388

caller-id enable

!

ccm-manager music-on-hold

!

sccp local FastEthernet0/0.15

sccp ccm 10.50.1.32 identifier 2

sccp ccm 10.50.1.31 identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate ccm 2 priority 2

associate profile 1 register CFB04FE7f2DA280

associate profile 2 register MTP04FE7F2DA280

keepalive retries 5

switchover method immediate

switchback method immediate

switchback interval 15

!

dspfarm profile 2 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 3

associate application SCCP

!

dspfarm profile 1 conference

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 1

associate application SCCP

!

!

dial-peer voice 1 voip

description DID to JKTCMP

preference 1

destination-pattern [1-8]...

progress_ind setup enable 3

progress_ind progress enable 8

voice-class codec 1

voice-class h323 1

session target ipv4:10.50.1.31

dtmf-relay h245-alphanumeric

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 2 voip

description DID to JKTCMP

preference 1

destination-pattern [1-8]...

progress_ind setup enable 3

voice-class codec 1

voice-class h323 1

session target ipv4:10.50.1.32

dtmf-relay h245-alphanumeric

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 3 voip

description Connection to UCCX

preference 1

destination-pattern 6388

progress_ind setup enable 3

progress_ind progress enable 8

voice-class h323 1

session target ipv4:10.50.1.31

dtmf-relay h245-signal

ip qos dscp cs5 media

no vad

!

dial-peer voice 100 pots

trunkgroup PSTN_FXO_Trunk

description Outgoing Call to PSTN via FXO

preference 1

destination-pattern 9.T

translate-outgoing called 2

no digit-strip

!

dial-peer voice 10 voip

description ** cue pilot number **

preference 10

destination-pattern 6388

voice-class h323 1

session protocol sipv2

session target ipv4:10.54.10.253

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 4 voip

description Connection to UCCX

preference 2

destination-pattern 6388

progress_ind setup enable 3

progress_ind progress enable 8

voice-class h323 1

session target ipv4:10.50.1.32

dtmf-relay h245-signal

ip qos dscp cs5 media

no vad

!

dial-peer voice 101 pots

trunkgroup PSTN_FXO_Trunk

description SiteToLocalDPS

destination-pattern 90361T

translate-outgoing called 3

no digit-strip

!

call-manager-fallback

secondary-dialtone 9

max-conferences 8 gain -6

transfer-system full-consult

ip source-address 10.54.0.1 port 2000

max-ephones 42

max-dn 144

alias 1 0 to 1100 preference 1

translate called 2

call-forward busy 1100

call-forward noan 1100 timeout 30

multicast moh 239.1.1.1 port 16388 route 10.54.0.1

!

VIP Super Bronze

Disconnect cause=38

Your call to 6388 matches dial-peer 3.

Here is dp 3 config. It says connection to UCCX. Are u sending the call direct;y to UCCX? I dont think you can do that. You need to send it to cucm first. If you are sending the call to cucm, is this your cucm ip (10.50.1.31)?

Have you configured this gateway as a h323 gateway on cucm?

dial-peer voice 3 voip

description Connection to UCCX

preference 1

destination-pattern 6388

progress_ind setup enable 3

progress_ind progress enable 8

voice-class h323 1

session target ipv4:10.50.1.31

dtmf-relay h245-signal

ip qos dscp cs5 media

no vad

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Disconnect cause=38

Hi Aonkanlawon,

That's correct that 10.50.1.31 is CCM manager IP. also i have configured h323 gateway on call manager too.

Any Idea?

Thanks.

VIP Super Bronze

Disconnect cause=38

I want to assume that your h323 gateway is not properly configured. I do not see in your configuration where you have enabled h323 bind commands for h323 signalling on any of your interface.

You need to configure an interface especially the one with the ip address you have configured on your cucm as the h323 interface

Please add the ff: to your config..

interface

h323-gateway voip interface

h323-gateway voip bind srcaddr X.X.X.X ( where x.x.x.x is the ip adress of the interface..this must match to the ip you are using in cucm)

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
Green

Disconnect cause=38

Hi,

Cause code 38 = Network Out Of Order.

Look at your H323 binding on interface fas 0/0.1

Your config is :-

!
interface FastEthernet0/0.1
description VLAN_Data_Gateway
encapsulation dot1Q 1 native
ip address 1.2.0.1 255.255.248.0
ip nat inside
ip virtual-reassembly
h323-gateway voip bind srcaddr 10.54.0.1
service-policy input QoS_Inside
!

To me this is wrong.
You are sending packets as H323 source Ip address 10.54.0.1
but your interface is 1.2.0.1

These need to be the same Ip address.

If you change the H323 address binding to 1.2.0.1 you will
need to change the ip address on the gateway page in CUCM to
be 1.2.0.1 along with your Call manager fall back references
in both the CUCM and the IOS config.

You could try changing the int face address to 10.54.0.1
but you would need to know what else this would affect

Another alternative would be to define 10.54.0.1 as a loopback interface
and bind the H323 there and also make sure you can route to and from the address
throughout your VOIP network.

!
interface loopback 100
description  *** H323 Gateway Binding ***
ip address 10.54.0.1 255.255.255.255.255
h323-gateway voip bind srcaddr 10.54.0.1
service-policy input QoS_Inside
!

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
New Member

Disconnect cause=38

Hi Aonkanlawon and acampbell,

sorry that i made a mistake in writing IP on interface fastethernet 0/0.1, the correct IP is 10.54.0.1 on my router configuration. i also can reach call manager by 10.54.0.1 and port 1720 is open.

need your advice,

Thanks,

Helmi

VIP Super Bronze

Disconnect cause=38

can you please add this command to your interface FastEthernet0/0.1

h323-gateway voip interface

Can you also confirm what IP is showing on cucm for the gateway?

Once you have added the command enbale the ff: debug

debug cch323 all

debug ip tcp transaction

Do a test call. Send the result of the logs here.

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Re: Disconnect cause=38

Hi Aonkanlawon,

Thanks for your support,

i've added the "h323-gateway voip interface" on my interface FastEthernet 0/0.1, but still coudn't reach call manager.

also i've debugged cch323 all and ip tcp transaction, i need your help to investigate it. i see that port 1720 is blocked (bold), is it true?

DPSRTR01#csim start 6388

*Jul 23 07:51:13.463: csim: called number = 6388, loop count = 1 ping count = 0

*Jul 23 07:51:13.463: csimSetupPeer peer type(2), destPat(6388), matched(4), target()

*Jul 23 07:51:13.463: //-1/xxxxxxxxxxxx/CCAPI/ccCallSetupRequest:

   Destination=, Calling IE Present=FALSE, Mode=0,

   Outgoing Dial-peer=3, Params=0x45629278, Progress Indication=NULL(0)

*Jul 23 07:51:13.463: //-1/xxxxxxxxxxxx/CCAPI/ccCheckClipClir:

   In: Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)

*Jul 23 07:51:13.463: //-1/xxxxxxxxxxxx/CCAPI/ccCheckClipClir:

   Out: Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)

*Jul 23 07:51:13.463: //-1/xxxxxxxxxxxx/CCAPI/ccCallSetupRequest:

   Destination Pattern=6388, Called Number=6388, Digit Strip=FALSE

*Jul 23 07:51:13.463: //-1/xxxxxxxxxxxx/CCAPI/ccCallSetupRequest:

   Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),

   Called Number=6388(TON=Unknown, NPI=Unknown),

   Redirect Number=, Display Info=

   Account Number=, Final Destination Flag=FALSE,

   Guid=026593FF-D3D2-11E1-8153-9FBA2AB422CC, Outgoing Dial-peer=3

*Jul 23 07:51:13.463: //-1/xxxxxxxxxxxx/CCAPI/cc_api_display_ie_subfields:

   ccCallSetupRequest:

   cisco-username=

   ----- ccCallInfo IE subfields -----

   cisco-ani=

   cisco-anitype=0

   cisco-aniplan=0

   cisco-anipi=0

   cisco-anisi=0

   dest=6388

   cisco-desttype=0

   cisco-destplan=0

   cisco-rdie=FFFFFFFF

   cisco-rdn=

   cisco-rdntype=-1

   cisco-rdnplan=-1

   cisco-rdnpi=-1

   cisco-rdnsi=-1

   cisco-redirectreason=-1   fwd_final_type =0

   final_redirectNumber =

   hunt_group_timeout =0

*Jul 23 07:51:13.463: //-1/xxxxxxxxxxxx/CCAPI/ccIFCallSetupRequestPrivate:

   Interface=0x47267AE0, Interface Type=1, Destination=, Mode=0x0,

   Call Params(Calling Number=,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),

   Called Number=6388(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,

   Subscriber Type Str=, FinalDestinationFlag=FALSE, Outgoing Dial-peer=3, Call Count On=FALSE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)

*Jul 23 07:51:13.467: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jul 23 07:51:13.467: :cc_get_feature_vsa malloc success

*Jul 23 07:51:13.467: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jul 23 07:51:13.467:  cc_get_feature_vsa count is 1

*Jul 23 07:51:13.467: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Jul 23 07:51:13.467: :FEATURE_VSA attributes are: feature_name:0,feature_time:1188712792,feature_id:227

*Jul 23 07:51:13.467: //-1/xxxxxxxxxxxx/H323/cch323_post_call_setup_request: callID=227

*Jul 23 07:51:13.467: //-1/xxxxxxxxxxxx/H323/cch323_post_call_setup_request: incoming_call=0 incoming_media=0

*Jul 23 07:51:13.467: //-1/xxxxxxxxxxxx/H323/cch323_post_call_setup_request: incoming_call=0 incoming_media=0

*Jul 23 07:51:13.467: //227/026593FF8153/CCAPI/ccIFCallSetupRequestPrivate:

   SPI Call Setup Request Is Success; Interface Type=1, FlowMode=1

*Jul 23 07:51:13.467: //227/026593FF8153/CCAPI/ccCallSetContext:

   Context

DPSRTR01#=0x49817F5C

*Jul 23 07:51:13.467: //-1/xxxxxxxxxxxx/H323/cch323_get_new_ccb: ccb (0x46490624) is in use

*Jul 23 07:51:13.467: //227/026593FF8153/H323/cch323_call_setup: gw_id=1

*Jul 23 07:51:13.467: //227/026593FF8153/H323/cch323_call_setup: Inserted ccb

*Jul 23 07:51:13.467: //-1/xxxxxxxxxxxx/H323/cch323_create_call_info_type_container:

cch323_create_call_info_type_container: creating callInfoType container for callID = 227

*Jul 23 07:51:13.467: //-1/xxxxxxxxxxxx/H323/cch323_get_dp_pref_mask:

cch323_get_dp_pref_mask:IPIPGW(227):setting mask for 729ar8 also as 729is configured

*Jul 23 07:51:13.467: //-1/xxxxxxxxxxxx/H323/cch323_get_dp_pref_mask:

cch323_get_dp_pref_mask:IPIPGW(227):setting mask for 729abr8 also as729b is configured

*Jul 23 07:51:13.467: //227/026593FF8153/H323/cch323_get_caps_chn_info: No peer leg setup params

*Jul 23 07:51:13.467: //227/026593FF8153/H323/cch323_get_peer_info: Entry

*Jul 23 07:51:13.467: //227/026593FF8153/H323/cch323_get_peer_info: Have peer

*Jul 23 07:51:13.467: //227/026593FF8153/H323/cch323_get_peer_info: faxrate[41] proto[3] bitmask[10082] t38_inhibit[0] global_fax[0] t38fax[0]

*Jul 23 07:51:13.467: //227/026593FF8153/H323/cch323_set_pref_codec_list: First preferred codec(bytes)=16(20)

*Jul 23 07:51:13.467: //227/026593FF8153/H323/cch323_get_peer_info: Preferred codec set to G729IETF with Bytes = 20

*Jul 23 07:51:13.467: //227/026593FF8153/H323/cch323_get_peer_info: Flow Mode set to FLOW_THROUGH

*Jul 23 07:51:13.471: //227/026593FF8153/H323/cch323_get_peer_info: peer: 47CCC450, peer->voice_peer_tag: 3, ccb: 46490624

*Jul 23 07:51:13.471: //227/026593FF8153/H323/cch323_set_h323_parms_from_dp: ccb h245addr bits = system[0x0007]

*Jul 23 07:51:13.471: //227/026593FF8153/H323/cch323_set_h323_parms_from_dp: ccb ccm bits = system[0x0028]

*Jul 23 07:51:13.471: //227/026593FF8153/H323/cch323_update_setup_callinfo: called_oct3 = 0x0, calling_oct3 = 0x0, calling_oct3a = 0x0

*Jul 23 07:51:13.471: //227/026593FF8153/H323/cch323_set_h323_control_options_outgoing: h245 sm mode = 271

*Jul 23 07:51:13.471: //227/026593FF8153/H323/cch323_set_h323_control_options_outgoing: h323_ctl=0x20

*Jul 23 07:51:13.471: //227/026593FF8153/H323/cch323_call_setup: No account/pin number available

*Jul 23 07:51:13.471: //227/026593FF8153/H323/cch323_store_call_info: Call_setup Playout Mode: 1,Init 60, Min 40, Max 250, Fax 300

*Jul 23 07:51:13.471: //227/026593FF8153/H323/cch323_call_setup_normal: Entry

*Jul 23 07:51:13.471: TCB49554014 created

*Jul 23 07:51:13.471: TCB49554014 setting property TCP_PID (8) 46E86194

*Jul 23 07:51:13.471: TCB49554014 setting property TCP_NO_DELAY (1) 46E86198

*Jul 23 07:51:13.471: TCB49554014 setting property TCP_TOS (11) 46E861E4

*Jul 23 07:51:13.471: TCB49554014 setting property TCP_NONBLOCKING_WRITE (10) 46E86228

*Jul 23 07:51:13.471: TCB49554014 setting property TCP_NONBLOCKING_READ (14) 46E86228

*Jul 23 07:51:13.471: TCB49554014 setting property TCP keepalive timeout (17) 46E86228

*Jul 23 07:51:13.471: TCB49554014 setting property TCP_VRFTABLEID (20) 497B23CC

*Jul 23 07:51:13.471: TCB49554014 setting property TCP_NO_DELAY (1) 46E861E4

*Jul 23 07:51:13.471: TCB49554014 setting property TCP_ALWAYSPUSH (15) 46E861E4

*Jul 23 07:51:13.471: TCP: Random local port generated 38757, network 1

*Jul 23 07:51:13.471: TCB49554014 bound to 10.54.0.1.38757

*Jul 23 07:51:13.471: Reserved port 38757 in Transport Port Agent for TCP IP type 1

*Jul 23 07:51:13.471: TCP: sending SYN, seq 1337104238, ack 0

*Jul 23 07:51:13.471: TCP0: Connection to 10.50.1.31:1720, advertising MSS 536

*Jul 23 07:51:13.475: TCP0: state was CLOSED -> SYNSENT [38757 -> 10.50.1.31(1720)]

*Jul 23 07:51:13.475: //227/026593FF8153/H323/cch323_store_call_info: Call_setup Playout Mode: 1,Init 60, Min 40, Max 250, Fax 300

*Jul 23 07:51:13.527: TCP0: state was SYNSENT -> ESTAB [38757 -> 10.50.1.31(1720)]

*Jul 23 07:51:13.527: TCP: tcb 49554014 connection to 10.50.1.31:1720, peer MSS 1460, MSS is 536

*Jul 23 07:51:13.527: //-1/xxxxxxxxxxxx/H323/cch323_ct_main: SOCK 2 Event 0x1

*Jul 23 07:51:13.527: //-1/xxxxxxxxxxxx/H323/cch323_iev_queue_service: Dispatch 0xB internal event to H225 SM

*Jul 23 07:51:13.527: //227/026593FF8153/H323/run_h225_sm: Received event H225_EV_SETUP while at state H225_IDLE

*Jul 23 07:51:13.527: //227/026593FF8153/H323/check_qos_and_send_setup: Setup ccb 0x46490624

*Jul 23 07:51:13.527: //227/026593FF8153/H323/cch323_rotary_validate: No peer_ccb available

*Jul 23 07:51:13.527: //-1/xxxxxxxxxxxx/H323/cch323_iev_queue_service: Dispatch 0xE internal event to H225 SM

*Jul 23 07:51:13.531: //227/026593FF8153/H323/run_h225_sm: Received event H225_EV_FS_SETUP while at state H225_IDLE

*Jul 23 07:51:13.531: //227/026593FF8153/H323/idle_fsSetup_hdlr: Setup ccb 0x46490624

*Jul 23 07:51:13.531: //227/026593FF8153/H323/idle_fsSetup_hdlr: send_fastStart_setup called

*Jul 23 07:51:13.531: //227/026593FF8153/H323/send_fastStart_setup: Entry

*Jul 23 07:51:13.531: //227/026593FF8153/H323/cch323_build_local_encoded_fastStartOLCs: state_mc_mode=0x10F on outbound leg

*Jul 23 07:51:13.531: //227/026593FF8153/H323/cch323_build_local_encoded_fastStartOLCs: srcAddress = 0xA360001, h245_lport = 0, flow mode = 1, minimum_qos=0

*Jul 23 07:51:13.531: //227/026593FF8153/H323/h245_set_local_audio_mask: Near-end Pref Codecs = G729IETF

*Jul 23 07:51:13.531: //227/026593FF8153/H323/cch323_generic_open_logical_channel: current codec = 16:20:20

*Jul 23 07:51:13.531: //227/026593FF8153/H323/cch323_generic_open_logical_channel: Codec is G729IETF

*Jul 23 07:51:13.531: //227/026593FF8153/H323/cch323_generic_open_logical_channel: Filling in qosCapability field to 0

*Jul 23 07:51:13.531: //227/026593FF8153/H323/generic_send_setup: Entry

*Jul 23 07:51:13.531: //227/026593FF8153/H323/generic_send_setup:

generic_send_setup: is_overlap = 0, info_complete = 0

*Jul 23 07:51:13.531: //227/026593FF8153/H323/generic_send_setup: ====== PI = 0

*Jul 23 07:51:13.531: //227/026593FF8153/H323/generic_send_setup: Send infoXCap=128, infoXRate=16, rateMult=0, xMode=128, info_layer1_prot=163

*Jul 23 07:51:13.531: //227/026593FF8153/H323/generic_send_setup: src address = 10.54.0.1; dest address = 10.50.1.31

*Jul 23 07:51:13.531: //227/026593FF8153/H323/cch323_h225_set_new_state: Changing from H225_IDLE state to H225_REQ_FS_SETUP state

*Jul 23 07:51:13.531: //-1/xxxxxxxxxxxx/H323/cch323_iev_queue_service: Dispatch 0x0 internal event to H245 IWF SM

*Jul 23 07:51:13.535: //227/026593FF8153/H323/run_h245_iwf_sm: received IWF_EV_FASTSTART while at state IWF_IDLE

*Jul 23 07:51:13.535: //-1/xxxxxxxxxxxx/H323/cch323_ct_main: SOCK 2 Event 0x1

*Jul 23 07:51:13.555: TCP0: FIN processed

*Jul 23 07:51:13.555: TCP0: state was ESTAB -> CLOSEWAIT [38757 -> 10.50.1.31(1720)]

*Jul 23 07:51:13.555: //-1/xxxxxxxxxxxx/H323/cch323_ct_main: SOCK 2 Event 0x1

*Jul 23 07:51:13.555: //-1/xxxxxxxxxxxx/H323/h323_set_cc_cause_for_spi_err:

Categorized cause:38, category:186

*Jul 23 07:51:13.555: //-1/xxxxxxxxxxxx/H323/h323_set_release_source_for_peer: ownCallId[227], src[6]

*Jul 23 07:51:13.555: TCP0: state was CLOSEWAIT -> LASTACK [38757 -> 10.50.1.31(1720)]

*Jul 23 07:51:13.555: TCP0: sending FIN

*Jul 23 07:51:13.555: //-1/xxxxxxxxxxxx/H323/h323_gw_clean_send_blocked_watch: fd 2

*Jul 23 07:51:13.555: //-1/xxxxxxxxxxxx/H323/cch323_cleanup_xport: hashDestroy for TcpFDTbl

*Jul 23 07:51:13.555: //-1/xxxxxxxxxxxx/H323/cch323_iev_queue_service: Dispatch 0x2D internal event to H225 SM

*Jul 23 07:51:13.555: //227/026593FF8153/H323/run_h225_sm: Received event H225_EV_CONN_LOST while at state H225_REQ_FS_SETUP

*Jul 23 07:51:13.555: //227/026593FF8153/H323/cch323_traverse_enum_contact_list: State = 2

*Jul 23 07:51:13.555: //227/026593FF8153/CCAPI/cc_api_call_disconnected:

   Cause Value=38, Interface=0x47267AE0, Call Id=227

*Jul 23 07:51:13.555: //227/026593FF8153/CCAPI/cc_api_call_disconnected:

   Call Entry(Responsed=TRUE, Cause Value=38, Retry Count=0)

*Jul 23 07:51:13.559: csim_do_test: cid(227), ev(12), disp(0)

*Jul 23 07:51:13.559: csimTraceSct: cid(227),st(0),oldst(0)

*Jul 23 07:51:13.559: csim err csimDisconnected recvd DISC cid(227)

*Jul 23 07:51:13.559: //227/026593FF8153/CCAPI/ccCallDisconnect:

   Cause Value=38, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=38)

*Jul 23 07:51:13.559: //227/026593FF8153/CCAPI/ccCallDisconnect:

   Cause Value=38, Call Entry(Responsed=TRUE, Cause Value=38)

*Jul 23 07:51:13.559: //227/026593FF8153/CCAPI/cc_api_get_transfer_info:

   Transfer Number Is Null

*Jul 23 07:51:13.559: //227/026593FF8153/H323/cch323_do_call_disconnect: gw_id=1, discCause=38

*Jul 23 07:51:13.559: //-1/xxxxxxxxxxxx/H323/cch323_iev_queue_service: Dispatch 0x9 internal event to H225 SM

*Jul 23 07:51:13.559: //227/026593FF8153/H323/run_h225_sm: Received event H225_EV_RELEASE while at state H225_REQ_FS_SETUP

*Jul 23 07:51:13.559: //227/026593FF8153/H323/cch323_h225_set_new_state: Changing from H225_REQ_FS_SETUP state to H225_IDLE state

*Jul 23 07:51:13.559: //227/026593FF8153/H323/cch323_call_generic_cleanup: Disconnected flag 1

*Jul 23 07:51:13.559: voip_rtp_release_port: rtcp_socket=0x47BFBC38

*Jul 23 07:51:13.559: //227/026593FF8153/H323/cch323_store_call_history_entry: Call Active Playout Mode: 1,Init 60, Min 40, Max 250, Fax 300

*Jul 23 07:51:13.559: //227/026593FF8153/H323/cch323_store_call_history_entry: Call History Playout Mode: 1,Init 60, Min 40, Max 250, Fax 300

*Jul 23 07:51:13.559: //227/026593FF8153/H323/run_h245_iwf_sm: received IWF_EV_H245_DISCONN while at state IWF_IDLE

*Jul 23 07:51:13.559: //227/026593FF8153/H323/defaultHdlr: DEFAULT: Received IWF_EV_H245_DISCONN in state IWF_IDLE

*Jul 23 07:51:13.559: //227/026593FF8153/CCAPI/cc_api_call_disconnect_done:

   Disposition=0, Interface=0x47267AE0, Tag=0x0, Call Id=227,

   Call Entry(Disconnect Cause=38, Voice Class Cause Code=0, Retry Count=0)

*Jul 23 07:51:13.563: //227/026593FF8153/CCAPI/cc_api_call_disconnect_done:

   Call Disconnect Event Sent

*Jul 23 07:51:13.563: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Jul 23 07:51:13.563: :cc_free_feature_vsa freeing 46DA5150

*Jul 23 07:51:13.563: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Jul 23 07:51:13.563:  vsacount in free is 0

*Jul 23 07:51:13.563: //-1/xxxxxxxxxxxx/H323/cch323_call_generic_cleanup: Freeing ccb (0x46490624)

*Jul 23 07:51:13.563: csim_do_test: cid(227), ev(13), disp(0)

*Jul 23 07:51:13.563: csimTraceSct: cid(227),st(2),oldst(0)

*Jul 23 07:51:13.623: TCP0: RST received, Closing connection

*Jul 23 07:51:13.623: TCP0: state was LASTACK -> CLOSED [38757 -> 10.50.1.31(1720)]

*Jul 23 07:51:13.623: Released port 38757 in Transport Port Agent for TCP IP type 1 delay 240000

*Jul 23 07:51:13.623: TCB 0x49554014 destroyed

*Jul 23 07:51:14.063: csim: loop = 1, failed = 1 

*Jul 23 07:51:14.063: csim: call attempted = 1, setup failed = 1, tone failed = 0

*Jul 23 07:51:14.063: //-1/xxxxxxxxxxxx/CCAPI/ccAppShutdownMode:

   ccAppShutdownMode: remove it from the queue

*Jul 23 07:51:14.895: //-1/xxxxxxxxxxxx/H323/cch323_process_carrier_update: Registered = 0, Event = 1, Reason = 2

*Jul 23 07:51:19.051: TCP514: SNDWND timeout timer expired

*Jul 23 07:51:19.051: 10.54.0.1:23 <---> 10.54.0.3:52802   congestion window changes

*Jul 23 07:51:19.051: cwnd from 11790 to 536, ssthresh from 65535 to 1072

*Jul 23 07:51:19.051: TCP514: probe #1 - timeout is 606 ms, seq 2443417070

*Jul 23 07:51:19.147: TCB4957941C setting property TCP_TOS (11) 47CCB0C0

*Jul 23 07:51:19.659: TCP514: SNDWND timeout timer expired

*Jul 23 07:51:19.659: TCP514: probe #2 - timeout is 1212 ms, seq 2443417070

*Jul 23 07:51:20.271: TCB48074AB0 setting property TCP_TOS (11) 47CCB0C0

*Jul 23 07:51:20.871: TCP514: SNDWND timeout timer expired

*Jul 23 07:51:20.871: TCP514: probe #3 - timeout is 2424 ms, seq 2443417070

*Jul 23 07:51:23.295: TCP514: SNDWND timeout timer expired

*Jul 23 07:51:23.295: TCP514: probe #4 - timeout is 4848 ms, seq 2443417070

*Jul 23 07:51:28.143: TCP514: SNDWND timeout timer expired

*Jul 23 07:51:28.143: TCP514: probe #5 - timeout is 9696 ms, seq 2443417070

*Jul 23 07:51:37.839: TCP514: SNDWND timeout timer expired

*Jul 23 07:51:37.839: TCP514: probe #6 - timeout is 9696 ms, seq 2443417070

*Jul 23 07:51:39.895: //-1/xxxxxxxxxxxx/H323/cch323_process_carrier_update: Registered = 0, Event = 1, Reason = 2

*Jul 23 07:51:41.423: TCP514: probed window opened, resetting RTT

*Jul 23 07:51:41.423: TCP514: timeout #1 - timeout is 606 ms, seq 2443417070

*Jul 23 07:51:49.147: TCB4957941C setting property TCP_TOS (11) 47CCB0C0

*Jul 23 07:51:49.375: TCP0: ACK timeout timer expired

*Jul 23 07:51:50.271: TCB48074AB0 setting property TCP_TOS (11) 47CCB0C0

*Jul 23 07:51:50.503: TCP0: ACK timeout timer expired

*Jul 23 07:52:04.895: //-1/xxxxxxxxxxxx/H323/cch323_process_carrier_update: Registered = 0, Event = 1, Reason = 2

*Jul 23 07:52:19.147: TCB4957941C setting property TCP_TOS (11) 47CCB0C0

*Jul 23 07:52:19.371: TCP0: ACK timeout timer expired

*Jul 23 07:52:20.271: TCB48074AB0 setting property TCP_TOS (11) 47CCB0C0

*Jul 23 07:52:20.499: TCP0: ACK timeout timer expired

VIP Super Bronze

Re: Disconnect cause=38

Can you tell me what the state of the gateway is on cucm? is it "unknown unknow" or  is it "unknown 10.54.0.1"

Can you also use the test below to check that port 1720 is opened between the cucm and the gateway

ciscogw#telnet 10.50.1.31 1720 

you should see something like this if the port is opened


Trying 10.50.1.31 1720 ... Open

[Connection to 10.50.1.31 closed by foreign host]
ciscogw#

From the trace..

Jul 23 07:51:13.471: TCP: sending SYN, seq 1337104238, ack 0

*Jul 23 07:51:13.471: TCP0: Connection to 10.50.1.31:1720, advertising MSS 536

*Jul 23 07:51:13.475: TCP0: state was CLOSED -> SYNSENT [38757 -> 10.50.1.31(1720)]

We can see that the gateway is sending a synscronisation packet "sending SYN",

we cal also see that cucm is not sending an ACK to the sent packet "ack 0"

Afterwards the gateway closed the connection "state was CLOSED -> SYNSENT [38757 -> 10.50.1.31(1720)]"

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Disconnect cause=38

Hi Aonkanlawon

the state gateway on CUCM  is "unknown 10.54.0.1" . also i have tried to telnet port 1720 on my call manager and the result is below.

DPSRTR01#telnet 10.50.1.31 1720

Trying 10.50.1.31, 1720 ... Open

[Connection to 10.50.1.31 closed by foreign host]

DPSRTR01#

does it matter if this voice traffic through the tunelling by mikrotik router?

Thanks,

VIP Super Bronze

Disconnect cause=38

Try and restart the cucm service and then do a test call again. Please send "debug ip tcp transaction"

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Disconnect cause=38

Hi Aonkanlawon,

I have tried to restart call manager server and the router site, but the problem is still not resolved. the debug results as same as above.

any idea?

Thanks for your support

cheers

New Member

Disconnect cause=38

Hi Aonkanlawon,

This is the debug results.

Thanks,

DPSRTR01#

*Jul 24 04:03:17.007: TCB45B532D8 created

*Jul 24 04:03:17.007: TCB45B532D8 setting property TCP_PID (8) 46787614

*Jul 24 04:03:17.007: TCB45B532D8 setting property TCP_NO_DELAY (1) 46787618

*Jul 24 04:03:17.007: TCB45B532D8 setting property TCP_TOS (11) 46787664

*Jul 24 04:03:17.007: TCB45B532D8 setting property TCP_NONBLOCKING_WRITE (10) 467876A8

*Jul 24 04:03:17.007: TCB45B532D8 setting property TCP_NONBLOCKING_READ (14) 467876A8

*Jul 24 04:03:17.007: TCB45B532D8 setting property TCP keepalive timeout (17) 467876A8

*Jul 24 04:03:17.007: TCB45B532D8 setting property TCP_VRFTABLEID (20) 4910014C

*Jul 24 04:03:17.007: TCB45B532D8 setting property TCP_NO_DELAY (1) 46787664

*Jul 24 04:03:17.007: TCB45B532D8 setting property TCP_ALWAYSPUSH (15) 46787664

*Jul 24 04:03:17.007: TCP: Random local port generated 11132, network 1

*Jul 24 04:03:17.007: TCB45B532D8 bound to 10.54.10.1.11132

*Jul 24 04:03:17.007: Reserved port 11132 in Transport Port Agent for TCP IP type 1

*Jul 24 04:03:17.007: TCP: sending SYN, seq 1679258265, ack 0

*Jul 24 04:03:17.007: TCP0: Connection to 10.50.1.32:1720, advertising MSS 536

*Jul 24 04:03:17.007: TCP0: state was CLOSED -> SYNSENT [11132 -> 10.50.1.32(1720)]

*Jul 24 04:03:17.039: TCP0: state was SYNSENT -> ESTAB [11132 -> 10.50.1.32(1720)]

*Jul 24 04:03:17.039: TCP: tcb 45B532D8 connection to 10.50.1.32:1720, peer MSS 1460, MSS is 536

*Jul 24 04:03:17.275: TCP0: ACK timeout timer expired

*Jul 24 04:03:17.303: TCB45B53834 created

*Jul 24 04:03:17.303: TCB45B53834 setting property TCP_PID (8) 4678732C

*Jul 24 04:03:17.303: TCB45B53834 setting property TCP_NO_DELAY (1) 46787330

*Jul 24 04:03:17.303: TCB45B53834 setting property TCP_TOS (11) 4678737C

*Jul 24 04:03:17.303: TCB45B53834 setting property TCP_NONBLOCKING_WRITE (10) 467873C0

*Jul 24 04:03:17.303: TCB45B53834 setting property TCP_NONBLOCKING_READ (14) 467873C0

*Jul 24 04:03:17.303: TCB45B53834 setting property TCP_VRFTABLEID (20) 4910045C

*Jul 24 04:03:17.303: TCB45B53834 setting property TCP_NO_DELAY (1) 4678737C

*Jul 24 04:03:17.303: TCB45B53834 setting property TCP_ALWAYSPUSH (15) 4678737C

*Jul 24 04:03:17.303: TCP: Random local port generated 17962, network 1

*Jul 24 04:03:17.303: TCB45B53834 bound to 10.54.10.1.17962

*Jul 24 04:03:17.303: Reserved port 17962 in Transport Port Agent for TCP IP type 1

*Jul 24 04:03:17.303: TCP: sending SYN, seq 999338211, ack 0

*Jul 24 04:03:17.303: TCP0: Connection to 10.50.1.32:39143, advertising MSS 536

*Jul 24 04:03:17.307: TCP0: state was CLOSED -> SYNSENT [17962 -> 10.50.1.32(39143)]

*Jul 24 04:03:17.331: TCP0: state was SYNSENT -> ESTAB [17962 -> 10.50.1.32(39143)]

*Jul 24 04:03:17.331: TCP: tcb 45B53834 connection to 10.50.1.32:39143, peer MSS 1460, MSS is 536

*Jul 24 04:03:17.379: TCB45BB036C setting property TCP_TOS (11) 47530680

*Jul 24 04:03:17.499: TCP0: ACK timeout timer expired

*Jul 24 04:03:17.663: TCP0: bad seg from 10.50.1.32 -- outside window: port 17962 seq 4022160242 ack 999338357 rcvnxt 4022160266 rcvwnd 4001 len 24

*Jul 24 04:03:18.687: TCP0: Data repacketized, seq 999338357, sent 54 byte

*Jul 24 04:03:18.687: 10.54.10.1:17962 <---> 10.50.1.32:39143   congestion window changes

*Jul 24 04:03:18.687: cwnd from 681 to 536, ssthresh from 65535 to 1072

*Jul 24 04:03:18.687: TCP0: timeout #1 - timeout is 2566 ms, seq 999338357

*Jul 24 04:03:18.687: TCP: (17962) -> 10.50.1.32(39143)

*Jul 24 04:03:21.255: TCP0: timeout #2 - timeout is 5132 ms, seq 999338357

*Jul 24 04:03:21.255: TCP: (17962) -> 10.50.1.32(39143)

*Jul 24 04:03:21.403: TCP0: state was ESTAB -> FINWAIT1 [11132 -> 10.50.1.32(1720)]

*Jul 24 04:03:21.407: TCP0: sending FIN

*Jul 24 04:03:21.407: TCP0: state was ESTAB -> FINWAIT1 [17962 -> 10.50.1.32(39143)]

*Jul 24 04:03:21.407: TCP0: sending FIN

*Jul 24 04:03:21.435: TCP0: bad seg from 10.50.1.32 -- Application closed: port 17962 seq 4022160266 ack 999338357 rcvnxt 4022160266 rcvwnd 4001 len 9

*Jul 24 04:03:21.435: TCP: sending RST, seq 999338357, ack 0

*Jul 24 04:03:21.435: Released port 17962 in Transport Port Agent for TCP IP type 1 delay 240000

*Jul 24 04:03:21.435: TCP0: state was FINWAIT1 -> CLOSED [17962 -> 10.50.1.32(39143)]

*Jul 24 04:03:21.435: TCB 0x45B53834 destroyed

*Jul 24 04:03:21.435: TCP0: state was FINWAIT1 -> FINWAIT2 [11132 -> 10.50.1.32(1720)]

*Jul 24 04:03:21.439: TCP0: FIN processed

*Jul 24 04:03:21.439: TCP0: state was FINWAIT2 -> TIMEWAIT [11132 -> 10.50.1.32(1720)]

*Jul 24 04:03:21.439: TCP: sending RST, seq 999338357, ack 0

*Jul 24 04:03:21.439: TCP: sent RST to 10.50.1.32:39143 from 10.54.10.1:17962

*Jul 24 04:03:21.639: TCP0: ACK timeout timer expired

*Jul 24 04:03:21.923: TCB45BB4060 created

*Jul 24 04:03:21.923: TCB45BB4060 setting property TCP_PID (8) 46787614

*Jul 24 04:03:21.923: TCB45BB4060 setting property TCP_NO_DELAY (1) 46787618

*Jul 24 04:03:21.923: TCB45BB4060 setting property TCP_TOS (11) 46787664

*Jul 24 04:03:21.923: TCB45BB4060 setting property TCP_NONBLOCKING_WRITE (10) 467876A8

*Jul 24 04:03:21.923: TCB45BB4060 setting property TCP_NONBLOCKING_READ (14) 467876A8

*Jul 24 04:03:21.923: TCB45BB4060 setting property TCP keepalive timeout (17) 467876A8

*Jul 24 04:03:21.923: TCB45BB4060 setting property TCP_VRFTABLEID (20) 491003EC

*Jul 24 04:03:21.923: TCB45BB4060 setting property TCP_NO_DELAY (1) 46787664

*Jul 24 04:03:21.923: TCB45BB4060 setting property TCP_ALWAYSPUSH (15) 46787664

*Jul 24 04:03:21.923: TCP: Random local port generated 65403, network 1

*Jul 24 04:03:21.923: TCB45BB4060 bound to 10.54.10.1.65403

*Jul 24 04:03:21.923: Reserved port 65403 in Transport Port Agent for TCP IP type 1

*Jul 24 04:03:21.927: TCP: sending SYN, seq 2882556076, ack 0

*Jul 24 04:03:21.927: TCP0: Connection to 10.50.1.31:1720, advertising MSS 536

*Jul 24 04:03:21.927: TCP0: state was CLOSED -> SYNSENT [65403 -> 10.50.1.31(1720)]

*Jul 24 04:03:21.955: TCP0: state was SYNSENT -> ESTAB [65403 -> 10.50.1.31(1720)]

*Jul 24 04:03:21.955: TCP: tcb 45BB4060 connection to 10.50.1.31:1720, peer MSS 1460, MSS is 536

*Jul 24 04:03:22.195: TCP0: ACK timeout timer expired

*Jul 24 04:03:22.223: TCB45BB2DA4 created

*Jul 24 04:03:22.223: TCB45BB2DA4 setting property TCP_PID (8) 4678732C

*Jul 24 04:03:22.223: TCB45BB2DA4 setting property TCP_NO_DELAY (1) 46787330

*Jul 24 04:03:22.223: TCB45BB2DA4 setting property TCP_TOS (11) 4678737C

*Jul 24 04:03:22.223: TCB45BB2DA4 setting property TCP_NONBLOCKING_WRITE (10) 467873C0

*Jul 24 04:03:22.223: TCB45BB2DA4 setting property TCP_NONBLOCKING_READ (14) 467873C0

*Jul 24 04:03:22.223: TCB45BB2DA4 setting property TCP_VRFTABLEID (20) 491001BC

*Jul 24 04:03:22.223: TCB45BB2DA4 setting property TCP_NO_DELAY (1) 4678737C

*Jul 24 04:03:22.223: TCB45BB2DA4 setting property TCP_ALWAYSPUSH (15) 4678737C

*Jul 24 04:03:22.223: TCP: Random local port generated 35568, network 1

*Jul 24 04:03:22.223: TCB45BB2DA4 bound to 10.54.10.1.35568

*Jul 24 04:03:22.223: Reserved port 35568 in Transport Port Agent for TCP IP type 1

*Jul 24 04:03:22.223: TCP: sending SYN, seq 174541042, ack 0

*Jul 24 04:03:22.223: TCP0: Connection to 10.50.1.31:58106, advertising MSS 536

*Jul 24 04:03:22.227: TCP0: state was CLOSED -> SYNSENT [35568 -> 10.50.1.31(58106)]

*Jul 24 04:03:22.255: TCP0: state was SYNSENT -> ESTAB [35568 -> 10.50.1.31(58106)]

*Jul 24 04:03:22.255: TCP: tcb 45BB2DA4 connection to 10.50.1.31:58106, peer MSS 1460, MSS is 536

*Jul 24 04:03:22.419: TCP0: ACK timeout timer expired

*Jul 24 04:03:22.587: TCP0: bad seg from 10.50.1.31 -- outside window: port 35568 seq 4168051269 ack 174541222 rcvnxt 4168051293 rcvwnd 4001 len 24

*Jul 24 04:03:22.663: TCB45BB036C setting property TCP_TOS (11) 47531020

*Jul 24 04:03:22.891: TCP0: ACK timeout timer expired

*Jul 24 04:03:23.607: TCP0: Data repacketized, seq 174541222, sent 54 byte

*Jul 24 04:03:23.607: 10.54.10.1:35568 <---> 10.50.1.31:58106   congestion window changes

*Jul 24 04:03:23.607: cwnd from 715 to 536, ssthresh from 65535 to 1072

*Jul 24 04:03:23.607: TCP0: timeout #1 - timeout is 2566 ms, seq 174541222

*Jul 24 04:03:23.607: TCP: (35568) -> 10.50.1.31(58106)

*Jul 24 04:03:24.099: 10.54.0.1:22 <---> 10.50.5.204:49371   congestion window changes

*Jul 24 04:03:24.099: cwnd from 44421 to 536, ssthresh from 65535 to 8160

*Jul 24 04:03:24.099: TCP515: timeout #1 - timeout is 606 ms, seq 2097625990

*Jul 24 04:03:24.955: TCB45C748A0 setting property TCP_TOS (11) 47531020

*Jul 24 04:03:25.183: TCP0: ACK timeout timer expired

*Jul 24 04:03:26.175: TCP0: timeout #2 - timeout is 5132 ms, seq 174541222

*Jul 24 04:03:26.175: TCP: (35568) -> 10.50.1.31(58106)

*Jul 24 04:03:26.323: TCP0: state was ESTAB -> FINWAIT1 [65403 -> 10.50.1.31(1720)]

*Jul 24 04:03:26.327: TCP0: sending FIN

*Jul 24 04:03:26.327: TCP0: state was ESTAB -> FINWAIT1 [35568 -> 10.50.1.31(58106)]

*Jul 24 04:03:26.327: TCP0: sending FIN

*Jul 24 04:03:26.331: TCB45B53834 created

*Jul 24 04:03:26.331: TCB45B53834 setting property TCP_PID (8) 46787614

*Jul 24 04:03:26.331: TCB45B53834 setting property TCP_NO_DELAY (1) 46787618

*Jul 24 04:03:26.331: TCB45B53834 setting property TCP_TOS (11) 46787664

*Jul 24 04:03:26.331: TCB45B53834 setting property TCP_NONBLOCKING_WRITE (10) 467876A8

*Jul 24 04:03:26.331: TCB45B53834 setting property TCP_NONBLOCKING_READ (14) 467876A8

*Jul 24 04:03:26.331: TCB45B53834 setting property TCP keepalive timeout (17) 467876A8

*Jul 24 04:03:26.331: TCB45B53834 setting property TCP_VRFTABLEID (20) 491005AC

*Jul 24 04:03:26.331: TCB45B53834 setting property TCP_NO_DELAY (1) 46787664

*Jul 24 04:03:26.331: TCB45B53834 setting property TCP_ALWAYSPUSH (15) 46787664

*Jul 24 04:03:26.331: TCP: Random local port generated 35871, network 1

*Jul 24 04:03:26.331: TCB45B53834 bound to 10.54.10.1.35871

*Jul 24 04:03:26.331: Reserved port 35871 in Transport Port Agent for TCP IP type 1

*Jul 24 04:03:26.331: TCP: sending SYN, seq 44634204, ack 0

*Jul 24 04:03:26.331: TCP0: Connection to 10.50.1.32:1720, advertising MSS 536

*Jul 24 04:03:26.335: TCP0: state was CLOSED -> SYNSENT [35871 -> 10.50.1.32(1720)]

*Jul 24 04:03:26.347: TCP0: bad seg from 10.50.1.31 -- Application closed: port 35568 seq 4168051293 ack 174541222 rcvnxt 4168051293 rcvwnd 4001 len 9

*Jul 24 04:03:26.351: TCP: sending RST, seq 174541222, ack 0

*Jul 24 04:03:26.351: Released port 35568 in Transport Port Agent for TCP IP type 1 delay 240000

*Jul 24 04:03:26.351: TCP0: state was FINWAIT1 -> CLOSED [35568 -> 10.50.1.31(58106)]

*Jul 24 04:03:26.351: TCB 0x45BB2DA4 destroyed

*Jul 24 04:03:26.351: TCP0: state was FINWAIT1 -> FINWAIT2 [65403 -> 10.50.1.31(1720)]

*Jul 24 04:03:26.351: TCP0: FIN processed

*Jul 24 04:03:26.351: TCP0: state was FINWAIT2 -> TIMEWAIT [65403 -> 10.50.1.31(1720)]

*Jul 24 04:03:26.351: TCP: sending RST, seq 174541222, ack 0

*Jul 24 04:03:26.351: TCP: sent RST to 10.50.1.31:58106 from 10.54.10.1:35568

*Jul 24 04:03:26.355: TCP0: state was SYNSENT -> ESTAB [35871 -> 10.50.1.32(1720)]

*Jul 24 04:03:26.359: TCP: tcb 45B53834 connection to 10.50.1.32:1720, peer MSS 1460, MSS is 536

*Jul 24 04:03:26.591: TCP0: ACK timeout timer expired

*Jul 24 04:03:26.619: TCB49406564 created

*Jul 24 04:03:26.619: TCB49406564 setting property TCP_PID (8) 4678732C

*Jul 24 04:03:26.619: TCB49406564 setting property TCP_NO_DELAY (1) 46787330

*Jul 24 04:03:26.619: TCB49406564 setting property TCP_TOS (11) 4678737C

*Jul 24 04:03:26.619: TCB49406564 setting property TCP_NONBLOCKING_WRITE (10) 467873C0

*Jul 24 04:03:26.619: TCB49406564 setting property TCP_NONBLOCKING_READ (14) 467873C0

*Jul 24 04:03:26.619: TCB49406564 setting property TCP_VRFTABLEID (20) 491004CC

*Jul 24 04:03:26.619: TCB49406564 setting property TCP_NO_DELAY (1) 4678737C

*Jul 24 04:03:26.619: TCB49406564 setting property TCP_ALWAYSPUSH (15) 4678737C

*Jul 24 04:03:26.619: TCP: Random local port generated 19387, network 1

*Jul 24 04:03:26.619: TCB49406564 bound to 10.54.10.1.19387

*Jul 24 04:03:26.619: Reserved port 19387 in Transport Port Agent for TCP IP type 1

*Jul 24 04:03:26.619: TCP: sending SYN, seq 1295648503, ack 0

*Jul 24 04:03:26.619: TCP0: Connection to 10.50.1.32:39152, advertising MSS 536

*Jul 24 04:03:26.619: TCP0: state was CLOSED -> SYNSENT [19387 -> 10.50.1.32(39152)]

*Jul 24 04:03:26.643: TCP0: state was SYNSENT -> ESTAB [19387 -> 10.50.1.32(39152)]

*Jul 24 04:03:26.643: TCP: tcb 49406564 connection to 10.50.1.32:39152, peer MSS 1460, MSS is 536

*Jul 24 04:03:26.815: TCP0: ACK timeout timer expired

*Jul 24 04:03:28.111: TCP0: Data repacketized, seq 1295648677, sent 30 byte

*Jul 24 04:03:28.111: 10.54.10.1:19387 <---> 10.50.1.32:39152   congestion window changes

*Jul 24 04:03:28.111: cwnd from 709 to 536, ssthresh from 65535 to 1072

*Jul 24 04:03:28.111: TCP0: timeout #1 - timeout is 2810 ms, seq 1295648677

*Jul 24 04:03:28.111: TCP: (19387) -> 10.50.1.32(39152)

*Jul 24 04:03:30.703: TCP0: state was ESTAB -> FINWAIT1 [35871 -> 10.50.1.32(1720)]

*Jul 24 04:03:30.707: TCP0: sending FIN

*Jul 24 04:03:30.707: TCP0: state was ESTAB -> FINWAIT1 [19387 -> 10.50.1.32(39152)]

*Jul 24 04:03:30.707: TCP0: sending FIN

*Jul 24 04:03:30.743: TCP0: state was FINWAIT1 -> FINWAIT2 [35871 -> 10.50.1.32(1720)]

*Jul 24 04:03:30.743: TCP0: FIN processed

*Jul 24 04:03:30.743: TCP0: state was FINWAIT2 -> TIMEWAIT [35871 -> 10.50.1.32(1720)]

*Jul 24 04:03:30.923: TCP0: Data repacketized, seq 1295648677, sent 39 byte

*Jul 24 04:03:30.923: 10.54.10.1:19387 <---> 10.50.1.32:39152   congestion window changes

*Jul 24 04:03:30.923: cwnd from 542 to 536, ssthresh from 1072 to 1072

*Jul 24 04:03:30.923: TCP0: timeout #2 - timeout is 5620 ms, seq 1295648677

*Jul 24 04:03:30.923: TCP: (19387) -> 10.50.1.32(39152)

*Jul 24 04:03:33.867: TCP0: bad seg from 10.50.1.32 -- Application closed: port 19387 seq 4032397819 ack 1295648683 rcvnxt 4032397819 rcvwnd 4025 len 24

*Jul 24 04:03:33.867: TCP: sending RST, seq 1295648683, ack 0

*Jul 24 04:03:33.867: Released port 19387 in Transport Port Agent for TCP IP type 1 delay 240000

*Jul 24 04:03:33.867: TCP0: state was FINWAIT1 -> CLOSED [19387 -> 10.50.1.32(39152)]

*Jul 24 04:03:33.867: TCB 0x49406564 destroyed

*Jul 24 04:03:52.663: TCB45BB036C setting property TCP_TOS (11) 47531020

*Jul 24 04:03:52.891: TCP0: ACK timeout timer expired

*Jul 24 04:03:54.327: TCP515: keepalive timeout (0/4)

*Jul 24 04:03:54.955: TCB45C748A0 setting property TCP_TOS (11) 47531020

*Jul 24 04:03:55.191: TCP0: ACK timeout timer expired

VIP Super Bronze

Disconnect cause=38

I can see that you have changed your configuration..

TCP sync packet is sent to 10.50.1.32 from 10.54.10.1

Is this correct? Does that suggest that you have two callmanager servers? Have you changed your h323 interface on the gateway from 10.54.0.1 to 10.54.10.1?

Do you have a device pool assigned to the gateway in cucm? is cucm service running on bothe your cucm servers?

what cucm version are you running?

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Disconnect cause=38

Hi Aonkanlawon,

That's correct that i have 2 call managers on 1 cluster. and i have changed dial-peer 3 pointing to second call manager 10.50.1.32. also i have changed h323 interface from 10.54.0.1 to 10.54.10.1.

That's right that cucm services running on both in my cucm server.

My CUCM version is 7.1.5.10000-12

That's very kind of you

VIP Super Bronze

Disconnect cause=38

Is there a firewall between the gateway and cucm?

Can you delete the gateway and re-add it?

Can you check your databse replication..do the ff:

Cisco Unified Reporting - Database Status Report

Choose "Cisco Unified Reporting" from the Navigation dropdown in the upper right corner of

the CCMAdministration page. Then choose "Database Status Report", and generate a new

report.

What does the replicate state show?

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Disconnect cause=38

Hi Aonkanlawon,

I have tried to remove and add the gateway, but the problem is still not resloved. the database replication is good.

no, there is no firewall beetween the cucm and gateway, but the important point is the traffic between cucm and gateway is through vpn tunneling by mikrotik. does it matter?

Thanks for your help Aonkanlawon

VIP Super Bronze

Disconnect cause=38

Well, Thats where your problem is. You need to speak with the miktrotik guys and check with them to see if they are inspecting h323 traffic on port 1720. This is most likely where the issue is

Please rate all useful posts

"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Hi,

Hi,

I had the same error code from CUE to CME. The issue was that in the CUE the IP address of the CME was not correct. If it is the loopback where SIP service is bind to, than the loopback (10.1.1.1) address must be added in the CUE:

ccn subsystem sip

gateway address 10.1.1.1

dtmf-relay rtp-nte

mwi sip sub-notify

14847
Views
15
Helpful
20
Replies
CreatePlease login to create content