Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

DMA not installing on CUCM 4.1.3

I am doing an upgrade from CUCm 4.1.3 to 7.1.3 and have attempted to install DMA, but the installation fails pretty quickly with an error saying that DMA cannot install as *installdb* is not found. I did not do the original install and cannot find any logs re: installdb that DMA is looking for.

Anyone seen this error and does anyone have any suggestions.

There are no other error messages, so I suspect that I may have missed a step.

Thanks for the help

Gavin

6 REPLIES

Re: DMA not installing on CUCM 4.1.3

A few things to look out for off the top of my head:

1) You must disable CSA to install.

2) You can't install using Terminal Services (i.e., Remote Desktop).  You can use VNC if you wish.  Otherwise, you must be at the local console.

3) Login to the server as Administrator.

Are those bases covered?

Hailey

Please rate helpful posts!

Community Member

Re: DMA not installing on CUCM 4.1.3

Thanks all those based are covered, and still no joy, thanks for the input though.

Re: DMA not installing on CUCM 4.1.3

Hi,

Investigate the datavalidation.log logfile located in c:\CiscoWebs\DMA\bin\, this should help identify what the exact error is:-


c:\CiscoWebs\DMA\bin\datavalidation.log


The following is a document which outlines a number of reasons why the DMA upgrade can fail, and the appropriate steps to resolve them:-

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a00807f3307.shtml#topic1


The following was taken from this document:-


The installdb operation that you see fail in  this output is the most       common source of failed DMA backups.

Finally, the installdb process generates a log in the DBL trace  folder       called installdbw1.log. This file is located in C:\Program       Files\Cisco\Trace\DBL\installdbw1.log.

In this log, search from the top down for the keyword *Error*.

Note: The asterisks that surround the word Error are very  important. In DMA, if a line simply has "Error" without the asterisks, it is  non-critical and      can be ignored. You also see *Warnings* which can also be ignored.

The reason for the top down search is that errors at the bottom of  the trace are most likely caused by an error occurrence earlier on. In  Example 1, look at the first line that says *Error* and see       that the DMA failed insert into the Informix Dynamic Server (IDS)  Database for Cisco CallManager 5.0.

Example 1 - Unspecified System Error = -239 on Informix db       Insert

10/23/2006 14:25:42.227 installdb|*ERROR* Error executing "insert into NumPlan
(authorizationcoderequired,authorizationlevelrequired,blockenable,
cfaptvoicemailenabled,cfavoicemailenabled,cfbintvoicemailenabled,
cfbvoicemailenabled,cfdfvoicemailenabled,cfnaintvoicemailenabled,
cfnavoicemailenabled,clientcoderequired,deviceoverride,dnorpattern,
fkroutepartition,iscallable,ismessagewaitingon,outsidedialtone,
patternurgency,personalroutingenabled,pff_cfb,pff_cfna,pffintvoicemailenabled,
pffvoicemailenabled,pkid,supportoverlapsending,tkautoanswer,tknetworklocation,
tkpatternprecedence,tkpatternusage,tkpresentationbit_callingline,
tkpresentationbit_callingname,tkpresentationbit_connectedline,
tkpresentationbit_connectedname,tkreleasecausevalue,tkstatus_
usefullyqualcallingpartynum)
      values('F',0,'F','f','F','F','f','f','F','f','F','F','1131',
'4a3945ba-7319-42ff-8f75-f2487e51380e','T','f','F','F','F','F','F','F','F',
'7917e56e-8c50-4f8f-b851-db45b23220b2','f',0,0,5,7,0,0,0,0,0,0):
[Informix][Informix ODBC Driver][Informix]Unspecified System Error =-239.|

Note the error number on the last line. This number is important because it helps you resolve the problem. You can see the DN or Pattern that has the issue in the bold font. In this case, it is a duplicate  voicemail pilot number that was created during an upgrade from Cisco CallManager 3.3(5) to     CallManager 4.1(3). It is also important to note that this problem was only found after looking in the Cisco CallManager Admin pages for directory  number (DN) 1131. These error messages can give some tips on where to look  for the problem, but many times, they do not indicate the exact problem directly.


Regards

Allan

Hope this helps, pls rate helpful posts.

Community Member

Re: DMA not installing on CUCM 4.1.3

DMA has not even installed yet, and no backup has been performed using DMA. I am atempting to install DMA.

"DBL trace  folder   called installdbw1.log. This file is located in C:\Program        Files\Cisco\Trace\DBL\installdbw1.log."

That folder exists but the installdbw1.log file does not exist

The only error message that I get is DMA failed to install *installdb* Error 2

Thanks, I may have to open a Sev 1 TAC case for this as it is getting critical

Gavin

Re: DMA not installing on CUCM 4.1.3

Hi Gavin,

My apologies, I assume that is was the DMA which had failed not the acutall installation, my bad!!

I just verified that according to the compatibility matrix a direct upgrade from 4.1.3 through DMA to 7.1.3b is definitely supported, so that can't be the issue.  Once other matter which was touch upon in a previous post was the CSA agent, and that in some cases you may have to uninstall the CSA before you can run DMA.  Did you simply disable CSA or have you removed it?

Regards

Allan.

Community Member

Re: DMA not installing on CUCM 4.1.3

Hey no sweat,   thanks for the assistance... This should not be this difficult ... but ths being a old military install anything could be going on and this is my 1st crack at DMA.

I tried disabling it first and that did not help so I removed it and got the same result. The version of CSA is 4.0 I believe (not onsite right now) but according to the matrix I should not have to disable it, but did so anyway.

This is quite troubling as there is no documentation for this error and when i sent it to Cisco they too said that they want additional info which is not available.

I also renamed the Administrator account back to Administrator and then logged in again using Administrator with Administrator privileges and I am performing these tasks on the CallManager.

I would like to back up and restore CUCM 4.1.3 to a non production box but the 4.1.3 software has gone missing so this is all that I have, which certainly is not an ideal situation.

Gavin

521
Views
0
Helpful
6
Replies
CreatePlease to create content